Neues Netzteil von C64PSU.COM / Electroware


    • Dekay
    • 8932 Views 154 replies

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    All users must confirm the minimum age (16) in their profile! From tomorrow the use of Forum64 will only possible after updating the profile data. The profile update is still possible after then. Thank you for your understanding. Team forum64.de
    • Snear wrote:

      Ich habe jetzt auch ein netzteil von c64psu.com erhalten. 4,75V beträgt die Spannung mit nacktem C64 (mit Ersatzmodulator statt HF-Modulator). Stecke ich eine Ultimate64 dazu, sind's 4,7V glatt. Ist das nicht ein bisschen wenig? Habe mal das Meßgerät gecheckt, aber das ist in Ordnung. Mein altes Original-Netzteil liefert 5.1V.
      Bei meinem PC-Netzteil kriege ich am Userport auch nur 4.73 V - 4.94 V, je Konfiguration (SCPU, RamLink).
      Das Netzteil liefert um 5V (200W, 20A), den Kabelquerschnitt habe ich auf 0.75 erhöht und die Leitung nur noch so kurz wie möglich.

      Vermute mal das der Schalter noch einiges "frisst", aber um den zu ersetzen bzw. zu brücken fehlt mir das Können.


      Wie weit das PSU-Netzteil beim Betrieb mit Erweiterungen einbricht, wäre noch interessant.

      Gruss C=Mac.
    • Sorry für die späte Antwort, ich wollte nochmal nachmessen:
      • Im Leerlauf 5,05 V, gemessen am Stecker
      • Unter Last 4,67 V, gemessen am Userport, dies ist ein C64C Assy 250469 mit TapeCart und 1541Ultimate II+ extern und intern mit SuperKernal, +60K RAM Erweiterung, MIXSID (6581+8580), Modulator Ersatz V3
      Dieses Setup läuft bei mir dem Netzteil jetzt seit knapp 2 Monaten ohne Probleme und stabil, auch über viele Stunden (pixeln und coden).
      +60K Speichererweiterung für den C64, TapeDevil Toolcollection fürs TapeCart, +4,
      C64 [Assy 250466, 1541U2+, MixSiD, Keyman64, Overlay64, Reprom64, AC/64], U64 [2xARMSID],
      A500+ [Rev 8A, TK68EC020], A600 [Rev 1.3, ACA630], A1200 [Rev. 2B, ACA1233n]
    • Ich hatte schon längere Zeit zweifel (durch eure Erfahrungberichte) an der langlebigkeit der Original Netzteile, daher habe ich mir diesen Thread von Anfang an durchgelesen und bin zu dem Schluss gekommen mir so ein "doppel" Netzteil auf Amazon von ELECTROWARE zu kaufen.

      Das Teil war innerhalb 10 Tagen bei mir, kurz angesehen, rein äusserlich absolut in Ordnung, gut verarbeitet, keine Anzeichen von Pfuscherei.
      Das Kabel das man für die 1541II benötigt war im Lieferumfang dabei. :D

      Natürlich gleich angeschlossen und naja was soll ich sagen, seht selbst-




      So ein schönes Bild hatte ich noch nie mit dem Original Netzteil, da waren immer offensichtliche Vertikale Streifen und seit dem neuen Netztteil kaum bis gar nicht mehr sichtbar.

      Auch die Floppy läuft einwandfrei.

      Natürlich kann ich aufgrund meiner Elektronik unwissenheit keine Details zum eigentlichen Aufbau des Netztteils sagen, aber mein Fazit bisher sagt, absolut OK und das Geld wert.
      Dieser Beitrag wurde bereits 6899 mal editiert, zuletzt von Vectorhead (16. Mai 1984, 19:01)
    • Moin,

      habe mir von Electroware eine spezielle Variante bauen lassen, nämlich ein C128er PSU mit 3A auf 5V mit einem Adapterkabel, so dass ich C64 und C128 damit betrieben kann. Genau genommen ist am 3A Netzteil ein C64 Stecker dran, den ich per Adapter dann an den C128 bekomme. Wollte eigentlich noch gern einen Plus/4 Adapter haben, das ging aber leider mangels Verfügbarkeit 4-Pol rechteckiger DIN Stecker nicht.

      Muss sagen, dass der Service, sowas abzubilden, sehr gut war. Finde auch die Qualität des Netzteils soweit in Ordnung. Die Leitung vom PSU zum Stecker ist recht dick, also keine Spinnenbeinchen, und es kamen glaube ich 5,2V am Stecker an. Am User Port waren es dann unter 5. Lag also nicht am PSU. Netzteil hat CE Zeichen, denke die Ebay Bewertung ist veraltet.

      Soweit meine 2 Cents.

      Gruss
    • Guybrush wrote:

      Moin,

      habe mir von Electroware eine spezielle Variante bauen lassen, nämlich ein C128er PSU mit 3A auf 5V mit einem Adapterkabel, so dass ich C64 und C128 damit betrieben kann. Genau genommen ist am 3A Netzteil ein C64 Stecker dran, den ich per Adapter dann an den C128 bekomme. Wollte eigentlich noch gern einen Plus/4 Adapter haben, das ging aber leider mangels Verfügbarkeit 4-Pol rechteckiger DIN Stecker nicht.

      Muss sagen, dass der Service, sowas abzubilden, sehr gut war. Finde auch die Qualität des Netzteils soweit in Ordnung. Die Leitung vom PSU zum Stecker ist recht dick, also keine Spinnenbeinchen, und es kamen glaube ich 5,2V am Stecker an. Am User Port waren es dann unter 5. Lag also nicht am PSU. Netzteil hat CE Zeichen, denke die Ebay Bewertung ist veraltet.

      Soweit meine 2 Cents.

      Gruss
      Du kannst auch einfach eine C64 Buchse im den plus/4 löten.
      Habe ich damals auch mal gemacht von einem defekten C64 geklaut.
      Dies ist der Anfang einer langen Reise...
      leicht und atemlos.
      Dies ist der Weg aus dem Tal der Tränen
      Nimm meine Hand und lass sie nie wieder los

      B.O.
    • Superingo wrote:

      Du kannst auch einfach eine C64 Buchse im den plus/4 löten.
      Habe ich damals auch mal gemacht von einem defekten C64 geklaut.
      Ich glaube da gehen die Meinungen auseinander. Wenn es Alternativen gibt würde ich die Platinen so belassen wie im Original. und ein 10er für so einen PSU-Mod ... :thumbup: Toller Service (hab auch zwei 64er+1541 PSUs).
    • Hab mir gerade auch so ein C64 Netzteil von Electroware bestellt.
      Möchte auch nicht, das mein guter 1984er Brotkasten plötzlich gegrillt wird ^^
      PS: Vielleicht wird das Bild bei mir auch noch etwas besser, obschon ich mich nicht gross beklagen kann.
      Der Krug geht zum Brunnen bis er bricht.

      The post was edited 1 time, last by treki ().

    • Guybrush wrote:

      Sicher! 10er Aufpreis aufs 128er Netzteil. Also 60 plus Porto. Fand ich sehr fair. Wie gesagt hab ich ja neben dem Adapter auch ne Sonderlocke am Netzteil durch den C64 Stecker.
      Hast Du mal ein Foto von dem NT? Ich hätte jetzt gedacht das wäre das C128-Netzteil mit C64-Stecker und dann hast Du eine Art Adapterstück oder -kabel, das dann auf C128-Stecker adaptiert. Der Preis hört sich auf jeden Fall vernünftig an.
    • darkvision wrote:

      Superingo wrote:

      Du kannst auch einfach eine C64 Buchse im den plus/4 löten.
      Habe ich damals auch mal gemacht von einem defekten C64 geklaut.
      Ich glaube da gehen die Meinungen auseinander. Wenn es Alternativen gibt würde ich die Platinen so belassen wie im Original. und ein 10er für so einen PSU-Mod ... :thumbup: Toller Service (hab auch zwei 64er+1541 PSUs).
      Darum schrieb ich auch du KANNST und nicht Du MUSST.
      Tatsächlich gab es den plus/4 teils ab Werk mit der C64 Buchse.
      Dies ist der Anfang einer langen Reise...
      leicht und atemlos.
      Dies ist der Weg aus dem Tal der Tränen
      Nimm meine Hand und lass sie nie wieder los

      B.O.