Hello, Guest the thread was called2.4k times and contains 51 replays

last post from derSchnippe at the

Unbekannte ISA Grafikkarte "Paradise"

  • Hallo,


    ich habe hier eine ISA 8-Bit Grafikkarte, die ich gerne als CGA Grafikkarte nutzen möchte. Ich habe leider bisher nicht ermitteln können, um was für eine Grafikkarte es sich handelt und was man mit den DIP-Schaltern/Jumpern einstellen kann. Ich habe aber herausgefunden, dass es sich bei diesen "Paradise"-Karten wohl um EGA/MDA/CGA Karten handelt, die man per Jumper/DIP-Schalter oder auch über Autokonfiguration in die verschiedenen Modi schalten kann. Interessant sind auch die beiden Cinch-Buchsen, kann dort evtl. sogar ein Video-Signal abgegriffen werden ?

    Aus den RAM-Chips sehe ich, das die Karte wohl 256 MB hat. Hat jemand evtl. nähere Informationen über diese Karte und kann mir sagen, ob und wie ich die auf CGA einstellen kann ?


    Grüße,

    Ralf


  • EGA klingt plausibel wegen des 9-Pin-Anschlusses und weil die FB+C-Sammlung dahinter 8 Signale suggeriert (6 Bit RGB plus HSync und VSync). Die hier scheint relativ ähnlich zu sein, vielleicht sind die DIP-Schalter-Stellungen ja kompatibel.

  • Hallo,


    Danke für die Hinweise. Es sind natürlich 256 KB - 256 MB wäre für die Zeit dieser Grafikkarte etwas zu viel ....


    Auf die "AUTOSWITCH EGA 350" bei Statson.org bin ich auch schon gestoßen. Was meinen die bei den DIP-Einstellungen mit "Primary" und "Secondary" Display ? Bezieht sich das dann auf den 9-poligen D-SUB und die Cinch-Buchsen oder wird das per Software umgeschaltet (Default = Primary) ? Dann müßte ich also für ein CGA Primary Display 80 Zeichen die Dip-Schalter 1-6 auf


    OFF OFF ON OFF OFF OFF


    einstellen ?


    Die Identifizierungsseite nach dem Layout bei statson.org kannte ich noch nicht, die werde ich mal durchforsten.


    Grüße,

    Ralf

  • Was meinen die bei den DIP-Einstellungen mit "Primary" und "Secondary" Display ?

    Probier es einfach aus? Vielleicht meinen die ja auch den Betrieb mit zwei Karten im Rechner, eine als CGA/EGA und eine als Monochrom konfiguriert.

  • Was meinen die bei den DIP-Einstellungen mit "Primary" und "Secondary" Display ?

    Probier es einfach aus? Vielleicht meinen die ja auch den Betrieb mit zwei Karten im Rechner, eine als CGA/EGA und eine als Monochrom konfiguriert.

    CGA parallel zu MDA und MGA geht. EGA nicht, da sich da die verschiedenen Adressbereiche in die Quere kommen.

  • CGA parallel zu MDA und MGA geht. EGA nicht, da sich da die verschiedenen Adressbereiche in die Quere kommen.

    CGA und EGA hatte ich nie - aber ich bin mir sicher, mal VGA und MDA gleichzeitig im Rechner verwendet zu haben, um den Turbo Debugger auf dem Mono-Display bedienen zu können. Sollte ja auch passen, MDA verwendet 0b0000h-0b7fffh für den Videospeicher und VGA (wie AFAIK auch EGA) verwendet 0a0000h-0affffh und 0b8000h-0bffffh, lässt also genau an der benötigten Stelle eine Lücke.

  • Ich meine, das funktioniert nicht, nur wenn die VGA-Karte im CGA-Modus arbeitet, wäre das möglich. Die Adressbelegung ist sehr gut für verschiedene Grafikkarten im Handbuch der Commodore AGA-Grafikkarte beschrieben. VGA in voller Nutzung müsste eigentlich einen größeren Adressbereich als CGA belegen.


    Aber selbst probiert habe ich es nicht. Gibt zu dem Thema auch ein Thema im Forum dazu, falls jemand suchen möchte. Das müsste im Commodore-PC-Bereich stehen. Da wurden auch verschiedene Tests im Zwei-Monitorbetrieb gemacht.

  • Mach ggf. mal die Kontaktflächen sauber. Die sehen auf den Fotos nicht so gut aus. War bei meiner Karte das Problem warum sie nicht erkannt wurde.

  • Ich meine, das funktioniert nicht, nur wenn die VGA-Karte im CGA-Modus arbeitet, wäre das möglich. Die Adressbelegung ist sehr gut für verschiedene Grafikkarten im Handbuch der Commodore AGA-Grafikkarte beschrieben. VGA in voller Nutzung müsste eigentlich einen größeren Adressbereich als CGA belegen.

    WIMRE hatten wir in der HTL CAD-Arbeitsplätze mit zwei Schirmen, 1 x MDA und 1 x EGA oder (wahrscheinlicher) VGA - definitiv kein CGA, dafür war das Bild zu bunt. Darauf lief irgend ein AutoCAD und beide Bildschirme waren gleichzeitig verwendbar.


    CGA/MDA bzw. CGA(HGC hatte ich selbst in Betireb, das klappt definitiv.

  • Ich besitze zwei Exemplare der Paradise-EGA-Karte, vermutlich das auf stason.org "AUTOSWITCH EGA 350" genannte Modell (zumindest vom Layout her ist sie identisch). Siehe Foto, so sieht die aus.



    Da es sich bei deiner Karte höchstwahrscheinlich um eine EGA-Karte handelt, dürfte diese vom Vorbesitzer mit >95% Wahrscheinlichkeit für EGA konfiguriert gewesen sein.


    Was auch immer du für ein CGA-Anzeigegerät hast (einen CGA-Monitor oder einen selbstgebauten CGA-auf-SCART-Adapter): du kannst damit auch eine EGA-Grafikkarte verwenden, nur im Textmodus und im 640x350-Grafikmodus wirst du kein korrektes Bild sehen.


    Ich habe dafür zwei kleine Tools geschrieben, mit denen man blind in den 640x200 CGA- bzw. EGA-Modus umschalten kann, siehe hier. EGA am Röhren-Monitor sieht aufgrund der Scan-Lines genial aus (so wie auch CGA).


    Rein interessenshalber: in was für einem PC möchtest du die Karte verwenden?


    CGA und EGA hatte ich aufgrund von jugendlichem Leichtsinn ein paar Jahre lang gleichzeitig eingebaut (aber nur die EGA-Karte hing am Monitor). Das funktioniert "mit Nebenwirkungen": ein paar Spiele spinnen (z.B. Alley Cat), aber ansonsten funktioniert es. Das sollte man dennoch heute besser nicht nachmachen.


    P.S. Wichtiger Hinweis: wofür die Cinch-Buchsen dienen, weiß ich bis heute nicht, aber da kommt mit ziemlicher Sicherheit *kein* Composite-Videosignal heraus. Ein Versuch, hier auf gut Glück einen Fernseher anzuschließen, könnte diesem schweren Schaden zufügen.

  • Moin,


    also normal funktionieren EGA-Karten auch nur an speziellen EGA-Monitoren.


    Wenn sich das "AUTOSWITCH" darauf bezieht, dass die Karte erkennt an welchem Monitor sie hängt und ein CGA-Sinal erzeugen kann dann sollte der Dip-Switch 1|5 auch auf ON stehen (Ob das so ist kann ich nicht sagen - solch eine Konfiguration hatten wir nie im Einsatz). Einfach mal versuchen?


    Die Cinch-Buchsen sind im Orginal EGA Design als AUX-Buchsen bezeichnet. Ich hab damals aber nie einen Rechner gesehen an dem diese Buchsen belegt waren. Auch habe ich nie eine Dokumentation gelesen welche auf diese Buchsen einging - die also einfach mal ignorieren, die haben für das Bild keine bedeutung.


    Hoffe ich konnte ein wenig Licht ins Dunkel bringen ...

  • Ich habe mal interessehalber auch etwas rumgesucht und bin auf das hier gestossen. Weiss nicht ob es hilft aber ein cooler link isses ja: :D


    https://hwmuseum.pp.ua/th99/v/v8ISA_1.htm


    Textsuche nach "Paradise" auf der page machen um zum relevanten teil zu kommen. Da gibt es eine Karte die vom layout her identisch scheint. Leider auch "not identified".

  • Hallo,


    Danke für die vielen Hinweise und Vorschläge. Ich hatte vor, die Karte einfach mal auf meinem Testboard zu prüfen, ob ein Bild kommt (DOS - Textmodus). Aber so wie ich das sehe würde das mit der Karte gar nicht funktionieren, auch wenn sie läuft ?


    Ich habe keinen speziellen EGA-Monitor, sondern einen CGA zu VGA Wandler, der funktioniert z.B. am C128 im 80 Zeichen Modus oder auch am Schneider Euro-PC I.


    Die Karte stammt aus einem größeren Konvolut von Teilen, die ich mal 2018 oder 2019 aufgekauft hatte, da waren auch viele "lose" Schneider PC - Teile dabei (Schneider PC, Euro AT, AT Tower ?) - möglicherweise gehört sie zu einem dieser Rechner. Das würde auch erklären, warum ich bisher nichts exakt über diese Karte (Anordnung der RAM-Chips, 6-fach DIP Schalter) finden konnte.


    Das Eprom werde ich heute mal auslesen, vielleicht gibt es daraus Hinweise über die Herkunft.


    Zu den Quarzoszillaoren: Bei den ähnlichen Karten sind folgende Oszillatoren drauf: 27256 / 25000 / 16257 kHz

    Bei mir sind drauf: 27256 und 24000 kHz (verlötet). Mal sehen, ob ich einen 16257 kHz Oszillator für den freien Sockel finde.


    Hier ein Foto von meinem Testboard (SI56P):



    Als ich die Karte nochmal an dem ganz äußeren Slot getestet hatte, hat der PC-Lautsprecher lange Pieptöne in Endlosfolge ausgegeben. Bei einem vorherigen Test am innersten Slot gab es keine Pieptöne, in beiden Fällen kein Bild. Die Kontakte an der Karte werde ich gleich nochmal reinigen.


    Grüße,

    Ralf