1571 Netzteil Reparatur

    • 1571 Netzteil Reparatur

      Hallo!

      Ich habe heute eine 1571 Floppy erhalten. Beim Einschalten lief der Motor und der Trafo brummte laut.
      Nach ein paar Sekunden kam dann auch schon der 'magic smoke', also Schalter wieder aus und aufgeschraubt die Kiste.
      Nun, was soll ich sagen, das Netzteil macht Probleme. Eine oder mehrere der Gleichrichterdioden wurden gebrutzelt. :encolere20:
      Sollte man das Netzteil reparieren oder sollte man gleich ein Schaltnetzteil einbauen? ?(

      Ich schau mir das demnächst mal in aller Ruhe an. Weiß leider nicht ob ich vor Weihnachten noch dazukommen werde.

      Danke im voraus für eure Tipps.
    • Danke für die Tipps!

      Ich werde euch berichten, wie es weitergegangen ist.
      Irgendwie reizt es mich aber, das alte Netzteil zu reparieren, damit das Laufwerk im Originalzustand bleibt.
      Oder ist das eine Schnapsidee? Ich denke ich werde als erstes mal probieren die Dioden & Elkos zu tauschen, vielleicht läuft es dann wieder?
      Eine der beiden Spannungen (schätze 12V) wird sogar funktionieren, weil der Motor ja dreht.
      Und das Brummen vom Trafo deutet auf einen fetten Kurzschluss hin.
    • Es spricht nix dagegen die alte Schaltung wieder auf Trab zu bringen; die 1571 überhitzt eh nicht so leicht wie die älteren 1541-Versionen (bessere Belüftung, höhere Integration und damit geringerer Stromverbrauch); wenn Du investieren willst ersetzt Du die Spannungsregler nicht durch 78xx-Typen, sondern durch kompatible Schaltregler-Module. Dann läuft die Kiste fast genauso kühl wie mit einem reingehackten Schaltnetzteil-Modul, bleibt aber jederzeit zurückbaubar.

      Vor allem zum Testen ist so ein Netzteil für externe Festplatten natürlich sehr praktisch. IDE-an-USB-Adapter kommen mitz so etwas. Tip: Wenn Du ein 5,25-Zoll-auf-3,5-Zoll-Strom-Adapterkabel verwendest, achte immer auf die Belegung! Nur weil das mechanisch auf den Stecker paßt muß die Pinbelegung noch lange nciht stimmen- und dann gibts wirklich gebratene Chips!
    • tulan schrieb:

      Kann ich mit einem C64 irgendwie testen ob BEIDE Schreib/Lese Köpfe der Floppy noch funktionieren?
      Soweit ich weiß wird vom C64 nur Single Side unterstützt.
      Das hat mit dem Rechner nur indirekt zu tun, die 1571 macht das Ganze.

      1. leere 2S/2D Disk - Seite A einlegen
      2. OPEN 1,8,15,"U0>M1" :CLOSE 1 (1571-Mode wird eingeschaltet)
      3. OPEN 15,8,15,"N:LEER,71": CLOSE 15

      damit wird Deine Disk im 1571-Mode formatiert. Wenn es hier keine Fehler gibt, dann tun es beide Leseköpfe so, wie sie sollen.


      achso, in den 1541-Emulations-Mode schaltest Du manuell zurück mit Power OFF/ON oder mit
      OPEN 1,8,15,"U0>M0" :CLOSE 1
    • Im 1541-Modus können nur die Dateien gelesen werden, die sich komplett auf der ersten Seite befinden; jeder Link auf die zweite Seite wird - wie auch von einer echten 1541 - mit "illegal track or sector" quittiert.
      Mit Jiffy ist die 1571 deutlich intelligenter und kommt immer mit beidseitigen Disks klar.
      Yes, I'm the guy responsible for the ACME cross assembler
    • Nein. Eine 1571-Disk hat auf der ersten Seite die logischen Spuren 1 bis 35 (genau wie eine 1541-Disk) und auf der zweiten Seite die logischen Spuren 36 bis 70.

      Eine 1571 im 1541-Modus bietet gegenüber einer echten 1541 die Möglichkeit, auf den zweiten Kopf umzuschalten, aber das ist etwas völlig anderes als das 1571-Format, denn dann lägen auch auf der zweiten Seite wieder logische Spuren 1 bis 35. Allerdings inkompatibel zum "normalen" 1541-Format, da die Drehrichtung anders ist und die Spuren um vier versetzt.
      Yes, I'm the guy responsible for the ACME cross assembler
    • tulan schrieb:

      Danke für die Tipps!

      Ich werde euch berichten, wie es weitergegangen ist.
      Irgendwie reizt es mich aber, das alte Netzteil zu reparieren, damit das Laufwerk im Originalzustand bleibt.
      Oder ist das eine Schnapsidee? Ich denke ich werde als erstes mal probieren die Dioden & Elkos zu tauschen, vielleicht läuft es dann wieder?
      Eine der beiden Spannungen (schätze 12V) wird sogar funktionieren, weil der Motor ja dreht.
      Und das Brummen vom Trafo deutet auf einen fetten Kurzschluss hin.
      Wenn man dran rumlötet ist es ja schon kein Originalzustand. Ich werd für meine 1571 zumindest jetzt so ein Mean Well Netzteil holen. Hat diverse Schutzmechanismen, die das Originalnetzteil nicht hat. Benutze so ein Netzteil auch schon für 1541-II/1581 Laufwerke, da dort die Originalnetzteile langsam alle den Geist aufgeben und dank Epoxyd nicht reparierbar sind.
    • Fröhn schrieb:

      Wenn man dran rumlötet ist es ja schon kein Originalzustand. Ich werd für meine 1571 zumindest jetzt so ein Mean Well Netzteil holen. Hat diverse Schutzmechanismen, die das Originalnetzteil nicht hat. Benutze so ein Netzteil auch schon für 1541-II/1581 Laufwerke, da dort die Originalnetzteile langsam alle den Geist aufgeben und dank Epoxyd nicht reparierbar sind.
      allerdings sollte hier noch zusätzlich erwähnt werden, daß die freiliegenden Klemmen für die Netzspannung zwingend vernünftig mit geeigneten Mitteln isolierend abgedeckt werden sollten - Stichwort: Berührungssicherheit !
    • GI-Joe schrieb:

      allerdings sollte hier noch zusätzlich erwähnt werden, daß die freiliegenden Klemmen für die Netzspannung zwingend vernünftig mit geeigneten Mitteln isolierend abgedeckt werden sollten - Stichwort: Berührungssicherheit !
      Das erledigt der Deckel der 1571 doch schon... Das Orignalnetzteil hat ebenso freiliegende Teile mit Netzspannung, also sollte der Deckel ausreichen. Wer die 1571 offen betreibt muss wissen was er tut.

      Um eine 1541-II zu betreiben benutze ich lieber das OnCommand-Netzteil für 1,95 von Pollin. Das hat ein Gehäuse.
    • Gerrit schrieb:

      Das erledigt der Deckel der 1571 doch schon... Das Orignalnetzteil hat ebenso freiliegende Teile mit Netzspannung, also sollte der Deckel ausreichen. Wer die 1571 offen betreibt muss wissen was er tut.
      Nenn mich ruhig altmodisch aber Sachen, die ich neu einbaue, bei denen decke gern blanke Klemmen, Kabel, Anschlüsse , die Netzspannung führen, ab - auch unter dem Deckel. Aber muss jeder selber wissen ...

      Gerrit schrieb:

      Um eine 1541-II zu betreiben benutze ich lieber das OnCommand-Netzteil für 1,95 von Pollin.
      Yo, das ist bei der 1541-II / 1581 / Oceanic für mich auch immer die erste Wahl. :thumbup:
    • Wenn du das Original NT wieder Reparieren willst, dann Empfehle Ich stärkere Dioden zu nehmen, oder gleich einen Brückengleichrichter. Die Originalen werden immer so Heiß weil sie im Grenzwert Betrieben werden. Und wenn Du schon dabei bist, dann stell den Trfo auch gleich auf 240V um falls noch nicht geschehen.
      Wem es beim Bit zählen schwindelig wird, der hat zuviel davon.

      Alt werden ist schön, das Altern nicht.
    • Der trafo der 1571 kann man auch auf 240V umbauen ? ...dann muß ich das auch noch 2x machen...so oft gibts die 1571 ja auch nicht mehr.

      Ist das eine gute idee ein meanwell schaltnetzteil dort einzubauen? Es wird ja empfohlen z.B. das oncommand netzteil nicht direkt neben oder auf die 1541II zu legen weil sie dann nicht mehr richtig arbeiten soll wegen störungen durch das netzteil. Daher, wohl eher das originale netzteil wieder auf vordermann bringen und vielleicht wie vorgeschlagen durch diverse bauteilauswahl optimieren.
      Defekte Backstein-Netzteile bitte nicht wegwerfen, ich nehme sie gerne.
    • katarakt schrieb:

      Der trafo der 1571 kann man auch auf 240V umbauen ?
      Richtig, man muß nur den Steckschuh von 220V auf 240V Umstecken, der Steckschuh 0V bleibt wo er ist. Das ganze ist auf der NT-Platine auch so Beschriftet. Das klingt Jetzt banal einfach und das ist es auch.
      Wem es beim Bit zählen schwindelig wird, der hat zuviel davon.

      Alt werden ist schön, das Altern nicht.