Hello, Guest the thread was viewed788 times and contains 18 replies

last post from mathias at the

C64 Fehler Horizontal gestrichelte Linien beim Einschalten

  • Hallo Forum,


    ich habe ein Problem mit meinem C64. Erstmal die Beantwortung der üblichen Fragen:


    Punkt 1:

    Die Platinenversion ist sehr Wichtig für korrekte Hilfe. Bei Commodore Platinen steht meist ASSY gefolgt von einer Nummer drauf, die wollen wir wissen.

    250469 Rev 3

    Punkt 2:

    Ist das Gerät modifiziert oder noch Orginal? eventuell andere ROM´s drin?

    Original

    Punkt 3:

    Ist das Netzteil Orginal oder schon mal durch ein anderes ersetzt worden?

    Ersetzt Electroware Kombinetzteil c64 und 1541

    Punkt 4:

    Tritt der Fehler nur auf wenn Zusatzhardware angeschlossen ist?

    Nein, immer

    Punkt 5:

    Tritt das Problem sporadisch auf oder ständig?

    ständig

    Punkt 6:

    Werden irgendwelche Chips besonders heiss? so das man sich fast die Finger dran verbrennt?

    Nein

    Punkt 7:

    Hat der Fragesteller ein Multimeter und weiss wie das benutzt wird?

    (Die billigen 5-Euro Multimeter reichen für diesen Job aus)

    Ja

    Punkt 8:

    Hat der Fragesteller irgendwelche Erfahrungen im Löten? wenn nicht gleich sagen.

    Basiswissen

    Nachträge:

    Punkt 9: Reagieren Laufwerke korrekt auf Ladebefehle, mit LED-Blinken oder gar nicht?

    ja, normal Sd2IEC

    Bonusbitte: Ein Foto von der Platine auf dem man die Chipbezeichnugnen lesen kann, erleichtert die Fehlersuche auch ungemein.

    anbei


    Also folgende Symptome: Beim Einschalten kommt ein blaues Bild mit feinen vertikalen gestrichelten Linien. Tastatur funktioniert normal auf Eingaben. Spielmodul funktioniert korrekt. Diagnose Modul C64 dead test STIO 1.20 funktioniert und läuft ohne Probleme durch, 781220 läuft ohne Probleme durch. 586220 wirre Zeichen auf dem Bildschirm (scheint aber durchzulaufen), Rossmöller das gleiche wie 586220. Spiel von SD geladen und funktioniert, aber es scheint, dass wenn das Spiel einen Text- Startbildschirm hat, so wird dieser falsch dargestellt, wie einige der Diagnosemodule. Das eigentliche Spiel läuft dann aber einwandfrei. Kung Fu flash zeigt wirre Zeichen. EF zeigt den normalen Startbildschirm.


    Anbei ein paar Bilder der Symptome und ein Bild des PCB's.


    Character ROM?


    Danke für Eure Einschätzungen.


    VG


  • Dead Test sieht fehlerfrei aus, bringt eigenen Zeichensatz mit.


    Der VIC scheint nicht korrekt auf das Char ROM zugreifen zu können. Da beim 250469 diesbezüglich alles im 64-Pin-Käfer integriert ist, kann es fast nur das Char-ROM selbst sein. oder eine Leiterbahn/Lötstelle auf dem Weg dahin.

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • kinzi


    Du hattest doch das Diagnostic noch "weiterentwickelt"...

    Mir kam gerade folgender Gedanke:


    Dort werden doch die Prüfsummen der ROMs ausgegeben... Beim CharRom sollte diese ja identisch bleiben sofern i. o.... Nur würde sich das hier optisch nicht erkennbar sein... Wäre es eine Möglichkeit bei falschen bzw unbekannten Prüfsummen den Wert in Rot auszugeben sodass man evt das denn daran erkennt? Beim Basic machts vlt auch Sinn... Beim Kernel guckt er doch bestimmt in eine Art Datenbank...

  • Das originale Diag macht das ja so - was manchen wieder nicht gefiel, weil ROMs mit anderen Prüfsummen dann als "BAD" ausgeworfen werden. Daher wird nur die Prüfsumme angezeigt.


    Diese Änderung ist aber nicht von mir.

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Das originale Diag macht das ja so - was manchen wieder nicht gefiel, weil ROMs mit anderen Prüfsummen dann als "BAD" ausgeworfen werden. Daher wird nur die Prüfsumme angezeigt.


    Diese Änderung ist aber nicht von mir.

    Ja, das ist bekannt und wahrscheinlich auch ganz gut.. (Jiffy, alternative Character Roms)... Nur ob dann die Checksumme in Blau als OK bzw bekannt, oder in Rot (falsche Checksumme, fehlerhaftes Rom)...


    Also ich kann anhand der Summe auf anhieb alleine nicht feststellen ob das Kernel oder Charrom in Ordnung ist... Und die rote Farbe könnte dann als Indikator herhalten...

    Hätte bei meiner Reparatur damals geholfen wenn die fehlerhafte Summe in Rot dargestellt würde... Dann hätte ich den eine Ram drin gelassen und gleich das Rom rausgenommen


    Aber gut, war ein Vorschlag zum erleichtern eines fehlerbehafteten Roms...


    [Edit]

    Ergänzung :


    Mir fiel gerade ein, das Kernel hatte er ja als "unknown" ausgespuckt... Von daher klar...


    Und wenn's CharRom fritte ist, ist eh nix, ausser ne rote Schrift zu erkennen... wenn...


    Vondaher überflüssig...

    [/Edith]

  • aIRwORX Ich verstehe deinen Ansatz schon. Nur "rot" ist dann nicht gut. Man müsste "grün" für bekannte Checksummen nehmen und "blau" wie bisher bei unbekannten. Das sähe man auch bei kaputtem Char-ROM.

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Hätte bei meiner Reparatur damals geholfen wenn die fehlerhafte Summe in Rot dargestellt würde... Dann hätte ich den eine Ram drin gelassen und gleich das Rom rausgenommen


    Aber gut, war ein Vorschlag zum erleichtern eines fehlerbehafteten Roms...

    bei einem defekten CharROM gibt es mindestens 22 verschiedene Möglichkeiten, warum er defekt sein könnte. Ähnlich siehts bei den anderen ROMs aus. Nicht jede Möglichkeit lässt sich mit ner Software-Diagnose (was ja die Deadtest-Cartridge ist) feststellen. Also 100% bekommst Du auch beim Deadtest nie. Es ist halt nur ein Werkzeug für einen schnellen Überblick, was oft sehr hilfreich ist genau so wie der ULTIMAX-RAM-Checker.

    Am Ende des Tages muss man aber halt doch mal messen und/oder auslöten/Crosschecks machen um sicher zu gehen.

    Ich weiß nicht, warum Viele damit solch ein riesen Problem haben.

  • Huch? ich hatte doch vertikal geschrieben, oder? <scroll nach oben>


    so das Board scheint nicht so wirklich stabil zu sein. ich habe den 781220 jetzt mal ein paar Stunden durchlaufen lassen. und wollte dann noch mal das Einschaltbild ansehen und die Fragmente von Zeichen sind verschwunden und manchmal werden die gestrichelten vertikalen Linien zu normal durchgezogenen Linien. Und machmal kommt gar kein Bild sondern 8 Flashes. Beim nächsten Mal, dann wieder wie vorher gestrichelte Linien. Manchmal läuft das Laden von Modul auch nicht, dann geht es wieder. Alles sehr kurios. Also ich besorg mir dann mal ein 901225-01 und baue das gezockelt ein und Seher dann weiter. Oder geben die Symptome oben noch Aufschluss, was sonst noch kaputt sein könnte. Diese Inkonsequenz der Symptome macht mir etwa Kopfzerbrechen.


    Danke iund schönen Abend. Macht Spass mit Euch.

  • da das nur sporadisch auftritt und Spiele laufen, sollte das RAM doch noch halbwegs stabil sein oder?

    Den Mac Bacon Ram test mal längere Zeit laufen lassen.


    Zu den 'vertikalen' :D Strichen: das sieht für mich aus wie Störungen von einem Schaltnetzteil die er sich irgendwo einfängt....

  • Huch? ich hatte doch vertikal geschrieben, oder? <scroll nach oben>


    so das Board scheint nicht so wirklich stabil zu sein. ich habe den 781220 jetzt mal ein paar Stunden durchlaufen lassen. und wollte dann noch mal das Einschaltbild ansehen und die Fragmente von Zeichen sind verschwunden und manchmal werden die gestrichelten vertikalen Linien zu normal durchgezogenen Linien. Und machmal kommt gar kein Bild sondern 8 Flashes. Beim nächsten Mal, dann wieder wie vorher gestrichelte Linien. Manchmal läuft das Laden von Modul auch nicht, dann geht es wieder. Alles sehr kurios. Also ich besorg mir dann mal ein 901225-01 und baue das gezockelt ein und Seher dann weiter. Oder geben die Symptome oben noch Aufschluss, was sonst noch kaputt sein könnte. Diese Inkonsequenz der Symptome macht mir etwa Kopfzerbrechen.


    Danke iund schönen Abend. Macht Spass mit Euch.

    Ich meine auch, Du hättest Vertikal geschrieben. Hat das vielleicht ein Mod. Geändert?

  • Also, nen Schaltnetzteil ist nicht in der Nähe und habe es jetzt auch mal mit anderen sogar Commodore-Netzteilen ausprobiert. Gleiches Bild.

    Lötzinn ich geschrieben habe.... ich hab das mit einem anderen Thread verwechselt.


    Das sieht doch sehr nach defektem Char-Rom aus.