PLA, Pla, pla....


  • RaimundP
  • 1806 Aufrufe 83 Antworten

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • PLA, Pla, pla....

    Neu

    Hallo,

    PLA Chip gesucht, Assy 250407, 6581

    in den letzten Monaten habe ich meine alten C64 wieder aktualisiert. Beides C64 Brotkasten, einer Seriennummer unter 120.000, der andere, mein "eigener" erster C64, damalig noch mit Speedos und Bastel-C64 der 80er Jahre. Beide C64 habe ich wieder aktualisieren können, ein paar Chips ausgetauscht, JIffy eingesetzt (es liefen verquere Bastelwerke / SpeeDos; SpeeDos Expert, etc). Beide Rechner sind "Assy 250407". Davon hatte ich drei Rechner. Einen habe ich komplett zerbaut, um die Chips in diesen beiden einsetzen zu können, Tastatur zu ersetzen, Ein-Ausschalter und sogar VIC auszutauschen. So konnte ich beide wieder zum leben erwecken.

    PROBLEM PLA CHIP: In dem "Bastel C64", also meinem eigenen aus 1985, läuft eins seltames, selber gebranntes Eprom als "PLA". Das Ding ist uralt, sieht wirr aus, Adapter, Eprom, Drähte verlötet, das ganze in Heisskleber gebettet. Aua.

    Mein Lieblingsspiel auf dem C64 ist "Great American Road Race", ein Spiel, das in der Presse unterging, da damalige "Tester" einfach nur ein wilder Haufen ohne Erfahrung waren. Tag- Nachtwechsel, 8 Highscores, diverse, mögliche Strecken. Rudimentär aber wir habend das Spiel geliebt. In diesem Spiel sieht man im oberen Teil die Strecke, Strassenverlauf und Sprites. Unten ist "HiResGrafik" aus Blocksatz für Tacho etc. Und genau hier bringt dieser "Bastel-PLA" die Anzeige nach wenigen Augenblicken zum Absturz. WIzball und Giana (nur schnell gestest) laufen aber z.B. Raid Over Moscow stützt wieder (Bastel-PLA) ab.

    Ich kann den PLA aus dem zweiten, anderen C64 herausnahmen und in dem "kranken" einsetzen: Funktioniert leider nicht (6581 R3).

    Einen "SuperPLA" habe ich dankenderweise erhalten: Dieser läuft aber in keinem der beiden C64. (Jumper sind richtig)

    Was tun?

    - Einen "alten" ur-6581, also kein R1, R2, etc. versuchen? (Hat noch jemand so einen vielleicht)?

    oder

    lieber gleich einen andere C64 Brotkasten irgendwo erwerben und Bastelversuche (Welcher Chip funktioniert = mögliche Kombination) belassen?


    Ray
  • Neu

    Ähm... 6581 (U18) ist aber nicht PLA (U17) sondern SID....

    906114-01 ist z.B. PLA oder 251064-01 oder 82S100

    Was Du wohl brauchst ist ein SID oder SID Ersatz...
    - Nano Swinsid (frag mal @ADAC ),
    - Swinsid Ultimate - soll hoffentlich bald wieder verfügbar sein polyplay bzw. restore-store
    - FPGA Sid fpgasid.de/

    Originale SID's gibts zu Wucherpreisen auf ebay für 50-80€


    RaimundP schrieb:

    Einen "SuperPLA" habe ich dankenderweise erhalten: Dieser läuft aber in keinem der beiden C64. (Jumper sind richtig)
    Eine SuperPLA wird als SID auch nicht funktionieren :sonicht:

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von ch1ller ()

  • Neu

    RaimundP schrieb:

    Und genau hier bringt dieser "Bastel-PLA" die Anzeige nach wenigen Augenblicken zum Absturz.
    Was macht Dich so sicher, dass die Bastel-PLA den Absturz verursacht? Wenn mit einer anderen, "normalen" PLA der Rechner überhaupt nicht funktioniert, scheint der Rechner noch ein ganz anderes Problem zu haben. Da würde ich vermuten, dass die Bastel-PLA lediglich dafür sorgt, dass dieses andere Problem sich unterschiedlich auswirkt.
    Yes, I'm the guy responsible for the ACME cross assembler
  • Neu

    Ich verstehe das eher so, dass er den 6581 in den PLA-Sockel gesteckt hat? Weil im SID-Sockel wird kein "EPROM-Ersatz" gesteckt sein?

    (Dass das der 6581 nicht überlebt haben dürfte steht auf einem anderen Blatt.)
    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten."
    (Quelle unbekannt)

    "Lege dich nie mit einem Idioten an! Er zieht dich auf sein Niveau hinunter und schlägt dich dann mit seiner Erfahrung!"
    (Volksmund)
  • Neu

    kinzi schrieb:

    Ich verstehe das eher so, dass er den 6581 in den PLA-Sockel gesteckt hat? Weil im SID-Sockel wird kein "EPROM-Ersatz" gesteckt sein?

    (Dass das der 6581 nicht überlebt haben dürfte steht auf einem anderen Blatt.)
    Ohne Bilder wird man wohl nur raten können was fürn Unfug hier getrieben wird/wurde... :bgdev

    Aber wie kommt man auf die Idee nen SID als PLA zu nutzen.. bei 2 gleichen 407er Boards sollte JEDEM auffallen, dass die IC's wo anders sitzen
  • Neu

    MalleB schrieb:

    dat erste mal wo icke nen 407 inner Hand hatte dachte ick och da hat jemand PLA und SID vertauscht, kurz im Internetz jeschaut und allet war klar :D
    Ja das iss fatal wenn man zwischen 407er und 425 hin und her switched *g* Da muss man echt höllisch aufpassen...
  • Neu

    Hallo,

    BRRRREMS: Copy und Paste am Morgen: Ich hatte zu dem Sid R4, also 6581R4 geschrieben, den habe ich gegen einen / den alten aus dem "alten" Bord zuvor getauscht und den R4 einen Sammler hier geschickt. Komme gerade von der Post zurück, sorry Leute. Vergesst die Nummer, bezieht euch bitte weiter auf "PLA":

    ALSO: Wirklich der PLA Chip, 906114. Ich habe hier einen alten 906114-01 von 83, den habe ich aber mal im "Ramsch" mit defekten Board bekommen, der war aber schon immer (wohl) defekt, zumindest ist das "OK" darauf gestrichen.

    SO weit kommt es dann doch nicht. Da wird und wurde nichts eingesetzt, was nirgends hingehört. ;)

    Foto anbei, da seht Ihr das "Ding".

    Den C64 hatte ich seit 2002 nicht geöffnet, da auch nur zur Reinigung. Irgendwann 1985 wurde da mal ein Bastel-SpeeDos verbaut und irgendeiner der Bastler hat wohl einen "neuen" PLA benötigt und gegen dieses Eprom getauscht. Einen ähnlichen hatte ich einmal in einem EBay C64, den ich aber so verschenkt habe (was mich ärgert = Teile). (Mit fünfzehn war ich noch nicht so weit, selber löten zu wollen, bzw. hatte auch damalig als Schüler nicht das Geld für Eprombrenner. Also waren wir / ich immer dem Wohlwollen von Technikern oder Bastlern unterworfen).

    Warum der PLA Grund für Spielabsturz sein soll: ich wüsste keinen anderen. Ich habe meine beiden C64 jetzt teils 4 bis sechs Stunden Test unterzogen: Einfach auf beiden Spiele in Dauerschleifen laufen lassen um alte 1701 Monitore zu testen. Bis auf dem Custom-PLA ist in dem C64 sonst alles original. Ich habe nur den Netzschalter ersetzt, da der wackelte.

    Mein Problem: PLA suchen und versuchen? Oder einen gesockelten C64 versuchen zu finden: was auf EBay ja schwierig ist. Ich möchte in beiden C64 Jiffy betreiben: also der Chip dafür muss gesockelt sein. (Jiffy, da ich meine 1541 alle darauf ausgelegt habe inzwischen). Ich möchte ungerne da herauslöten und Sockel wieder einlöten. Zumal ich hier auch keine Lötstation / Absaugpumpen mehr habe und auch nicht mehr erstehen soll (Absprache Frau) / möchte (sonst wird das wieder mehr und mehr ;) ). Ideal, wenn jemand das tauschen könnte, sollte der "Fehler" nicht an dem PLA-XYZ hier liegen.

    Einfache Lösung: anderen PLA rein, bzw. überhaupt einen und kein Eprom. oder wenn, etwas aktuelles und nicht gestricktes aus 1985irgendwann.
    Bilder
    • CHIP.jpg

      428,7 kB, 1.613×1.045, 41 mal angesehen

    Dieser Beitrag wurde bereits 4 mal editiert, zuletzt von RaimundP ()

  • Neu

    Du schriebst:

    RaimundP schrieb:

    Warum der PLA Grund für Spielabsturz sein soll: ich wüsste keinen anderen.
    Vorher schriebst Du:

    RaimundP schrieb:

    Ich kann den PLA aus dem zweiten, anderen C64 herausnahmen und in dem "kranken" einsetzen: Funktioniert leider nicht

    Einen "SuperPLA" habe ich dankenderweise erhalten: Dieser läuft aber in keinem der beiden C64. (Jumper sind richtig)
    Wenn die SuperPLA in keinem der beiden Rechner läuft, könnte sie einfach nur defekt sein. Ok.
    Aber wenn die PLA aus dem zweiten 64er im "Problem-64er" nicht funktioniert (was genau passiert da eigentlich?), dann liegt das Problem doch offensichtlich beim Rechner, und nicht bei der PLA, mit der der Rechner so halb funktioniert.
    Es erscheint mir nicht zielführend, sich bei der Fehlersuche sofort auf "PLA!" zu versteifen, wenn der Rechner mit einer anderweitig funktionierenden PLA auch nicht läuft.
    Yes, I'm the guy responsible for the ACME cross assembler
  • Neu

    feltel schrieb:

    Ich hab als PLA-Ersatz gute Erfahrungen mit dem "U17 PLAnkton" gemacht. Lief bisher in jedem Board. Gibts u.a. bei polyplay oder bei Retrolum aus UK. Idealerweise hat er den Sockel in den er hineingehört gleich im Namen.
    Das hat die PLAdvanced auch! SCNR! :D
    PLAdvanced+ - The all in one PLA replacement!
    PLAdvancedA1060 - Amiga Sidecar A1060 replacement!
  • Neu

    Mac Bacon schrieb:

    Wenn die SuperPLA in keinem der beiden Rechner läuft, könnte sie einfach nur defekt sein. Ok.
    Das kann ich ausschließen, ich habe sie vor dem Versand getestet und sie hat einwandfrei funktioniert.
    Restore-Store - Platinen, Bausätze, Zubehör und Ersatzteile für Commodore Computer - Offizieller JiffyDOS Reseller
  • Neu

    Also wenn ich das jetzt richtig verstehe, hast Du aber bereits eine funktionierende PLA aus einem der anderen beiden C64er in dem C64er mit Bastel PLA gestetet? Richtig?

    Und da lief der Rechner trotzdem nicht....

    Dann wird das sicher nicht nur ein Problem mit der PLA sein, sondern noch mehr..

    Warum die AdvancedPLA jetzt in den anderen Rechnern nicht lief steht erstmal auf einem ganz anderen Blatt und bringt Dich der Problemlösung bei Deinem Bastel-PC aktuell auch nicht weiter...

    Was genau verstehst Du jetzt unter "funktioniert nicht" ? Hast Du ein Bild? Geht es mal? Geht es nur ne Zeit lang? Oder nur schwarzes Bild? Tut sich irgendwas`?

    Ohne Werkzeug wirst Du nicht groß weiter kommen (ausser halt die Chips mal zu tauschen, die gesockelt sind)

    Ich hab sicher noch ein repariertes/funktionierendes 250407er Board rumfliegen, wenns nur darum geht, dieses zu ersetzen.

    Gruß Marcel
  • Neu

    Hallo,

    Danke Euch schon einmal. CPU: Immer Kerben der Sockel nach oben oder, wenn hier SuperPLA (auch) gekennzeichnet: Pin 1 oben links. Ja, das sollte stimmen. Sie passt auch gerade und fest in den Sockel der PLA-Bastellösung (SuperPLA ist etwas grösser, berührt etwas anderen Chip, liegt aber sauber ein).

    AAABER: Wenn die Abstürze der Grafik, bzw. meine gefundenen Probleme gar nicht von der PLA herrühren: bin ich genau so weit wie gerade. Dieser, mein alter C64 wurde im Laufe der Zeit oft von den Bastlern zwischen 1985 und 1990 "überholt". Einige Chips haben z.B. rote "punkte", andere "gelbe". Ich war nie beim öffnen dabei, ich kann nicht ausschließen, dass vielleicht doch bunt gewürfelt wurde. Grübel. Wer weiss, was da ist.

    Ich wollte das Board möglichst wieder "Zurückbauen". So im Hinterkopf ist es unschön, wenn da unbekanntes Bastelwerk anno 1985 verbaut ist. Und noch unangenehmer, wenn der C64 hier nicht richtig läuft. Zwei Geräte, nur zwei Geräte wollte ich haben ;) Hier auf dem "Platten land" war ich in der Zwischenzeit auf EBay angewiesen. Und da wurde oft verkauft, was nicht beschrieben: C64 Brot ersteigert, C64II bekommen (behalten aber nicht gesucht), "Unveränderter C64" und ein Bastelding mit einer SD2IED Lösung (an Bastler verschenkt) bekommen. Ich müsste also weiter "Blind" kaufen.

    Plan war aber, "meinen" C64 wieder zu reaktivieren. Während ich alle fünf 1541 wieder hinbekommen habe, fehlen mir hier schlicht : Teile. Und Möglichkeiten. Also: Lötpumpe, neuen Lötkolben UND ein Board kaufen?

    Vielleicht einfach doch besser, ein Board mit Sockel für Jiffy zu suchen, das funktioniert? Gehäuse kann ich ja behalten, nur eben Platine austauschen? Dann aber einen C64 zuverlässig haben?
  • Neu

    RaimundP schrieb:

    Vielleicht einfach doch besser, ein Board mit Sockel für Jiffy zu suchen, das funktioniert? Gehäuse kann ich ja behalten, nur eben Platine austauschen? Dann aber einen C64 zuverlässig haben?
    Du hast 2 Möglichkeiten...

    1) Das Board reparieren (lassen) und behalten, dabei Kernal sockeln (lassen)
    2) Das Board austauschen und mit einem ersetzen, wo Kernal + PLA gesockelt ist, damit Du dort Dein Jiffy drauf poppen kannst.

    Was Du machst ist Dir überlassen.

    Wenn Du willst, schicks mir zu und ich schau mal drüber... Und bekommst dann so oder so ein Board zurück, worauf Dein Jiffy dann läuft.

    Jiffy und PLA Ersatz packste mit bei, SID behälste bei Dir, dann kann dem nix passieren.

    Bei Interesse, schreib mir ne PM.. Keine eMail..

    Gruß Marcel
  • Neu

    Ich formuliere mal um:

    Zwei C64 besitze ich. Einen habe ich komplett fehlerfrei, den zweiten, hier beschrieben, der macht Probleme, Bastel-PLA verbaut.

    Hat von Euch hier jemand ein Board, das funktioniert? Jiffy habe ich, könnte ich einsetzen, der Chip muss nicht vorhanden sein aber nat. Sockelmöglichkeit.

    Dann hätte ich verlässlich (m)einen zweiten C64 als funktionierende Lösung. und keine Probleme mehr...

    Ich würde gerne zwei funktionierende C64 haben, da auch zwei unterschiedliche Monitore. So sieht es derzeit in der mir zugestandenen Bastelecke aus:

    EDIT: ch1ller hat in genau meiner Überlegung gerade geantwortet: Ich denke, beste Lösung. So handhaben wir das am besten. "Blind" weiter einkaufen und oder PLA Test "ins ungewisse" macht weniger Sinn, als Betrachtung durch Profi. Melde mich. PS: Bitte die kleine Ecke entschuldigen. Ich werde das in mein Arbeitszimmer regulär aufbauen, wenn der letzte Problemfall, der C64 hier gerade, auch funktioniert. Das hier war zum Testen in den letzten sieben Monaten, jeden Monat etwas mehr.
    Bilder
    • ECKE.jpg

      420,15 kB, 1.600×1.012, 47 mal angesehen

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von RaimundP ()

  • Neu

    RaimundP schrieb:

    Irgendwann 1985 wurde da mal ein Bastel-SpeeDos verbaut und irgendeiner der Bastler hat wohl einen "neuen" PLA benötigt und gegen dieses Eprom getauscht.

    RaimundP schrieb:

    Einfache Lösung: anderen PLA rein, bzw. überhaupt einen und kein Eprom. oder wenn, etwas aktuelles und nicht gestricktes aus 1985irgendwann.
    bitte mal den aufkleber von der eprom-pla abmachen und ein foto senden.
    welches herstellungsjahr es hat.

    in den 80er war ich eigentlich der einzige, der ein eprom als pla benutzt hat.

    weil ein 27512 eprom viel teuerer war als die original pla

    und die original pla war von meinem großhandel (ultra electronic Helmut Proxa GmbH & Co. KG) immer lieferbar.
    ich belieferte auch sehr viele commodore händler.

    ich setzte die eprom pla nur ein, wenn ich platinen für meine maschinen steuerungs usw. kunden geliefert habe.

    da habe ich bewust die dekodierung usw. in der pla immer geändert, damit es zusätzliche (software) möglichkeiten gibt.

    die eprom pla benutzte ich damals eigentlich nur für die prototypen test serie,
    dann wurde sie durch eine günstige programmierte pla f93459 (f93458) / 82s100 (82s101) / pls100 (pls101) ersetzt.

    nun würde mich sehr interessieren, welches herstellungsjahr das eprom hat.

    gruß
    helmut