Hello, Guest the thread was called19k times and contains 53 replays

last post from ronduc at the

kickrom files brennen

  • "restliche 256k FF" ist falsch, das sollte auf jeden Fall zweimal hintereinander sein. Bei den Überhand-Adressleitungen soltlest Du erstmal in den Schaltplan gucken, welchen Pegel die standardmäßig haben. Du kannst nicht einfach nen Pin auf Masse ziehen ohne zu wissen, was im Rechner dabei abgeht.


    Jens

  • ok dann kopiere ich das teil halt 2x hintereinander....
    aber bisher hat das ja geklappt wenn ich es dann 4x hintereinander gebrannt habe... sollte also gehn denke ich.


    jo aber wenn ich garnichts mache mit den pins sollte wenigstens die erste bank angesprochens ein, zumindest ist es so, wenn ich 1.3 oder 3.1 alleine 4x brenne... dann kommt das direkt.


    sobald ich irgendwas untereinander mische kommt nix mehr!

  • so ich komme einfach nicht weiter!


    stand:


    ausgelesenes 1.3 / 3.1 / 2.04
    alle für a500/2000


    wenn ich diese 4x hintereinander in ein 27c160 brenne klappt es! ich stecke das eprom mit den letzten beiden beinchen in derluft hängend (a18 + a19) in den sockel und der amiga geht einfach an!
    das klappt wie gesagt mit allen drei davon


    wenn ich aber nun diese kicks in irgendeiner kombination mische geht nichts mehr! mal roter bildschirm mal gelber mal garnichts...
    also kick 1.3 + 3.1 + 1.3 + 3.1
    oder 2.04+204+31+31
    oder 13+13+31+31
    oder 31+13+31+13 etc... nichts geht!


    jemand ne idee? bin am verzweifeln!


    irgendein system müsste ja dann kommen! auch einfach nur wenn die beinchen in der luft hängen und ich nichts geschaltet habe bisher. es müsste ja eine bank angesprochen sein! bei 4x hintereinander demselben gehts ja.


    komme hier echt nicht weiter


    und wie muß ich eigentlich schalten? a18 + a19 jeweils auf vcc legen?
    also 18+19 nichts = bereich0
    18 auf vcc = bereich1
    19 auf vcc = bereich2
    18+19 auf vcc = bereich3


    stimmt das so?


    hoffe jemand kann mir helfen!


    danke

  • Hallo,



    wenn ich diese 4x hintereinander in ein 27c160 brenne klappt es! ich stecke das eprom mit den letzten beiden beinchen in derluft hängend (a18 + a19) in den sockel und der amiga geht einfach an!
    das klappt wie gesagt mit allen drei davon


    wenn ich aber nun diese kicks in irgendeiner kombination mische geht nichts mehr! mal roter bildschirm mal gelber mal garnichts...


    Wenn A18 und A19 gar nicht beschaltet sind, dann "floaten" die in der Gegend herum und nehmen zufällige, auch wechselnde Pegel an. D.h., das Eprom schaltet - auch mitten im Zugriff - zufällig zwischen den verschiedenen Kick-Versionen hin und her. Kein Wunder, daß da nichts geht.


    Jede Leitung muss einen eindeutigen Pegel haben. Üblicherweise gibt man mit je einem Widerstand (z.B. 10 kOhm) nach VCC High-Pegel vor und zwingt nach Wunsch per Schalter nach Masse einen oder beide Pins auf Low.


    Quote


    irgendein system müsste ja dann kommen! auch einfach nur wenn die beinchen in der luft hängen und ich nichts geschaltet habe bisher. es müsste ja eine bank angesprochen sein! bei 4x hintereinander demselben gehts ja.


    Kein Pin darf in der Luft hängen!


    Ersetze "nichts" durch "Masse", dann stimmts.


    Oliver

  • Ersetze "nichts" durch "Masse", dann stimmts.


    bereits versucht ohne erfolg!


    klar hast du recht.... aber praktisch ist es nicht notwendig!
    habe das bereits dutzendfach beim cevi gemacht... auch ohne die auf VCC zu legen und auf GND zu ziehn muß das klappen.


    und bei einer reinen kickrom kombi klappt es ja, also wenn NUR 3.1 drauf ist gehts ja einwandfrei!


  • klar hast du recht.... aber praktisch ist es nicht notwendig!
    habe das bereits dutzendfach beim cevi gemacht... auch ohne die auf VCC zu legen und auf GND zu ziehn muß das klappen.


    Bei NMOS Eproms mags gehen, bei CMOS nicht.

    Quote


    und bei einer reinen kickrom kombi klappt es ja, also wenn NUR 3.1 drauf ist gehts ja einwandfrei!


    Wenn in allen Bereichen identische Inhalte drin sind, dann ist es natürlich egal, auf welchen Bereich gerade zugegriffen wird.

  • Bei NMOS Eproms mags gehen, bei CMOS nicht.


    und warum gehts bei all meinen 256er und 512er für den cevi? sehr seltsam! ein wunder ;)
    denn das sind auch 27c modelle... und sollten deiner aussage nach NICHT laufen! was sie aber tun.
    ich lege nur bei bedarf auf vcc


    das man normalerweise IMMER auf vcc liegen haben sollte und bei bedarf auf GND zieht ist die bessere variante.


    ich werde es trotzdem die tage mal versuchen, vielleicht verhalten sich die >512 eproms anders....

  • ich hab mir nun aus 2 sockeln einen gebastelt und a18+a19 immer über nen 10k mit vcc verbunden


    dann per schalter bei bedarf auf Vss ziehn und ich muß sagen ich hattet RECHT!


    es klappt wunderbar, hätte ich echt nicht gedacht!
    ich weiß das man nie was ohne definierten zustand lassen sollte, hatte aber bisher immer wunderbar geklappt weswegen ich nicht gedacht hätte das es daran liegt!


    also nochmal:


    VIELEN DANK!


    hab nun 4 kicks in einem eprom, sehr praktisch :D

  • Glückwunsch....


    Nun hab ich mal ne Frage....
    Hat jemand ne Anleitung wie so ne Kickumschaltung beim A1200 funktionieren soll?
    (Hat jemand eventuell 'nen Schaltplan oder sowas in der Art?

    :chuck: Chuck Norris brauch keine Datasette oder eine Floppy. :chuck:


    Das Programm startet schon beim Einschalten des C=64

  • Hm , gab es nicht damals eine reihenfolge wie die grbrannten EPROM´s eingebaut werden sollten, even, odd, even ?!


    Also mit einem EPROM 27512. Gut nicht Zielführend für dein Problem, aber du hast es ja geschafft. Ich damals nicht, Eprom währe noch voll, usw, hatte so damls 1990 oder doch später ? aufgegeben, mit einem Eprombrenner für ca. 358 DM gekauft damals, und nun liegt er nur herum...Scheinbar Electronic Schrott heute. Hetzlichen Glückwunsch das du es geschafft hast.


    Brotscheibe

  • Meinst du jetzt mich ?


    Warte mal muss ich erst mal gucken, wie Das Teis heißt wen ich es noch habe.


    Der Name: Junior Prommer ( der Prommer für alle AMIGA )


    Preiß damals 258 DM.


    Hersteller:


    MERLIN-Computer GmBH
    Industriesstraße 26
    6236 Eschborn
    06196481811


    Entweder bin ich damals über der KICKSTARTER Zeitschrift aufmerksahm gemacht worden, oder ich habe das Teil darüber bezogen. Aber genau weiß ich das jetz nicht mer. War so um 1988 oder so.

  • Frage in die heitere Runde, AmigaOS 3.1.4 ist ja verfügbar. Für die Leute ohne ACA500+ gibt es ja das BIN File. Ich bin gerade auf der Suche nach einer Möglichkeit das ROM auf ein EPROM zu brennen um es dann im A500 zu verwenden. Das EPROM was beim Amiganet beschrieben wird (MX27C4100 bzw. das replacement M27C400) sind anscheinend auch abgekündigt. Was nimmt man denn jetzt und hat schon mal jemand versucht das BIN aus dem AmigaOS zu brennen?
    Alternativ gibt es jemanden der mir das ROM auf einen Baustein packen könnte (hab eine Lizenz gekauft die ich auch vorlegen kann)?


    Danke schön

  • Frage in die heitere Runde, AmigaOS 3.1.4 ist ja verfügbar. Für die Leute ohne ACA500+ gibt es ja das BIN File. Ich bin gerade auf der Suche nach einer Möglichkeit das ROM auf ein EPROM zu brennen um es dann im A500 zu verwenden. Das EPROM was beim Amiganet beschrieben wird (MX27C4100 bzw. das replacement M27C400) sind anscheinend auch abgekündigt. Was nimmt man denn jetzt und hat schon mal jemand versucht das BIN aus dem AmigaOS zu brennen?
    Alternativ gibt es jemanden der mir das ROM auf einen Baustein packen könnte (hab eine Lizenz gekauft die ich auch vorlegen kann)?


    Danke schön

    27c400 gibts doch noch massig auf ebay....


    Das bin liegt doch brennfertig vor... Allerdings brauchst Du nen Adapter für die meisten Eprom Brenner... Damit klappt auch das Brennen :thumbsup:

  • Frage in die heitere Runde, AmigaOS 3.1.4 ist ja verfügbar. Für die Leute ohne ACA500+ gibt es ja das BIN File. Ich bin gerade auf der Suche nach einer Möglichkeit das ROM auf ein EPROM zu brennen um es dann im A500 zu verwenden. Das EPROM was beim Amiganet beschrieben wird (MX27C4100 bzw. das replacement M27C400) sind anscheinend auch abgekündigt. Was nimmt man denn jetzt und hat schon mal jemand versucht das BIN aus dem AmigaOS zu brennen?
    Alternativ gibt es jemanden der mir das ROM auf einen Baustein packen könnte (hab eine Lizenz gekauft die ich auch vorlegen kann)?


    Danke schön

    Bei Interesse schreib mir einfach eine PN.