Hello, Guest the thread was called1.6k times and contains 49 replays

last post from twretro at the

C64 Assy 250407 - Bildschirm schwarz

  • Hallo zusammen,


    ich habe kürzlich den C64 von meinem Vater erhalten, der ihn vermutlich irgendwann Mitte / Ende der 80er gekauft hat.

    Seit mindestens zwei Jahrzehnten fristete er (also der C64) nun ein trauriges Dasein im Wohnzimmerschrank. Er lag also alle Jahre warm und trocken.

    Im Zuge einer Renovierung musste er dann weichen und bevor mein Vater ihn wegschmeißen konnte, wollte ich mal mein Glück versuchen.

    Ich kann mich noch daran erinnern, wie wir als Kinder zusammen mit Papa daran gespielt haben.


    Alle Kabel angeschlossen und mit dem Antenneneingang am LCD verbunden (mit dem Kabel aus dem Anhang - linke Seite an den Antenneneingang am Fernseher und rechte Seite an den C64).

    Den C64 eingeschaltet und die rote Leuchte leuchtet.

    Den Fernseher auf Antenneneingang gestellt.

    Erstmal ist nur Schnee zu sehen, daher dann den Sendersuchlauf gestartet.

    Resultat: Ein Sender wird gefunden, aber das Bild auf dem Sender bleibt schwarz (siehe Anhang).


    Wie sollte ich in meinem Falle nun am Besten vorgehen?


    Punkt 1:

    Die Platinenversion ist sehr Wichtig für korrekte Hilfe. Bei Commodore Platinen steht meist ASSY gefolgt von einer Nummer drauf, die wollen wir wissen.

    ASSY NO. 250407


    Punkt 2:

    Ist das Gerät modifiziert oder noch Orginal? eventuell andere ROM´s drin?

    Ich vermute modifiziert. Auf der Rückseite ist noch ein roter Taster und ein Schalter angebracht - die stehen in der Bedienungsanleitung nicht drin.


    Punkt 3:

    Ist das Netzteil Orginal oder schon mal durch ein anderes ersetzt worden?

    Aufgrund des Aussehens und Alters würde ich auf Original tippen.


    Punkt 4:

    Tritt der Fehler nur auf wenn Zusatzhardware angeschlossen ist?

    Nein, auch wenn keine Zusatzhardware angeschlossen ist.


    Punkt 5:

    Tritt das Problem sporadisch auf oder ständig?

    Ständig.


    Punkt 6:

    Werden irgendwelche Chips besonders heiss? so das man sich fast die Finger dran verbrennt?

    Nein, keine Auffälligkeiten.


    Punkt 7:

    Hat der Fragesteller ein Multimeter und weiss wie das benutzt wird?

    (Die billigen 5-Euro Multimeter reichen für diesen Job aus)

    Ja, ich besitze ein günstiges Multimeter. Ist aber lange her, dass ich das verwenden musste, daher eher keine Ahnung.


    Punkt 8:

    Hat der Fragesteller irgendwelche Erfahrungen im Löten? wenn nicht gleich sagen.

    Ja, rudimentäre Kenntnisse sind vorhanden.


    Neben dem C64 war noch eine Datasette und ein Floppy 1541 dabei.

    Die Datasette (Vorspulen, Rückspulen, Abspielen) funktioniert zumindest beim Anschluss an den C64.


    Sollten weitere Informationen benötigt werden, stelle ich diese gerne zur Verfügung.


    Danke im Voraus!

  • Schwarzer Bildschirm ist gut, du hast den Sender gefunden.



    Blau: IC samt Adaptersockel mal rausnehmen und neu stecken, vielleicht ist da der Kontakt schlecht.

    Grün: Das ist der Sound-Chip - vorsichtig rausnehmen und auf der Seite liegen lassen; Beinchen nicht mit den Händen anfassen!

    Pink: IC (CPU) vorsichtig aus der Fassung nehmen. Kontrollieren ob alle Beinchen da und gerade (nicht verbogen). Vorsichtig wieder einsetzen, vielleicht ebenfalls Kontaktproblem.


    Ausprobieren.


    Rot: Diese beiden sind ansonsten die ersten Verdächtigen. Davor aber noch Spannung messen, Takt und Reset prüfen. Das machen wir, wenn du die ersten drei Dinge erledigt hast.

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Versuch hinten mal den Schalter (Kernel-Umschaltung) umzulegen bzw. den auf Wackelkontakt zu checken. Gibt es den Original-Kernel-ROM-Chip (901227-0x) noch?

    Den Schalter umzulegen hat kein Ergebnis gebracht.

    In beiden Stellungen ist der Bildschirm schwarz.

    Einen anderen Chip dazu habe ich leider nicht - nur was im Gerät verbaut ist.

  • Blau: IC samt Adaptersockel mal rausnehmen und neu stecken, vielleicht ist da der Kontakt schlecht.

    Grün: Das ist der Sound-Chip - vorsichtig rausnehmen und auf der Seite liegen lassen; Beinchen nicht mit den Händen anfassen!

    Pink: IC (CPU) vorsichtig aus der Fassung nehmen. Kontrollieren ob alle Beinchen da und gerade (nicht verbogen). Vorsichtig wieder einsetzen, vielleicht ebenfalls Kontaktproblem.

    Pink konnte ich rausnehmen und wieder einsetzen. Alle Beinchen gerade.

    Blau und grün kann ich nicht ohne Weiteres lösen - möchte da auch nichts kaputt machen.


    Wie geht man am Besten vor, um die Chips zu entfernen?

    Darf / sollte Kontaktspray verwendet werden?

  • Darf / sollte Kontaktspray verwendet werden?

    Nein.


    Wie geht man am Besten vor, um die Chips zu entfernen?

    1. zwei neue ICs besorgen (das sind 74LS257, gibts an jeder Ecke)

    2. an den alten Chips mit einer kleinen Zange (oder du vergewaltigst eine Nagelschere) die Beinchen abknipsen (dabei die Platine nicht Beschädigen) und die ICs entsorgen

    3. die Pins in der Platine mit Pinzette und Lötkolben vorsichtig rausziehen

    3b. die Lötstellen an der Platine von Zinn befreien, sodass man dort wieder was einlöten kann (Entlötlitze oder besser Handpumpe)

    4. neue Doppelfederkontakt-Sockel einlöten (die du natürlich zusammen mit den ICs besorgt hast)

    5. Chips draufstecken

    6. Einschalten

  • Konnte die IC's nun entnehmen mit Hilfe eines Kunststoffspachtels, den ich noch von einer Handreparatur hatte.

    Blau, Grün und Pink habe ich nun einmal entnommen gehabt und augenscheinlich waren die in Ordnung. Alle Beinchen gerade.

    War beim ersten Mal wohl doch zu zaghaft - da fehlt die Erfahrung einfach. "Nach fest kommt ab..."


    Habe sie danach wieder in die Fassung gesetzt und getestet.

    Das Bild bleibt schwarz.


    Dann geht es wohl doch hiermit weiter?


    Rot: Diese beiden sind ansonsten die ersten Verdächtigen. Davor aber noch Spannung messen, Takt und Reset prüfen. Das machen wir, wenn du die ersten drei Dinge erledigt hast.


    Aber wie ist die Frage? :-)

  • Vor dem Austausch der MOS Multiplexer 74LS257, sollte ich da noch was nachmessen?

    Rot: Diese beiden sind ansonsten die ersten Verdächtigen. Davor aber noch Spannung messen, Takt und Reset prüfen. Das machen wir, wenn du die ersten drei Dinge erledigt hast.

    Also Spannung messen, Takt und Reset prüfen? Nur wie mache ich das?


    Was ist das "Blaue" da?

    Sieht aus wie Farbe. Detailfoto siehe anbei.

  • Also Spannung messen, Takt und Reset prüfen? Nur wie mache ich das?

    Versorgungsspannungen messen: Messpunktbilder


    Takt: Hat dein Multimeter Frequenzmessung?


    Reset: Spannung messen an Pin 40 der CPU beim Einschalten.

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • So, die Messpunkte aus dem genannten Link bin ich gerade durchgegangen - Messpunkte siehe Anhang.


    Messpunkt 1: 4,67 V

    Messpunkt 2: 5,06 V


    Messpunkt 3: 15,05 V



    Nachdem der C64 nun ca. 15 Minuten eingeschaltet war, habe ich nochmal geprüft, ob Bauteile warm werden.

    Das einzige Bauteil, das ziemlich heiß wurde war das aus dem Anhang - müsste dann ja der Soundchip sein und erstmal nichts mit der Bildproblematik zu tun haben:



    Eine Frequenzmessung kann ich mit meinem Multimeter leider nicht vornehmen.


    EDIT:
    An Pin 40 der CPU habe ich 4,67 V gemessen.

  • Messpunkt 3: 15,05 V

    etwas viel, hier sollten 12 V anliegen. Nicht gut für SID und VICII

    "Was heute noch wie ein Märchen klingt,kann morgen Wirklichkeit sein.Hier ist ein Märchen von übermorgen.Es gibt keine Kupferka­bel mehr,es gibt nur noch die Glasfaser und Terminals in jedem Raum.Man siedelt auf fernen Rech­nern.Die Mailboxen sind als Wohnraum erschlossen.Mit heute noch unvorstellbaren Geschwindigkeiten durcheilen Computerclubs unser Da­tenverbundsystem.Einer dieser Com­puterclubsist der CCC.Gigantischer Teil eines winzigen Sicher­heitssystems,das die Erde vor Bedrohungendurchden Gilb schützt.Begleiten wir den CCC und seine Mitglieder bei ihrem Patrouillendienst am Rande der Unkenntlich­keit. CCC'84 nach ORION'64"

  • Sollten die 12V dauerhaft anliegen oder nur direkt nach dem Start?

    Bei der Messung von 15,05 V lief der C64 bereits wenige Minuten.


    Welche Handlungsempfehlung ergibt sich aus den genannten Messungen?

    die 12 V sollten dauerhauft anliegen. Eine gewisse Toleranzzwischen 11,75 und 12,25 V ist durchaus möglich. Aber 15 V ist zu viel. Also würde ich erstmal den Regler (7812) tauschen, kostet nur paar Cent. Und falls du Teile bestellst, dann auch gleich Ersatz für die oben angemahnten Logik-Chips von MOS. Das sind 74LS257 .

    Den Soundchip kannst du entnehmen, den braucht es für ein Bild erstmal nicht.


    Generell hilft ein Diagnose-Modul mit den wichtigsten Test´s drauf. Da gibt es sicher jemanden, der dir so ein Modul verkauft. Bobbel hat evtl. Modul wie auch oben genannte Bauteile.


    Reset: Spannung messen an Pin 40 der CPU beim Einschalten.

    das kannst du auch noch machen. Bei Einschalten geht der Wert kurz auf 0 V um dann dauerhaft bei 5 V zu bleiben. ist sehr kurz, aber man sieht es auf dem Multimeter

    "Was heute noch wie ein Märchen klingt,kann morgen Wirklichkeit sein.Hier ist ein Märchen von übermorgen.Es gibt keine Kupferka­bel mehr,es gibt nur noch die Glasfaser und Terminals in jedem Raum.Man siedelt auf fernen Rech­nern.Die Mailboxen sind als Wohnraum erschlossen.Mit heute noch unvorstellbaren Geschwindigkeiten durcheilen Computerclubs unser Da­tenverbundsystem.Einer dieser Com­puterclubsist der CCC.Gigantischer Teil eines winzigen Sicher­heitssystems,das die Erde vor Bedrohungendurchden Gilb schützt.Begleiten wir den CCC und seine Mitglieder bei ihrem Patrouillendienst am Rande der Unkenntlich­keit. CCC'84 nach ORION'64"

    Edited once, last by Markus64 ().

  • Das einzige Bauteil, das ziemlich heiß wurde war das aus dem Anhang - müsste dann ja der Soundchip sein und erstmal nichts mit der Bildproblematik zu tun haben:

    Grün: Das ist der Sound-Chip - vorsichtig rausnehmen und auf der Seite liegen lassen; Beinchen nicht mit den Händen anfassen!

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Messpunkt 3: 15,05 V

    Das ist zu viel...

    Messpunkt 1: 4,67 V

    Und das ist ein bisschen wenig...

    Zumindest wenn man ein gutes Netzteil nutzt!

    Könnte evtl. sein, dass einer der Chips intern nen Kurzschluss hat und deshalb die Spannung etwas nach unten zieht...


    Wie geht man am Besten vor, um die Chips zu entfernen?

    Es gibt spezielle IC-Zieher... Vor kurzem gabs aber in nem anderen Forum schon mal die Diskussion, dass die nicht optimal seien...

    Ich nehm dafür meistenen nen flachen Schlitz-Schraubendreher oder ein Slotblech eines alten Computers...

    Wichtig hierbei nur: an beiden Seiten immer Stück für Stück langsam hebeln... sonst verbiegt man die Pins.



    Und: Glaub in dem Fall bitte Kinzi! Wenn der SID defekt ist und die Spannung runter zieht, dann hast du auch nen schwarzen Bildschirm...

    Und nachdem der gesockelt ist: raus damit!

    Vielleicht vorher aber mal an den Erdungspin der Steckdose fassen... Ein ESD Armband wäre natürlich besser...

  • Die gelöteten Chips kann man am Besten mit ner Entlötstation auslöten... wenn das nicht vorhanden ist: die 74LS257-Chips tatsächlich vorsichtig abknipsen... dabei aber bitte versuchen keinen Druck auf das Board aufzubauen!

    Bei den anderen Chips das bitte nicht machen! Die kosten neu teilweise bis zu 25€....


    Wobei ich auch Markus64 zustimme... ohne eine Diagnosekarte, einem Logikstift oder einem Oszi wird die weitere Fehleranalyse etwas schwierig...

    Wo wohnst du denn? Vielleicht wohnt ja jemand mit mehr Ausrüstung in deiner Nähe...