Hello, Guest the thread was called4.8k times and contains 102 replays

last post from drerich at the

A2000 Reanimation - GVP G-Force 68040 EPROM wohl hinüber

  • Du hast ja Recht; es gibt viele Fehlerquellen bei einem alten Computer und natürlich sind auch EPROMs verdächtig mal auszufallen - ist zwar selten, aber könnte sein... ein Guru-Rom hätte ich hier in meinem GVP-Controller..


    Durch den Test von muellerarmack haben wir ja schon gelernt, dass ansich der 2000er nicht die Ursache deines Problems ist - denn es wäre unwahrscheinlich, dass sein 2000er die gleichen "defekte" hat wie deiner.


    Ein Problem, welches sich - zumindest bei anderer Amiga-Hardware - herausgestellt hat, sind alternde Elektrolyt-Kondensatoren, die ihre Kapazität verlieren und dadurch gerade Versorgungsspannungen nichtmehr störfrei puffern.

    Auf der Karte sind aber - zumindest was ich auf den Referenz-Bildern gesehen habe, eher Tantals.. also auch das könnte man ausschliessen.


    Was noch sein könnte, wären Kontaktprobleme bei den gesockelten Chips (sowohl die Fat-Packs als auch die "normalen" ICs..) - wenn du einen "größeren" Akkuschaden hattest, dann kann es durchaus vorkommen, dass die Akkudämpfe sich auch dort niedergeschlagen haben ... evtl. könnte man die Chips einmal herausnehmen und neu einsetzen? Etwas Vorsicht ist geboten, weil gerade die großen Sockel aufgrund des Alters leicht brechen können. (oder evtl. schon sind?)

  • Auf der Karte sind aber - zumindest was ich auf den Referenz-Bildern gesehen habe, eher Tantals.. also auch das könnte man ausschliessen.

    Jaien.... alte Tantals neigen gerne mal zu Kurzschlüssen. Und nicht immer verabschieden die sich dabei in einer kleinen Rauchwolke.


    Das nur mal so als Hinweis.

  • Das mit den Kondensatoren finde ich nun spannend.

    Frage eines Unwissenden: Kann man die eingebaut testen? Auslöten will ich die nur, wenn es anders nicht geht.

    Sichtkontrolle ist sowieso die erste Option.

    Auf der Karte ist nur ein IC gesockelt. Den hatte ich herausgenommen und vorsichtig gereinigt.

    (Auf dem Motherboard hatte ich das mit allen gesockelten Bausteinen gemacht. Erfolgreich - danach lief der A2000 erst wieder. s.o.)

  • Tantals in dem Alter sind tickende Zeitbomben. Die gehören mMn ohnehin allesamt ausgetauscht. Entweder die rauchen heute oder morgen ab, oder sterben halt leise. Machen auf jeden Fall nur Probleme über kurz oder lang.

    Wenn man SMD Tantals ersetzen will kann man auf Kyoceras Niobium Kondensatoren wechseln, die sollen angeblich hochohmig sterben. :)


    https://www.kyocera-avx.com/products/niobium/


    Allerdings kann man glaube ich auch einfach durch moderne Tantals tauschen, die werden uns vermutlich auch überleben...

  • Man sollte niemals nie sagen. Ich würde die Kondensatoren zunächst in Ruhe lassen.


    Mal grob überschlagen habe sicherlich über 100 Retrogeräte repariert. Vom VC20 über div. Karten bis hin zum A3000. Defekte Kondis verursachen Probleme wie instabiler Betrieb, Störungen von

    Bauteilen, so dass z.B. die Grafik o. die Soundausgabe gestört sind, aber bisher hatte ich keinen Fall, dass ein (teil)defekter Kondi einen Totalausfall verursachte. Wie gesagt, ich will das nicht ausschließen,

    sondern nur meine Erfahrung hier teilen.


    Wenn das meine Karte wäre, würde ich nur Teile auslöten / prüfen, die für die Symptomatik in Fragen kommen. Dafür musste Du aber eine Top Ten der wahrscheinlichsten Fehler zunächst recherchieren. Also

    entweder Leute Fragen, die die Karte haben o. sich damit auskennen (Vielleicht Blindgermen, Mig, A1k) oder die Foren durchwühlen. Beim C64 arbeitet man sich beim Klassiker "Blackscreen" an den wahrscheinlichsten

    Bauteilen wie z.B. den PLA ab.


    Bei Deiner Karte kenne ich leider nicht diese Topten. Defekter Ram und Oszi waren halt meine persönlichen Erfahrungen mit der 2630er.


    Bevor Du den Lötkolben schwingst würde ich mir so eine Liste der Most Wanted zusammenstellen und diese abarbeiten.


    Alternativ wie ich oben angemerkt habe, Multi und Oszi zücken und die Karte durchmessen. Dafür wirste Du das Board vom A2000 ausbauen müssen, ansonsten kommst Du an die Messpunkte

    der Karte im eingebauten Zustand nicht richtig ran. Du siehst damit schon, dass wird dauern.


    Daher mein Tipp: Recherchiere Dir zunächst eine TopTen zusammen.


    PS.: Nicht kleinkriegen lassen. Die Karte wird zu reparieren sein.

  • Ich tippe ja mal auf die GALs und PALs, falls die CPU auf dem Board noch lebt. Die Frage ist, wie kann man die testen? Man könnte ja zumindest mal schauen, ob die bei gewissen Inputs überhaupt irgendwelche Outputs generieren.


    Wie man die ersetzen könnte? Tja, ich vermute jemand könnte die vielleicht von einer intakten Karte reverse engineeren...?


    Oder vielleicht kann man schauen, ob man jemanden findet, der an der Karte gearbeitet hat? Die Firma ist in einer gewissen Form zumindest noch im Netz präsent, auch wenn da seit 10 Jahren nix aktualisiert wurd:


    http://gvp-m.com/


    Ansonsten schaut es so aus, dass Jeff Boyer der technische Chef der Firma gewesen ist. Er war scheinbar bis 1989 noch bei Commodore, und danach bei GVP. Auf Linkedin habe ich den Kollegen nicht gefunden, aber vielleicht hat die obige Firma ja Kontaktinformationen und irgendwer hat noch Schematics, JED-Tabellen oder sonstwas. :)


    Es ist nur ein Strohhalm, aber wer weiß... Welche Arten von GALs und/oder PALs stecken denn auf der Karte?

  • da fällt mir noch was ein, Mist hätte ich auch gleich mittesten können: Eine einfache Methode wäre die Überprüfung der Chiptemperaturen.


    Baue die Karte ein, schmeiß den Amiga an, warte ein paar Minuten. Dann fühlst Du die Chips ab. Sollte einer dabei sein, der richtig heiß wird, dann hättest

    Du einen Übeltäter gefunden. Nur oberflächlich den Kunststoff abtasten, keine Kontakte berühren!

  • Ohne jetzt die Karte zu kennen:


    Tantals sind ja damals meist in Bereichen der Spannungsversorgung eingesetzt worden.


    Wenn da was defekt ist....geht halt erstmal nix bis sehr wenig.

  • Sehe ich auch so, ich würde erstmal gucken ob alle ICs die benötigte Spannung bekommen und ggf die Leiterbahnen dann zurückverfolgen .... Problem ist warscheinlich der fehlende Schaltplan ;)


    Ich hatte die Karte selber mal im Einsatz, leider kam man damals nur schwer bis garnicht an GVP RAM heran so dass ich die ziemlich bald wieder verkauft habe :(

  • nun muss ich mal schimpfen...

    ich hatte diese Frage gestellt und die entsprechende Antwort vom muellerarmack bekommen

    Quote

    - wechselt der Bildschirm von dunkel auf grau? oder macht etwas ähnliches? (kurzes Aufblitzen, etc..)

    => Nein


    drerich schreibt im A1K-Forum aber, dass der Bildschirm durchaus von dunkel-grau auf hell-grau wechselt.


    Beim Amiga ist das ein riesen Unterschied, weil es mehrere Aussagen zulässt:

    1. Die CPU arbeitet Befehle ab, die den Farbwechsel erzeugen.. diese kommen aus dem Kickstart-ROM

    ergo: Takt okay, Spannungsversorgung ausreichend, Buszugriff von TK auf Mainboard okay


    2. Vor dem Wechsel werden üblicherweise alle Bootroms der Erweiterungskarten (auch die der Turbokarte) ausgeführt

    ergo: zumindest "stört" das die Kickstartroutine nicht, was dort drin steht - also wären auch die Bootroms (GuruRom) in Ordnung


    3. nach dem hellen Bildschirm folgt ein RAM-Test (Detektion von Chipram und Fastram-Bereichen) mit anschliessendem Umbiegen der exec-base auf den Fastram.

    da es zu keinem weiteren Farbwechsel kommt (es folgt ein "schnee-weiss"), muss der Fehler zu diesem Zeitpunkt stattfinden

    ergo: Zugriff auf den Turbokarten-RAM fehlerhaft(defekter Riegel, defekte Leitungen) oder Burstmode problematisch oder falsche RAM-Größe erkannt/eingestellt, defekter Bustreiber auf der Karte auch möglich.

  • Siehe mein post 60, Stichwort TFT

  • es geht ja nicht darum, wer Recht hat oder so.. ich wollte es eben nur einmal sagen, dass wir mit diesem Hinweis schon einen Schritt weiter an der Lösung sein können.

    Am Ende wollen wir doch dem drerich helfen und er soll eine funktionsfähige Karte haben...

    Und dass sie oben beschriebenes Verhalten "zeigt", macht mir nun etwas mehr Hoffnung.


    PS: wo ist die Karte denn inzwischen? wieder zurück bei erich? oder hast du sie noch, muellerarmack ?

  • Ach - GVP mal wieder..... :thumbdown:


    In meinen Augen ist GVP mal gut gewesen - früher :pumpkin:


    Die Programmierten Bausteine haben ihre Lifetime überschritten und versagen ihren Dienst. Da die Inhalte nicht bekannt sind - insbesonderen auch jedwede Form von den "MACH" ICs nicht mehr zu bekommen sind, sind die GVP TKs nur noch Deko für die Wand.


    Solange sie laufen? Gut! Wenn defekt -> Kernschrott! In letzter ZEit häufen sich die Anfragen mit Reparaturenvon defekten GVP TKs :loet


    Ich habe hier 3 Karten - allesamt -> :bmotz:  :grab1:

  • Kernschrott!

    naja.. hier "zuckt" die Karte ja noch - zumindest möchte ich das mal glauben. :rolleyes:


    Vielleicht finden wir ja den Übeltäter doch noch ausserhalb der Logik-ICs .. dann könnte man es reparieren.

    Speicher ist ja wohl auch so ein Sonderthema bei den GVPs.


    DigitalKeeper , hast du denn schonmal eine Karte gehabt, die zumindest die erste Hürde vom Kickstart nimmt, dann aber nicht weitermacht? und was würdest du unternehmen ?


    PS: ja.. immer in 2 Foren nachzugucken, wo welche Informationen dazu stehen, ist auf Dauer mühsam, jedoch wollen/können nicht alle F64er im A1K sein und umgekehrt...


    hier wäre der A1K-Link: https://www.a1k.org/forum/inde…reads/81845/#post-1542707 (den müsste man auch sehen, wenn man nicht angemeldet ist, oder?)

  • Meine "Zucken" gar net - da bleibt alles schwarz, was üblicherweise bei dem "GVP Kram" auch Normal ist.


    Ich habe so den Verdacht, das eine "Lifetime" in den programmierten ICs und der Logik eingebaut ist, respektive programmiert wurde.


    Das Thema ist an verschiedenen Stellen schon einmal angepsrochen worden, da sich in Bestimmten Situationen die "Ausfälle" häufen, was ein klarer Hinweis auf so etwas ist.


    SO - viele - Zufälle - gibt es nicht! :pumpkin:

  • Ich habe so den Verdacht, das eine "Lifetime" in den programmierten ICs und der Logik eingebaut ist, respektive programmiert wurde.

    Warum sollte man sowas machen? Damit es 2021 kaputt geht, und für nen Computer Oldie nicht mehr vorhandener Ersatz gekauft wird, bzw bei einem Hersteller (falls überhaupt noch vorhanden) der die Karte gar nicht mehr führt?

    Vielleicht sind einfach nicht so besonders haltbare Bauteile genommen worden (ungleich bewusst "einprogrammierte" Lifetime)

  • Ich habe so den Verdacht, das eine "Lifetime" in den programmierten ICs und der Logik eingebaut ist, respektive programmiert wurde.

    Warum sollte man sowas machen? Damit es 2021 kaputt geht, und für nen Computer Oldie nicht mehr vorhandener Ersatz gekauft wird, bzw bei einem Hersteller (falls überhaupt noch vorhanden) der die Karte gar nicht mehr führt?

    Vielleicht sind einfach nicht so besonders haltbare Bauteile genommen worden (ungleich bewusst "einprogrammierte" Lifetime)

    PALs und GALs haben auf jeden Fall ne begrenzte Lebensdauer. Irgendwann gehen sie karpott... Vermutlich haben die halt die gleichen Bauteile für die Karten genommen und daher gehen die jetzt auch alle mehr oder minder karpott... Vielleicht sollten wir mal herausfinden, ob noch Beteiligte aus dem Unternehmen Unterlagen dazu haben. Man weiß ja nie...