gestörte Bildausgabe - Plus/4 läuft aber trotzdem

  • Ich hatte mir quasi als Teilespender für meinen Haupt-Plus/4 einen weiteren gekauft, in der Annahme ich könnte dort die Gehäuse- und Tastatur-Teile rausnehmen, die bei meinem Haupt-Plus/4 nicht so toll sind. Leider habe ich genau so einen Rechner erwischt, bei dem die Teile nicht passen (andere Tastaturmechanik). Das Tastaturkabel ist ausgefranst, die Leertaste fehlt und der Board-Connector ist auch irgendwie beschädigt. Nunja, dann versuche ich den Teilespender so gut es geht wieder hinzubekommen. Ich habe dazu schon ein bisschen mit @cbm-warrior geschrieben, aber ich denke, die Fehlersuche kann evtl. auch für andere und zur Doku interessant sein.


    Der Teilespender hat eine kaputte CPU, die weder da noch im Hauptrechner funktioniert. Der TED funktioniert, wenn ich ihn umsetze. Also schon mal ein Punkt auf der Habenseite. Mit der CPU aus dem Hauptrechner funktioniert auch der Teilespender in soweit das ich eine Ausgabe in dieser Form hier bekomme:



    Just für diesen Rechner habe ich mir ein Diag264-EEPROM brennen lassen und eine Original-Cartridge gesockelt. Mit der so gebauten Diag-Cartridge gebootet sehe ich Bildwechsel auf dem Schirm und irgendwann ertönen auch die Testtöne. Der Rechner funktioniert also und nur die Bildausgabe ist durch irgendetwas gestört. Jetzt dachte ich mir, es könnte das Trimpoti im TED-Käfig sein. Drehe ich leicht daran, dann sehe ich auch in gewissem Maße eine Änderung, aber nichts durchschlagendes.


    Was könnte für so einen Bildfehler verantwortlich sein? Die Spannungen stimmen und wie geschrieben funktioniert der TED in einem anderen Board 1a. Die ROMs und den RAM würde ich bei so einem Fehler jetzt mal ausschließen. Das könnte doch dann eigentlich nur noch irgend ein Kondensator oder der Modulator sein?


    Hier mal eine Aufnahme vom Board.



    Nicht wundern, das hier die Tastatur dran hängt. Ich habe die losen Enden abgeknipst und als Übergangslösung den Kunststoff von den Leiterbahnen weggemacht und das ganze in den Connector gefummelt. Wenn ich den Rechner wieder ganz bekomme, dann will ich dort auf beiden Seiten Pin-Header einlöten und dann die Tastatur mit Dupont-Jumperkabeln anschließen.

  • What @ADAC said, miss mal mit dem Frequenzzähler den Takt am TED. Die 17,73 MHz müssen am TED, Pin 14 anliegen, an Pin 12 der CPU-Takt (886 kHz oder 1,76 MHz).


    Siehe: https://www.c64-wiki.de/wiki/TED


    Die Takterzeugung passiert diskret wie beim C16 mit einer Transistorstufe:



    Eventuell ist eines der Bauteile stark gealtert.

    Just für diesen Rechner habe ich mir ein Diag264-EEPROM brennen lassen und eine Original-Cartridge gesockelt. Mit der so gebauten Diag-Cartridge gebootet sehe ich Bildwechsel auf dem Schirm

    [OT]


    Tipp am Rande:


    Von Diag264 gibt es auch eine Kernal-Version, die sich statt des Kernal-ROMs einsetzen lässt; diese ist universeller, weil für deren Funktion die Cartridge-Erkennung, das Kernal, usw. nicht funktional sein müssen. Würde ich mir auch noch brennen (lassen).


    [/OT]

  • Da ist tatsächlich ein NTSC-Kernel drauf. *whoot*. Hatte mich jetzt nur am Oszi-Takt orientiert, und da sind 17,xx MHz ja PAL. Da hat mir ja einer was zusammen gestoppelt. *grrrr*


    Aber das Diag264 läuft doch imho Kernelneutral, oder? Da müsste doch dann ein sauberes Bild kommen? Ob mein TV jetzt NTSC kann kann ich Dir adhoc garnicht beantworten. Ich würde jetzt mal nicht von ausgehen, ist ja ein Modell für den Euro-Markt.

  • Aber das Diag264 läuft doch imho Kernelneutral, oder?

    Nein, sowohl das Cartridge- als auch das Kernal-Diag gibt es als PAL- und als NTSC-Variante, siehe: http://inchocks.co.uk/commodore/Diag264/


    Und hier noch der Schaltplan des plus/4 in der Schaltplangalerie:
    https://www.forum64.de/gallery…6/3317-86160f0e-large.gif

  • Ich hab was gefunden. Mit "P" gedrückt startet das Diag264 im PAL-Mode.


    Nevertheless, for both the cartridge and kernal options, it is possible to override the default by holding down ‘P’ or ‘N’, as the machine is powered on, to force the software into PAL or NTSC respectively.


    Und wenn ich das mache, dann hab ich auch ein Bild. Bestens. Heißt also ich muss nochmal um eine ROM-Brennung bitten, aber da weiß ich schon, wen ich kontakte.


    Case closed. Und wieder mal Lehrgeld bezahlt das einem so ein zusammengestoppeltes Ding untergejubelt wurde.


  • Case closed. Und wieder mal Lehrgeld bezahlt das einem so ein zusammengestoppeltes Ding untergejubelt wurde.

    Mal ganz blöd gefragt: ist auf der Unterseite ein normales Typenschild?


    Ab und an tauchten auch mal umgebaute NTSC-Rechner auf, die erkennt man am Gehäuse jedenfalls einfach, das das US-Typenschild nicht in die Aussparung dafür paßt und meist irgendwo daneben geklebt wurde.


    Umbau ist ja nur Tausch des Quartzes und des Kernel-ROM. Ob der Modulator bei Antennenbetrieb auch getauscht werden muß, weiß ich nicht, bei Monitorbetrieb jedenfalls nicht.

  • Mal ganz blöd gefragt: ist auf der Unterseite ein normales Typenschild?

    Ja, ein ganz normales. Die Seriennr. DA4 ..... und Made in W.-Germany. Ich nehme mal an, da wird einfach einer einen vermeintlich und auf den ersten und zweiten Blick kompletten Rechner zusammengesteckt haben. Fällt ja erst bei näherer Diagnose auf, wie wir hier gesehen haben. Oder jemand hat versucht ein defektes PAL-Kernal zu ersetzen und war sich der PAL/NTSC-Problematik nicht bewusst. Ersatz hat nicht geklappt also wurde der Rechner verkloppt. Aber ich denke eher erstes ist der Fall, da ich auch auf der Tastatur eine für das Tastaturmodell nicht passende Leertaste hatte. Es war eine für das Tastaturmodell mit "blankem" Tastatur-PCB und geraden Federn. Beim Rechner war aber eine Tastatur mit Blech-Rückseite und kegelförmigen Federn verbaut. Daher suche ich jetzt noch so eine Spacebar.