Hello, Guest the thread was called1.8k times and contains 29 replays

last post from Spider1982 at the

C64/128-Lazarett mit Check64 durchgetestet

  • Habe ein paar Computer mit so einem ausgeborgten Check64-Modul durchgetestet.
    Zwei davon gehen, mit ein paar kleinen Wehwehchen, die anderen sind leider im derzeitigen Zustand nicht in der Lage irgendwas zu starten.


    Falls jemand dazu Tipps und Anmerkungen hat wäre ich sehr dankbar.


    Hier das Ergebnis:


    C64-DIAGNOSTIC REV 586220
    C128-DIAGNOSTIC REV 789010


    Generelle Anmerkung zum C128DCR:
    Wenn die Tastatur-Diagnose-Platine angesteckt ist, landet man im Basic-Monitor des C128, d.h. der Test geht dann nicht.
    Außerdem war das Kabel für den Datasetten-Test zu kurz und hätte auch nicht hineingepasst, da der blaue Stecker zu breit ist. Dementsprechend war natürlich am C128D immer "Cassette Bad".


    ------------------------------------------
    C64C
    Defekt: Dinge am User-Port gehen nicht (WLAN-Modem und 4-Spieler-Adapter). Schuld ist vermutlich ein defekter CIA, durch einen falsch angesteckten 4-Spieler-Adapter:


    Ergebnis:
    Control Port: BAD
    6581 U18: BAD
    User-Port: OK


    ------------------------------------------
    C128DCR:
    Defekt: Rote Farbe beim 80-Zeichen-Modus fehlt, Datasetten-Port geht nicht (kein Strom?)
    Beides Fehler, die mich nicht wesentlich stören.


    Mit dem C128-Diagnostic Modul:
    6526 U1 BAD
    6526 U4 BAD
    6581 U5 BAD
    Keyboard BAD
    Control Port BAD
    Serial Port BAD


    Mit dem C64-Diagnostic Modul:
    6526 U1 BAD
    6526 U2 BAD
    6581 U18 BAD
    Control Port BAD
    User Port BAD
    Serial Port BAD
    Interrupt BAD


    ------------------------------------------


    C128DCR:
    Defekt: Die Tastatur macht lauter Blödsinn, auch wenn ich die Tastatur verwende, die am anderen C128D funktioniert.
    Die Tastatur, die mit diesem Computer gekommen ist, ist ebenfalls defekt.


    Mit dem C64-Diagnostic hingegen hat das Modul funktioniert, ergebnis:
    6526 U1 BAD
    6526 U4 BAD
    6581 U5 BAD
    Keyboard OPEN
    Control Port BAD
    Serial Port BAD


    ------------------------------------------


    C128:
    Defekt: Zunächst gleich ein Error beim Einschalten. Mittlerweile gibt der Computer nur ein Bild aus wenn man die Commodore-Taste beim Einschalten gedrückt hält. Da gibt es dann aber nur Chaos am Bildschirm.


    Keines der Module hat hier ein Ergebnis geliefert. Beim C64-Dead-Test war ein schwarz/weiß-flackerndes Bild.

  • Beim C128 den Dongle erst nach dem Einschalten aufstecken. Steht auch so in der Dokumentation zum C128 Diag.


    Und das Kabel für den Kassettenport wurde um 10cm verlängert und liegt den aktuellen Bausätzen fertig zusammengebaut bei.

  • Ok, ich hab das jetzt mit dem Tastatur-Dongle richtig getestet. Beim einen war Keyboard erwartungsgemäß ok, und beim anderen "BAD".


    Und jetzt ist die Frage: Was könnten diese Geräte haben?


    1. C64: 4-Spieler-Adapter geht am Userport, WLAN Modem geht dort nicht. Tipp den ich bekommen habe: CIA.


    2. C128D: Da hat wohl der VDC etwas. Und das mit dem Kassetten-Port ist nicht so wichtig.


    3. C128D: Tastatur-Controller am Computer und die Tastatur selbst kaputt. Was könnte da passiert sein?


    4. C128: Tja... Was ist dann kaputt wenn gar nichts mehr geht? Zuerst habe ich auf den RAM getippt, aber offenbar ist da nun mehr defekt.


    Bin für Tipps dankbar, vielleicht kann ich ja beim ein oder anderen Computer doch das ein oder andere Problem beheben.

  • Beim C64-Dead-Test war ein schwarz/weiß-flackerndes Bild.

    Das bedeutet, dass (mindestens) ein RAM defekt ist. Die Anzahl der "Blinker" entspricht der Bitnummer: 1 x Blinken = 1. Bit = Bit #0 defekt.
    Die Blinkfolge wird nach kurzer Pause wiederholt.


    [EDIT]

    Ist beim 128D(CR) normal, da die interne Floppy den Test stört. Beim 128D kann man sie ausstecken; beim 128DCR müsste man eine Verbindung auf der Platine abschaltbar machen.
    Die restlichen


    [/EDIT]

  • Da kommt nun ein neuer C64 dazu.


    Nach dem Anstecken des 8-Spieler-Adapters (der an anderen Geräten problemlos funktioniert) gibt es nun Grafikfehler.
    Das Diagnosemodul zeigt eigentlich nur die Fehler an, die es bei meinem funktionierenden C64 anzeigt.
    Funktionieren tut er - bis auf die Anzeige - ganz normal. Mit Shift + Commodore lassen sich sogar die Zeichen ändern (wie man beim schwarz/roten Beispiel sieht, das eigentlich das Menü vom AC6 anzeigt).
    Das mit der Schrift ist nicht dauerhaft sondern kommt und geht hin und wieder.

  • Schlechte Verbindung bei Datenbit D6?
    Wären nur die Zeichen streifig, wäre das Char-ROM verdächtig.
    Wären nur die Screencodes falsch, wäre das RAM verdächtig.
    Da aber beides auftritt, würde ich am VIC suchen.

  • Alsooo:
    - Tastatur geht wieder! Wurde geöffnet und durchgeputzt, dabei hat sich herausgestellt dass an zwei stellen (Enter-Taste und 0 vom Ziffernblock) die Metallklammern herausgesprungen sind). Womöglich war das der Grund, und vielleicht wurde im C128DCR als das passiert durch einen Kurzen irgenein Chip beschädigt. Welcher das wohl sein könnte? Der CIA?


    - Beim C128 mit dem vermuteten RAM-Fehler wurde ein RAM-Baustein mit seltsamer Lötstelle neu gelötet. Der zeigt nun wieder ein Bild. Wenn auch seltsamer weise mit zwei Klammern am Bild. Schreibt man lauter 0er, so wird an der Position wo die Klammer steht ein 8er draus.
    Das lustige: Schreibt man "Goto 10" dann wird an dieser Stelle des Bildschirms im Basicprogramm wirklich "Goto 18", an einer anderen Stelle "Goto 10" wie erwartet. Ich kann morgen mal Screenshots dazu posten.
    Und schreibt man "Go64" dann landet man im C64-Modus aber mit einem Out of Memory Error. Könnte da eventuell noch ein weiterer Speicherbaustein defekt sein?

  • Beim C128 mit dem vermuteten RAM-Fehler wurde ein RAM-Baustein mit seltsamer Lötstelle neu gelötet. Der zeigt nun wieder ein Bild. Wenn auch seltsamer weise mit zwei Klammern am Bild.

    Könnte da eventuell noch ein weiterer Speicherbaustein defekt sein?

    Ja sicher, genau deshalb werden da ja Klammern statt Leerzeichen angezeigt.

  • - Beim C128 mit dem vermuteten RAM-Fehler wurde ein RAM-Baustein mit seltsamer Lötstelle neu gelötet. Der zeigt nun wieder ein Bild. Wenn auch seltsamer weise mit zwei Klammern am Bild. Schreibt man lauter 0er, so wird an der Position wo die Klammer steht ein 8er draus.
    Das lustige: Schreibt man "Goto 10" dann wird an dieser Stelle des Bildschirms im Basicprogramm wirklich "Goto 18", an einer anderen Stelle "Goto 10" wie erwartet. Ich kann morgen mal Screenshots dazu posten.
    Und schreibt man "Go64" dann landet man im C64-Modus aber mit einem Out of Memory Error. Könnte da eventuell noch ein weiterer Speicherbaustein defekt sein?

    Ja, da ist mindestens ein RAM defekt (Bank0)

  • Obwohl der Test ihn als OK angibt?

    Der PLA-Test testet nur, ob von ROM auf RAM umgeschaltet werden kann und ob aus den drei ROMs jeweils ein Byte korrekt gelesen werden kann. Das PLA generiert aber noch viele andere Signale, die vom C64 selbst gar nicht überprüft werden können (IO1 und IO2, usw.). Die Idee war, dass der Achtspieleradapter irgendwas an einer solchen Leitung "kaputt gemacht" hat und nun mehr als eine Komponente selektiert wird.


    Was ist denn das genau für ein Achtspieleradapter? Wie ist der aufgebaut? Vielleicht ist das die sinnvollere Herangehensweise.