Hello, Guest the thread was called8.6k times and contains 242 replays

last post from Mikson at the

Assy 250407, Rev B - nur schwarzer Bildschirm, auch Module gehen nicht

  • Ich werde mir die Tage nochmal die Chipselects der drei ROMs anschauen und/oder gleich das Basic-ROM tauschen.

    Zumindest ihre Temperaturentwicklung erscheint unplausibel (Messung ohne Dead Test):


    Das Kernal ist jetzt wie gesagt ein EEPROM (AT28C256) - das mag erklären, warum es nur noch so ca. 30° warm wird. Oder auch nicht. Zumindest kann ich die 5V an den drei Adreß-Pullups messen.

    Aber im direkten Vergleich zwischen Basic- und Character-ROM wird das Basic-ROM auffällig warm - zumal es ja gar nicht benutzt werden sollte.

    Also: sind das noch plausible Temperaturen (angenommen, es wird aufgrund anderer Fehler dauernd auf das Basic-ROM zugegriffen) oder ist das ein Kennzeichen, daß es hin ist?


    Nebenbei: ich habe mal versucht, die Lötstellen des Sockels des Kernal-ROMs aufzufrischen (wurde Mitte der 80er bei einem etwas zwielichtigen Händler eingebaut). Dabei fängt aber das verharzte Flußmittel aus den 80ern richtiggehend an zu kochen. Meine Reinigungsversuche waren auch nicht so richtig erfolgreich. Außerdem sehen die Pins extrem breit aus (füllen selbst auf der Lötseite den ganzen Durchmesser des Loch aus). Vermutlich sollte ich den Sockel entsorgen, aber ich sehe da eine ziemliche Gefahr, das Mainboard zu beschädigen. Einziger Lichtblick: muß nicht zerstörungsfrei sein (was den Sockel angeht).

  • Wenn schon Rückbau, dann ist kompletter Rückbau sicher am sinnvollsten. Je mehr du freilegst, um besser kannst du nach Fehlerstellen suchen. Wenn der Sockel an sich (mechanisch) in Ordnung ist, kannst du auch erstmal alle Kontakte einzeln durchklingeln.


    BASIC-Roms sind ungefähr genauso oft hin wie KERNAL-Roms, auch wenn ich jetzt keinen 5er riskieren würde wollen. :) Die hohe Temperatur kann durchaus ein Anzeichen für einen Defekt sein. Der Deadtest sollte aber trotzdem gehen und dir diesen Defekt anzeigen.


    Das Kolophonium, was da mit großer Wahrscheinlichkeit verwendet wurde, ist nicht verharzt, das IST Harz.

  • Der Deadtest sollte aber trotzdem gehen und dir diesen Defekt anzeigen.

    Zweimal nein:

    • Dead Test testet keine ROMs, weil diese im Ultimax-Mode gar nicht eingeblendet sind. (Kann es also gar nicht. ;) )
    • Ein kaputtes BASIC-ROM kann sehr wohl den Start des Dead Test verhindern ("Bus-Blocker"), erst letzte Woche selbst erlebt. Es wurde aber auch so heiß, dass ich reflexartig die Finger davon genommen habe.
  • Ich hatte das so verstanden, daß ein wirklich defektes Basic-ROM des Bus blockieren und damit auch die Ausführung des Dead Tests verhindern könnte. Oder habe ich das mißverstanden?

    Natürlich gibt es verschiedene Arten von Defekten. Wenn "nur" die Daten im ROM hin sind, geht halt das Basic nicht mehr o.ä. Dann geht der Dead Test noch bzw. vermutlich würden sogar die meisten "nornalen" Module tun.

    Was das "verharzen" angeht: ich wollte da jetzt keine Grundlagendiskussionen lostreten, sondern nur den Effekt beschreiben. Daß Kolophonium zumindest früher als Flußmittel benutzt wurde und zumindest bei Löten von Hand nach wie vor wird, dürfte jedem klar sein, der schon mal was gelötet hat.


    [EDIT]

    @kinzi: war mal wieder zu spät

  • Ich hatte das so verstanden, daß ein wirklich defektes Basic-ROM des Bus blockieren und damit auch die Ausführung des Dead Tests verhindern könnte. Oder habe ich das mißverstanden?

    Nein, da hast du nichts Mistversatnden. Jedes Rom (Kernal, Basic oder Char) kann dir den Bus blockieren wenn es defekt ist.

  • Ups, klar, das war ja Commodore Diagnostics mit der Checksummen-Prüfung, nicht der Deadtest.


    Aber Kolophonium blubbert, wenn es heiß wird. Da ändert sich nicht viel, auch nicht nach dreißig Jahren. Da bin ich mir nun aber sicher. :)



    EDIT: Mit dem VIC20-DeadTest vermengt. Der prüft auch die ROMs. Sorry für die Verwirrung.

  • Die hohe Temperatur kann durchaus ein Anzeichen für einen Defekt sein.

    "kann" aber muss nicht - wenn ein anderer Fehler dafür sorgt dass sich die Roms aufheizen weil sie dauerhaft angesprochen werden liegt man nämlich mit der Annahme falsch die Temperatur könnte ein Anzeichen dafür sein...


    Interessant wirds nämlich wenn z.B. Kernal Basic und Charrom alle drei heiß werden (was sie sonst eigentlich nicht so sehr sind)...Dann liegt der Fehler eben nicht an den drei Roms sondern eben woanders.

  • Wobei ja wie gezeigt nur das Basic-ROM wirklich heiß (>50°C) wird. Wenn man sich meine älteren Bilder (noch mit dem original Kernal auf der alten Umschaltplatine) anschaut, sieht man, daß auch da schon das Basic-ROM wärmer als das Kernal-ROM war.

    Also entweder wird aus irgendwelchen Gründen das Kernal-ROM öfter strärker benutzt als die anderen ROMs oder es hat einen Hau.

    Nebenbei: mußte gerade feststellen, daß zwei ROM/E(E)PROM-Adapter nicht wirklich nebeneinander passen. Das fehlt mindestens 1mm. Es ist aber auch nichts einfach.

  • Also entweder wird aus irgendwelchen Gründen das Kernal-ROM öfter strärker benutzt als die anderen ROMs oder es hat einen Hau.

    Das BASIC wird gar nicht benutzt, kann also nicht heißt werden, außer es wird fälschlicherweise dauernd selektiert - da das PLA aber nicht defekt ist kann das nicht sein.

    Es ist aber auch nichts einfach.

    Ja, das ist bei unserem Hobby so. Einfach ist, in den Media Markt zu gehen, 1000 Euro auf den Tresen zu knallen und ein Notebook mitnehmen. Aber wer will das schon ... :D

  • Hatte auch mal so ein Chinateil, aber so richtig glücklich war ich damit nicht. Ich habe mir deshalb vor vielen Jahren eine etwas bessere (und leider überproportional viel teurere) Entlötstation von Metcal/OKi (MFR 1300) zugelegt. Damit geht es definitiv besser als mit einer mechanischen Entlötpumpe, aber ein reiner Spaß ist es auch nicht. Bei DIPs hängt halt irgendwie immer noch ein winziger Rest Lötzinn fest und dann muß man immer wieder neu löten und entlöten, bis irgendwann alle Pins frei sind.

  • Bei DIPs hängt halt irgendwie immer noch ein winziger Rest Lötzinn fest und dann muß man immer wieder neu löten und entlöten, bis irgendwann alle Pins frei sind.

    Quatsch, die Reste kommen mit etwas Entlötlitze weg, da muss man nicht immer wieder löten und entlöten.

  • Hm, ich habe mir auch gerade eine ZD-Lötstation zugelegt, und das Entlöten funktioniert damit

    wirklich gut. Mich stört nur, dass die Entlöte pistolenförmig ist, sodass ich die Platinen hochkant

    nehme, und dass das Ding beim Absaugen klingt wie eine Kuh und dabei auch ungefähr genauso

    laut ist. Ansonsten traumhaft. Wenn ein Beinchen minimal hängt, läßt sich das mit einem Messer

    eigentlich meistens durch Wegdrücken von der Stelle, an der's hängt, frei machen.

    Vorheriges Neulöten der Stelle inklusive Begradigung von vorm Einlöten umgebogenen Beinchen

    muss aber sein; Lötauge, sei wachsam! :-D

  • Vorheriges Neulöten der Stelle inklusive Begradigung von vorm Einlöten umgebogenen Beinchen

    muss aber sein; Lötauge, sei wachsam! :-D

    Also ich "wiege" die Beinchen mit der ZD-915 etwas frei; wichtig dabei ist, dass die Temperatur hoch genug ist und man die Düse schräg auf das Lötauge ansetzt, nur so hat man optimale Wärmeübertragung. Setzt man die Pistole genau senkrecht auf klappt es schlecht. Dann das Beinchen wie gesagt etwas frei wiegen ("einmal links, einmal rechts") und schön kräftig saugen. Bei den ganz hartnäckigen gehe ich an der Oberseite wie gesagt noch mit Entlötlitze ran - feddisch. :pumpkin: Nur beste Erfahrungen damit. :thumbsup:


    Ich hab noch so gut wie nie ein Lötauge nochmals nachgelötet und erneut entlötet.

  • Da muss ich also noch üben. ;-)

    Ohne zuerst alle Lötstellen einmal neu zu löten klappt das bei mir nicht, wie Du's beschreibst;

    selbst, wenn die Beinchen sich schon bewegen, läßt sich nicht alles absaugen. Temperatur habe

    ich auf 360 Centigrades..


    Im Grunde bin ich allerdings jetzt schon ganz glücklich, dass es doch viel komfortabler ist als mit der

    beheizbaren Entlötpumpe und mir nix mehr abreißt. Die Übungs-469er sollte ich am besten als

    Winterprojekt für einen Reparaturmeister anbieten... :whistling: :loet:odo