Hello, Guest the thread was called494 times and contains 27 replays

last post from Gerrit at the

1541-II ewig "searching for"

  • Hallo liebe c64-community :),


    ich habe ein defektes floppy 1541-II in kombination mit einem funktionierendem c64 erstanden und wollte euch experten hier einmal nach eurer ersten einschätzung des defekts vom floppy fragen ;).

    Beim einschalten hört man kurz den motor drehen und beide led's leuchten, später nur noch die rote, soweit alles normal, wenn ich mich richtig an früher erinnern kann :thumbsup:.

    Wenn ich nun zb "LOAD "$",8" an das laufwerk schicke tut sich nichts, kein geräusch und die led's ändern sich auch nicht. Auf dem bildschirm steht währenddessen die ganze zeit "searching for".

    Mir ist aufgefallen, als ich diese anweisungen durchgegangen bin (1541: Wartungs- und Einstellarbeiten), dass die widerstandswerte für die leitungsfarben bei mir alle um den gleichen faktor größer sind, als die, die sie eigentlich sein sollen:



    Braun nach Schwarz: 96 ohm sollen sein 64 Ohm

    Braun nach Rot: 48 ohm sollen sein 32 Ohm (hier ist bei mir, wenn ich das äußerste rot nehme ein unendlich großer widerstand)

    Schwarz nach Rot: 49 ohm sollen sein 32 Ohm (auch unendlich großer widerstand mit dem äußerem rot)


    Orange nach Gelb: 96 ohm sollen sein 64 Ohm

    Orange nach Rot: 50 ohm sollen sein 32 Ohm (hier umgekehrt: unendlich großer widerstand mit innerem rot)

    Gelb nach Rot: 50 ohm sollen sein 32 Ohm (wieder wie bei orange-rot)


    beim kopf passen alle widerstandswerte.


    Mir ist aufgefallen, dass die widerstandswerte für die ds-50f-mechanik mit meinen werten viel besser übereinstimmt, allerdings steht auf der mechanik mitsumi d500 drauf :/


    beim genaueren hingucken ist mir eine (vielleicht unterbrochene) leiterbahn aufgefallen.





    ein chip ist gesockelt, ich habe ihn bereits einmal raus- und wieder reingesteckt, aber immer noch der gleiche fehler.


  • Bring' mal bitte, sofern nie erfolgt, den Kopf in Mittelstellung auf der Schiene, und miß' mal bitte die 5V und 12V DC Versorgungsspannung.

    3332-dc5ecddb.jpg

    '°'°'°'°'°'°'°'°'°Oo.~>| BASIC programmers never die! They just GOSUB without RETURN! |<~.oO°'°'°'°'°'°'°'°'°'

  • Der C64 geht mit einer anderen Floppy ?

    Ja, mit einem anderen laufwerk funktioniert alles problemlos.



    Könntest du bitte mal den Fehlerkanal auslesen? Hiermit:


    10 open 1,8,15

    20 input#1,ff$,fb$,sp$,se$

    30 print ff$,fb$,sp$,se$

    40 close 1

    beim mir tut sich gar nichts oder ist das normal, dass das sehr lange dauert?

    das laufwerk macht auch keinen einzigen ton

  • Entweder das oder der 7406 oder LS14 am IEC ....

    Der 74LS86 hängt auch am IEC, da wird ATN durchgeroutet. Bei meinen hatten bei dem fraglichen Gatter beide Eingänge UND der Ausgang denselben Pegel. Das geht bei einem XOR aber nur wenn es defekt ist.


    julian_ : Miss mal die Pegel an Pin 11, 12 und 13 des 74LS86 wenn die Floppy eingeschaltet ist.

  • Ich sehe bei reichelt verschiedene mit zb. "hd" oder "sn" am anfang. Ist das egal welche ich nehme solange ls 86/14/06 draufsteht?

    Was vor "74" steht ist nebensächlich, das ist die Herstellerkennung.


    Wichtig ist, dass du die richtige Logikfamilie nimmst, die wird mit keinem, einem oder mehreren Buchstaben zwischen "74" und der Modellnummer gekennzeichntet, z. B. "74LS86". Im C64-Bereich kannst du "74LSxx" und "74xx" (ohne Buchstaben, die Standardfamilie) gefahrlos austauschen. Ebenso sollten 74HCTxx (mit T!) in den meisten Fällen funktionieren.


    Keine gute Idee sind 74HCxx (ohne T), 74ACxx und 74Cxx, wobei man letztere nur noch sehr selten findet.


    Langer Rede, kurzer Sinn: Einen SN74LS86 kannst du nehmen. :)

  • Miss mal die Pegel an Pin 11, 12 und 13 des 74LS86 wenn die Floppy eingeschaltet ist.

    würde ich gerne machen, wenn ich wüsste, wie das geht:D.

    Denke nicht, dass das mit einem multimeter geht, oder? Denn das ist das einzige, was mir zur verfügung steht




    Langer Rede, kurzer Sinn: Einen SN74LS86 kannst du nehmen.

    Danke ^^, diese ganzen bezeichungen haben mich ein wenig verwirrt :S

  • würde ich gerne machen, wenn ich wüsste, wie das geht :D .

    Denke nicht, dass das mit einem multimeter geht, oder? Denn das ist das einzige, was mir zur verfügung steht

    Doch, das geht mit einem Multimeter.

    Zu erwarten wäre:

    Pin 12 und 13: 5V

    Pin 11: 0V

  • würde ich gerne machen, wenn ich wüsste, wie das geht :D .

    Denke nicht, dass das mit einem multimeter geht, oder? Denn das ist das einzige, was mir zur verfügung steht

    Doch, das geht mit einem Multimeter: Schwarze Strippe an Pin 7 des 74LS86, Spannungsmessung DC (Gleichspannung), 20 V-Bereich wählen, dann die rote Strippe nacheinander an die Pins halten, die Gerrit erwähnt hat und die Werte ablesen.

    Danke ^^ , diese ganzen bezeichungen haben mich ein wenig verwirrt :S

    Deshalb habe ich dir ja ein TL;DR angehängt. ;)