Hello, Guest the thread was called2.1k times and contains 29 replays

last post from Goethe at the

Spontaner Tod eines 250469?

  • ja, der VSP Bug ist ein Feature, aber bei den meisten 64ern halt ein von Commodore undokumentiertes, nicht vorgesehenes verbugtes;)

    Von meinen 4, 64ern war zB nur einer

    mit 425 Board wirklich auf der sicheren Seite, habe dann aber mit VIC Tausch und SRAM Ersatz nachgeholfen.

    Man sollte VSP aber auch nicht überschätzen, da wirklich nur eine Hand voll Programme davon wirklich Gebrauch machen.

  • Die Sammelbestellung ist seit dem 2.11.2019 beendet. Ich habe alle Daten aus der Sammelbestellung gelöscht und kann Dir nicht sagen, ob Du Dich eingetragen hast. Wenn Du Dich eingetragen hast, dann hast Du auch etwas bekommen;)


    Aber bevor Du Dich nach SRAM umsiehst, teste erst einmal Deinen Rechner mit VSP-Lab. Ich hatte viele Rechner die innerhalb einer Stunde nur 2-3 Ereignisse hatten. Ich musste lange suchen bis ich eine Rechner hatte, der im Sekundentakt Ereignisse produzierte.

  • VSP wandert mit dem VIC mit, der ist im Prinzip "Schuld" daran. Ich hatte von ca. 5 469er Boards nur eines, wo gar kein VSP auftrat. Die anderen schmissen entweder gleich oder nach spätestens einer Stunde minütlich VSP-Ereignisse raus. RAM tausche (außer SRAM) hat nix gebracht, aber der VSP-Bug-freie VIC war in den anderen Boards auch VSP-Bug-frei. Goethe , ich hätt' noch so eine SRAM64 fertig im Regal (funzt, hatte einen Transportschaden und wartet auf bessere Zeiten) und auch Sockel und Löteisen usw. Wenn's "nur" VSP wäre, wäre das schnell erledigt. Weitere Diagnose müssten echte Experten machen. ;-)

  • knusis danke für den Auffrischer. Ich hatte wohl in einer Zeit weniger Forenaktivität den Absprung von "Ankündigung Sammelbestellung" zu "tatsächlicher Bestellung" verpasst. Kann man den SRAM-Ersatz nun trotzdem noch nachkaufen, gibt es mittlerweile andere Alternativen, oder bleibt mir nichts übrig als einen anderen C64 zu "schlachten"?


    Zum VSP-Thema:


    So, rund 1 Stunde VSP-Test (gestartet mit "kaltem" Gerät) ist nun "durch".

    Da scheine ich wirklich einen Problemgerät erwischt zu haben, immerhin 14 Ereignisse innert dieser Stunde.

    Lustig, dass mir das noch nicht aufgefallen war. Wahrscheinlich sind alle beobachteten Probleme darauf zurückzuführen.


    Gruß, Goethe.
    _______________
    C64, C128DCR, SX64, plus/4, A600HD+Vampire600V2, A300+ACA620, Atari 800+810
    Vectrex, Game Boy, Game Gear, Mega Drive, Mega CD, Genesis 32X, Multimega, Nomad, Saturn, Dreamcast, XBox, PS2, PSP, PS3, Ouya, PS4

    Edited 2 times, last by Goethe ().

  • Was sagt denn das Diagnostic mit Test Harness nun nach mehreren Minuten Durchlauf?

    Das hat auch nach längerer Zeit (mehr als 20min hatte ich es allerdings nicht laufen lassen) "OK" gemeldet.

    VSP wandert mit dem VIC mit, der ist im Prinzip "Schuld" daran. Ich hatte von ca. 5 469er Boards nur eines, wo gar kein VSP auftrat. Die anderen schmissen entweder gleich oder nach spätestens einer Stunde minütlich VSP-Ereignisse raus. RAM tausche (außer SRAM) hat nix gebracht, aber der VSP-Bug-freie VIC war in den anderen Boards auch VSP-Bug-frei. Goethe , ich hätt' noch so eine SRAM64 fertig im Regal (funzt, hatte einen Transportschaden und wartet auf bessere Zeiten) und auch Sockel und Löteisen usw. Wenn's "nur" VSP wäre, wäre das schnell erledigt. Weitere Diagnose müssten echte Experten machen. ;-)

    Danke für das Angebot, aber würde das denn wirklich helfen bei einem VSP-verbuggten VIC? Ist ja nun nach dem Test klar, dass der VIC in diesem Gerät buggy ist. Kann ein Tausch der normalen RAMs gegen knusis' SRAM das denn beheben? Falls ja, würde ich mich über PM zu Abwicklung freuen. :)

  • In der zweiten Betriebsstunde des Gerätes tauchten dann sogar 17 VSP-Bugs auf.

  • Danke für das Angebot, aber würde das denn wirklich helfen bei einem VSP-verbuggten VIC? Ist ja nun nach dem Test klar, dass der VIC in diesem Gerät buggy ist. Kann ein Tausch der normalen RAMs gegen knusis' SRAM das denn beheben? Falls ja, würde ich mich über PM zu Abwicklung freuen. :)

    Ja, das hilft und funktioniert zuverlässig. Man sollte nur, wenn man JiffyDOS gewohnt war, per EF3 einzubinden, daran denken, dass es zu einem leicht veränderten Timing kommt und einige Demos (nur in genau dieser Konstellation) nicht mehr laufen. Hier kann man aber einfach auf den Original-Kernel zurückgreifen oder Jiffy als echtes ROM einbinden, was das behebt. Für die Praxis spielt das also keine Rolle.


    Abwicklung können wir gerne per PM weiter ausführen. :-)

  • Super, vielen dank an ius für einen Bausatz von knusis SRAM!

    Damit klappt der "Problem-Cevi" bzw. Problem-8565R2 nun wieder einwandfrei.

    1h VSP-Test ohne jeden Fehler. :thumbsup: