Hello, Guest the thread was called2k times and contains 30 replays

last post from fepo at the

Newbie Reparaturhilfe / Diagnose ASSY 250407 251137 rev. B - Kein Bild am Antennenausgang, Av-Out schwarz-weiß

  • Hallo, ich bräuchte bitte mal eine Schritt-für-Schritt-Hilfe für Deppen.


    Hab hier nen alten braunen Brotkasten (mit braunen Tasten), der nicht so will wie ich.


    Fehler: kein Bild am Antennenausgang und am AV-Out ist das Bild ganz kurz blau und dann wirds schwarz-weiß


    Punkt 1:

    Die Platinenversion ist sehr Wichtig für korrekte Hilfe. Bei Commodore Platinen steht meist ASSY gefolgt von einer Nummer drauf, die wollen wir wissen.

    ASSY 250407 251137 rev. B


    Punkt 2:

    Ist das Gerät modifiziert oder noch Orginal? eventuell andere ROM´s drin?

    Ich denke original, weiß es aber nicht 100%ig.


    Punkt 3:

    Ist das Netzteil Orginal oder schon mal durch ein anderes ersetzt worden?

    Hab mehrere NT hier, es funktioniert auf jeden Fall eins mit nem anderen C64.


    Punkt 4:

    Tritt der Fehler nur auf wenn Zusatzhardware angeschlossen ist?

    Nö. Hab nix angeschlossen.


    Punkt 5:

    Tritt das Problem sporadisch auf oder ständig?

    ab und an ist das Bild am AV Out auch direkt schwarz und wird erst gar nicht blau. Blau wärs aber auch nur für Sekunde(n).


    Punkt 6:

    Werden irgendwelche Chips besonders heiss? so das man sich fast die Finger dran verbrennt?

    Muss ich noch schaun


    Punkt 7:

    Hat der Fragesteller ein Multimeter und weiss wie das benutzt wird?

    (Die billigen 5-Euro Multimeter reichen für diesen Job aus)

    Ja, ein ganz simples ist vorhanden.


    Punkt 8:

    Hat der Fragesteller irgendwelche Erfahrungen im Löten? wenn nicht gleich sagen.

    Nur wenig im Vergleich ;)


    Nachträge:

    Punkt 9: Reagieren Laufwerke korrekt auf Ladebefehle, mit LED-Blinken oder gar nicht?

    Ist das hier wichtig?


    Fotos kann ich gleich gern nachreichen. Irgendwas bestimmtes ablichten?


    Danke euch schonmal! :thumbup:

  • Wenn er ein Bild macht (egal ob S/W) ist die Einschaltmeldung da?

    Ich denke unter Einschaltmeldung verstehst du den Startbildschirm? Dann ja.

    Zwischen VIC (6569) und dem 74LS629 ist bei der 250407 ein kleines Poti zu finden. Damit kann man die Frequenz in Grenzen nachstellen. Markier dir wie das Poti steht und dann schau ob ein leichtes Nachregeln die Farbe wiederbringt.


    Wegen Antennenausgang... Ist der Fernseher auf Kanal 36 eingestellt?

    Poti bringt keinen wirklich Effekt. Kann ja aber auch nur auf AV Out probieren, auf K36 hab ich ja gar kein Bild. Auf/in dem Metallkasten für die Antennenbuchse sitzen ja auch noch 2 Potis, was können die?


    Ja, Kanal 36, ein anderer C64 funktioniert dort.

  • Ja, Kanal 36, ein anderer C64 funktioniert dort.

    Das heißt ja noch nicht, dass dieser C64 auch auf Kanal 36 sendet, vor allem weil ...

    Auf/in dem Metallkasten für die Antennenbuchse sitzen ja auch noch 2 Potis, was können die?

    ... hier schon mal jemand "optimiert" haben könnte. ;-) Sollte man nicht machen, bringt so gut wie nie was und wenn man es einmal verstellt hat, ist es ohne Messmittel nur sehr schwer wieder in die Gänge zubekommen. Also tune besser mal den TV fein bzw. such mal die ganzen 30er-Kanäle ab.


    Wenn allerdings am A/V auch nur schwarzweißes Bild vorherrscht ist eher noch was anderes im Eimer. Möglicherweise ist der Quarz stark gealtert. Kannst du Frequenzen bis 20 MHz messen, z. B. mit dem Multimeter?

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Juhu! Hab grad mal nen Suchlauf rennen lassen. Auf 33 hab ich ein blaues Bild =) Warum auf AV schwarz-weiß? Muss das mal an nem Commodore-Monitor testen, allerding macht ein anderer C64 an meinem TV ja auch ein blaues Bild. Vielleicht liegt das an unterschiedlichen VIC oder Boardrevisionen?


    Jetzt mal die große Preisfrage: mit einem der beiden Potis auf dem Metallkasten kann ich die Helligkeit oder Kontrast einstellen. Wie ist es optimal? Außen ein hellblau? Oder darf es schon deutlich ins grau gehen? Hab jetzt mal nach Gefühl eingestellt.


    Hab aber schon das nächste Problem:


    Die Floppy reagiert nicht auf Eingabe. An nem anderen 64er klappt sie. Identische Floppy, identisches Kabel.


    Es steht nur "SEARCHING FOR $" und das wars. Keine Reaktion des Laufwerks. Als würde der Brotkasten kein Steuersignal an die Floppy rausschicken.


    Grad nochmals getestet, am anderen 64er geht sie einwandfrei. Irgendein Chip, der nicht das macht, was er soll? Kontaktproblem irgendwo?

  • Es steht nur "SEARCHING FOR $" und das wars. Keine Reaktion des Laufwerks. Als würde der Brotkasten kein Steuersignal an die Floppy rausschicken. Kontaktspray?

    Eher der 7406 defekt, oder CIA2 (U2).

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Es steht nur "SEARCHING FOR $" und das wars. Keine Reaktion des Laufwerks. Als würde der Brotkasten kein Steuersignal an die Floppy rausschicken. Kontaktspray?

    Eher der 7406 defekt, oder CIA2 (U2).

    Kann ich das mit Hausmitteln prüfen?


    Ach ja: wenn die Floppy an ist und ich den C64 einschalte, dreht der Motor der Floppy ein paar Sekunden. IRGENDEIN Signal bekommt sie also schonmal...

  • Kann ich das mit Hausmitteln prüfen?

    Ja, am 7406 mal prüfen, was an den Eingangspins (1, 3, 5, 13, 11, 9) anliegt und was an den zugehörigen Ausgangspins (2, 4, 6, 12, 10, 8). Der 7406 ist ein Inverter, es muss immer "das Gegenteil" vom Eingang am Ausgang anliegen, entweder GND (0 V) oder VCC (+5 V).


    Ansonsten, wenn beide CIAs gesockelt sind, diese mal kreuztauschen.

    Ach ja: wenn die Floppy an ist und ich den C64 einschalte, dreht der Motor der Floppy ein paar Sekunden. IRGENDEIN Signal bekommt sie also schonmal...

    Ja, den RESET in dem Fall. ;-)

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Kann ich das mit Hausmitteln prüfen?

    Ja, am 7406 mal prüfen, was an den Eingangspins (1, 3, 5, 13, 11, 9) anliegt und was an den zugehörigen Ausgangspins (2, 4, 6, 12, 10, 8). Der 7406 ist ein Inverter, es muss immer "das Gegenteil" vom Eingang am Ausgang anliegen, entweder GND (0 V) oder VCC (+5 V).


    Ansonsten, wenn beide CIAs gesockelt sind, diese mal kreuztauschen.

    Sind beide verlötet.


    Gegen was messe ich denn die Pins? Eingang gegen Masse, also bspw. Metallabdeckung VIC o.ä.? Und den Ausgang? Auch?

    Pin 1 ist unten links, wenn ich die Schrift lesen kann, korrekt?

  • Jetzt mal die große Preisfrage: mit einem der beiden Potis auf dem Metallkasten kann ich die Helligkeit oder Kontrast einstellen. Wie ist es optimal? Außen ein hellblau? Oder darf es schon deutlich ins grau gehen? Hab jetzt mal nach Gefühl eingestellt.

    Da sollte man eigentlich nicht dran herumstellen... Hab ich noch nie müssen.



    Gegen was messe ich denn die Pins? Eingang gegen Masse, also bspw. Metallabdeckung VIC o.ä.? Und den Ausgang? Auch?

    Natürlich, gemessen wird immer gegen Masse. Ausnahmen gibt es, aber die werden immer genannt.

  • Gegen was messe ich denn die Pins? Eingang gegen Masse, also bspw. Metallabdeckung VIC o.ä.? Und den Ausgang? Auch?

    Ja, immer gegen Masse, Modulatorgehäöuse oder Expansionportblech ist ein guter Bezugspunkt.

    Pin 1 ist unten links, wenn ich die Schrift lesen kann, korrekt?

    Pin 1 ist unten links, wenn die Kerbe nach links zeigt:



    Falls keine Kerbe vorhanden ist, ist Pin 1 mit einem "Punkt" (Vertiefung, "Sackloch" im Gehäuse) gekennzeichnet. Ganz selten ist anstatt der Kerbe auch eine durchgehende "Kante" von Pin 1 zum gegenüberliegenden Pin (hier im Beispiel 14) zu finden.

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Falls es okay ist habe ich eine "Zwischenfrage" , da ich ein ähnliches Problem mit einem 250469er hatte ,

    das aber wieder läuft.

    Die Floppy reagiert nicht auf Eingabe. An nem anderen 64er klappt sie. Identische Floppy, identisches Kabel.


    Es steht nur "SEARCHING FOR $" und das wars. Keine Reaktion des Laufwerks.

    Eher der 7406 defekt, oder CIA2 (U2).

    Mein Verdacht war auch 7406 oder U2 . Das DIAG 64 hat mit Dongles angezeigt U2 und U1 Bad ; Serial Port ; User Port ; Interrupt gleich Bad .

    Die Tastatur funktiunierte und der Joystick auch .

    Ja, am 7406 mal prüfen, was an den Eingangspins (1, 3, 5, 13, 11, 9) anliegt und was an den zugehörigen Ausgangspins (2, 4, 6, 12, 10, 8). Der 7406 ist ein Inverter, es muss immer "das Gegenteil" vom Eingang am Ausgang anliegen, entweder GND (0 V) oder VCC (+5 V).

    Jetzt die ergänzende Frage die hierzu passt. Kann man beim Messen der Pins am 7406 feststellen , ob der 7406 die Ursache ist oder der CIA ( U2 ) ,

    wenn ja , woran würde man das erkennen ?


    Ich hatte mit einem einfachen Messgerät den Logic Pegel gemessen , dort war an PIN 13 vom 7406 weder High noch LOW . Die Spannung war

    rund 1,77 Volt.

  • Mein Verdacht war auch 7406 oder U2 . Das DIAG 64 hat mit Dongles angezeigt U2 und U1 Bad ; Serial Port ; User Port ; Interrupt gleich Bad .

    Die Tastatur funktiunierte und der Joystick auch .

    U1 BAD kann durch einen kaputten U2 verursacht werden, manche Leitungen des Teststeckers verbinden U1 und U2. Ist einer von beiden defekt, schlägtr der Test fehl. Da das Diag nicht weiß, auf welcher Seite der Defekt, werden beide als BAD markiert. Wenn die Tastatur funktioniert, ist U1 zu 99 % in Ordnung.

    Jetzt die ergänzende Frage die hierzu passt. Kann man beim Messen der Pins am 7406 feststellen , ob der 7406 die Ursache ist oder der CIA ( U2 ) ,

    wenn ja , woran würde man das erkennen ?

    Ja, man kann die CIA-Ports von Hand auf 0 bzw. auf 1 POKEn. Registeradressen siehe hier: https://www.c64-wiki.de/wiki/CIA

    Dann muss am CIA-Port entsprechend 0 oder 1 zu messen sein, am 7406-Eingang auch und an dessen Ausgang genau das Gegenteil.

    Ich hatte mit einem einfachen Messgerät den Logic Pegel gemessen , dort war an PIN 13 vom 7406 weder High noch LOW . Die Spannung war

    rund 1,77 Volt.

    Das ist grundverkehrt. Es muss entweder (fast) 0 V (bis 0,4 V sind erlaubt) zu messen sein oder sehr viel mehr. An welchem Pin war das genau?

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Hallo ,


    Das ist grundverkehrt. Es muss entweder (fast) 0 V (bis 0,4 V sind erlaubt) zu messen sein oder sehr viel mehr. An welchem Pin war das genau?

    ich habe das nur noch auf dem "Schmierzettel" notiert . Das soll Pin 13 an U22 gewesen sein. Der geht soweit ich das sehe an Pin 7 von U2.


    Deshalb habe ich erst vermutet das es U2 sein könnte, nur fehlt mir die Erfahrung :rolleyes: Ich habe dann zuerst den 7406 ausgelötet und nochmal

    gemessen . Da war an Pin7 von U2 immer noch 1,77 Volt. Den habe ich dann ausgelötet und der war auch defekt.


    Nachdem ich meine "Lötfehler" beseitigt hatte :wand Lief dann auch das DIAG 64 problemlos durch . U1 war nicht defekt.

  • Da sollte man eigentlich nicht dran herumstellen... Hab ich noch nie müssen.



    Natürlich, gemessen wird immer gegen Masse. Ausnahmen gibt es, aber die werden immer genannt.


    Gut, danke. Mach ich mich später dran und melde die Ergebnisse.

  • 1 0,09

    2 2,36

    3 1,67

    4 2,07

    Das passt nicht. Prüfen, wo Pin 2 und 4 hingehen und warum sie auf 2 V heruntergezogen werden. Da muss ein Pull-Up-Widerstand nach +5 V sein. Irgendein Bauteil an diesen zwei Leitungen zieht kräftig daran und sorgt dafür, dass der Pegel zu niedrig ist. Für TTL-Standard müssten es mindestens 2,8 V sein.

    5 0,02

    6 5,01

    7 0,00

    Passt.

    Passt.

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • 2 war jetzt bei erneutem Messen bei 2,48. Rest identisch.

    1 0,09

    2 2,36

    3 1,67

    4 2,07

    Das passt nicht. Prüfen, wo Pin 2 und 4 hingehen und warum sie auf 2 V heruntergezogen werden. Da muss ein Pull-Up-Widerstand nach +5 V sein. Irgendein Bauteil an diesen zwei Leitungen zieht kräftig daran und sorgt dafür, dass der Pegel zu niedrig ist. Für TTL-Standard müssten es mindestens 2,8 V sein.

    8| Äääähhhhh...ööööhhhh...... :/ So spreche er in meiner Sprache :rolleyes::D


    Mit anderen Worten: rupf das Board aus dem Gehäuse und guck, wo die Leitungen hinlaufen?


    Und dann? :/


    Bzw. kann man das ja schon so sehen. Die 2 läuft auf einen kleinen Widerstand. R29. Müsste 200 Ohm sein? Oder 1000, kein Plan von welcher Seite ich die Ringe anfange :)


    Messgerät zeigt 572 Ohm bei diesem. Bei weiteren identischen auf dem Board: 600, 995, 988, 998. Also wahrscheinlich ein 1kOhm?


    Pin 4 läuft meines Erachtens an J314B2 / NB556N, kann das sein?