Hello, Guest the thread was called744 times and contains 10 replays

last post from dl1av at the

flashx20, ein Floppy- und Bildschirmsimulator für den Epson HX-20

  • Der Epson HX-20 war in den Achtzigerjahren ein cooler Handheld-Computer. Er hatte ein 4x20-Zeichen-LCD-Display und ein Microkoassettenlaufwerk eingebaut. Über seinen seriellen Port an der Rückseite konnte man verschiedene Periphegriegeräte anschließen, die sich über ein Epson-spezifisches Protokoll mit dem HX-20 unterhielten.


    Ich habe jetzt das Programm "flashx20" geschrieben, mit dem ein PC an den HX-20 angeschlossen werden kann, wobei der PC das Epson-Protokoll interpretiert und einen externen Bildschirm-Controller und vier externe Diskettenlaufwerke simuliert. Damit bekommt man für den kleinen HX-20 einen großen Schirm (den PC-Monitor) und Speicherplatz auf der PC-Festplatte, die dann auch für Programm- und Datenaustausch genutzt werden kann.


    Hier ist ein Bildschirmfoto um einen kleinen Eindruck zu geben:



    Wer einen Epson HX-20 hat und mehr erfahren möchte oder sich das Programm herunterladen will, kann auf meiner Webseite unter http://members.aon.at/nkehrer/ vorbeischauen.


    Viele Grüße


    Norbert

  • Funktioniert bei mir nicht.


    Ich hab allerdings keine modernen PCs, sondern hab es auf zwei verschiedenen XP-Rechnern mit verschiedenen com-ports probiert.


    So, wie ich das verstanden habe, ist das Windows-Programm der Server, der also nie abbricht, sondern nach dem Aufruf im Vordergrund bleibt und auf das Einschalten des HX20 wartet.


    Bei mir kommt nach der Copyright-Meldung nur: Error in serial connection (createfile failed) und dann wieder der C:\



    Kann vielleicht mal jemand auf einem Windows7/10-PC ausprobieren, ob er den Server gestartet bekommt? Dazu brauchts gar keinen HX20 dran.
    http://members.aon.at/nkehrer/flashx20/flashx20.zip


    Dabei ist es egal, ob ich den HX20 dran hab. Den DIP-switch4 hab ich auch umgestellt. Mein HX20 meldet sich dann leider auch nicht mit dem "Disk-Basic", aber das hat erstmal nichts mit dem Server-Abbruch zu tun.



    Noch ein Update: Ich hab den Server zum Laufen bekommen, auch auf einem Windows98-Rechner.


    Allerdings verbindet sich mein HX20 nicht. Er bootet zwar beim Einschalten länger, nachdem ich den DIP-switch umgestellt habe, es kommt aber keine Disk-Basic-Interpretermeldung (wie auf der Webseite des Autors). Wahrscheinlich ist meine Firmware einfach zu alt und das Disk-Basic ist nur unvolständig enthalten.


    Vielleicht hat ja einer Lust, das mal mit einem neueren HX20 zu testen. Zumindest den DIPswitch 4 auf "ON" zu schalten und zu sehen, ob er dann die Disk-Basic-Meldung beim Einschalten bekommt

  • Bei mir kommt nach der Copyright-Meldung nur: Error in serial connection (createfile failed) und dann wieder der C:\



    Kann vielleicht mal jemand auf einem Windows7/10-PC ausprobieren, ob er den Server gestartet bekommt? Dazu brauchts gar keinen HX20 dran.

    Hast Du die .PDF-Dokue auf Seite 4 und 5 zum Start des Servers gelesen?
    Wenn ich flashx20.exe ohne Parameter starte (unter Windows 10 64Bit) bekomme ich auch nur die Meldung
    "Error in establishing serial connection 'COM3' (createfile failed)."


    Aber wenn ich einen existenten COM-Port angebe und evtl. eine Grafikaufloesung - bleibt der Server auch am laufen:
    C:\flashx20>flashx20 -g1 COM1

  • Ja, das hab ich dann auch gesehen, dass meine com-ports etwas verbogen waren. Auf einem sauberen Rechner ist der server dann bereit geblieben und es kam keine Fehlermeldung. Danke dir fürs ausprobieren.


    Allerdings funktioniert das mit meinem HX20 wohl aus irgendeinem Grund nicht. Ich kann zwar diesen Disk-ROM einblenden (die "screen"-Befehle stehen sonst gar nicht zur Verfügung), allerdings gibts bei mir nicht diese "Disk-Basic"-Meldung wie auf dem Foto in der Anleitung.


    Danach hab ich nochmal ein einfaches Terminal an den HX20 angeschlossen: Da psssiert gar nichts. Nicht mit 38k4 und auch nicht mit 19k2 oder 9k6. Aus der Bootreihenfolge (erst PC, dann HX20) schliesse ich mal, dass der HX20 beim Initialisieren irgendwie den Server pollt und es dann erst richtig los geht. Aber aus meinem HX20 kommt nichts raus. Auch nicht, wenn ich an dem Diodenstecker links und rechts vertausche (manchmal sind sich die Leute nicht so einig, was nun 1 und was 3 ist).


    Also falls es nicht noch einen in der Anleitung vergessenen Tastendruck gibt, funktioniert das bei mir nicht.

  • Hi dl1av und guidol,


    danke für's Testen. Ich habe flashx20 mir auch noch einmal auf meinem 10 Jahre alten Windows-Vista-Rechner ausprobiert. Dort läuft es. Es sollte also auch auf älteren 32-Bit-Windows-Versionen gehen.


    Zum Anschluss ist noch zu sagen: Die Verbindung läuft über die Epson-Buchse mit der Aufschrift "SERIAL", nicht über die mit "RS-232C.


    Wie dl1av richtig vermutet, pollt der HX-20 beim Start von BASIC den Server und lädt die Routinen für Disk-Basic vom PC in den HX-20. Damit das geht, muss man BASIC starten. Also am HX-20 mit der "MENU"-Taste ins Menü gehen und dann mit "2" Basic starten. Eventuell hilft auch ein "Initialize" mit "§" im Menü und dann "2" für Basic.


    Wenn die Verbindung zwischen HX-20 steht, aber das Disk-Basic aus irgend einem Grund nicht geladen wurde, kann man trotzdem mit dem Befehl "SCREEN 1" am HX-20 auf die externe Bildschirmausgabe umschalten, und die HX-20 Ausgabe sollte dann auf dem PC-Terminalfenster erscheinen. Mit "SCREEN 0" kommt man wieder auf die LCD-Display-Ausgabe zurück.


    Ich hoffe, das kann etwas weiterhelfen. Sonst fällt mir nur mehr das Verbindungskabel als Problemursache ein.


    Viele Grüße


    Norbert

  • Hallo Norbert und guidol,


    danke für euren schnellen Input.


    Das Ergebnis zuerst: es geht :)


    Das mit dem com-port habe ich gestern schon geklärt, da hing bei mir ein anderes Transferprogramm davor. Mit einem sauberen WinXP-Rechner ging das auf dieser Seite. Nur die Verbindung hat nicht funktioniert.


    Nach einer Nacht drüber schlafen ist mir eingefallen, dass es hier manchmal Probleme mit den Pegeln gibt. Diese nichtRS232-Highspeed-Schnittstellen hatten ja meist TTL-Pegel. Mit V.24 zusammen kann das gehen, muss aber nicht.
    Das Kabel hatte ich erst grosszügig dimensioniert, 2m alte Strippe aus der Kabelkiste, die an einem Ende sogar noch einen angegossenen Dsub-Stecker hat.
    Anscheinend kam damit nichts mehr an. Heute morgen hatte ich es dann nochmal mit einem simplen Breakout-Aufbau und 20cm Klingeldraht probiert. Nun funktioniert es anscheinend, zumindest kann ich die File-list sehen und es erscheinen die Eingaben am HX20 auch auf dem ThinkPad.


    Am Wochenende will ich mir vielleicht mal ein besseres Kabel bauen (irgendwo hab ich noch diese MAX232-Platinchen) und das Programm dann weiter testen. Mit dieser kurzen Kabelverbindung jetzt ist das etwas nervig. Mal sehen, ob das auch auf dem Win98-Rechner geht.


    Vielen Dank nochmal und bis bald!
    Stefan

  • Drei Sachen sind mir noch auf die Schnelle aufgefallen:


    1. Die "Disk-Basic" Copyright-Meldung kommt nicht immer beim Starten des HX20 mit dem Server. Trotzdem kann man "screen 1" erfolgreich ausführen, auch wenn diese Meldung vorher nicht angezeigt wurde.


    2. Die Zeilen scrollen furchtbar langsam am PC durch. Langsamer, als das eigentlich bei 38k4 zu erwarten wäre. Ein Zeilenvorschub dauert gefühlt eine halbe Sekunde. bei dem langen Filelisting ist das jetzt schon etwas lang.
    Liegt das an dem lahmen Server bei mir? Geht das auf einem aktuellen PC schneller? Hab dafür gerade keinen zur Hand. Es läuft jetzt auf einem Pentium 1 mit 80MB RAM und Win2000.


    3. Sauberes TTL-Kabel gebaut, mit 60cm Kabellänge gehts, länger macht Probleme.

  • Ja, das müsste man wirklich mal machen. Und erstmal messen, was da überhaupt raus kommt.


    Insgesamt scheint das nicht viel zu sein. Richtig stabil jedesmal die "Disk-Basic"-Meldung bekomme ich erst, seit ich wirklich beide Abschirmkappen über den Steckern drüber und auf den Kabel-Schirm gelegt habe. Das kann also kein V.24 sein, das wäre nämlich deutlich robuster.


    Jetzt klappt das aber jedesmal, mein System ist zumindest dafür stabil zusammengestellt :) .


    Wenn im Screenmode die shell auf dem PC vollgeschrieben ist und anfängt zu scrollen, wird es aber sehr langsam. Da bräuchte man einen schnelleren Server, oder man schaut sichs auf dem HX20 an. Filetransfer funktioniert.


    Allerdings kann ich manche Dateien einfach nicht laden, das bricht immer mit einer allgemeinen DU-Fehlermeldung ab.
    Erst dachte ich, das liegt am Speicher.
    Habe dann mal die 16k-Erweiterung angeschraubt. Das funktioniert leider gar nicht. Es gibt schon gleich eine Fehlermeldung, sobald der HX20 zum ersten mal den Server pollt. Nicht nur eine Fehlermeldung, sondern eine trap, die nur durch einen Hardware-reset zu beenden ist.


    Hier scheint es also einen massiven Speicherfehler zu geben, vielleicht hat der Programmautor das gar nicht testen können.


    Ansonsten: Es funktioniert, auf jeden Fall für kleinen Filetransfer. Das Kabel muss sehr sorgfältig gebaut werden, weil die Pegel anscheinend recht klein sind. Display funktioniert auch, allerdings sollte man dafür einen schnellen Rechner haben.



    Alles in allem eine feine und unkomplizierte Sache, wenn man die Tips aus diesem Thread berücksichtigt. Seit 15 Jahren schon hab ich den HX20 und konnte nie was mit anfangen, weil ich keine Programmcassetten hatte. Jetzt gehts los :)