Hello, Guest the thread was called1.5k times and contains 12 replays

last post from Mikson at the

250407 Rev. B - kein Bild

  • Die Vorgeschichte: Vorgeschichte und Vorstellung


    Der Fehler: Kein Bild.
    Angeschlossene VC 1541 reagiert auf Einschalten des C64 und lädt auch Summergames II nach blind getipptem Befehl.


    Punkt 1:
    Die Platinenversion ist sehr Wichtig für korrekte Hilfe. Bei Commodore Platinen steht meist ASSY gefolgt von einer Nummer drauf, die wollen wir wissen.
    --> 250407 REV. B


    Punkt 2:
    Ist das Gerät modifiziert oder noch Orginal? eventuell andere ROM´s drin?
    --> ja, ein roter minidonut ist oben rechts aussen am gehäuse, innen führt ein kabel mit widerstand zu einem widerstand (? ohne ringe?) zwischen der bezeichnung fb13 (oben drüber) / r6 (unten drunter)
    Soweit ich sehen kann sind die ICs von 1983, überwiegend aus woche 22. Sind die Roms noch mal ganz bestimmte, die ich nachschauen soll?


    Punkt 3:
    Ist das Netzteil Orginal oder schon mal durch ein anderes ersetzt worden?
    --> Original


    Punkt 4:
    Tritt der Fehler nur auf wenn Zusatzhardware angeschlossen ist?
    --> mit und ohne vc1541


    Punkt 5:
    Tritt das Problem sporadisch auf oder ständig?
    --> ständig


    Punkt 6:
    Werden irgendwelche Chips besonders heiss? so das man sich fast die Finger dran verbrennt?
    --> hmmmm, muss ich noch testen (im, Laufe des langen WE)


    Punkt 7:
    Hat der Fragesteller ein Multimeter und weiss wie das benutzt wird?
    (Die billigen 5-Euro Multimeter reichen für diesen Job aus)
    --> ja, ich habe eines - nein, ich weiss nicht, wie es benutzt wird. meine erfahrungen beschränken sich bisher darauf, eine 9V Batterie zu berühren (das Gerät zeigt dann 9,5V an, ich bin mir unschlüssig, ob ich das nah dran finde)


    Punkt 8:
    Hat der Fragesteller irgendwelche Erfahrungen im Löten? wenn nicht gleich sagen.
    HA! Ich habe einen Lötkolben. Und ich habe ein Conrad-Päkchen: ich lerne löten. Nun, ich sag es mal so, das Päkchen wurde noch nicht benutzt, der Lötkolben einmal auf 100°C aufgeheizt, da schmolz nix. Und dan auf 150°C, das ergab einen unförmigen Klecks wieder festgewordenes etwas.


    Nachträge:
    Punkt 9: Reagieren Laufwerke korrekt auf Ladebefehle, mit LED-Blinken oder gar nicht?
    --> Reagiert prima: Zuerst kurz, wenn ich den C64 einschalte kurz und dann lang wenn ich Summergames II lade.


    Bonusbitte: Ein Foto von der Platine auf dem man die Chipbezeichnugnen lesen kann, erleichtert die Fehlersuche auch ungemein.
    --> ich versuche es später / im Laufe des langen WE


    Ich lese in anderen Threads, dass der Monitor / der Fernseher die Verbindung dahin das Problem wäre. Jedoch habe ich mit einem andere C64 Bild (gleiches Kable, gleicher Fernseher). Mir fällt gerade noch ein, dass ich das Bild mit dem anderen C64 zwar vorher hatte, aber nicht auch nohc mla hinterher gegengeteste,. Ich häng den anderen C64 noch mal dran und gucke, ob immer noch Bild ist. Eventuell verstellt sich da was von mal zu mal.

  • Sorry, ich finde gerade keine Möglichkeit, den Beitrag oben zu editieren:
    Also es wird kein Chip heiß.
    Der andere C64 macht sofort Bild. Die Einstellungen des Fernsehers bleiben also korrekt.
    Mir ist dann noch aufgefallen, dass das "Gegriesel" geringfügig Struktur annimmt, wenn ich den defekten C64 einschalte.
    Es sind so vertikale Wellenformen.

  • Sorry, ich finde gerade keine Möglichkeit, den Beitrag oben zu editieren:
    Also es wird kein Chip heiß.
    Der andere C64 macht sofort Bild. Die Einstellungen des Fernsehers bleiben also korrekt.
    Mir ist dann noch aufgefallen, dass das "Gegriesel" geringfügig Struktur annimmt, wenn ich den defekten C64 einschalte.
    Es sind so vertikale Wellenformen.

    Du hast also über den Antenneneingang einen TV angeschlossen?
    Dann starte mal den Sendersuchlauf, vielleicht ist der C64 auf einen anderen Kanal eingestellt.

  • Hallo,
    ich bin zwar selbst noch nicht lange hier und sicher weit weg vom "Experten" (keine Angst, hier gibt es "echte Cracks"), aber vielleicht kann ich dir Tipps für den Anfang geben.
    Zuerst solltest du die Spannungen messen. Du findest auf der Platine zwei Spannungsregler. Der eine links unten, neben dem größeren Metallkasten mit Deckel. Dieses ist der 12V Regler. Der zweite rechts daneben an ein gewinkeltes Metallteil. Dieser regelt die 5V. Wenn du ein einfaches Multimeter hast, dann stelle es auf Gleichpannung (V=) und auf 20V (oder höher). Die Minusleitung wird an den mittleren Pin des Reglers gehalten, die Plusleitung an den rechten Pin. Aber Vorsicht, keinen Kurzschluss bauen.
    Du müsstest 12V bzw. 5V angezeigt bekommen.
    Wenn diese anliegen, dann messe die Spannungen an den ICs. Die Pinbelegungen und wie gezählt wird, findest du bei www.c64-wiki.de.
    Die Ergebnisse sind schon mal hilfreich.
    Noch eine Frage: Du hast ja einen funktionierenden C64. Hat dieser auch eine 407 Platine?
    Wenn du die ICs auf Hitze prüfst, dann vergesse nicht den VIC (sitzt in der "Metallkiste")


    Noch vergessen. Du kanst auch noch versuchen den SID (U18 6581) rauszunehmen, wenn er gesockelt ist, und dann den C64 zu starten. Aber immer das Netzteil abziehen wenn du ein IC ziehst.

  • Und bitte auch auf ESD achten - also Dich vorher entladen und das gezogene IC nicht in eine normale Plastktüte oder in Styropor packen - sonst ist es mit ziemlicher Sicherheit wirklich defekt. Der SID ist sehr empfindlich und auch rar (also relativ teuer) - den würde ich zunächst lassen, wo er ist (im Sockel auf der Platine), da passiert ihm am wenigsten. Erst wenn abgeklärt ist, dass er als Verursacher des Fehlers in Betracht kommt, würde ich ihn entfernen.

  • Danke schon mal für Eure Antworten!


    Ich habe den Sendersuchlauf noch mal laufen lassen. Ergebnis: zwischendrin sieht man ab und zu Strukturen im Schneegestöber (Linien, Wellen). Aber nur bei CH36 bietet der Fernseher an, zu speichern. Hier hab ich jetzt ein schwarzes Bild. Lasse ich den Suchlauf mit dem funktionierenden C64 laufen und speichere den CH36, dann bekomme ich mit dem defekten C64 Schneegestöber mit erkennbaren vertikalen Wellen. Lasse ich den Suchlauf direkt mit dem defekten C64 laufen, bekomme ich bei CH36 ein schwarzes Bild.



    Ich habe antistatische Tütchen. Davon habe ich eines geholt, bekomme den Chip aber nicht so ohne Weiteres aus dem Sockel. Das versuche ich morgen ausgeschlafen noch mal, ebenso wie erste Messungen.


    Hier ein Bild (da ist nichts gebogen, die Kamera ist seltsam):


    Der andere, der funktioniert hat ein 250425.

  • BÄÄÄÄM, Junge:



    Wow. :) Ich freu mich gerade. Ich habe meinen ersten C64 "repariert".
    - entferne SID6581 aus C64
    - das geht so nicht
    - benutze Schraubenzieher mit SID6581
    - ich sollte erst den Strom entfernen
    - ziehe stecker
    - benutze Schraubenzieher mit SID6581
    - ich sollte mich erst entladen
    - untersuche Heizung
    - ok, ich habe die Heizung angefasst
    - benutze Schraubenzieher mit SID6581


    Also: ohne 6581 hatte ich gleich Bild. Und das Beste: mit dem SID6581 aus meinem dritten defekten C64 bleibt das Bild und Ton habe ich auch noch.
    Der dritte ist ja so defekt, dass die Floppy nicht auf blind getippten Befehl reagiert. Jetzt hat er vorläufig eben auch keinen SID6581 mehr und ich werde an ihm üben, wie man mit einem Multimeter misst.
    Mikson: ist mir noch unklar, wie ich ein Scartkabel anschliessen könnte und RCA sagt mir so erst mal nichts. Aber in einer Woche kann und weiss ich beides. Ich kann mich nur wiederholen, es gibt so viel zu lesen ... wie schön. :)
    Danke an Euch alle!

  • Glückwunsch! :)


    Und vor allem dafür ...

    Aber in einer Woche kann und weiss ich beides.

    :respect: ... das ist die richtige Einstellung! :thumbup:

    "Wenn du überredet, ermahnt, unter Druck gesetzt, belogen, durch Anreize gelockt, gezwungen, gemobbt, bloßgestellt, beschuldigt, bedroht, bestraft und kriminalisiert werden musst. Wenn all dies als notwendig erachtet wird, um deine Zustimmung zu erlangen, dann kannst du absolut sicher sein, dass das, was angepriesen wird, nicht zu deinem Besten ist." - Quelle unbekannt.


    "Steve Jobs hat User hervorgebracht, Jack Tramiel Experten." - Quelle unbekannt.

    "Mein Herr, ich teile Ihre Meinung nicht, aber ich würde mein Leben dafür einsetzen, dass Sie sie äußern dürfen." - Voltaire.

    "Diskutiere nie mit einem Idioten - er zieht dich auf sein Niveau hinunter und schlägt dich dort mit seiner Erfahrung!" - Volksweisheit.


  • Scartkabel bzw RCA (Das ist das, mit den 3 Chinch-Steckern Gelbd, Rot, Weiß) gibts für die Videobuchse an der Rückseite. Damit lässt sich dann herausfinden, ob der Modulator nen Schuss hat oder ob man weiter suchen muss. Bei dir scheint der SID die Betriebsspannung in die Knie gezwungen zu haben und deshalb kam kein Bild mehr. Schön dass er wieder läuft und die anderen kriegt man auch wieder hin :thumbup: