Hello, Guest the thread was called6.4k times and contains 42 replays

last post from leon22 at the

CF Karte einrichten lassen

  • Hallo!


    Gibt es eine Firma, die mir meine CF für den A1200 einrichtet? Ich habe
    leider sehr wenig Zeit mich mit solchen Problemen zu befassen. :(


    WB3.1 läuft mittels einer CF-Card per IDE-Adapter intern.


    Ziel
    ist es, über PCMCIA meine 4GB CF einzurichten. Diese muss nicht
    bootfähig sein. Sie soll dazu dienen, am PC angeschlossen zu werden um
    ADF Files darauf zu packen.


    Also wenn jemand eine Firma kennen würde, bitte bescheid sagen.
    Wäre Euch sehr dankbar.


    LG Malcolm

  • Ziel
    ist es, über PCMCIA meine 4GB CF einzurichten. Diese muss nicht
    bootfähig sein. Sie soll dazu dienen, am PC angeschlossen zu werden um
    ADF Files darauf zu packen.


    Da braucht man in dem Fall nicht die Karte einzurichten sondern muss dem Amiga ein passendes Filessystem verpassen damit er die Karte lesen kann.
    Normalerweise ist das das fat95-Filesystem aus dem Aminet.

  • Also ich hatte mir ne rarfile besorgt, die Files auf dem PC entpackt und mittels Amiga Explorer
    die Datei Fat95 in Ordner "L", compactflash.device in Ordner "Devs" und die CF0 in das "Root-Verzeichnis" meiner WB-Partition kopiert.


    Nach einem Neustart taucht die CF0 aber nicht auf. Laut WinUAE ist die CF Card noch im MBR Modus.


    Und formatieren kann ich die am Amiga nicht, weil diese ja nirgends auftaucht. Und 4GB und Fat ist eh so eine Sache ;)

  • Was für ein RAR-File ? Hole Dir am besten das Paket aus dem Aminet. EDIT: und entpacke sie auch auf dem Amiga und nicht am PC. /EDIT
    Warum hast Du die CF0-Datei im Root ? Die gehört in den Ordner DEVS/Dosdrivers. Dann wird die CF-Karte auch evtl. gemountet.
    Die Karte nicht am Amiga formatieren, sonst kann der PC sie nicht lesen.


    Quote

    Und 4GB und Fat ist eh so eine Sache


    aus dem Readme von Fat95

    Quote

    * up to 4 GBytes of partition size for FAT16

  • Die RARfile aus diesem Thread (1. Posting).


    Und dort steht CF0 ins Stammverzeichnis kopieren. Aber die Variante von Dir, die File nach DEVS/Dosdrivers zu kopieren funktioniert ebenfalls nicht.


    Also formatieren am Amiga nicht ,sondern wohl am PC. Da brauche ich dann wohl wieder ein Fat95 Tool. Sicherheitshalber noch die Transferrate und Mask einstellen.

  • Ein letzter Versuch:


    1. LHA-File mit dem Fat95 Filesystem (Link s.o.) aus dem Aminet downloaden und auf den Amiga übertragen.
    2. Das File auf dem Amiga entpacken (wichtig) mit dem Befehl

    Code
    1. lha x fat95.lha RAM:

    .
    3. RAM-Disk öffnen, und von dort aus installieren.
    4. Neustart durchführen, PCMCIA-Karte mit CF einstecken
    5. Falls ein CF0: BAD erscheint, CF-Karte am PC mit Fat16 formatieren (aus der CMD-Shell)


    fertig.


    Nix Transfermask, Nix Toolbox ;)

  • Ab Punkt 3 gibts natürlich wieder Probleme. Doppelklick auf die install Datei und es tut sich nichts.


    Ich habe im Netz nen Shop gefunden, der Amiga Hardware verkauft. Ich frage dort mal an.


    Danke Dir trotzdem.

  • Ich bin erstaunt. Nach nur 1 1/2 Stunden bilateraler Versuche bist Du schon bereit Geld für so etwas auszugeben? ;)


    Bevor Du zuviel Kohle weghaust: Such im eBay nach "ADF Transfer Kit", da kriegste einen PCMCIA Reader, ne CF Karte und ne Diskette mit einem hübschen, einfachen Install-Programm drauf. Musst nur noch den Doppelklick an der richtigen Stelle setzen.


    Was erhoffst Du dir eigentlich, wenn Du auf der PCMCIA Karte dann die ADFs drauf hast? Direkt von dort kannst Du die nämlich nicht starten.



    Was hier so gezeigt wird haste alles schon versucht? Es geht nämlich durchaus auch ohne größere Investitionen.

  • Achtung:


    SD-HC-Karten scheinen damit nicht zu funktionieren.


    Jedenfalls hat bei mir keine einzige meiner HC-Karten, egal welcher Hersteller funktioniert.



    Die "alten" SD-Karten sind allerdings kein Problem.

  • Die guten Videos aus YouTube kenne ich.


    Wie auch schon anfangs habe ich alles noch einmal so gemacht wie im Clip. Aber: Nix tut sich da auf meinem Workbench Screen ?(
    Meine Vermutung geht in die Richtung, dass das Formatieren unter W7 nichts bringt. Fat16 mit 64KB hat die Karte jetzt aktuell.
    32KB Zuordnungseinheit wie im Clip bekomme ich nicht hin.


    Zum Mäuse melken...

  • Ich habe DiskPart benutzt um ersteinmal die Karte komplett zu löschen, am PC WinUAE mittels Adminrechte gestartet, A1200 gewählt, die WB3.1 InstallDisk ins virtuelle Floppy und die HDD zugefügt. Mit der HDToolBox dann die HDD (CF) konfiguriert und partitioniert 2x2GB. Virtuell erscheinen sie unter WB3.1. Natürlich noch eben fix formatieren . In WinUAE kann ich die Karte benutzen, aber nicht direkt am A1200 über den PCMCIA-Slot :( Da werden mir die beiden LW gar nicht angezeigt.


    Ich glaube, ich hatte dann unter WB3.1 mal testweise dieses "PrepCard" (oder wie das hieß) gestartet. Zumindest wird die CF unten links im Textfeld aufgeführt. Also Reader scheint ok zu sein.


    In dem obigen Video ist das so simpel angeblich, Karte aus dem Slot am Amiga herausnehmen, am PC in den CardReader hinstecken und Dinge daraufladen.


    Achso, ich hatte noch zus. probiert die CF0 zu editieren (Mount = 1) ... hilft auch nix...


    Dabei sollte diese Karte laut jemanden gut funzen...

  • Wieso eigentlich FAT16, FAT32 funktioniert bestens per PCMCIA am Amiga. Denke auch es liegt an der Kombination CF Karte und PCMCIA Adapter, wenn es trotz richtiger Installation nicht klappt.


    Transcend CF 4GB 133x ... sollte angeblich wohl laufen. Einige haben damit Probleme, andere widerum nicht. Dasselbe gilt auch für SanDisk.

  • Ich habe DiskPart benutzt um ersteinmal die Karte komplett zu löschen, am PC WinUAE mittels Adminrechte gestartet, A1200 gewählt, die WB3.1 InstallDisk ins virtuelle Floppy und die HDD zugefügt. Mit der HDToolBox dann die HDD (CF) konfiguriert und partitioniert 2x2GB. Virtuell erscheinen sie unter WB3.1. Natürlich noch eben fix formatieren . In WinUAE kann ich die Karte benutzen, aber nicht direkt am A1200 über den PCMCIA-Slot :( Da werden mir die beiden LW gar nicht angezeigt.


    Ja, langsam langsam. Das was Du da gemacht hast ist die Einrichtung einer CF Karte als Festplattenersatz für den internen IDE Port des A1200. Diese Karte wird im PCMCIA Adapter nicht funktionieren, da sie ja mit dem Amiga Dateisystem FFS eingerichtet worden ist. FAT95 erwartet allerdings eine FAT formatierte CF Karte.


    Leider gibt es die Fälle, dass bestimmte Karten/Adapter/Amiga Kombinationen nicht laufen wollen. Hast Du mal gecheckt, ob Dein PCMCIA Port überhaupt funktioniert? Hast Du vielleicht eine Speichererweiterung/Turbokarte im Trapdoorslot? Manche von denen vertragen sich nicht mit dem PCMCIA und blockieren ihn komplett.


    Shodan
    ...ehm...wir reden von CF Karten, nicht von SD ;)

  • Das Compact Flash.device aus deinem Forum64 Link ist ganz schön veraltet. Versuch mal die angehängte Version von mir.


    Auf PC entpackt und das Device per Amiga Explorer rüberkopiert. Neustart - keine Änderung :( Komischerweise kann ich dieses Device nicht editieren wg. Mount = 1


    Allerdings hatte ich zwischendurch auch wieder die CF am PC formatiert (FAT).

  • Ja, langsam langsam. Das was Du da gemacht hast ist die Einrichtung einer CF Karte als Festplattenersatz für den internen IDE Port des A1200. Diese Karte wird im PCMCIA Adapter nicht funktionieren, da sie ja mit dem Amiga Dateisystem FFS eingerichtet worden ist. FAT95 erwartet allerdings eine FAT formatierte CF Karte.


    Leider gibt es die Fälle, dass bestimmte Karten/Adapter/Amiga Kombinationen nicht laufen wollen. Hast Du mal gecheckt, ob Dein PCMCIA Port überhaupt funktioniert? Hast Du vielleicht eine Speichererweiterung/Turbokarte im Trapdoorslot? Manche von denen vertragen sich nicht mit dem PCMCIA und blockieren ihn komplett.


    Shodan
    ...ehm...wir reden von CF Karten, nicht von SD ;)

    PCMCIA Port sollte funktionieren, da ich die "PrepCard" unter Tools mal gestartet habe. Da Karte wird dort aufgeführt vom Modell her.


    Turbokarte ist NOCH nicht drin.
    Die ACA 1220/33 128 MB werde ich mir erst Morgen bestellen (hoffe, die macht nicht so viel zicken) ^^


    Habe die im Moment unter Win7 formatiert als FAT mit 64KB Zuordnungseinheit. Mehr Optionen habe ich leider nicht :(