Hello, Guest the thread was called33k times and contains 311 replays

last post from Tommi_nrw at the

Neuauflage von Prologic Dos

  • Interessant wäre jetzt ob das Prologic-Dos Rom der Userport Variante die selbe Belegung des Dolphin-Dos Parallelkabels verwendet ?
    Und ob die direkte Verkabelung vom 6522 zum Userport ausreicht, oder ob das Kabel dann vom Userport zum 10-fach Stecker auf der Prologicdos Platine im Floppy gehen muss ? (und dann auch von Dolphindos weiterhin 'sichtbar' ist ?)

    Ja, Userportbelegung ist bei allen (mir bekannten) Speedern immer gleich.


    Ich habe mir ein Kabel gebaut das sowohl den 10pligen Stecker des Prologic als auch den Userportstecker hat.
    Guckst DU: Floppyspeeder Nachbau


    Prologic ist es egal ob es am Userport oder am Ex-Port betrieben wird, richtiger Kernal ist eben wichtig.


    Wichtig zum Bertieb von Dolphin UND Prologic-DOS in EINER Floppy (umschaltbar) ist, dass es Dolphin DOS 2.0 und Prologic-DOS von Jann Datentechnik
    (beide ohne den zusätzlichen I/O auf der Floppyplatine) sind, also beide den 6522 der Floppy nutzen. Habe ich selbst schon so aufgebaut.


    Beim Betrieb in zwei verschiedenen Floppies ist das natürlich Latte ...

  • Prologic System Userport :Prologic_Classic_Userport.rom


    Das Ex-Port-Kernal ist auf der Platine, aber es benötigt eine zwei Leitungen zur PLA um
    sauber eingebunden zu sein. Außerdem muss es dann auch auf der Platine ausgeschaltet werden
    wieder an die anderen Kernals zu kommen. Kann also auch gut in das 8fach wenn Platz ist.

    Ich habe jetzt mal die hashwerte deines user-port kernals (Prologic_Classic_Userport.rom) mit dem von wiesel (Prologic_Kernal_A.BIN) und x1541 (PDC-K-A.BIN) verglichen. Die anderen zwei müßten ja auch user-port varianten sein soweit ich das herausgelesen hatte. Wiesel und x1541 sind identisch, deines weicht ab...hat jemand die möglichkeit die kernal mit seinem user-port prologic dos zu testen? ...nachher hab ich vielleicht genau das drauf welches dann nicht funktioniert falls es mal was werden sollte mit nem PD-clone und das will ich auf jeden fall vermeiden.

  • deines weicht ab...hat jemand die möglichkeit die kernal mit seinem user-port prologic dos zu testen?

    Kann sein, dass ich Hintergrund auf schwarz und Schrift auf grün gesetzt habe ...


    Wichtig zum Bertieb von Dolphin UND Prologic-DOS in EINER Floppy (umschaltbar) ist, dass es Dolphin DOS 2.0 und Prologic-DOS von Jann Datentechnik
    (beide ohne den zusätzlichen I/O auf der Floppyplatine) sind, also beide den 6522 der Floppy nutzen. Habe ich selbst schon so aufgebaut.

    Ich habe auch nicht alles richtig gelesen wie ich gerade feststelle ... Du schaltest ja auf dem Prologic um auf Dolphin ...
    Also hat Du ein Classic. Und das Dolphin nutz dann welchen Baustein? den 6821 auf der Platine oder den 6522 der Floppy?

  • Es macht eigentlich keinen Sinn, ein einem Rechner und Floppy umschaltbar Dolphin und Prologic zu verwenden. Speedmäßig nehmen die sich kaum was, aber Dolphin ist kompatibler und komfortabler (F-Tastenbelegung, @-Befehle). Das Ergebnis wird sein, dass man eh immer Dolphin nutzt. So wars damals bei mir, und so ist es heute: Ich nehme meistens den SX-64 wo ich Dolphin verbaut habe, den Zweiten mit PDC nutze ich eher seltener, meistens dann wenn ich beide gleichzeitig nutze.

  • Naja, ich habe hier x-verschiedene Versionen weil ich gesammelt habe auf der Suche
    nach der einen, die zusätzlich auch IEEE488 am Ex-Port kann.


    Ich habe auch irgendwo eine Exceltabelle in der ich die Unterschiede
    aufgeführt habe, allerdings habe ich anschließend nicht mehr analysiert
    was genau die Unterschiede bewirken ...

  • Naja, ich habe hier x-verschiedene Versionen weil ich gesammelt habe auf der Suche
    nach der einen, die zusätzlich auch IEEE488 am Ex-Port kann.


    Ich habe auch irgendwo eine Exceltabelle in der ich die Unterschiede
    aufgeführt habe, allerdings habe ich anschließend nicht mehr analysiert
    was genau die Unterschiede bewirken ...

    Achso....also das heißt die von dir kann alles + zusätzlich dieses IEEE488 am EX-Port und ist die 1.wahl fürs 8-fach kernal ?...das rom läuft bei dir mit der user-port variante oder hast du nur die ex-port version? ....ich hab jetzt nicht alles im thread gelesen daher sorry wenn dies schon irgendwo beantwortet wurde.

  • Achso....also das heißt die von dir kann alles + zusätzlich dieses IEEE488 am EX-Port und ist die 1.wahl fürs 8-fach kernal ?...das rom läuft bei dir mit der user-port variante oder hast du nur die ex-port version? ....ich hab jetzt nicht alles im thread gelesen daher sorry wenn dies schon irgendwo beantwortet wurde.

    Nein, leider nicht. Diese Version ist nur Userport und zwar eine Version von Rex wenn ich richtig liege.


    Die Version mit dem IEEE488 habe ich leider noch nicht identifiziert (falls sie in meiner Sammlung ist).
    Ich habe letztens erst den richtigen Hinweis dazu gefunden wie das IEEE488 Interface wahrscheinlich
    angeschlossen wird .... aber jetzt habe ich die letzte Zeit erst mal am Professional aus dem anderen Thread gebastelt :D

  • Ok...naha...jetzt weiß ich halt immer noch nicht welches user-port rom funktioniert von den geposteten. Vielleicht meldet sich noch jemand der die verschiedenen user-port kernal-roms auf dem ef3 oder so kurz testen kann mit seinem prologic dos um zu sehen welche nun funktionieren.

    Also diese Variante hier habe ich im Moment in meinem Prom und die läuft.
    Prolo-Userp.bin

  • Die IEEE488-Version nutzt meines Wissens den "Userport" der Expasionport-Version von PDC, und zwar pinkompatibel zu IEEE488-Lösungen am originalen Userport.


    Der Meinung bin ich nicht:


    Am Port hinten findet man nicht alle für IEEE488 benötigten Signale. Ich habe in Anlehnung an das IEC64 von Jann Datentechnik (Ein Danke nochmal an EWU) ein Kabel für das Prologic Dos erstellt. Ich vermute aber, ich habe immer noch nicht den benötigten Kernal.
    Schade, dass wirklich niemand diese Version des PD zu haben scheint :cry:
    (Falls doch: MELDET EUCH BITTE ENDLICH ;) ), denn dann wäre es recht einfach.


    Meine SFDs laufen auf jeden Fall schon mal wieder - jetzt kann die Suche nach dem richtigen Kernal und der richtigen Belegung weiter gehen.

  • Also diese Variante hier habe ich im Moment in meinem Prom und die läuft.
    Prolo-Userp.bin

    Ok, das ist jetzt die grüne schrift auf schwarzem hintergrund version von der du gesprochen hast, also manuell geändert? Wie sieht eigendlich die offizielle version aus? ganz normal wie die anderen kernel (schrift weiß, hintergrund blau) ?


    Ich würde ja gerne das ganze am original user-port prologic dos auf einem retro treffen testen wollen, wird sich doch jemand finden lassen der seins mitbringen könnte...aber diese treffen sind ja leider immer am "arsch der welt" :D . Gibts hier niemand der die user-port version hat und die 4 kernel kurz durchtesten kann ??? Seltsam ?( ....aber schon ein grund mehr das ganze nach dem proff. dos projekt anzugehen, hiermit nochmal ein appell an die könner unter euch :thumbsup: . Klar braucht mans nicht unbedingt wenn man prof. und dolphin hat...aber wenn man schon den kernel hat würde es einfach spaß machen sich die 3 tenöre (dolphin, proffessional und prologic) für die sammlung zu basteln solange es noch funktionsfähige 1541er gibt ;)

  • Gibts hier niemand der die user-port version hat und die 4 kernel kurz durchtesten kann ???

    ??? Du willst doch nur eine Version rein nehmen, oder? Also meine läuft definitiv... Wie gesagt die ist im Moment in einem meiner ROMs. Und die Farbe kannst Du ja aus dem ersten nehmen ... das sollten die Originalfarben sein wenn es nicht scharz / grün ist. Ich habe auch, glaube ich, keine Professional Kernals gefunden das nicht liefen ...
    Also wird der erst auch gehen.

  • Ok, also dann das allererste welches du in diesem post verlinkt hattest ist dieselbe variante wie die mit der schwarz/grünen farbe von dir, richtig? Ja klar möchte ich nur eines nehmen. Ich wundere mich auch daß es auf youtube nicht ein einziges video gibt wo man das originale prologic dos inkl. der floppy und hardware etc. sieht, zumindest habe ich nix gefunden...jeder mist wird dort gepostet aber sinnvolle dinge immer weniger, sowas aber auch. Danke dir für die hilfe!

  • Muss diesen alten Beitrag mal wieder ausgraben....


    Ich hab hier 3x die alte Jann Variante von Prologicdos, welche noch den 6522 in der Floppy nutzt.

    Das ist diejenige, wo der Floppy-Teil aus 2 Platinen besteht, also eine am 6502 Platz, und eine am 6522 (die beiden Platinen sind mit einer Leitung verbunden)

    Zusätzlich ist dann noch die C64 Platine, welche in den Expansionsport kommt, und über das Parallelkabel mit der 6522 Platine in der Floppy verbunden ist.


    Nun, mein Problem ist, daß keines der 3 funktioniert. :(

    Das heißt egal wie ich den linken DIP Schalter auf der Expansionsport-Platine auch stelle, meldet sich die Floppy immer mit dem originalen DOS 2.6, und nicht mit Prologicdos. Daher natürlich auch keine Beschleunigung.

    Das Kernal auf der Expansinsport-Platine ist bei allen 3 ok, und der C64 meldet sich mit Prologicdos, wenn ich den entsprechenden rechten DIP Schalter auf OFF schalte.


    Iirgendwann hat mal zumindest eines der 3 funktioniert, und ich wollte durch Quertauschen der einzelnen Platinen rausfinden, wo bei den anderen 2 das Problem liegt. War aber wohl keine so gute Idee....denn ich hab dabei nix rausgefunden, außer daß ich nimmer weiß, welche Platienen ursprünglich mal zusammengehört haben... ;)

    Und jetzt bekomme ich gar nichts mehr zum Laufen (also nur als DOS 2.6, aber nicht als Prologicdos), egal wie ich sie kombiniere. :(


    Von der Hardware her scheinen die Platinen von allen 3 identisch zu sein, also könnte lediglich in den Eproms Unterschiede sein.

    Kann mir aber eigentlich nicht vorstellen, daß deshalb durch eine falsche Kombination etwas in der Elektronik kaputt geworden wäre? Ganz defekt scheint auch nichts zu sein, sonst würde die Floppy vermutlich auch nicht mehr mit dem Original-DOS starten? Es scheint so als würde es sich lediglich nicht einschalten lassen?


    Ich würde einfach mal gerne rausfinden wie ich die Floppy-Platine direkt, also nicht über das Parallelkabel über den DIP Schalter auf der Expansionsport Platine einschalten kann?

    Hat vielleicht jemand eine Ahnung wie das geht? Ich nehme an es müssten dazu 2 Pins auf dem Parallelkabel-Anschluss kurzgeschlossen werden?

    Leider hab ich keinen Schaltplan von dem Teil, und bisher auch noch nicht genügend Motivation um auf dem Anschluss jeden Pin gegen jeden je nach Schalterstellung duchzumessen..... ;)


    Hoffe es kann mir hier jemand helfen?

    Vielen Dank schon mal!

  • Du kannst drei Sachen falsch machen die diesen Effekt haben:


    1. DIP Schalter falsch gestellt -> das hast Du schon ausprobiert.
    2. Parallelkabel (auf einer Seite) falsch herum aufgesteckt

    3. Die Querverbindung zwischen den beiden Platinen falsch oder garnicht gesteckt.

    Ich würde einfach mal gerne rausfinden wie ich die Floppy-Platine direkt, also nicht über das Parallelkabel über den DIP Schalter auf der Expansionsport Platine einschalten kann?


    Lege den Anschluss, auf den das grüne Kabel (die Querverbindung) hier auf dem Bild geht, einfach auf Masse. Die anderen beiden sind für eine Leuchtdiode.

    Neuauflage von Prologic Dos



    Bin im Moment nicht zuhause. Falls ich heute Anbend daran denke, dann kann ich auch den Schaltplan mal posten.

    Habe einen davon erstellt. :)

  • Vielen Dank!


    Tommi_nrw :

    Leider kann ich auf dem Foto von deinen Floppyplatinen nicht so genau erkennen wo das grüne Verbingundskabel stecken sollte?

    Und wozu ist das weiß/schwarze Kabel? Ist das zum ein/ausschalten? Dieses fehlt bei mir nämlich....


    Hab gestern dann noch einen anderen Betrag zu Prologicdoes gefunden:

    Prologic DOS (nicht Classic Version) Flachbandkabel Pinout / Anschluß


    Ich wusste nicht dass die beiden Paralelkabel Anschlüsse auf der Floppy Platine unterschiedliches Pinout haben! (hätte ich natürlich messen bzw. allein an den Leiterbahnen erkennen können, aber wer kommt denn schon auf diese Idee?!?)

    Außerdem hat der Kollege dort das Kabel zwischen den Platinen offenbar auf einem anderen Pin gesteckt (Frage ist nur ob es auf beiden so gehört?!)


    Werde da heute Abend mal bisschen herumspielen. Hoffe nur ich kann mir nicht etwas zerstört haben, wenn ich das Parallelkabel bzw. Verbindungskabel falsch herum oder an einem falschen Pin dran hatte?!

  • Und wozu ist das weiß/schwarze Kabel? Ist das zum ein/ausschalten? Dieses fehlt bei mir nämlich....

    Die anderen beiden sind für eine Leuchtdiode.


    Es gibt dort nur drei Pins. Grün EIN/AUS. Den Pin einfach auf Masse legen.

    Wo das Kabel hin geht ist egal. Es kann sein, dass ich das bei dem auch einfach an Masse angeschlossen habe.


    Damit kannst Du testen. und wenn die Platine funktioniert, dann einfach wieder mit dem Kontakt auf deranderen Platine verbinden.

    So kann wieder vom Expansionsport geschaltet werden.

    Ich bin nicht ganz sicher, aber ich meine die DIP Schalter auf der Platine stehen in unterschiedliche Richtungen wenn beide (Rechner und Floppy) eingeschaltet sind.


    Schwarz und Weiss sind der LED Anschluss! Wird zum Betrieb nicht benötigt.


    Werde da heute Abend mal bisschen herumspielen. Hoffe nur ich kann mir nicht etwas zerstört haben, wenn ich das Parallelkabel bzw. Verbindungskabel falsch herum oder an einem falschen Pin dran hatte?!

    Da passiert normal nix


    Ich wusste nicht dass die beiden Paralelkabel Anschlüsse auf der Floppy Platine unterschiedliches Pinout haben! (hätte ich natürlich messen bzw. allein an den Leiterbahnen erkennen können, aber wer kommt denn schon auf diese Idee?!?)

    Die sind nur seitenverkehrt zueinander