Hello, Guest the thread was called855 times and contains 24 replays

last post from the_best_time at the

Amiga 500 Erweiterungskarte - Akku ausgelaufen - was tun?

  • Hallo zusammen in die Runde,


    nach sehr vielen Jahren, habe ich meinen Amiga 500 wieder gefunden. Wie viele / alle von euch, denen es ähnlich ergeht, steht man nun vor vielen Fragen / Problemen. Ich möchte mit dem ersten Thema anfangen. Vorab, ich habe leider keine Ahnung von der Hardware, von Lötarbeiten oder sonstigen größeren Basteleien.


    Ich habe die Erweiterungskarte entdeckt und da ist wohl beim Akku etwas ausgelaufen?

    Ist das Teil für die Zeitanzeige? Die Erweiterungskarte an sich funktioniert jedenfalls. Jetzt meine Frage, kann man diesen Akku auch einfach mit einem Seidenscheider von dem Board trennen, also zwischen dem Akku und den Füßen welche im Board stecken (leider auf dem Foto nicht zu sehen) oder muss so etwas ausgelötet werden?


    Ich denke, das Teil soll lieber heute als morgen (zeitnah) von dem Board, damit es keinen Schaden trägt.
    Ich habe jedenfalls das ausgelaufene, kristallisierte Zeugs vorsichtig mal weggemacht. Wenn dieser Akku für eine Uhr ist, dann könnte ich darauf verzichten oder ist das sonst noch wichtig?


    Vielen Dank für eure Hilfe und Antwort.


    Beste Grüße

  • Der Akku hält die Uhr am Laufen. Nutzt Du den A500 nur zum Spielen von Floppy, brauchst Du den nicht.

    Wenn Du doch wieder eine Uhr haben möchtest, kannst Du statt dem Akku eine Knopfzelle mit Diode einlöten. Bauanleitungen gibt es zu Hauf im Netz, auf ebay auch vorgelötet.

    Was ich machen würde: Akku abkneifen und an die Stellen wo etwas auf die Platine ausgelaufen ist, mit Essig dran gehen, dann mit einem feuchten Tuch, abschließend mit einem trockenen. So habe ich das beim auslaufenden Akku meines A2000 gemacht. Dann nach Laune die Knopfzelle rein, oder eben nicht.

  • Wenn man ganz auf Nummer Sicher gehen will, könnte man auch den ganzen Bereich (Widerstände und Sockel) runter machen. Dann richtig säubern und wieder drauf löten. Die Erweiterungen sind nicht besonders teuer. Man kann also auch erstmal grob sauber machen und hoffen, dass die Säure nicht irgendwo unter den Bauteilen weiter frisst.

  • Das Foto ist nicht besonders gut, soweit ich das sehe, liegt kein Grünspan an den direkt anliegenden Bauteilen (also die Sockel und Widerstände) an.


    Du hast wohl recht viel Glück gehabt und die Akkulauge ist an Ort und Stelle des Akkus verblieben.


    Schaue Dir mal genau die Bauteile an. Bei den Sockel am besten von der Seite betrachten, ob Du zw. Kunststoff und Platine Grünsüff erkennen kannst. Falls

    nein, dann sollte es reichen den Akku einfach webzuknipsen und die Schadstelle zu säuben wie zuvor beschrieben.


    Essig ist m.E. nicht notwendig. Nach all diesen Jahren ist die Pampe eh trocken und hat sich totreagiert. Das musst Du selbst entscheiden.


    Ich würde mit'm Glasfaserstift die Schadstelle säubern und gut ist. Ggf. den freigelegten Kupfer noch versiegeln mit Stopplack (Gibts in der Bucht für'n 5er), dann wäre es

    wirklich sauber.


    Die Uhr ist m.E. gerade beim A500 bis Kick 1.3 nutzlos, der Kalender hat das Jahr 2000 Problem, er springt also wieder auf 1900 zurück. Ok. Uhrzeit würde natürlich laufen,

    aber wenn man schon die Zeit braucht für eine bessere Sortierung von Daten ist das Datum ja ebenfalls wichtig, aber größer 1999 kannst Du halt nicht konfigurieren.

  • Die Uhr ist m.E. gerade beim A500 bis Kick 1.3 nutzlos, der Kalender hat das Jahr 2000 Problem, er springt also wieder auf 1900 zurück.

    Behauptet wer (außer dir)? :gruebel:nixwiss:



    Und ja, die Uhr geht nach.

    Und ja, der 17.07.2021 ist ein Samstag.

  • ist keine Behauptung, so ist es bei meinen Amigas bis Kick 1.3


    Hast Du etwas nachgepatcht

  • ok, mal ganz fix gegoogelt:


    The Year 2000 problem and the Amiga (free.fr)


    Ich habe den Artikel nur überflogen und noch nicht 100%ig verstanden. Ich glaube die Wahrheit liegt dazwischen.


    Über die Prefs kann ich nicht über 1999 hinausgehen, aber über die Konsole funktioniert es doch...Falls das jetzt so stimmt, habe ich wieder was gelernt.

  • "4.4 SetClock stops working in the year 2000
    The SetClock program shipped with the Amiga Workbench disk revisions 1.2 and 1.3 exhibits a bug which causes it to miscalculate the battery backed up clock time starting with the year 2000. It is accurate only for the years 1978..1999. Once the year counter rolls over to 00, SetClock will believe that the year is 1978 until the year 2079 is reached; that's when it will believe that the year is 1979 -- which is not necessarily an improvement.#"


    Jetzt erinnere ich mich auch als ich mir damals den A500 flott gemacht habe. Hatte die Zeitsetzung ebenfalls über Setclock auf der Konsole vorgenommen, was leider nicht funktioniert hat. Mir war gar nicht bewusst, dass unterschiedliche Auslieferungen für SetClock gab. Da hatte ich dann wohl die fehlerhafte Variante genutzt.

  • setclock load ist auch keine wirkliche Hilfe.


    Der 17.07.1921 ist ein Sonntag. Der 17.7.2021 ein SA. So gesehen dürfte das passen. Du hast die Clock über Prefs eingestellt, korrekt? Mhh..vielleicht haste die gepatchte Version.


    Ich muss das mal gegenchecken, aber ist hier jetzt off-Topic

  • Hallo zusammen,


    ihr seid klasse. Vielen Dank für eure schnellen Antworten und Tipps.


    Genau, ich habe den Amiga 500 nur zum Spielen, benötige an dieser Stelle also keine Uhr.


    Ja, sorry. Das Foto ist leider nicht gut, es liegt auch daran, weil ich die Karte nicht ausgebaut hatte. Ich versuche das morgen oder spätestens am WE nachzuholen.


    Abknipsen - alles klar nur muss der Rest unbedingt ausgelötet werden oder darf das auch so bleiben (auch wenn es nicht so schön ausschaut)? Mir geht es nur darum, wenn es neg. Auswirkungen auf die Karte hat, dann muss es raus - ansonsten würde ich es dann so lassen.


    Ich knipse den Akku dann ab und poste ein Bild, damit ihr gerne ein Bild von dem Schaden machen könnt, wenn die Erweiterungskarte entsprechend von dem Zeugs etwas abbekommen haben sollte.


    Danke und beste Grüße

  • Guten Morgen zusammen,


    so, ich habe die Karte jetzt entfernt und was auf den ersten Blick so toll aussah, entpuppt sich jetzt als nicht mehr so toll?


    Für was ist denn dieser OKI Mikrochip? Ist der für den Akku und die Uhr oder hat er was mit der Speichererweiterung zu tun?

    Wenn es mit der Uhr zu tun hat, wär es nicht so wild, aber sonst... . Seht ihr auch den blauen Schmodder zwischen dessen Füßchen?


    Ich hoffe, die Fotos helfen euch jetzt mehr die Lage einzuschätzen.


    Vielen Danke euch schon mal. Ich versuche jetzt den Akku abzuknipsen. Scheint gar nicht so leicht zu sein, da man keinen Platz hat da ran zu kommen.


    Beste Grüße und allen ein schönes WE.

  • ja, das ist der RTC IC ... https://www.amigawiki.org/doku.php?id=de:parts:m6242b


    Ich würde tatsächlich als erstes den alten Akku mit einem kleinen Seitenschneider runternehmen und alles mit IPA reinigen so gut es geht, den OKI IC entfernen und auch unter im Sockel reinigen ....


    Am besten wäre natürlich den Sockel auszulöten und nach der Reinigung der Platine durch einen neuen zu ersetzen ...

  • Hallo zusammen,


    meine erste Löt-/ Entlötarbeit ist vollbracht.


    So schaut es aus:


    Ich habe im Anschluss der Fotos noch Q-Tipps und ein wenig Essig genommen und mit einem Zahnstocher den Schmodder entfernt.


    Habe leider nur eine Lötpistole mit ganz dicker Spitze zur Verfügung, so dass Feinarbeiten gar nicht möglich sind und bin froh, dass ich den Akku überhaupt rausbekommen habe. An die Klammer bin ich gar nicht gekommen. Letztendlich habe ich diese vom Akku immer Stück für Stück immer weiter von oben nach unten geschält, bis diese Trommel nicht mehr mit der Klammer verbunden war. Danach konnte ich den Akku nach oben klappen und habe dann die Klammer zusammen mit dem Akku rausgelötet.


    Ich hoffe, dass die Karte noch funktioniert und werde berichten.


    Muss ich sonst noch was beachten oder kann ich die Karte so wieder einsetzen?


    @SkulleateR

    Danke für deine Antwort und die Info. OK, der Chip wäre also nicht so wichtig, da ich keine Uhrzeit benötige.


    Beste Grüße

  • die Platine sieht ja noch ziemlich gut aus, Ich würde den Sockel vom Oki rausnehmen, darunter alles reininge. Ggf. ein paar Leitungen flicken und alles wieder zusammenbauen.


    Mit'ner Knopfzelle kriegste dann die Karte wieder vollfunktionasfähig inkl. Uhr. Ich habe deutlich üblere Kandidaten wo großflächig die Platine im A* war. Da habe ich den OKI weggelassen.


    Hier siehts aber doch recht gut aus.


    Ein Löter in Deiner Nähe gibts bestimmt.