Hello, Guest the thread was called1.1k times and contains 32 replays

last post from Zyntrion at the

Externes Floppy flott machen

  • Hallo zusammen,


    habe mir über e... Kleinanzeigen ein externes LW bestellt .... dummerweise macht er keinen mux

    Frage : ohne meine Amiga in Mitleidenschaft zu ziehen. Wie kann ich ,quasi im Ausschluss verfahren herausfinden was defekt ist ?

    Gehen die Externen 1:1 am internen Kabel ? Gibt es ein vernünftiges Pinout bzw. Bilder der Stecker ? woran ich mich orientieren kann

    Ich nehme an am Poweranschluss muss "nur" 5 Volt ankommen oder ?


    Falls jemand auf die Idee kommt mir lieb zu raten das Lw zurück zu schicken ... Geld an freunde -> keine Rückerstattung und der "freundliche" Verkäufer ist nicht erreichbar .


    Danke für konstruktive Vorschläge

  • Um welches externes Laufwerk handelt es sich denn (Bezeichnung auf einem Sticker auf der Rückseiote? , oder evtl. ein Foto davon machen?)

    Mir sind die meisten davon die es gab ein Begriff.


    Und welches Laufwerk ist intern darin eingebaut? Es gibt da nicht allzu viele, ca. eine Hand voll unterschiedliche, die recht verbreitet sind, und ein paar wenige seltenere.

    Je nach Type brauchen die entweder 5V und 12V, oder nur 5V.

    (wenn du nur einen 2-poligen Power-Stecker zum Laufwerk siehst, dann merk dir gut wo und wie herum der an den 4 Pins dransteckt, damit du ihn später nicht versehentlich verkehrt rum ansteckst, und dir dann evtl. das Laufwerk killst!!)


    Prinzipiell kannst du das Laufwerk aus dem externen Gehäuse rausnehmen, und intern anschließen.

    Wichig ist nur, daß es auf 'DS0' konfiguriert ist, und nicht auf 'DS1'! Das ist je nach der Elektronik, die in dem externen Gheäuse drinsitzt, unterschiedlich. Die Laufwerke haben dafür meist einen Jumper oder Schiebe-Schalter.


    So kannst du zumindest mal rausfinden ob es an der Elektronik vom Gehäuse, oder am Laufwerk selbst liegt.

    Je nachdem kann ich dir dann noch weitere Tips geben.


    Was auch öfters mal vorkommt, wenn die externen Laufwerke keinen Mux von sich geben, oder evtl. sogar der Amiga bei angeschlossenem Laufwerk nicht startet, der Bildschirm wild blinkt, oder ähnliches:


    Die meisten Gehäuse haben unten 6 Schrauben, wovon 2 etwas kürzer sind. Die kürzeren Schrauben Gehören dort rein, wo NICHT das Laufwerk im gehäuse mit festgeschraubt wird, also auf der Seite wo sich das Anschluss-Kabel befindet, und nicht der Schacht für die Diskette.

    Wenn dagegen von irgendjemandem die längeren Schrauben hinten reingedreht wurden, dann komen diese mit der Platine in Berührung, und führen dann je nachdem zu einem mehr oder weniger üblen Kurschluss der Elektronik über das Gehäuse.

    Ist mir öfters schon mal untergekommen ;) Aber glücklicherweise überleben es die Laufwerke und Elektroniken offenbar meist. :)

  • Hallo Overdoc


    es handelt sich um Mitsumi LW


    Anbei die Bilder


    Einen Jumper bzw. einen Schiebeschalter kann ich nirgends erkennen . Daher stellt sich die Frage wie er dann letztendlich ( falls ich ihm intern einbauen soll) angesprochen wird.

    Eine explizite df0 Zuweisung kann nur per externe Elektronik erfolgen



    Das Gehäuse wurde "nur" mit 2 Schrauben festgehalten. Wurde von mir ohne hin in geöffneten Zusatnd geprüft.


    Bin froh über Tipps


    Gruß

    Chris

  • Hallo ,


    hmm das Laufwerk ist genau so verlötet wie auf mojo Bilder . Was bedutet das ? ist er jetzt als extern ( df1) umgebaut oder intern df0 ?

    Wie dann umswitchen ?


    Anbei mein Laufwerk:




    Die "verbindungen" an den DS0 usw ... das ist ja ein Resistor ? oder ? wieviel Ohm hat er denn ? Ihm umzulöten ist sicherlich spassig

    Kann ich hier ne Drahtverbindung nehmen ?

  • Das Laufwerk ist korrekt als DS0 gejumpert, das sollte so am internen Stecker funktionieren. Die Herausforderung ist nur, die Stecker richtig herum draufzustecken, weil sie häufig nicht verdrehsicher kodiert sind. Der Stromstecker ist da kritisch, wenn der verdreht wird, jagst Du 12V in den 5V Anschluß, danach ist die Floppy hinüber. Beim 34-poligen Shugart Floppy-Stecker ist die eine Seite nur GND, das kann man mit dem Multimeter herausbekommen (deshalb auch nur die eine Leiste am Anschlußstecker im externen Laufwerk). Den Pinout findet man per Google oder in den Schematics des Amiga.


    Deine Fehlerbeschreibung "tut keinen mux" ist leider nicht sehr hilfreich. Wenn Du die Workbench startest, wird das externe Laufwerk erkannt und als DF1: auf dem Desktop angezeigt? Wenn nicht, hat das Kabel einen Bruch oder der 23-polige D-Sub-Stecker Kontaktprobleme oder die kleine Platine im Laufwerk ist kaputt bzw. hat eine kalte Lötstelle. Muß man mit dem Multimeter durchklingeln. Andernfalls: Bekommst Du das typische Klickgeräusch? Läuft der Motor? etc. etc.


    Viele Grüße,


    Patrick

  • Danke Jungs ich glaube wir reden ein bissl an einander vorbei.

    Zunächst kein mux = Keine Klickgeräusche, Motor dreht nicht.


    Dann:

    Das Laufwerk sollte als Externes Drive Laufen

    Intern wollte ich es es quasi NUR Testen ob es was von sich gibt

    Das Laufwerk soll aber EXTERN betrieben werden


    Was zurück zu meiner Frage führt : Was muss ich hier alles umschalten respektive umlöten um es als DF1 zu verwenden ?


    Wenn du jetzt schreibst das Laufwerk kann intern betrieben werden , fein werde es gleich testen und bescheid geben ob es läuft.

    Aber auf Dauer ist es als DF1 also als zweit Laufwerk - Externes Laufwerk vorgesehen.


    Muss ich hier um es extern betreiben zu können also auf DS1 umlöten ?


    Kabel messe ich durch. Gute Idee


    Kann ich bedenkenlos das Kabel an amiga einstecken und die Powerleitung messen ? Oder besser nach Pinout die Positionen durchgehen und hoffen das mein Amiga die erforderlichen 5 bzw. 12 Volt liefert.

    Denn hier bin ich mir auch nicht sicher ob der Amiga die Signale entsprechend über den Stecker auch bereitstellt.


    Workbench konnte ich bis heute Mittag nicht testen denn Mein Gotek ist mir hops gegangen Ein anderes Thema


    Gruß


    Chr.

  • Das Laufwerk muß normalerweise intern wie extern als DS0 gejumpert sein. Es ist die Aufgabe der kleinen Platine im externen Laufwerk, das korrekt umzusetzen. Normalerweise kannst Du interne und externe Floppies einfach tauschen. Es sei denn, Du hast einen der Escom Amiga 1200, die intern eine PC-Floppy verbaut haben. Das Kabel der externen Floppy kannst Du dranstecken und durchmessen, da werden auch 12V geliefert. Ich würde aber erstmal eine Workbench zum Laufen bringen.

  • Habe nun Kabel durchgeprüft scheint alles ok zu sein. Extern angeschlossen gibt er keine Reaktion von sich.

    Ich meine mich zu erinnern, dass ein externer zumindest die Diskette lesen soll. Booten kann er nicht da ich kick 1.3 ohne bootselector habe.


    Kann sein dass genau das Laufwerk noch zusätzlich zu den 5 Volt 12 Volt Anschluss braucht ?

    Komisch ist das er intern eingebaut prima läuft ....


    So arg rumexperimentieren will ich nicht da ich sehr stark vermute dass mein Gotek deswegen irgendwie das zeitliche segnete ....

  • Ehhm die Frage nach den 12 Volt ist immer noch offen


    Kann ich problemlos die 12 Volt vom Externen Kabel abzwacken ?

    Wo ich bedenken habe ist folgendes. Entweder ab Werk oder weil da schon jemand herumgefummelt hat sind alle GND verbunden (siehe Bilder oben) obwohl 2 Kabel dafür vom Stecker weggehen.


    Ich will mir nicht meinem CIA killen, daher Frage ich die Elektrik experten unter euch lieber .

  • Danke für die Fotos.

    Bei dem Mitsumi Laufwerk handelt es sich um ein für den Amiga adaptiertes PC Laufwerk. Es ist aber eines wo das prinzipeill möglich ist, und wurde vom Vorbesitzer so wie es aussieht auch korrekt umgebaut. (daher läuft es ja auch intern problemlos)


    Das Problem scheinen die fehlenden 12V zu sein. Bin mir recht sicher, daß das Mitsumi Laufwerk neben den 5V auch die 12V benötigt. Ohne die 12V laufen die Motoren nicht.

    Die 12V könntest du dir aber mit etwas Bastelei vom 23-poligen Anschluss holen. Eigentlich sind es nur zwei Kabel, die 12V, und GND, welche du vom Stecker des externen Gehäuses (oder der Platine) zum Laufwerk verbinden musst.


    Darüber hinaus handelt es sich bei dem externen Gehäuse um eines wo das Laufwerk nur 1-reihig angeschlossen wird. Da musst dzu darauf achten daß die Platine nur auf die oberen Pins des doppel-reihigen Anschlusses am Laufwerk aufgesteckt wird.

    Wenn du es so ansteckst und dem Laufwerk auch die 12V zukommen lässt, dann sollte es klappen.

  • Wie unschwer auf dem Typenschild zu lesen, ist das D359T5 ein 5V-Laufwerk, braucht also keine 12V

    Man kann die 12V anschließen, bringt aber nix, da - wie unschwer auf dem unteren Bild erkennbar - das 12V-Pad des Steckers nirgendwo angeshlossen ist.

    Und nein, das ist keine 2seitige Platine.

  • SamW:

    Stimmt, hätte mir das Foto vom Laufwerk näher anschaun sollen....

    Könnte aber sein daß das Laufwerk falsch angeschlossen war?


    Die Platine des externen Gehäuses muss wie erwähnt an die obere Reihe des Steckers am Floppy dran.

    Und der 2-polige Power Stecker muss an die inneren beiden der 4 Pins am Laufwerk (also von hinten gesehen die rechten beiden) , und zwar so herum, daß GND in der Mitte (von den 4 Pins) liegt.

    Ob das rote oder das gelbe Kabel GND ist kannst du mit dem Mulitmeter ausmessen, indem du auf Durchgang z.b. zum Blech rund um den Anschluss für ein weiteres Laufwerk hinten am Gehäuse misst.

  • Im Prinzip bleibt dann nicht viel übrig:


    A) Stromstecker falsch draufgesteckt ...aber, mess mal vorher an dem Stromstecker, ob da auch 5V anliegen und nicht 12v! Evtl. war da ja ein 12v Laufwerk original verbaut, nicht, dass du das Mitsumi brätst, wenn du den Stecker falsch draufsteckst !!

    B) Lötjumper auf DS1 setzen ...manche Platinen in den externen Laufwerken möchten das Laufwerk auf DS1 gesetzt haben, die meisten aber auf DS0.