Hello, Guest the thread was called2.4k times and contains 49 replays

last post from Ruudi at the

DELA Eprommer II (redesign)

  • hallo an euch alle,


    bitte diese dela schaltung nicht benutzen.

    ich war der erste gewesen mit einem eprom (brenner) programmer an einem pet, ende der 70er.
    ich vermute, dela gab es da noch garnicht. von dela habe ich erst jahre später etwas mitbekommen.

    und nur, weil ihre schaltungen, ähnlichkeiten mit meinen damals hatten und mancheiner in meinen laden,
    aachener str. 29 eingang brüsseler str. gekommen ist. der probleme mit dela sachen hatte.

    aachener str. 27 war p+m elektronik. die schickten die dela leute mit ihren problemen um die ecke zu uns.
    dela war brüsseler platz, ca. 50m entfernt.

    erst viele jahre später, ca. 1993, haben zwei meiner früheren mitarbeiter, mir in einer kneipe, gebeichtet und sich entschuldigt,
    das sie manche meiner prototypen, nach feierabend, in meinem laden, für einen kasten bier,
    der konkurenz, zum nachbauen presentierten.

    ich wunderte mich damals nur, das auch andere, zu der gleichen zeit, auf die gleiche idee kamen.
    so habe ich, von manchen sachen damals, nach der prototypen serie für meine läden und die tester,
    dann keine serienproduktion mehr gestartet. der home computermarkt war nicht so wichtig mehr für mich.

    ich schaltete die programmierspannung damals mit dem lm317 um, dafür ist er auch ideal.


    mit dem 7805 wird es nur umständlicher.
    dela wollte es wohl aber anders lösen, als mit einem 317. wohl unbedingt komplizierter, unsicherer und teuerer.


    der 7805 darf absolut maximal nur 35V am eingang haben. keiner würde ihn mit mehr als 35v am eingang betreiben.
    erstrecht nicht bei einem programmer, wenn der durchschlägt, dann zerstört er sofort jedes eprom.

    gruß
    helmut

  • Soderle. Unabhängig von etwaigen IP-Fragen aus vergangenen Tagen habe ich den Brenner mal seinem Einsatzzwecke in einer kleinen Testreihe zugeführt.


    27C128A (12V) - Normalmode - ok

    27C128A (12V) - Schnellmode - ok


    27C256B (12V) - Normalmode - fail

    27C256B (12V) - Schnellmode - ok


    M5L2764K (21V) - Normalmode - ok

    M5L2764K (21V) - Schnellmode - ok


    28C64 - fail


    Das zweite 21V-EPROM funktionierte nicht richtig, nachdem ich es in einem Modul testen wollte. Zwar startete die gerbannte Software, lief aber nicht oder jedenfalls nicht so richtig. Ein Vergleich mit dem anderen EPROM ergab Unterschiede (Abbruch bei Speicherzelle $05). Nach merhmaligem hin- und herwechseln und Vergleich mit einem dritten gleichgegrannten EPROM, war auf einmal alles ok und auch im Modul funktionierte auf einmal alles. Da tippe ich mal auf oxidierte Kontakte oder sowas. Das war vermutlich auch der Grund, warum das erste 27C256B nicht wollte. Es sind alles auch gebrauchte Teile (Datecodes von 1984-1998). Die "neuen" wollte ich nicht riskieren. :)


    Warum das EEPROM nicht geschrieben wird, zeigt ein Blick ins Datenblatt. Die Methode unterscheidet sich vom Beschreiben eines EPROMS. Keine Ahnung, ob sich das softwareseitig implementieren lässt, es ist jedenfalls ganz offenbar nicht vorgesehen. Die Löschmöglichkeit habe ich nicht ausprobiert, zumal das EEPROM ja auch leer blieb. Da ich das Brennen dann aber eh mit einem anderen Gerät machen würde, ist diese Möglichkeit am DELA nicht wirklich sinnvoll für mich.


    Das alles lief hintereinander weg. Der 7805 wurde gut warm, schaltete sich aber offensichtlich nicht ab und die Spannungen, einschließlich der Logik-Pegel, waren angesichts der grundsätzlichen Erfolge auch alle stabil und auf der richtigen Höhe. Great Success! Very Nice!


    Die Schnellmethode verdient ihren Namen übrigens! :D Vor allem bei den 32k-EPROMS eine Erleichterung.

  • Original Keilnetzteil.

    Ah ok. Dann hast du ja tendenziell auch eher zuviel Spannung auf den 9V-Leitungen. Das macht meinen Fall ja noch mysteriöser, wo ich doch einen 230V-Trafo im Netzteil habe. :gruebel


    Oder liegt es vielleicht (auch) am Board? Ich habe hier eine 469 in Betrieb. Dort werden die 9V ja nicht wirklich anderweitig belastet. Das dürfte bei einer 407 sicher anders aussehen und dann ist deswegen vielleicht die Spannung am 7805 niedriger? Hab gerade keine 407 in betriebsbereitem Zustand.

  • Die 78xx gab (gibt?) es in speziellen HV-Versionen, dann können die mehr als 35V am Eingang.


    Aber LM317 (ebenso in Hochvoltversion) ist sicher die DEUTLICH bessere Lösung, wie Helmut axorp ja schon schrieb, denn dort wird die Ausgangsspannung dann umschaltbar GEREGELT, nicht hingepfuscht.. Ausgangskondensator NACH Regler MUSS relativ klein sein dabei, denn Rückströme kann weder der 78xx noch der LM317 ab. (Diode Antiparallel drüber würde helfen...). Siebung VOR der Regelung, Kondensator hinten NUR zur Vermeidung einer Schwingneigung!


    Die Elko-Spannungsauslegung sehe ich als weniger kritisch an, sofern Marken-Elkos verwendet werden. Da die Aufgabe eines Elko als Speicherkondensator ja gerade ist, Spannungsspitzen wegzubügeln, ist eine Auslegung auf Urms hin m.E. durchaus valide.


    Da es heute aber hochkapazitive keramische Kondensatoren (z.b in X7R) gibt, würde ich die Elkos rauswerfen. Ein Längswiderstand ist dann allerdings notwendig, um die Schwingneigung am Längsregler in den Griff zu bekommen, aber das Ergebnis ist langzeitstabil und kann nicht auslaufen und Ätzschäden verursachen...