Darstellungsprobleme bei Bildern

  • Seit gestern tauchen bei mir im Wiki Bilder auf, die einen weißen Hintergrund haben, wo keiner sein sollte.


    Als Beispiel hier einmal Satan. Ich hatte das gestern auch bei einem anderen Artikel gesehen, weiß aber nicht mehr, in welchem. Es handelt sich wohl um PNGs, bei denen das Transparent-Bit gesetzt wurde.


    Hier nochmal als Screenshot. Ist aber kein mobiles Problem, passiert auch auf'm Desktop. Allerdings hab ich es nur in Chrome getestet.


  • Die Transparenz bei den Bildern scheint mir das Problem zu sein. Also die Bilder sollten den schwarzen Hintergrund nicht transparent deklarieren. Dann hängt es immer vom Hintergrund der Umgebung ab, wie das Bild dargestellt wird. Da zeigen sich dann offenbar die Unterschiede der Browser.
    Firefox zeigt die Bilder auf schwarzem Hintergrund. Chrome (und Abkömmlinge) nehmen da brav die Artikelhintergrundfarbe ...
    Vielleicht mag das der Artikelautor beheben (vielleicht gibt es bei dessen Artikel auch noch weitere solche Bilder) ... ;)

  • Ich habe bei diesen Artikeln vor Jahren noch einen anderen Photoshop benutzt, der leider manchmal aus schwarz transparent machte :(


    Ich dachte das sei alles ausgemerzt... Okay, Keyfinders, Satan... und bei Knight Orc hab ich noch was bemerkt. Der Fehler ist nicht mit Firefox erkennbar, da sieht es normal aus. Beim Explorer z.B. wirds transparent angezeigt.


    Abhilfe ist nicht schwer: Das Bild runterladen, einmal mit Paint oder sowas aufmachen, speichern. Dann ist transparent weg, weil Paint das nicht kennt.


    Werde mich mal dransetzen und das erledigen. Da ich Firefox verwende und diesen Fehler selbst nicht sehe, bitte Bescheid sagen (oder selbst fix fixen).