Hello, Guest the thread was called12k times and contains 252 replays

last post from Juergen Johannes at the

DT64 Native-Copy Test für MP64

  • (Nachdem ich nun weiß das das Pro nach Blöcken gefragt hat)

    Denk aber daran das Pro fragt nach Blöcken ä 64 KB, ist nicht das Gleiche wie die Block's auf Disketten.
    Der Begriff ist ein wenig unglücklich gewählt.



    Hab jetzt mal eine HD-Partition in ein DNP kopiert (gleiche Grösse).
    Wie lange es gedauert hat, kann ich nicht sagen.
    Als ich nach 20 min. nachschaute war das Kopieren schon beendet, was aber nicht sein kann bei > 7 MB-Daten. ?(


    Ein UV kann ich nicht öffnen: Diskfehler $02, ungültiger Track.
    Ebenfalls wird beim Aufräumen eine Datei als fehlerhaft bezeichnet, egal ob Dein TD, Werner's TD oder GeoDOS V 2.963.
    Komischerweise ist diese Datei nicht (mehr) vorhanden, dies kann auch der Grund für verschiedene Blockwerte sein.


    Hab die gleiche Partition noch mit GeoDOS kopiert (Dauert über 1 Std.), hier gibt es keinen Fehler.
    Ebenfalls wird in der Partition kein Fehler gefunden.


    Gruss C=Mac.



    Edit: Ich hasse dieses xxxxxx Cloudflare

  • Könntest Du bitte mal genauere Angaben zu Deiner Systemkonfiguration machen und wohin Du was kopieren wolltest?
    Hast Du auch wirklich den letzten MP64-SnapShot und meinen DT64 vom 21.10.18 installiert?


    Pusti64

  • Könntest Du bitte mal genauere Angaben zu Deiner Systemkonfiguration machen und wohin Du was kopieren wolltest?

    A: SD2IEC DNP's
    B: FD 2000 (1581)
    C: CMD-HD (Native) Parallel
    D: RamLink (Native)
    SCPU on, 20 MHZ, RamCard 16 MB nur für die DACC


    Kopierrichtung: Von C -> A.



    Hast Du auch den letzten MP64-SnapShot installiert?

    Jap, Snapshot vom 19.10.18.


    Gruss C=Mac.

  • .. und auch meine aktuelle Testversion vom 21.10.18? Denn die vorherige Version hatte da noch einen groben Fehler drin.


    Pusti64

  • ... und vor allem: Bist Du Dir sicher das auf keinem anderen Laufwerk eine alte Version von TopDesk enthalten war? Wenn da die alte Routine nachgeladen wurde dann wird wesentlich weniger kopiert -> Schneller fertig.


    Die GEOS-Klasse findet sich im SourceCode den ich von Pust64 hab, d.h. der TopDesk könnte Unterprogramme nachladen und dabei nach einem TopDesk mit der entspr. GEOS-Klasse suchen. Und die scheint unverändert auch beim neuen DT64Nat identisch mit dem letzten Release zu sein.


    Ich weiß nicht ob sich das mit RamTopDesk ausschließen lässt... der muss ja auch erstmal Code nachladen und lädt dann ggf. ebenfalls den falschen ins RAM...

  • Sorry, aber irgendetwas musst Du da falsch machen. Denn ich habe Deine Systemkonfiguration nachgestellt und kann ein 3.2 MB DNP (das von Werner) in beide Richtungen problemlos kopieren und aufräumen.


    Pusti64

  • Wollte die nächste und scheinbar finale Änderung als Patch rausgeben. Oder möchtest Du das gleich mit in Dein Patch einfließen lassen? Nicht das es zum Schluss tausend Patch für ein und die selbe Applikation gibt. Ist nur eine Frage, kein muss ;-)
    Bisher sollten zumindest die letzten zwei drei D64-Datein im Disknamen das Datum mit stehen haben.


    Pusti64

  • Ich glaub ich hab den Fehler.


    ... und vor allem: Bist Du Dir sicher das auf keinem anderen Laufwerk eine alte Version von TopDesk enthalten war?

    Ups, auf der aktiven RL-Partition war noch eine TopDesk-Version. :schande:
    Oder es lag daran, dass ich vorher MP3-64 (mit dem normalen TD) benutzt und dies normal verlassen habe.
    SCPU-Reset (laannges drücken der Resettaste), MP3 mit modifiziertem TD booten.


    Naja, hab jetzt die gleiche Partition noch einmal kopiert, dauerte 1 Std. 20 min.
    Das beschädigte UV, war jetzt in Ordnung.
    GeoDOS hat beim Aufräumen kein Fehler gefunden.
    Im Moment ist TD am aufräumen.



    Was anderes ist mir aufgefallen (betrifft nicht nur Deine TD-Version).


    Im LfW-Fenster werden die Icons durchnummeriert, linke Seite 1, 5, 9 etc.
    Hat das LfW-Fenster die halbe Grösse (in der Höhe) und ich scrolle nach unten, z.b. Position 13 und öffne dieses UV in einem neuen Fenster.
    Wird im alten Fenster die Positionsnummer von 13 auf 1 geändert.
    Öffnen ich jetzt die Info von diesem UV, wird der Infoblock vom UV welches wirklich auf Position 1 ist angezeigt.
    Auch bei den Anderen im gleichen Fenster sind die Positionen verschoben.
    Also 14 wird zu 2, 15 zu 3, 16 zu 4 usw.
    Dies Betrifft aber nur den Infoblock, geöffnet wird das korrekte UV.




    Wollte die nächste und scheinbar finale Änderung als Patch rausgeben. Oder möchtest Du das gleich mit in Dein Patch einfließen lassen? Nicht das es zum Schluss tausend Patch für ein und die selbe Applikation gibt. Ist nur eine Frage, kein muss

    Wie wäre es gleich fixfertig?
    Mit allen nötigen Patch, neuer Versionsnummer und Datum.


    Gruss C=Mac.

  • Wenn Werner nicht möchte, dann würde ich einen Native-Copy-Patchtext für das Patch System von Falk Rehwagen rausgeben.


    Pusti64

  • Wenn Werner nicht möchte, dann würde ich einen Native-Copy-Patchtext für das Patch System von Falk Rehwagen rausgeben

    Es geht weniger um möchten, als um Zeit zu finden, das zu ändern.


    Mal ne Frage: Bei TD128 benutzt die letzte bereits geänderte Version von 2017?


    Kannst Du das für die C64-Version ändern und dann gleich einen kompletten TD rausbringen? Die nötigen Infos kann ich Dir schicken (spätestens am Wochenende). Da muss nur ein Byte geändert werden, damit die Boot-Sektor-Prüfung bei TD64 weg ist.....


    Gruß
    Werner

  • Es geht weniger um möchten, als um Zeit zu finden, das zu ändern.
    Mal ne Frage: Bei TD128 benutzt die letzte bereits geänderte Version von 2017?


    Kannst Du das für die C64-Version ändern und dann gleich einen kompletten TD rausbringen? Die nötigen Infos kann ich Dir schicken (spätestens am Wochenende). Da muss nur ein Byte geändert werden, damit die Boot-Sektor-Prüfung bei TD64 weg ist.....


    Gruß
    Werner

    Ja, die 2017er Version.


    Kann ich auch für die C64-Version machen ;-)


    Pusti64

  • Ich hab den neuen TD heute auch getestet.


    Bei mir werden die Nummern vor den Icons 1-9 Normal angezeigt, alles ab 10 sind komische Zeichen.
    Ebendso beim anwählen von Dateien, bei mehr als 10 Dateien sieht man im TD keine Zahlen mehr sondern auch nur Zeichen.
    Auch im Calender wird das Datum nur bis 9 angezeigt, danach Komische Zeichen..........


    Ansonsten keine Abstürze oder Sonstige Fehler.
    Das Kopieren 1:1 hab ich noch nicht getestet,

  • Könntest Du mal ein Foto davon machen.


    Pusti64