Hello, Guest the thread was called1.6k times and contains 15 replays

last post from BlutAxt74 at the

WinUAE unter Win10 minimiert sich

  • Moin, ich hoffe jemand kann mir helfen weil ich bekomme es nicht hin.


    Erklärung:

    Ich versuche eben WinUAE unter Windows 10 für die Aufnahme/Streaming mit OBS zum laufen zu bringen.

    Ich nutze dafür zwei Monitore, einen für den Emulator, den anderen für die Aufnahme.


    WinUAE läuft mit einer alten OS3.9 HDF und das funktioniert wie es soll. Alles ok also mit dem Emulator


    Problem:

    Ich muss WinUAE offen lassen, um das richtige Fenster bei OBS erfassen zu können aber sobald ich aus dem WinUAE Fenster rausgehe, minimiert sich der Emulator und OBS "sieht" das Fenster nicht mehr.

    Habe es als Fenster, Vollbild und als Monitor Erfassung versucht aber wenn WinUAE verschwindet, ist es echt weg.



    Wie bekomme ich also WinUAE dazu, daß es sich nicht minimiert?

  • Eventuell in den Display-Settings auf Windowed umstellen? Vgl. Screenshot anbei.


    Kurzer Test ergab, dass die Erfassung des WinUAE-Fensters (aus dem zugehörigen winuae64.exe Prozess) mit "Windowed" Einstellung in WinUAE zumindest bei mir soweit zu funktionieren scheint (Aufnahmemethode Windows Graphics Capture):

  • syshack

    Changed the title of the thread from “WinUAE unter Win10 minimiert sich! Shit” to “WinUAE unter Win10 minimiert sich”.
  • HurricaneMick Nein, der Haken war NICHT gesetzt aber es bringt auch nichts.

    [External Media: https://youtu.be/2quCI8zJyUE]


    hexfile


    Auch der Window Mode bringt nichts. Auch dieses Fenster wird minimiert und ich kann es in OBS nicht erfassen.

    [External Media: https://youtu.be/K9Okbd6AvR0]


    Kann das daran liegen, das ich eben über den internen Grafikchip gehe? Mein Grafikkarte ist durch geknallt.

  • Ja das Thema kann wohl dicht.


    Ich finde keine Lösung für das Phänomen und andere auch nicht.


    Dazu kommt, das ich kein WHDLoad Spiel starten kann.

    WHDLoad ist die 18.5 und bei jeden Spiel wird mir gesagt, dass ich den Slave aktualisieren soll.

    Aber egal ob ich den uralten Slave verwende, mit denen unter Win7 alles lief oder den aktuellen von der WHDLoad Seite installiere.

    WinUAE lädt bis zu den Requester wo ich die Cheat oder ECS Version auswählen kann (Hier mal von Alien Breed Tower Assault) und ich warte einfach bis das Spiel starten will.

    Aber alles was kommt ist ein komplett Grüner oder Weißer oder Roter Bildschirm.

    Ich komme da auch nur raus mit F12 und einen Reset des Amiga.


    Das ist bei allen Spielen so.


    Schade, kein retro Stream von Amiga Spielen also.

    Zum zocken werde ich dann wohl einfach einen meiner RetroPie Automaten nehmen

  • Quote

    WHDLoad ist die 18.5 und bei jeden Spiel wird mir gesagt, dass ich den Slave aktualisieren soll.


    Dann hast du für OS3.9 in WinUAE das Internet aktiviert. Das mußt du abschalten, dann kommt die nervige Meldung von WHDLoad nicht mehr. Einfach in der s:whdload.prefs Datei den Tooltype "NoNetwork" aktivieren. Dazu einfach das ";" am Start der Zeile rausnehmen und im Amiga Editor abspeichern.

    http://www.whdload.de/docs/de/net.html


    Zum Thema minimieren:


    Die Funktionen "Main Window always on Top", und oder "GUI Window always on top" helfen nicht?

  • Retro-Nerd

    Nein, das bringt auch nichts mit GUI / Main Window on Top.

    Sobald ich F12 oder Middle Mouse Button drücke, geht WinUAE in die Leiste und das Fenster in OBS wird deaktiviert.


    Mit einem Trick habe ich es jetzt zumindest hinbekommen, das OBS den amiga in Fullscreen aufnimmt.

    Habe dazu die Leinwandgröße bei OBS auf 1920x1080 gestellt und dann über das Menü "Transformieren" den Bildschirm angepasst.

    Sieht jetzt doof aus, weil das Overlay Teile der WB überlagert aber besser als vorher.


    Und zu WHDLoad, der Fehler mit den Roten, Grünen oder Weißen Bildschirm kommt nur bei WHDload ab Version 18.1

    Bleibe ich bei 18 oder darunter, laufen alle Spiele.

    Was ist das denn?


    Weiß jemand, wo ich einen Keyfile für die 18.0 herbekommen kann?



    Hagtrix

    Habe es mit gefrickel so hinbekommen. Ohne noch mehr Progs im Hintergrund laufen zu lassen aber falls es jetzt doch nicht klappt, werde ich es auch mal vesuchen.

  • Nutzt du da einen alten raubkopierten WHDLoad Key? Die sind alle von Wepl auf der Blacklist. Dann gibt es Abstürze. Aber einen Key brauchst du heute nicht mehr, WHDLoad ist schon längere Zeit ohne Restriktionen frei downloadbar. Schau mal in den S:, L: oder C: Ordner deiner Workbench (mitunter versteckt der sich auch in vorinstallierten Spielen, in einem C Unterordner), ob da noch eine alte WHDLoad.key Datei rumliegt. Löschen und dann die aktuelle 18.5 nutzen.

  • Ja den Key bekommt man mit der 18.5 von der WHDLoad Seite. Aber der funktioniert auch nur mit dieser Version.


    Aber die 18.5 funktioniert nicht bei mir, das gibt einen Absturz.


    Bis 18.0 ist aber alles okay


    Bei der 18.5 scheint die CPU abzustürzen. Hier ein Video. Was bedeutet das Gelbe H1 Kästchen unten rechts?

    [External Media: https://youtu.be/xCxRLXALy1Q]



    Hier das gleiche Game mit WHDLOad 18.0 und damit laufen alle Spiele

    [External Media: https://youtu.be/fj4IxP9Mmqk]



    Was sollte im WHDLoad.key drin stehen? Wenn ich das mit ED öffne, steht da nur mein Name drin (bei dem 18.5 Key)

  • NEIN, den Key bekommt man nicht einfach so von der WHDLoad.de Seite. Der Key mußte damals gekauft werden, als Programm Registrierung der dann auch für alle zukünftigen Versionen galt. Den kann man aber seit 2015 nicht mehr kaufen, da WHDLoad mittlerweile komplett frei ist.


    Bei Version 18.0 hast du keinen Key, soviel steht fest. Denn da kommt das nervige Fenster mit der Wartezeit. Bei v18.5 kommt aber bei dir komischerweise keine Namenseinblendung, den man sonst bei einem registrierten Key bekommt (mußte man sich damals einen aussuchen und Wepl nennen). Aber da WHDLoad ab V18.2. (2015) keinen Key mehr braucht muß da auch kein Name mehr zwingend auftauchen. Wenn dem so wäre hätte ich auf einen raubkopierten getippt. Keine Ahnung, aber generell ist OS 3.9 eh nicht die ideale Lösung, mit all den Patches im Hintergrund. Ein klassische Workbench 3.1 wäre dafür deutlich besser geeignet. Die "H1" Einblendung im OSD vom Emulator sagt mir erstmal nichts. Keine Ahnung, ob du da eine Extrafunktion mit aktiviert hast.


    Aber wenn du da wirklich doch noch einen Key hast, den du damals NICHT selber gekauft hast, löschen (die illegalen sind alle deaktiviert und gehen eh nicht mehr, verursachen aber Black und Red Screens). Wie gesagt, WHDLoad benötigt den nicht mehr ab 18.2. Den kannst du auch nicht mit dem Editor bearbeiten. Das geht nur mit der whdload.prefs Datei, wo du globale Starteinstellungen (siehe weiter oben wo ich NoNetwork erwähnt hatte) festlegen kannst.

  • Ne also da ist kein alter Key im Sys: drin und auch bei dem Game Alien Breed TA ist kein Key drin.


    Ich habe alles neu gemacht, die ganze WB3.1 und dann updates bis 3.9 gemacht.

    Habe die 18.5 Version von WHDLoad einfach von der Webseite whdload.de geladen und installiert. Da war dann der Key bei.

    Gerade heruntergeladen. Da ist kein Key enhalten. Laut der Info hier: http://www.whdload.de/reg.html ist seit der 18.2 auch keine Registrierung mehr erforderlich.

  • Hier gibt es wohl Mißverständnisse. Der WHDLoad key ist eine 888 Bytes große Datei, und der ist natürlich niemals im Download der WHDLoad Versionen auf der offiziellen Seite zu haben. Der wurde einem nach dem Kauf immer von Wepl (Bert Jahn) per E-Mail zugeschickt. Keine Ahung, was bei dir da nicht läuft. Fernwartung ist leider immer schwer, die v18.5 läuft jedenfalls bestens.