Hello, Guest the thread was called466 times and contains 6 replays

last post from tfhh at the

ICD AdSCSI-ST+ "gestorben"

  • Ich war gerade nochmal dabei an meinem Mega ST4 mit der ICD AdSCSI-ST+ Lösung zu "spielen" auf einmal erkennt er keine Platten mehr. Als "Platte" habe ich eine SCSI2CF Lösung verbaut.

    Kann es sein, dass die GALs auf der Platine oder sonstige Käfer den Alterstot gestorben sind?


    Sind die GAL Inhalte bekannt?

  • Jogi

    Changed the title of the thread from “ICD AdSCSI-ST+ "gesorben"” to “ICD AdSCSI-ST+ "gestorben"”.
  • Ich war gerade nochmal dabei an meinem Mega ST4 mit der ICD AdSCSI-ST+ Lösung zu "spielen" auf einmal erkennt er keine Platten mehr. Als "Platte" habe ich eine SCSI2CF Lösung verbaut.

    Kann es sein, dass die GALs auf der Platine oder sonstige Käfer den Alterstot gestorben sind?


    Sind die GAL Inhalte bekannt?


    Mir ist nicht bekannt, daß irgendjemand es geschafft hat, die GALs zu re-engineeren. Gerade beim AdSCSI+ sind ja sechs? sieben? GALs drauf, die wild miteinander verknüpft sind. Es ist ohne monatelanges Analysieren und schrittweise Nachbauen wohl nicht möglich, die Gleichungen zu rekonstruieren. GALs haben laut Hersteller eine MTBF von max. 30 Jahre. Die sind, so schrecklich es ist, teilweise schon erreicht - denn es gilt ab Produktionsdatum, nicht erstem Brennen. Wenn Du also nicht versehentlich einen Kurzen produziert hast, wird es absoluter Zufall sein. Und theoretisch kann auch einer der 74er TTL ICs kaputt sein, darauf würde ich jedoch nicht so sehr wetten.


    Ich selbst habe nie so ein SCSI2CF oder SCSI2SD Dingens in der Hand gehabt - vielleicht solltest Du trotzdem nochmal mit einer 08/15 SCSI HDD gegentesten. Ich kann Dir ggf. testweise eine installierte & bootfähige HDD zukommen lassen ==> EMail.

  • Ich hatte zuerst ne alte SCSI HD dran dich ist aber nach ein paar Tagen den Heldentod gestorben. Danach hatte ich die Idee mit dem SCSI2CF, funzte bestens.

    Jedoch nach wieder ein paar Tagen, meldete sich die HD nicht mehr, er findet kein Device am Strang. Ich glaube nicht, dass es an der HD / CF liegt, werde ich aber nochmal gegen testen, hab ja noch SCSI HDs.


    Deshalb kam mir der Gedanke, dass da wohl was gestorben ist. Es ist ja recht überschaubar aufgebaut ein paar 74 und die 5 oder 6 GALs.

  • Ich hatte zuerst ne alte SCSI HD dran dich ist aber nach ein paar Tagen den Heldentod gestorben. Danach hatte ich die Idee mit dem SCSI2CF, funzte bestens.

    Jedoch nach wieder ein paar Tagen, meldete sich die HD nicht mehr, er findet kein Device am Strang. Ich glaube nicht, dass es an der HD / CF liegt, werde ich aber nochmal gegen testen, hab ja noch SCSI HDs.


    Deshalb kam mir der Gedanke, dass da wohl was gestorben ist. Es ist ja recht überschaubar aufgebaut ein paar 74 und die 5 oder 6 GALs.


    Ja, es ist nicht die Hölle an Bauteilen, aber Ausgang X des GAL 1 geht nach Eingang Y des GAL 2 usw.usf., ein einziges Hin- und Her. Ich habe Mitte der 90er mal probiert, den zu re-engineeren, aber durch den dann doch absoluten Tod der SCSI Welt (zumindest außerhalb der Server-/Enterprise-Installationen) und später dem Aufkommen modernerer Lösungen wie SatanDisk (Vorläufer der heutigen UltraSatan) das ganze Projekt fallengelassen.


    Die ICD Adapter hatten eigentlich nur eine Schwachstelle: Die RESET Leitung. Es gab manchmal, sporadisch und nicht eindeutig an einer Platinenversion o.ä. Probleme mit denen, daß keine Devices erkannt wurden. Vorwiegend Mega ST, aber auch andere Kisten. Ich habe seinerzeit dann in _jeden_ ST den Reset-Patch eingebaut, damit liefen dann alle SCSI Adapter von ICD problemlos. Patch ist simpel: RESET-Leitung vor dem DMA-Port auftrennen (bei vielen ST kann man den LineFilter entfernen, dann muß mal nicht mal etwas kratzen) und die RESET-Leitung in Richtung DMA-Port über einen Treiber-IC laufen lassen. Entweder 74LS04 (inverter, dann halt 2x hintereinander, ist absolut zeitunkritisch) oder 74LS06 oder... was Du halt da hast. Mit Schmitt-Trigger (74LS14) ist auch fein. Wenn Dein Adapter an einem anderen ST wieder laufen sollte, kannst Du diesen Patch mal testen. Er schadet auf keinen Fall und muß auch nicht zurückgebaut werden.

  • Ich weiß nicht, ob man die Fehler am Host finden kann, die Adapter von ICD gelten als sehr robust. Eher könnte ich mir einen Treiberdefekt vorstellen. Hast Du mal versucht, die Platte mit Hilfe der Treiber Installationsdisk ins System zurückzuholen? Ich habe bislang SCSI-tools verwendet und es immer geschafft, in solchen Fällen immer wieder eine ausgefallen HDD zurückzubringen, wenn diese nicht den komplette HW-Tod gestorben war!

  • Ja habe ich, aktuell nutze ich ja ein SCSI2CF Adapter welcher einwandfrei funktioniert hat. Die CF ist auch o.k.


    Ich wollte jetzt meinen anderen mega ST4 versuchen, nur scheint der ein altes TOS zu haben. Welches TOS wird denn mindestens benötigt und kann ich das einfach in ein EPROM brennen und austauschen?

  • Ja habe ich, aktuell nutze ich ja ein SCSI2CF Adapter welcher einwandfrei funktioniert hat. Die CF ist auch o.k.

    Ich wollte jetzt meinen anderen mega ST4 versuchen, nur scheint der ein altes TOS zu haben. Welches TOS wird denn mindestens benötigt und kann ich das einfach in ein EPROM brennen und austauschen?


    Also generell sind alle TOS Versionen Harddisk-fähig, aber beim TOS 1.00 gibt es massive Probleme. TOS 1.02 (das sogenannte "Blitter-TOS") ist minimum das, was auf Deinem Mega ST installiert ist und kommt mit Festplatten problemlos klar, allerdings nur bis zu einer Partitionsgröße von max. 16 MByte im "GEM" Format (Standard AHDI, der Ur-Treiber von Atari). Auch die Gesamtkapität ist entsprechend deutlich unter 1 GByte. Ab TOS 1.04 ("Rainbow-TOS") sind auch - über entsprechende Treiber - auch mehr als 16 MByte pro Partition möglich.


    Beim Mega ST sind meistens nur 2 Spezial-ROMs (128 KByte mit nur 28 pins) vorhanden, Du kannst aber ein TOS 1.0x auf 6 EPROMs zu je 32 KByte (also 27x256er) verteilen. Es müssen drei Lötbrücken in der Nähe der TOS-ROMs geändert werden, die stehen jetzt auf "1M" und müssen auf "256K" geändert werden. Die passsenden EPROM-Files finden sich auf jeder gut sortierten Download-Seite :)