Commodore PET online BBSing


This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Commodore PET online BBSing

    Hallo Zusammen,

    wer Lust hat kann seinen PET mit Hilfe des WiModem von cbmstuff.com und der Terminalsoftware PETTERM nun online auf Bulletin Board Systemen surfen lassen.

    Hier mein CBM 8032 der gerade auf A 80's Apple II BBS (telnet: a80sappleiibbs.ddns.net:6502 ) surft - dort findet sich auch eine genaue Beschreibung, wie man das WiModem mit dem PET verbindet.

  • danke für die Info!

    Gibts irgendwo eine Liste zur Kompatibilität, habe im Manual nichts zu den CBM Maschinen gefunden (nur C64 usw.).
    Habe selber einen Pet2001

    b.t.w. was ist die 2. Karte die in Deinem CBM eingesteckt ist? C64toCas, Audiointerface?

    Und wo findet sich dieses PetTerm?

    VG

    The post was edited 2 times, last by Plexar ().

  • Sorry, wer lesen kann ist klar im Vorteil, steht ja alles im ersten Post... 8o

    Quote from a80sappleiibbs.ddns.net
    ...
    1. The Modem
    Get the WiModem from cbmstuff.com. Get a PowerBank and an USB cable. Cut
    one end of the cable and have a look at it. The red wire is the 5V and the
    black wire is GND. Solder the red to PIN 2 of the WiModem and the black wire to
    PIN 1 or GND at the screen pins. Now cut the connection of PIN 2 to the board
    of the WiMmodem. Now you can connect the modem to the userport of your PET.
    2. The Terminal Program
    The common terminal programs for the PET like MC Term will not work with the
    WiModem as they have a different PIN setting. So go to
    github.com/ChartreuseK/PETTERM and download the .zip file. You find it
    by clicking on 1 release.
    3. Cassette Interface
    I use the cassette interface from amigastore.eu, but there are a lot of ways to
    send a program to your PET.
    ...
  • .... so, da mein PET inzwischen läuft :smoke: .... :)

    hat das hier inzwischen sonst jemand mit Wifi-Modem mal ausprobiert ??
    hört sich doch toll an... :) :stompa:

    PS: Frage1: was für Software soll man denn unter dem Link PETTERM (?) downloaden...
    im ZIP haben diese die Endung: xxx.s ??

    Das passende Wifi-Modem habe ich hier "rumliegen" :))

    mfG. Micha
    gepflegt werden: VC20, VIC20, C16, 116, C/plus4, C64, C64 II, SX64, C128, C= PC20-III, C= LT286-C,... :thumbup: + amigos
  • TurboMicha wrote:

    PS: Frage1: was für Software soll man denn unter dem Link PETTERM (?) downloaden...
    im ZIP haben diese die Endung: xxx.s ??
    Das sind Assembler-Source-Files. Man braucht einen (nein, genau den passenden) Assembler um daraus ein PRG-File zu erstellen.
    Sehr zuvorkommend vom Autor, dass er das PRG-File nicht bei GitHub hinterlegt. X/

    Und das WiModem passt tatsächlich auch am PET? Gibt es irgendwo die Pin-Belegung des Modems?
    Ohne die gesehen zu haben, würde ich das Teil nicht aufstecken.

    $55 ist auch nicht schlecht. Das wäre mal ein schönes Arduino-Projekt. Hardware-Kosten ca. 10 Euro. Die Arduino-Software muss man dann aber selber schreiben.

    EDIT: Die sind bei CBM-Stuff aber sparsam mit Infos. Nicht mal im Manual ist eine Pin-Belegung. Sowas mag ich ja gar nicht.

    Das schreit geradezu nach einem gut dokumentierten Selbstbauprojekt. :D

    Zutaten:
    - ein D1 mini für 2 Euro
    - ein OLED Display für 1,60 Euro
    - Userport-Buchse für 2 Euro
    - Kleinkram für 2-3 Euro
    - etwas Software (ein RS232<->Telnet-Umsetzer)

    The post was edited 5 times, last by detlef ().

  • detlef wrote:

    Man bin ich blöd! :facepalm:
    Man muss natürlich das Release herunterladen. So wie oben beschrieben. :whistling:
    nicht du ,.. oder wenn,... dann wir :schande:

    wobei dieser Link schon irritierend ist...
    besser gleich: github.com/ChartreuseK/PETTERM/releases

    nur ?? warum gibt es Version 0.3.0 "Zum downloaden",..
    wenn es: "übersetzt: NICHT VERWENDEN - Gebrochene Empfangsabwicklung!

    und zur Pinbelegung vom CBM Modem: es ist ja eigentlich für den c64,.. also muss ja auch die Pin-Belegung dem
    C64 Userport entsprechen... ?( :/ so meine "Interpretation"... :saint:

    ich will hier aber auch nicht als "Erster" meinen PET opfern :thumbsup:
    gepflegt werden: VC20, VIC20, C16, 116, C/plus4, C64, C64 II, SX64, C128, C= PC20-III, C= LT286-C,... :thumbup: + amigos
  • also das Wimodem funktioniert bestens am Pet2001


    Modifikation steht oben in meinem Post als Quote.

    Ich habe noch festgestellt, dass es nur mit 300bd funktioniert, alles was höher ist gibt nur "garbage", egal ob mit Basic 1, 2 oder 4.

    Habe den Autor von PETTerm dazu kontaktiert, Antwort:
    "The program in its current form can only go up to 300 baud, and has really only been tested at that, none of the higher baud rates will work. It'll let you pick other baud rates and will attempt to do them, but the CPU isn't capable of keeping up with the code. 110 baud should also work just fine. The higher baud rates were left in the code but not disabled."

    Die funktionierende Version ist die 0.22, der Autor, Hayden Kroepfl, wollte sich falls er Zeit hat um die "defekte" Version 0.3 kümmern

    VG

    The post was edited 1 time, last by Plexar ().

  • Hallo Plexar...

    super,.. danke für die Rückinfo...

    ich war nur vorsichtig,.. weil der User "Commodore CBM 8032" hier nur "einmal" online war... ;)

    was die Geschwindigkeit angeht, wird die "Grenze" ja auf das "Programm" geschoben...
    ==> sollte ein C64 wirklich so viel schneller sein ;)

    aber erste einmal testen,.. andere Programme können ja folgen...
    es geht ja auch mehr um den "Aha!! Effekt" :D

    Hast du auch die Software 0.3.0 genutzt ?? oder ein anderen DFÜ-Programm probiert ??

    Danke...
    Micha
    gepflegt werden: VC20, VIC20, C16, 116, C/plus4, C64, C64 II, SX64, C128, C= PC20-III, C= LT286-C,... :thumbup: + amigos
  • zur Geschwindigkeit: auf dem PET2001 ist wohl bei 300Bd schluss, verwendet wurde die Petterm Version 0.21 und 0.22
    Für den Pet gibts aktuell wohl nichts anders was funktioniert.

    auf dem SX64 habe ich mit StrikeTerm2014 experimentiert (bis 2400bd)

    Die Stromversorgung habe ich "steckbar" gemacht, auf dem PET hole ich die 5V vom Kassettenport

    VG
  • Plexar wrote:

    Modifikation steht oben in meinem Post als Quote.
    Ok, sorry. Nicht richtig gelesen. Es hätte mich gewundert, wenn das ohne Modifikationen funktioniert hätte.

    Plexar wrote:

    Ich habe noch festgestellt, dass es nur mit 300bd funktioniert
    Auch hier habe ich mich gewundert, wie das mit den 9600 Baud per Bitbanging funktioniert soll.

    Aber 300 Baud ist doch ok. Damit habe ich meine ersten DFÜ-Erfahrungen gemacht. Da kommt richtiges Akustikkoppler-Feeling auf und man kann in Ruhe mitlesen, wenn die Texte auf dem Bildschirm geschrieben werden. Nur damals lief der Gebührenzähler. :D

    Ich könnte da jetzt gleich loslegen und mir ein WLAN-Modem bauen - aber zuviele andere Projekte. Das muss warten.
  • detlef wrote:

    Ich könnte da jetzt gleich loslegen und mir ein WLAN-Modem bauen - aber zuviele andere Projekte. Das muss warten.
    Mein Wifi-Modem liegt eigentlich schon fertig hier rum :-))

    detlef wrote:

    Es hätte mich gewundert, wenn das ohne Modifikationen funktioniert hätte.
    Aber das ist ja nur die 5V Power-Versorgung,.. der Rest muss ja anscheinend C64 <=> PET /CBM kompatibel sein... tolle Sache!!


    Plexar wrote:

    Die Stromversorgung habe ich "steckbar" gemacht, auf dem PET hole ich die 5V vom Kassettenport
    so wollte ich es nun auch machen... sind ja nur zwei Drähte (oder auch nur einer (5V) ) vom Kassettenport...


    hach.. was freue ich mich auf die nächste Bastelei :-)))
    PPS: Schade, dass mein CBM610 KEINEN Userport hat...
    gepflegt werden: VC20, VIC20, C16, 116, C/plus4, C64, C64 II, SX64, C128, C= PC20-III, C= LT286-C,... :thumbup: + amigos
  • Plexar wrote:


    b.t.w. was ist die 2. Karte die in Deinem CBM eingesteckt ist? C64toCas, Audiointerface?
    ahja... gerade erst "erkannt", er hat die "Analog-Platine", mit welcher man ein Audio-Signal zum "Einspielen" als "echte Datasette" nutzen kann/konnte...
    da kann man natürlich auch das 5V Signal direkt abgreifen...

    Meine Modem Platine ist schon "angekommen" :)



    und Jens (Icomp) hatte bei mir ja an Pin-2 bereits ein RC-GLied angelötet (und dadurch verändert)..
    links ist die günstigere Variante... (ohne Display)...
    gepflegt werden: VC20, VIC20, C16, 116, C/plus4, C64, C64 II, SX64, C128, C= PC20-III, C= LT286-C,... :thumbup: + amigos
  • detlef wrote:

    Aber der hat doch dafür eine echte RS232-Schnittstelle.
    ja... beim CBM610 aber als Buchse... muss ich erst mit male/male Stecker "umwandeln":..
    und damit kann ich dann ja wirklich nur "Analog" kommunizieren... (mit einem Analog-Modem)

    oder muß wieder "teuer" ein WIModem232 extra kaufen :( https://www.cbmstuff.com/proddetail.php?prod=WiModem232OLED
    gepflegt werden: VC20, VIC20, C16, 116, C/plus4, C64, C64 II, SX64, C128, C= PC20-III, C= LT286-C,... :thumbup: + amigos

    The post was edited 1 time, last by TurboMicha ().

  • so... da mein CBM610 mit einem analogem Modem schon nicht arbeiten wollte :( ;(

    habe ich mir gedacht, mache ich wenigstens diesen kleinen Umbau, sodass der CBM 8032 Telnet machen kann...

    wie auch oben beschrieben, den Pin2 am Userport geöffnet (auf der oberen Leiste) und mit einem Draht auf
    5V vom Datasetten Anschluss gebracht. Damit ich nicht immer eine "blanke" Datasettenleiste raus ziehen muss
    habe ich mir die 5V (über den zweiten PIN) von einem Datasetten-Analogwander abgezapft.


    Ein Test an einem (Opfer) C64 war auch positiv...
    (noch nicht eingeschaltet, aber am C64 funktioniert meine 5V Drahtlösung normal)

    ABER!! am CBM8032 bleibt das Display schwarz und ich sehe nicht, dass irgendwas funktioniert. (der Rechner startet aber normal)

    WARUM ?? hier oben im Thread ist mir noch ein zweiter Draht (vom GND) am Display aufgefallen.


    Der wurde nirgends erwähnt, aber braucht das Display noch einmal extra Ground ??
    (komisch,.. nur am CBM/PET und nicht am C64??)

    Danke für Hinweise..
    @Plexar: hattest du nicht das gleiche Wifi Modem getestet ??

    Schöne Feiertage :ChPeace
    gepflegt werden: VC20, VIC20, C16, 116, C/plus4, C64, C64 II, SX64, C128, C= PC20-III, C= LT286-C,... :thumbup: + amigos
  • ahja,.. danke... hast du also den grünen an Pin2 angelötet und den gelben an die Platine,
    so kannst du quasi "zurück" stecken, wenn ich das richtige verstände habe :-))

    ich habe bei dem Tape-Adapter zwar auf dem zweiten PIN unten angelötet, aber beim Tape-sollte oben und unten gleich sein ?!

    ich gucke noch mal nach dem Fehler, und ob wirklich 5V ankommen..
    gepflegt werden: VC20, VIC20, C16, 116, C/plus4, C64, C64 II, SX64, C128, C= PC20-III, C= LT286-C,... :thumbup: + amigos