Hello, Guest the thread was called98 times and contains 2 replays

last post from markusC64 at the

1571+Zoomfloppy+Windows 10 x64

  • Hallo,


    ich habe da mal ein Problem und wollte mal hören, ob hier einer schon ähnliches erlebt hat. Hier ist mein Problem:

    Ich habe zwei 1571 Laufwerke, eines, nennen wir es " A", ist mein Arbeitstier (incl. JiffyDos), das zweite, nennen wir es "B" dient als schreiberling für Zoomfloppy / CBMXfer (CBM-Dos). Die Zoomfloppy hängt an einen Win 10 x64 PC (Version 1909).

    Mit älteren Windowsversionen konnte ich *.g64 images ohne Probleme mit Laufwerk "B" schreiben und diese dann in Laufwerk "A" am C64 (Jiffy-Dos) nutzen, ohne Probleme, auch meine 1541-II (Jiffy-Dos) kann die Disketten lesen. Vor einigen Tagen hatte ich das Problem, das die in Laufwerk "B" neu erstellten Disketten (hier das Geos System 2.0r aus der Wolke) in keinen Laufwerk mehr lesen liesen, bzw. Geos nicht starten wollte, eh hängt bei "GEOS Bootet", nur Laufwerk "B" am C64 ließ Geos durchstarten.

    Ich habe erst an eine dejustierung der 1571 / 1541 gedacht, aber intensives testen mit "FloppyAdjust" brachte keine schlechten Werte, auch die Drehzahlen aller Laufwerke passte (300 +/- 1 UPM), diese möglichkeit scheidet also aus.

    Ein Schreiben mit Zoomfloppy und Laufwerk "A" war von Anfang an zum Scheitern verurteilt, Wieso? Keine Ahnung. (Später mehr).

    Nach einigen gefrusteten Versuchen an mehreren Abenden, krammte ich mein altes Win 7 x64 Laptop heraus, hier schrieb ich die Disketten erneut mit Laufwerk "B" und testete dies in einer 1541-II und jetzt startete Geos bis zum Desktop und ein arbeiten ist möglich. Das Problem scheint wohl bei Win 10 x64 zu liegen. Hat hier einer schonmal ähnliches erlebt?


    Zu den Problem Zoomfloppy und Laufwerk "A":

    Wenn ich hier ein *.G64 zurückspielen möchte, fängt das Laufwerk an, der Kopf fährt an einige Positionen und zum Start des eigentlichen schreibens bricht der Vorgang ab und auf den Laptop wird der USB Portes / der Zoomfloppy abgeschaltet / abgemeldet. Laufwerk "A" macht kein Problem. Ich Vermute ein Hardwareproblem mit Laufwerk "A" und das einschalten des "Burst"-modus. Welche Bauteile können bertoffen sein, als 1541-Ersatz zickt das Laufwerk nicht, auch unter Geos / MP3, alles gut.


    Ich hoffe das ich alles soweit verständlich beschrieben habe und sage schonmal Danke für Tipps und Hinweise


    @MOD: Falls das hier in der falschen Rubrick ist, Sorry, und danke für das Verschieben.


    Gruß Thomas

  • Zu dem "Laufwerk A" Problem: ICh vermute, dass die 1571 nicht per Parallelkabel, sondern mit seriellem Kabel angeschlossen ist?

    Dann nutzen die nibtools das sogenannte SRQ-Nibbing. Es benutzt den seriellen Port der CIA 6526. Leider scheint es da einige Varianten zu geben, von denen nicht alle gut funktionieren. Es gab auch mal berichte, dass bei einigen längere oder kürzere Kabel helfen, bei anderen hingegen nicht.


    Das parallele Nibblen scheint jedenfalls deutlich zuverlässiger zu sein.


    Wohlgemerkt: Wenn es funktioniert, dann funktioniert es meistens genauso gut wie das parallele.


    Woran das erste Problem mit GEOS liegt kann ich allerdings nicht sagen, ich bin kein Spezialist für die nibtools.

  • Wenn man mit nibwrite es "geschafft" hat, ein Geos so zu schreiben, dass es nicht will, würde ich es mal mit nibread wieder einlesen. Wenn wir dann mal die gelesene nib-Datei anschauen, was schiefgegangen ist, erfährt man ggf. mehr.


    Ich habe hier z. B. zwei Geos Originale liegen. Eines davon kann ich per Kombi nibread, nibwrite kopieren, das andere nicht. Das hat damit zu tun, wie viele Bytes das Image beim nibwrite pro Track hat. Wenn die Rotationsgeschwindigkeit die Byteanzahl nicht hergibt, so wird der Track gekürzt. Und wie man beim Wiedereinlesen sieht, eben manchmal so, dass dabei erkennbare Lesefehler entstehen (sprich: CBM DOS erkennt Sektoren als defekt).


    Ich ziehe in Betracht, dass etwas analoges passiert sein könnte - aber wie gesagt, wiedereinlesen und analysieren oder hier zur Analyse posten bringt Erkenntnisse über mögliche Ursachen.



    Nachtrag: Wobei bei Geos-Disketten es häufig (d. h. wenn der neuere Kopierschutz zum Einsatz kommt, also fast immer - ausnahme: Geos 1.2 sowie Geos 1.3 US sowie einige US Applikationen) - es hilft, per nibconv nach d64 zu wandeln und dann mit einem gepatchten nibconv oder meinem g64conv den Kopierschutz beim Zurückwandeln nach g64 wieder aufzubringen... Dadurch werden die Tracks im g64 kürzer, so dass nibwrite unter keinen Umständen mehr den Track kürzen muss. Das hilft beim Zurückschreiben wirklich.