Hello, Guest the thread was called3.4k times and contains 62 replays

last post from synthpeter at the

FPGASID Support Thread (english)

  • Hey there;


    I've just got the two FPGASIDs in the mail today, and probably will install them this weekend. Concerning the C128, it's just a drop in? I'm not interested in stereo, so I should be able to just pull the existing chip out, throw the FPGA in, and I should be off to the races? Do I need to run ConfigGuru to update?


    The packaging was well done. Got nailed for import taxes because .. well.. because gov't... but anyways

  • You can do so. Then it will be just mono. But you can still go for pseudo stereo when you connect at least the second audio signal.


    You can run Configuru to switch between 6581 and 8580 mode etc... But it'll have to run in C64 Mode. The is no extra C128 version so far.


    Update is not required in the moment. There will be a new firmware soon, but we had some issues with the update at some test customers so we stopped the rollout.
    Once this is fixed I will announce the new firmware on the website.


  • Hi, I wonder if anyone could explain the filter BIAS settings in some detail to me? I use Lightforce as a test on a lot of my "real" SIDs due to the heavy use of filters and it also plays some very high notes which tend to get cut off or missed on SIDs with hard,faulty or restrictive filters. I noticed that the default filter BIAS of 0 exhibits this same cut off when playing Lightforce, so I increased to +7 and the Filter was too light, I finally settled on +5 and LF sounds pretty much spot on, like it does on my good sounding (subjective I know) R3 SIDS. Am I understanding the BIAS value correctly? Does anyone have a a "BIAS MAP" for say emulating specific 6581 revisions etc, I apprecuate they vary wildly in sound even on the same rev but just some rough guidelines. I did notice one reviewer mentioned that he liked Filter BIAS 0 but for me some of the SIDs I played sounded choked with this default BIAS value. Also am I correct in assuming that DAC should be "crunchy" for 6581 and "linear" for 8580 in order to sound as close to their physical counterparts as possible? Any help, guidance or detailed explanation much appreciated. Love the FPGA SID thus far, just waiting for a luma and chroma to svideo splitter so I can take the video and second SID feed out in to my Monitor and AMP :) Regards, Ross.

  • Am I understanding the BIAS value correctly?

    Totally - and there's no other guidance than your hearing.
    If you like to get an impression why, try out "JSIDSPLAY2"
    by @kenchis. This emulator includes accurately measured
    models for a number of different actual 6581 SIDs taken from
    the wild. You can hear them in fake stereo
    (mono with a different SID each ear), and you can compare them
    by their characteristic curve. And what you will experience is that
    chips from totally different revisions will sound more similar to each
    other than two of similar revisions and production dates.


    When you use the FPGASID in fake stereo mode with 1x6581 and 1x8580,
    you'll see that the setting you find to be optimal for Lightforce (I use BIAS +6)
    will be too close to the sound of the 8580 to make some stereo effects happen
    that rely on such programming that results in only one of the SIDs getting
    partially muted. So you'll need at least a second setting for other purposes,
    which FPGASID allows you by adding a switch.

    3332-dc5ecddb.jpg

    '°'°'°'°'°'°'°'°'°Oo.~>| BASIC programmers never die! They just GOSUB without RETURN! |<~.oO°'°'°'°'°'°'°'°'°'

  • Is there a definitive cable that anyone has found to connect to the breakout cable for s-video output?


    Unfortunately not. Seems these cables are hard to get.


    What about these here:


    only B2B: https://www.kramerav.com/de/Product/C-SM/2RVM
    China 0.25m: https://de.aliexpress.com/item/S-Video-2-RCA-Audio-Cables-Combo-4-Pin-SVideo-Male-Cord-Gold-Plated-0-25m/32964496431.html?spm=a2g0x.10010108.1000016.1.69fb35f2GAtVgo&isOrigTitle=true
    US ~1.8m: https://vetco.net/products/6-s…-x-rca-y-c-breakout-cable
    US: https://www.svideo.com/svideo2rca.html
    ebay UK - need additional S-Video cable: https://www.ebay.co.uk/itm/6-S…S8AAOSwhYJcUNw5:rk:1:pf:0


    let's see how long these links will last. A good way of searching is to do a image search for "s-video breakout" and then check all the images visually.

  • HI I have purchased two FPGASids. One is on the way, the other is being used in a "breadbox" C64 NTSC unit with an early 250407 board. I am using it to replace a real MOS 6581 which was otherwise working but had bad POTX/POTY inputs. I have had two problems I'd like your advice with.


    First, when I use this SID as a "single" SID without connecting any cables (just plug it into the socket) the FPGA SID works OK, but when I connected the cable for the 2nd SID to pin 7 of the A/V connector (as shown in the instructions) I get a black screen on boot. When I remove the wire the computer boots fine again. The schematics show AV pin 7 as NC, so I don't understand why I get no picture (and possibly it's not booting at all) when SID 2 is connected. This issue does not concern me much, I just leave the 2nd SID unconnected as i'm fairly happy with just one and the audio is connected internally to both channels (one channel duplicated L/R on the board as shown in the schematic of this machine). But I thought I would ask as I find this to be quite curious.


    The second problem is a little more concerning. I have a Retrotink 2x line doubler as shown here to improve the C64's picture on modern screens. Video wise the device works very well but when the audio outputs of the C64 are connected to the audio inputs of the retrotink there is no audio from the FPGASid. It will remain this way even if the audio is disconnected from the retrotink and connected directly to a TV/Amp. However, once the C64 has been power cycled the audio works so long as I have never connected it to the retrotink. If unplug the now working audio from the TV/AMP and connect it to the retrotink again, the audio is gone until the C64 audio is disconnected from the retrotink and the C64 power cycled.


    I have tested this on two retrotink units and both behave the same way with the FPGASid. Audio input on both retrotinks works fine when used with other consoles like a Sega Genesis or SNES. The FPGASid on the other hand works fine when connected directly to a TV or amplifier, just not the retrotink. So I am unsure of which device to blame here?


    Thanks

  • Strange... :gruebel

    In the moment I have no clue what could be wrong...


    Problem 1:

    but when I connected the cable for the 2nd SID to pin 7 of the A/V connector (as shown in the instructions) I get a black screen on boot. When I remove the wire the computer boots fine again.

    Are you sure you connected the correct wire to PIN7 of AV? There is a single wire cable with a single red wire and a three wire cable with yellow, black and red wires. The correct cable is the single red wire cable.


    Was the Retrotink connected when you experienced this problem?




    Problem 2:

    Video wise the device works very well but when the audio outputs of the C64 are connected to the audio inputs of the retrotink there is no audio from the FPGASid.

    Unfortunately I do not have very much details on the Retrotink. Just read about it on Reddit today and a few hours later I saw your question here...
    How did you connect Retrotink? Are you using the breakout cable that we sell together with the FPGASID? Or does Retrotink com with it's own cable (I think it is not specially made for the C64, so it will not have a specialized cable for the C64).


    Can you check, if the second problem is gone when you use the original 6581 SID? That should rule out (or identify) the FPGASID as the troublemaker.


    Can you take pictures of your setup and post them here, please? Especially the wiring should be visible and the cables between Retrotink and the '64.


    Do you have a Multimeter/Circuit indicator to check some of the connections?

  • Problem 1:
    Are you sure you connected the correct wire to PIN7 of AV? There is a single wire cable with a single red wire and a three wire cable with yellow, black and red wires. The correct cable is the single red wire cable.

    Maybe the pinout was mirrored?
    I had a reset loop when I tried to use Pin 8 as a ground connection
    (as it had almost no resistance against ground) for the TRS plug I
    used as an audio output.

    3332-dc5ecddb.jpg

    '°'°'°'°'°'°'°'°'°Oo.~>| BASIC programmers never die! They just GOSUB without RETURN! |<~.oO°'°'°'°'°'°'°'°'°'

  • Andi6510,
    Thanks for the reply. To answer your questions. With respect to problem 1 I did not have it connected to the retrotink at that time. I did not have an opportunity to remove the board again and double check that Pin 7 was not connected to anything. However like in your photo on the installation guide, pin 7 is clearly indicated on the slikscreen on the top of the PCB near the AV connector. I will do some further troubleshooting.


    With respect to problem 2. I am using this cable here I purchased off e-bay: https://www.ebay.ca/itm/Commod…eEAAOSwvYha4gFD:rk:8:pf:0


    Just an S-video and audio breakout cable with a standard S-video connector and RCA jacks for the audio. The cable works fine with a small monitor I have which has a S-Video input and RCA audio jacks. When the retrotink 2x is in use the S-Video input is in use and the audio RCA connectors are connected to the audio input of the retrotink. The HDMI output is connected to the TV. The retrotink has a 2-channel 24-bit A/D which should digitize the audio input and mux it with the video output on the HDMI.


    I have both a multimeter and an oscilloscope so I can do some more in depth troubleshooting if required, but I was hoping you may have had an idea of what was wrong. I have two other C64's i'm testing/repairing (if required) coming to me early next week so I can test with a 6510 SID via the retrotink at that time and let you know the result. However I have seen posts in the past indicating folks have used the retrotink on a C64 without issue do I do expect that to work. I will let you know the result.

  • hpxca :
    I think problem #1 is weird enough - we should solve this first before we check problem #2.


    What about power supply? Did you check that the PSU you are using is OK and can supply enough current? The FPGASID consumes roughly twice as much as a standard SID. So it is comparable with a stereo-solution with 2 SIDs. But when the PSU is already at the limit, the additional current might be too much. (not related to Problem #1, but how do you power the Retrotink? With a separate 5V USB supply?)
    When you have opened the case again, you could measure if pin 7 is high-ohmic against ground and everything else, when nothing is connected to it. Then connect the AV cable and check again (maybe the AV cable is tying pin 7 to ground or something else?). I think the AV cable you have purchased does not know about a potential audio signal on PIN7. So it will not provide access to the second audio channel. On the other hand it could do something nasty to PIN7. So better check this.


    Please also check the contact in the SID socket especially when it should be worn out by many insertions. I have seen the funniest effects that where gone once the SID Socket was changed.


    And please take good sharp pictures. It is very helpful for me to get a better idea of the setup.

  • Hi Andi6510,
    The power supply being used in all cases is a Ray Carlson - built C64 replacement supply. It should be adequate to power the FPGASid (I think?). The retrotink is powered via micro-usb with its own 5VDC power supply.


    Indeed the cable I have does not use Pin 7. I have one of your complete breakout cables coming with my 2nd FPGASid for that reason, although it is not here yet. I will have two more C64's here today and I will let you know the results of some further troubleshooting as soon as I have the time to do it - Although that may not be until tomorrow.


    Thanks!

  • Hi Andi6510,
    Thanks for your patience. I spent a bunch of time last night troubleshooting both this issues and I was unable to reproduce either of them :(. I even used two different C64's both with a real 6581 and with the FPGA SID and both worked with the retrotink both times. I think the main thing I did differently here from the last time was that I used a different power supply with the retrotink. This was just a co-incidence, the one I used last time was being used for my Pi1541. I also removed and reseated the FPGASid in the socket in both cases


    I also had the FPGASid connected to pin 7 on the AV connector again, but this time the computer started up no problem (Both the one I was having issues with last time and the other one I had).


    So unless I can reproduce this again I think you can consider this matter closed. I don't know for certain what was wrong the first time I was trying it, but it is working now.