Hello, Guest the thread was called685 times and contains 5 replays

last post from Daniel78 at the

ZX Spectrum im Gehäuse einer zeitgenössischen Zubehör-Tastatur

  • Vor drei/vier Jahren (ungefähr) brachte ein Radiokollege beim Stammtisch-Grillfest ein paar Kisten mit Material und Geräten aus einem Nachlass mit. "Was heute keiner nimmt, wandert morgen auf den Wertstoff". Übrig blieb eine mir unbekannte tastaturähnliche Kiste mit ein paar Kabeln und einem huckepack aufgesteckten Modul.


    Das es sich hier wohl um einen Rechner handelte dachte ich mir gleich. Auch dass das Gehäuse nicht "ab Werk sein konnte.


    Ein paar Tage später demontierte ich das Gehäuse, um zu sehen, was da im Innern steckt.


    Nun hab ich den Kasten mal wieder aus dem Lager geholt um ihn gründlich zu reinigen.


    Dazu hatte ich alle Tasten vom Keyboard entfernt und nass gereinigt. Manche Tasten blieben etwas lose, durch Einschieben eines Kreppbandstreifens lassen sich die Tasten fest montieren.


    Wenn's klappt stelle ich noch Bilder vom dem Teil in Betrieb ein.

  • Jetzt wollte ich endlich mal mit dem ZX spielen und ihn dafür wieder startklar machen, aber daraus sollte nichts werden :(
    Nachdem die gereinigte Tastatur ins gereinigte Gehäuse zurückfand, fiel auf, dass die obersten Tasten am Gehäuse der Tastatur anliegen und dass manche Tasten dadurch klemmen.
    Die Tastatur war aber schon immer so eingebaut, was man an leichten Schabspuren auf den Tasten erkennen kann. So wie sie war, ließ sich die Tastatur nicht nach unten verschieben, da die Platine im Tastaturgehäuse an den unteren Zapfen für die Bodenverschraubung anlag. An den betreffenden drei Stellen hat die Platine keine Leiterbahnen - also nur blankes Hartpapier. Nachdem die Positionen der Zapfen auf die Platine übetragen waren, konnten die betreffenden Stellen abgefeilt werden. Nun passt die Tastatur prima ins Gehäuse.
    Die Flachband-Folienleiter, welche die Tastatur mit dem Mainboard verbinden hatte jemand an der Tastaturplatine angelötet. Eines der Bänder löste sich komplett ab, da alle Bahnen an den Lötstellen abgebrochen waren. Zum Glück besteht so ein Leiter aus mehreren Lagen Folie, in die dünne Kupferstreifen eingelassen sind. Die Enden ließen sich auf mehrere mm Länge freilegen und neu verlöten.
    Jemand hatte leider den Modulator komplett ausgeräumt und eine Freiluft-Drahtigelschaltung mit einem Transistor, mehreren Widerständen und einem Keramikkondensator eingebaut.
    Ein Test des Mainboards ohne Tastatur verlief zunächst mehr oder weniger erfolgreich, das Prompt erschien auf dem Bildschirm, aber an der Cinchbuchse im leeren Modulatorgehäuse war ein Wackelkontakt - interessanterweise an der Masse.
    Irgendwann beim Testen fiel das Bild aus und seit dem kommt am Ausgang nur noch ein schwarzer Bildschirm mit vertikal durchlaufenden horizontalen Störstreifen. *GRMBFX*"§!$/%&!!!!
    Zum Drahtigel im Modulator führt die Seele einer abgeschirmten Leitung, die direkt auf Pin 17 der ULA gelötet ist. Dort wird irgendein Signal abgegriffen und über den Transistor im ausgeräumten Modulatorgehäuse mit einem anderen Signal zum Videosignal gemischt. Leider hat der Schöpfer dieser Konstruktion den Draht direkt angelötet. Vielleicht wäre ein in Reihe gelöteter Koppelkondensator besser gewesen.


    Vermutlich hat es jetzt die ULA zerschossen :(