Hello, Guest the thread was called692 times and contains 7 replays

last post from sauhund at the

[erledigt] C64 hat ohne Joystick Dauerfeuer

  • Hallo Community,
    gestern habe ich von einem Arbeitskollegen einen C64G geschenkt bekommen. Optisch 1A leider mit einem technischen Problem.


    Nach dem Anschalten alles OK, Tastatur funktioniert, Spiele lassen sich ganz normal laden.


    1: Platinenversion: ASSY 250469 PCB 252311 Rev.B
    2: Das Gerät ist nicht modifiziert
    3: Netzteil ist Original, 2 Stück getestet
    4: Fehler tritt immer auf, bis auf Floppy 1541II keine Zusatzhardware vorhanden
    5: Problem tritt ständig auf (in Spielen, mehrere getestet)
    6: kein Chip wird heiß
    7: Multimeter vorhanden (ohne Piepser) und ich weis wie man damit umgeht
    8: Löterfahrungen sind vorhanden


    Problembeschreibung:
    Soabld der C64 in einem Spiel ist, ist Dauerfeuer aktiviert. Es ist egal ob ein Joystick am Port hängt oder nicht. Sogar wenn die Tastatur abgeklemmt ist, feuert er lustig weiter.
    Stoppen lässt sich dies mit dem Halten von "I", "O", "J", "K", "N" oder "M". Solange man eine dieser Tasten gedrückt hält läuft alles ganz normal. Lässt man die Taste los -> Dauerfeuer



    Meiner Recherche zufolge liegen die benannten Tasten alle in Spalte 4 der Tastaturmatrix, was auf einen defekten CIA deutet. Gesockelt sind die Chips nicht. Die Kontakte beider Joystick-Ports sehen gut aus, denke dort wird das Dauerfeuer nicht ausgelöst.


    Bin ich damit auf dem richtigen Weg? Sollte ich noch etwas anderes überprüfen bevor ich die Chips gegeneinander tausche?




    Vielen Dank für jede Hilfe und für jeden Tip ;)

  • Hab mal durchgemessen:


    nur Platine ohne Sonstige Hardware, keine Stecker angeschlossen, ohne Tastatur


    Netzschalter auf OFF
    Port 1: 1680 Ohm
    Port 2: 1235 Ohm


    Netzschalter auf ON
    Port 1: 1960 Ohm
    Port 2: 1240 Ohm


    nur Platine ohne Sonstige Hardware, keine Stecker angeschlossen, mit Tastatur


    Netzschalter auf OFF
    Port 1: 193 Ohm
    Port 2: 190 Ohm


    Netzschalter auf ON
    Port 1: 456 Ohm
    Port 2: 450 Ohm


    Druck auf eine der Tasten aus Matrix Spalte 4 verringet Widerstand um ca. 30 Ohm (egal ob Netzstecker ON oder OFF)




    Die Filter habe ich durchgemessen "EM5" hat einen abweichenden Wert, ca. 750 Ohm weniger als bei den übrigen 8

  • So, ein Update.


    Um es vorweg zu nehmen, die Kiste läuft wieder. :thumbup:


    Hab beide CIA´s ausgelötet, Sockel aufs Board gemacht und gegeneinander getauscht. Das blöde Dauerfeuer ist weg


    Werde morgen nochmal zu dem kleinen Elektroladen gehen, wo ich die Sockel gekauft habe, der hat nämlich noch tatsächlich diverse C64 Chips auf Lager. Unter anderem auch den CIA 6526A, welcher bei mir scheinbar defekt ist. Als ich fragte was er kostet meinte er, hier steht: 38,95DM drauf :anonym


    Wenn der nen guten Kurs in € macht dann schlag ich zu.