Hello, Guest the thread was called1.9k times and contains 58 replays

last post from ralf02 at the

Schneider AT Tower 201 80287 nachrüsten

  • Schade,, dann kriegen wir das nicht mehr raus.


    Prinzipiell sind die Optokopplertypen vom Pinning her kompatibel.

    4N35: Den schätze ich so ein, dass der langsamer als der CQY80N ist. Sind nicht so viele Parameter spezifiziert.

    CNY17-1: Von der Geschwindigkeit ist der etwa gleich wie der CQY80N. Von den anderen Parameter sieht der auch passend aus. Damit könnte man zumindest mal testen ob man beim Netzteil einen Unterschied sieht zum Beispiel wenn der CQY80N nicht mehr in Ordnung ist, würde ich einen Unterschied erwarten. Wenn der CQY80N ok ist, würde ich erstmal keinen Unterschied erwarten.

    Alle Angaben, soweit ich das gesehen habe und es vergleichbar ist. Es sind nicht alle Parameter im Datenblatt aufgeführt. Als Grundlage habe ich Datenblätter von Vishay genommen. Die haben alle drei Typen. Andere Hersteller habe ich nicht quer geprüft.

  • Im Moment finde ich die CNY17-11 gerade nicht wieder (irgendwo in dem IC-Haufen oder ich habe sie schon separat gelegt und weiß nicht mehr wo ....). Jedenfalls hatten die die Bezeichnung CNY17-11 (nicht CNY17-1 wie in den Datenblättern beschrieben), macht die zweite "1" da einen wesentlichen Unterscheid ? Ich hoffe, dass heute die UC3844N in der Post sind, dann kann ich schonmal weiter testen.

  • Die UC3844N waren noch nicht in der Post aber dafür ein Standard 80x80x25 Ventilator. Den habe ich eingebaut und erneut den Ripple gemessen: Bei den 5V nach wie vor ca. 80mV, bei den 12V etwas mehr, zwischen 80-100mV. Also bei den 12V immer noch deutlich besser als mit dem alten Ventilator und auch noch in der ATX-Spezifikation. Für den Fall dass ich die CNY17-11 nicht mehr wiederfinde, habe ich jetzt einen originalen Optokoppler bestellt, dann kann ich den als Fehlerquelle auch ausschließen.

  • Interessant der Einfluss des Lüfters. Man könnte versuchen, dem Anschluss des Lüfters noch einen "dicken" Elko parallel zu schalten oder mit einer Kombi aus Tantal-/Keramikkondensatoren zu experimentieren. Irgendwie stelle ich mir vor, dass ein Lüfter nicht so einen Ripple verursachen sollte.


    CNY17-1/-11: Ja, hatte ich gelesen, dass Du einen -11 hast. In dem Datenblatt von Vishay habe ich jedoch nur die Angabe -1, -2, -3 und -4 gefunden. Allerdings habe ich bei den elektrischen Parametern jetzt keine Unterscheidung in Erinnerung. Habe aber auch nicht abschließend alles abgesucht.

    Ziel war eigentlich erstmal zu sehen, ob der schneller ist. Ist aber erstmal gleich schnell wie der CQY80N. Aber vielleicht findest Du den CNY17-11 ja wieder.

  • Also mit dem neuen Lüfter habe ich das so gemeint, dass sich der Ripple mit dem neuen Lüfter gegenüber dem Zustand ohne Lüfter kaum verstärkt hat. Also bei beiden Spannungen ca. 80mV. Mit dem alten Lüfter war der Ripple auf den 12 Volt etwa 3mal so hoch. Die UC3844N waren leider immer noch nicht in der Post, dafür aber der CQY80N. Den habe ich ausgetauscht (hatte ich ja auch gesockelt), danach hat sich aber nichts verändert. Also liegt beim Optokoppler jedenfalls kein Problem.


    Dann habe ich mal direkt am Tastkopf des Oszis einen 22uF Tantal + 100nF parallel geschaltet. Irgendwo hatte ich auch gelesen, dass man auf diese Weise den Ripple messen sollte - also so wie die Spannung auf dem Mainboard an den Verbrauchern ankommt, da ist ja auch an jedem IC mindestens ein 100nF Kerko.


    So sieht der Ripple auf den 5 Volt mit dieser Messmethode aus (22uF Tantal + 100nF parallel am Tastkopf):



    Maßstab ist 20mV pro Kästchen, also nur noch 40-50mV. Wenn man das mal mit dem Foto im Post#29 vergleicht, sieht man sehr schön, dass durch die Kondensatoren die "Nadeln" sehr schön weggeglättet werden.

  • Ok, dass hatte ich dann mit dem Lüfter falsch verstanden. Ok, der Papst-Lüfter ist danach ein Ripple-Verursacher. Dazu zwei Fragen:

    a) Hattest Du als Ersatz einen baugleichen oder anderen Lüfter verwendet?

    b) Hattest Du versucht, den Ripple in Verbindung mit dem Papstlüfter zu verringern, wenn parallel zum Lüfter Tantal-/Keramikkondensatoren angeschlossen werden?


    CQY80N: Ok, dann ist der originale offenbar nicht defekt. Ob man eine Verbesserung erreicht, wenn man einen schnelleren Optokoppler verwendet wissen wir aber nicht. Laut Datenblatt schafft der ja nur etwa 100 oder 110 kHz.


    Messmethode: Wenn Du parallel zu Tastkopfspitze die Kondensatoren schaltest, verfälscht Du das Messergebnis aber. Von daher halte ich die Messung für falsch. Der Vorteil des Oszilloskops ist ja, das anzuzeigen, was tatsächlich an der Stelle, wo Du die Messspitze hinhälst, los ist. Deswegen ist es ja ein Qualitätsmerkmal, dass die Tastkopfspitze eine möglichst kleine kapazitive Last an die Messstelle einbringt. Kleiner pF-Bereich bei einem guten Tastkopf. Das Qualitätsmerkmal machst mit Tantal-/Keramikkondensator "kaputt".

    Dann müsstest Du insgesamt das Netzteil pimpen und weitere Kapazitäten anschließen. So kannst Du den Ripple (testweise) vielleicht auch reduzieren.

    Wir wissen natürlich nicht, was das Schneider-Netzteil neu im Originalzustand mal hatte. Aber man kann Schaltungen fast immer verbessern.


    Läuft denn der Rechner mit dem reduzierten Ripple dann mit normaler Taktfrequenz stabil und Koprozessor läuft auch?

  • Also der Ersatzlüfter ist ein neuer von Ebay 80x80x25mm, 12 Volt, zweiadrig (kein Pabst Lüfter, sondern irgendein China-Teil). Wobei man ja mittlerweile wirklich bei allen möglichen Elektronikbautreilen damit rechnen muss, dass diese in China nachgebaut werden. So habe ich in der Bucht Lüfter gesehen, die von Schriftform, Größe und Layout exakt dieselbe Beschriftung wie der Pabst-Lüfter aus dem Schneider PC haben, und dort als "fabrikneu" verkauft werden. Mit dem Pabstlüfter hatte ich keine weiteren Experimente zur Reduzierung des Ripples durch Parallelschaltung von Kondensatoren gemacht.


    Zum Optokopller: Ich habe mal versucht, den Takt des Ripples zu ermitteln. So ganz grob sind das knapp 20uS pro "Schwingung", sodass sich ein Schalttakt des Netzteils von etwas mehr als 50kHz ergibt. Das wäre ja komfortabel innerhalb der 100kHz, die der CQY80N schafft.


    Heute werde ich prüfen, ob der Schneider mit den verschiedenen möglichen CPU/BUS Frequenzen läuft und auch prüfen, ob der 80287 nun erkannt wird.

  • Ja, da binich gespannt, ob der PC jetzt läuft, wie man es eigentlich erwartet.


    50 kHz wären keine untypische Frequenz in so einem Netzteil. Allerdings aus dem Bauch heraus finde ich die 100 kHz des Optokopplers nicht großzügig bemessen. Ich könnte mir vorstellen, dass das nochmal besser wird, wenn der dann 200 kHz oder mehr packen würde, denn ohne das zu recherchieren, würde ich aus dem Bauch heraus sagen, Faktor 4 wäre sinnvoll. Gemäß Datenblatt wird zwar mit der (bis zu) doppelten Frequenz rückgekoppelt, aber sampling von Informationen ist der Faktor zwei nicht rühmlich. Mehr ist an der Stelle besser. Allerdings bekommt oder bekam man damals vielleicht auch keine schnelleren Optokoppler.

    Die restliche Schaltung muss ja nachdem der Optokoppler die Regelinformation geliefert hat auch noch reagieren. Erst dann wird quasi am Ausgang etwas sichtbar.


    Vielleicht wird das Netzteil auch noch besser, wenn man mehr oder schnellere Glättungskondensatoren spendiert.

  • Eben habe ich den 80287 eingesetzt und ....... läuft ! Hier das Beweisfoto:



    Ich denke ich werde jetzt nur noch die 22uF Tantal / 100nF Kerko-Kombination am 5V Ausgang einsetzen und dann ist das Projekt erfolgreich abgeschlossen. Die ganzen Start-Probleme und auch die Probleme mit dem 80287 lagen also tatsächlich am Netzteil. Vielen Dank nochmal allen, insbesondere Schmitti für die Hilfe!

  • Hmm die 22uF Tantal / 100nF Kerko-Kombination könnte ich ja fest im Netzteil am 5V Ausgang installieren. Eben habe ich im Bios alle CPU/BUS-Takt Kombinationen durchprobiert. In allen Kombinationen startete der Rechner auf Anhieb ohne Probleme. Beim nächsten Test kommt der 80287 rein.

    :thumbup:



    Eben habe ich den 80287 eingesetzt und ....... läuft ! Hier das Beweisfoto:



    Ich denke ich werde jetzt nur noch die 22uF Tantal / 100nF Kerko-Kombination am 5V Ausgang einsetzen und dann ist das Projekt erfolgreich abgeschlossen. Die ganzen Start-Probleme und auch die Probleme mit dem 80287 lagen also tatsächlich am Netzteil. Vielen Dank nochmal allen, insbesondere Schmitti für die Hilfe!

    :thumbup:

    Freut mich, dass es läuft und dass Du nicht aufgegeben hast. :-) Habe auch gerne dabei geholfen. Finde die Schneider PC-Serie auch schön. Habe selbst zwar keinen sondern nur Commodore-PCs, aber toll, dass Du den hast. Und nun auch mit Koprozessor. Das ist schon was feines.

    Wirst Du den auch für irgendwelche Dinge verwenden? Das fände ich auch super, wenn Du eine Anwendung für das Gerät hast. Ich glaube 4 MB konnte man dem Gerät auf dem Mainboard spendieren oder?

  • Das mit dem Zusatzspeicher ist möglich aber wohl sehr aufwändig, da traue ich mich erstmal noch nicht ran. Der Rechner bekommt aber jedenfalls noch eine Adlib Soundkarte. Die Platinen hatte ich mir ja bei JLPCB in Hong Kong anfertigen lassen. Immerhin sind die PCBs jetzt nach fast 2 Wochen durch den Zoll gekommen. Mal sehen ob ich sie noch vor Weihnachten bekomme.