Posts by philio

    Okay, das ist natürlich erstmal richtig. Nur: zwischen "käuflich erwerbbar" und "herstellen lassen" gibt es für mich einen Unterschied. Das eine Produkt steht schon fertig im Regal, das andere wird erst noch produziert. Das ist für mich nicht das gleiche.


    Außerdem fehlen dem Board bisher offenbar neben einem regulären S-Video-Output (ohne vertauschte Pole) u.a. Schnittstellen für eine Datasette und ein Userport. Auch ein Ein-/Ausschalter fehlt. Die Tastatur muss mithilfe der Files auf github in einem 3D-Drucker erstellt werden ...


    So banal es klingen mag: allein ein fehlender Ein-/Ausschalter nimmt mir spontan einiges von dem Retro-Feeling weg, das ich von der Beschäftigung mit dieser alten Technik erwarte. Einen Schritt weiter und ich bin bereits im (VICE-)Emulator auf meinem Mac angelangt.

    Darauf bin ich vor kurzem auch schon gestoßen. Dieses Board existiert seit (na?) dem Jahre 2020. Genauer gesagt Mai 2020 wie sich leicht dem zugehörigem Youtube-Video von The-8-Bit-Guy entnehmen lässt (einfach "Vic-2020" als Suchbegriff eingeben). Sehr vielversprechend, aber noch in der Entwicklungsphase, soweit ich das sehen kann und daher bislang nicht käuflich erwerbbar.

    Die Idee, Pin 5 dafür zu verwenden, ist hier im Thread auch gekommen:

    Du hast recht. Das war noch, bevor der Adapter in die Welt kam, also in der Planungsphase :)

    Ich hatte nur noch die späteren, also Post-Adapter-Beiträge in diesem Thread im Kopf.


    Das mit den Standards hat natürlich etwas für sich: ich habe zB. zwei Kabel für meinen VC-20, von denen einer das Compositesignal meines 1981er-VC-20 auf Pin 4 abnimmt (weitergeführt auf Scart) und ein weiteres, das dieses Signal auf Pin 5 abnimmt (weitergeführt auf Koaxial-Cinch). Die Ausgabequalität der beiden Wege ist durchaus ein wenig unterschiedlich. Ohne Beschriftung der beiden Kabel mit "4" bzw. "5" als Gedächtnisstütze wüsste ich ohne Ausmessen wahrscheinlich schon nach Wochen, geschweige denn nach Monaten nicht mehr mit Gewissheit, woher genau nun welches Kabel welche Videoausgabe bekommt. Bei einem Einbau einer 8-poligen, C64-kompatiblen Buchse kann einem das nicht mehr passieren. Da gibt es nur eine Norm. Insofern spricht natürlich so manches für den (leider invasiven) Einbau einer 8-poligen Videobuchse auf die VC-20-Platine.

    Den ersten Versuch oben verstehe ich nicht. Der "Witz" an dem Kinzi-Board ist doch gerade, dass man nix am Board rumkratzen muss, oder?

    Das dachte ich zuerst auch. Wie man hier in diesem Thread u.a. in den Beiträgen #187-188 und #197-198 jedoch nachlesen kann wird das Auftrennen von Leitungen auf dem VC-20-Board ausdrücklich empfohlen. Nur wer den Jumper auf der Position "Composite" belässt braucht natürlich keine Auftrennung dieser Leiterbahnen. Aber dann braucht man auch keinen S-Video-Mod, da der Signalweg der Bildausgabe dann unbeeinflusst bleibt.


    Der Jumper auf Position Y/C gibt ohne weitere Modifikationen intern oder extern ein Schwarz-Weiß-Bild aus, da die Farbe (Chroma) dann separiert auf der Rückseite des Adapters auf eine neuen Leitung umgelegt wird die für den VC-20 so nie vorgesehen war. Übrig bleibt dann das Helligkeitssignal (Luma) auf dem VIDEO-Signalweg. Im Unterschied zum Videoanschluss des C64 gibt es keine(n) unbelegten Anschluss/Anschlüsse an der nur 5-poligen DIN-Buchse des VC-20. Dafür bekommt man das Compositesignal gleich zweifach (Pin 4 und 5), was die Möglichkeit eröffnet eines dieser redundanten Signalwege extern zu kappen um sie neu zu belegen wie ich es oben im zweiten Anlauf beschrieben habe. Leider fehlte in diesem Thread bisher die Beschreibung einer solchen externen Lösung, da stets versucht wurde den Videoausgang eines VC-20 C64-kompatibel zu machen und damit zu ersetzen. Das funktioniert leider nicht ohne Auftrennen von Leiterbahnen auf dem Board, die u.a. die anliegende 6V-Spannung auf Pin 1 unterbricht um diese für das Luma-Signal neu zu belegen. Der S-Video-Adapter hat auf diese Neubelegungen keinerlei Einfluss. Er verhindert lediglich, dass das vom VIC ausgehende Chromasignal auf das Board gelangt und mit Luma zu einem Compositesignal gemischt wird. Das ist im Grunde genommen alles.

    Hallo,

    ich möchte Euch hier meine Erfahrungen beschreiben, die ich in den vergangenen Wochen mit kinzis S-Video-Mod gemacht habe. Vielleicht kann der eine oder andere Nutzen daraus ziehen. Ich finde die folgende Beschreibung besonders interessant, da ich zwei sehr unterschiedliche Wege beschritt um ans Ziel zu kommen. Dabei bin ich im ersten Anlauf gescheitert: das Ergebnis, die Bildausgabe meines VC-20, war nicht zufriedenstellend, sondern eher schlicht mangelhaft. Im zweiten Anlauf dagegen hatte ich, nach einigen Tagen und vielen Stunden Tüftelei, schließlich Erfolg.


    Vorausgeschickt sei, dass im Folgenden zwei beinahe identische ("ältere") Boards aus dem Jahre 1981 zum Einsatz kamen (ASSY 324003), also diejenigen mit 2-Pin/9-Volt-AC-Stromversorgung und unterschiedlichen Signalen auf den Pins 4 und 5 der Videobuchse ("Video Low" und "Video High"). Das ist wichtig zu erwähnen, da in diesem Thread stets von Boards der ("neueren") Revisionen ab 1982 die Rede ist, die u.a. einen mehr oder weniger vollständigen Käfig um den VIC haben und deren Signale an den Pins 4 und 5 im Unterschied zu den ersten Boards identisch sind.


    Nachdem ich Kinzis Bausatz bestellt, erhalten und zusammengebaut hatte bemerkte ich, dass ich auf halber Strecke auf dem Weg zu einem besseren Bild mit getrenntem Luma-/Chroma- anstelle eines gewöhnlichen, gemischten Composite-Signals liegen blieb. Ich hatte mir im Vorfeld noch keine ernsthaften Gedanken gemacht und dachte nur: alles notwendige sollte in diesem Thread oder anderswo im Netz stehen sowie in kinzis Anleitung. Also folgte ich erstmal diesem Weg, den ich im Nachhinein den invasiven Weg nennen möchte. Invasiv deshalb, da er einen nicht unerheblichen Eingriff auf das jeweilige Board voraussetzt. Mein im Anschluss eingeschlagener, alternativer Weg dagegen stellt eine nicht-invasive Lösung dar, bei der das Board vollkommen unversehrt bleibt.


    Als erstes stand also, wie hier vorgeschlagen, der Austausch der 5-Pin-Videobuchse gegen eine 8-Pin-Videobuchse an. Bereits hier hatte ich Pech, ich riess während des Auslötens nicht nur die Buchse aus dem Board, sondern auch Teile des anliegenden Kupfers an den Lötaugen heraus (Bild1). Macht nichts, dachte ich mir, es wird im Anschluss sowieso noch alles neu verdrahtet und verlötet. Als nächstes durchtrennte ich auf der Unterseite des Boards die Leitungen 1 (6V DC), 4 und 5 (Video) und verdrahtete den Signalweg für Luma auf Pin 1 der neuen 8-Pin-Buchse (Bild2). Nur die 3 für's Audiosignal und die 2 für Masse blieben auf dem bisherigen Pfad, da diese beiden Wege bei VC-20 und C64 die gleichen sind. Als nächstes verlötete ich die beiden vom S-Video-Adapter ausgehenden Leitungen mit Pin 6 auf der Rückseite der Videobuchse (für Chroma) bzw. mit dem Board (GND) (Bild3). Das Ergebnis dieser Operation könnt ihr in Bild4 sehen. Aus irgendeinem Grund erhielt ich ein gestörtes Bild: horizontal verlaufende, unregelmäßig unterbrochene Streifen legten sich über das Einschaltbild. Außerdem wanderten diese Streifen langsam von oben nach unten durch das Bild. Anscheinend war der Signalweg vom Adapter ausgehend bis zum Monitor nicht sauber.





    Nach dieser Enttäuschung versuchte ich es noch einmal mit einem zweiten, fast identischem Board (gleiche ASSY No.) und setzte dort den Adapter ein (Bild5). Diesmal entschloss ich mich dazu, alles auf dem Board zu belassen wie es ist und das mit Hilfe des Adapters vom Composite-Signal abgekoppelte Chroma-Signal meinem Monitor erst außerhalb des VC-20 mit auf den Weg zu geben. Dafür musste ein spezielles Kabel her, das die Signalwege entsprechend anpasst. Da es ein solches Kabel nicht zu kaufen gibt bastelte ich mir selbst eines.



    Als erstes nutzte ich die Tatsache, dass jedes Videokabel am VC-20 entweder Pin 4 oder Pin 5 für das Composite-Signal nutzt, jedoch niemals beide zugleich. Nach einigen Tests mit unterschiedlichen Kabeln, von denen manche Pin 4, andere Pin 5 als Signalweg nutzen, entschied ich mich dazu, Pin 4 für das Compositesignal zu nutzen und daher Pin 5 für das vom Adapter ausgehende (neue, dh. isolierte) Chromasignal zu nutzen. Damit bleibe ich außerdem ohne weiteren Aufwand kompatibel mit Videokabeln für den C64. Um den Pin-5-Signalweg vom Board in das neue Kabel zu unterbrechen durchschnitt ich Pin 5 im Stecker (Bild6), so dass nur noch 4 Pins in der Videobuchse des VC-20 verbleiben.


     

    Mit einem Steckbrückenkabel konnte ich nun auf der Innen- bzw. Rückseite des Steckers auf Pin 5 das Chromasignal vom Adapter mit einem Kabel verlöten, das zur 8-Pin-Buchse weiterführt (Bild7). In letzterem landet dieses Kabel auf Pin 6, während das Signal von Pin 4 im Stecker bzw. vom Board in der grau ummantelten Buchse auf Pin 1 landet, womit C64-Kompatibilität hergestellt wird und mit dieser Lösung jedes entsprechende Kabel genutzt werden kann. Der 6V-Strom auf Pin 1 vom VC-20 kommend läuft dagegen ins Leere, ist also mit keiner Leitung im Kabel verbunden (habe keinen Bedarf dafür). Auf der Platine sieht diese zweite Lösung aus wie in Bild8 zu sehen. Die Leitung für die Masse (schwarz) habe ich einfach mit einer bereits vorliegenden Schraube ganz links mit dem Board verschraubt.


    Das Ergebnis hat mich spontan sehr beeindruckt (Bild9) und ich bin heilfroh, doch noch das von mir gewünschte Ziel erreicht zu haben. Und es ist eine Sache, nur Fotos aus dem Netz für diesen Mod zu sehen oder ihn direkt vor sich auf seinem eigenen Monitor zu haben. Dieses Bild wird übrigens zusätzlich durch einen Analog/Digital-Konverter geschickt, der das Bild absolut ruhig macht (ohne flimmert es ein wenig). Damit habe ich eine Bildausgabequalität erreicht, die mit derjenigen aus meinem C64 reloaded MK II (via S-Video) absolut vergleichbar ist! Das habe ich noch vor einigen Monaten nicht für möglich gehalten. Und im Übrigen zeigt es für mich eindrucksvoll, welche schon immer verborgenen Fähigkeiten aus dem betagten VC-20 noch herauszuholen sind!


    Vielen Dank an dieser Stelle an kinzi für seine Arbeit an diesem durchdachten Adapter! Mit seiner Lösung habe ich nun stets die Wahl den Originalzustand herzustellen (Jumper auf "Composite" in Verbindung mit einem "VC-20-Kabel") oder die S-Video-Ausgabe zu nehmen (Jumper auf "Y/C" und eigenes Spezialkabel). Keine andere Lösung, die ich im Netz gesehen habe, lässt mir beide Wege gleichermaßen offen.