Hello, Guest the thread was called170 times and contains 11 replays

last post from T3V6 at the

Amiga 1200HD Festplatte formatieren - Problem

  • Hallo liebe Community,


    ich bin nach 15 Jahren Anstinenz wieder auf den Amiga gekommen. Leider muss ich feststellen, dass ich scheinbar vieles vergessen habe. Erschwerend kommt für mich hinzu dass die Modder und Tüftler Szene in den vergangen Jahren viele neue Hard- und Software Upgrades hervor gebracht hat.

    Ich habe mir vergangene Woche einen nahezu "neuwertigen" (!!!) Amiga 1200 HD gekauft.
    Irgendwie ist da eine 80 GB Festplatte drin. 2x in knapp 40 GB partitioniert. Beide wurden in der Workbench als unformatiert angezeigt. Ich wollte sie formatieren. Dabei gab es eine Fehlermeldung. Nun meckert der Amiga sowohl beim Start, als auch beim Booteten von Diskette als allererstes rum, das mit der Platte etwas nicht stimmt. Wenn ich auf abbrechen klicke, fährt er mit booten in die Workbench fort, oder er läd die Diskette.

    Nun zeigt er an, das die fehlerhaft partitionierte Platte zu 100% voll sei.

    Vieles in der Workbench ist mir unbekannt. Ich habe mal entsprechende Bilder angehängt.

    Ich hoffe mir kann da Jemand helfen ein wenig Licht ins Dunkel zu bringen. :whistling:


    Marcus

  • Hm äh also tja. ich versuch´s mal aus dem Kopf:


    1. Du scheinst ein AmigaOS3.1.4 zu haben (zu sehen am Copyright 2018 Hyperion). Das kann von Natur aus schonmal grössere Platten als 4GB verwalten. Gut.

    2. Die Workbench kann zwar formatieren, aber nicht partitionieren. Dafür gibt es in einer Unter-Schublade das Tool "HDToolbox". Damit kannst du sehen, wie die Festplatte partitioniert ist. Ich nehme an, da nur eine Platte in den Amiga passt, sind 4 Partitionen drauf: 36GB, 38GB, DH0 und DH1.

    3. Irgendwas ist beim Formatieren falsch gelaufen. Ein Validation-Error ist normalerweise durch einen nicht beendeten Schreibvorgang entstanden, d.h. irgendwo ist eine Datei nicht ganz fertig, oder die Verzeichniseinträge/Grösseneinträge sind zerschossen.

    4. Der Amiga versucht, die zerschossene Partition so weit zu reparieren, dass sie wenigstens bis auf den fehlerhaften Eintrag ansonsten gelesen werden kann, und stellt auch die Schreibfähigkeit wieder her. Dieser "Validation"-Vorgang braucht seine Zeit und seinen RAM-Speicher. Bei damaligen 80MB-Festplatten mag das funktioniert haben, bei deinen 80GB (bzw 30+ GB pro Partition) ist wohl dein RAM von 2MB zu knapp, um die ganze Partition zu validieren. Eine nicht-validierte (und damit schreib-unfähige) Partition wird als 100% voll markiert.


    Gib in der Shell/CLI mal "info" ein.

    Das zeigt dir zum Laufwerksbuchstaben auch den Disk-Namen an. Weil deine Bilder zeigen zwar DH0/DH1/36GB/38GB, aber nicht, welche davon denn nun "Leer" heisst.

    Da 36GB zu 100% voll ist, würde ich schätzen, diese heisst "Leer". Deine 38GB Partition scheint unformatiert (keine %-Angabe zur Belegung).

    DH0 und DH1 sind formatiert und leer, deine Workbench wurde von Floppy gebootet.


    Achtung:

    Deine Workbench-Floppy sollte auch min OS3.1.4 sein.

    Frühere Versionen 3.0 und 3.1 unterstützen nur bis 4GB-Platten. Die HDToolbox auf diesen Disketten zeigt dann falsche Grössen an, das Partitionieren und auch das Formatieren könnte deutlich in die Hose gehen (habe ich noch nie selbst probiert).


    Du kannst auch mit 2MB weiterkommen. Ich habe meine Speichererweiterung auf 8MB auch erst 2018 gekauft, ca 26Jahre nach der Festplatte :-)

    Du musst nur die Partitionen klein halten. Ich hatte max 2x 4GB.


    PS: Mein 3.1.4 ist copyrght 2019,

    nicht 2018?! Was ist das los?! Aber egal

  • Das hilft weiter.

    1. Die Workbench liegt auf DH0, ist aber so klein, dass die Platte immernoch als "0% belegt" angezeigt wird. Nuja, die paar MB auf 700+ MB sind halt weniger als 1% :-)

    2. DH1 mit Games scheint auch erstmal intakt. Schön für dich :-)

    3. Ob die beiden 36/38GB-Klopper nicht wollen, weil dein Speicher nicht reicht, oder weil etwas anderes dazwischengekommen ist, weiss ich nicht. Aber du siehst ja selbst: "Leer" wird validiert, und wird wahrscheinlich mangels Speicher nie fertig (oder schmeisst ne Fehlermeldung).


    Mit HDToolbox könntestdu jetzt "36GB" komplett löschen. Dann hast du zwar eine Lücke auf der Festplatte, aber wärst erstmal den Fehler los. Formatieren von "38GB" könnte natürlich die gleichen Fehler machen!

  • So, ich habe mir HDToolbox mal angeschaut. Also ich klicke da auf die 38GB Parttion (ist jetzt schwarz) und dann Partition löschen und ok? Wie lange dauert das? Muss morgen wieder bei zeiten auf Arbeit. Partition löschen sollte ja instant gehen, quasi.

    Ach, und Thema Turbokarte.... Ich habe mich mal umgeschaut. Neue gibts immer da wo ich gucke keine mehr. Derzeit nicht lieferbar.
    Wo bezieht ihr eure? Kann man da was empfehlen?

  • Kauf dir eine turbokarte mit mehr Speicher.

    ...

    Besorg dir AmigaOS 3.2 bitte


    Das finde ich dann doch etwas zu hart vor den Latz geknallt.


    Der Amiga läuft auch mit 2MB ab Werk, so hatte ich seit den 90ern OS 3.0, und für "das übliche" war das immer ausreichend.

    Gut, 80GB sind da evtl etwas hoch angesiedelt, aber man kann die Funktionalität ja auch mit weniger Festplatten-Partitionen angehen.


    Der Hardcore-Rytracingmann, oder der WHDLoad-Freak kommt mit der Grundkonfiguration nicht weit: akzeptiert.

    Aber meine Aufrüstung auf 8MB FastRAM (und OS3.1.4) in 2018 sehe ich als reinen Luxus, auf den ich wegen WHDLoad Bock hatte.

    Alle WHDLoad-Titel, und ne ClassicWB, haben bei mir auf 8GB Festplatte Platz gefunden.


    Es soll ja Leute geben, die nicht mal eben 100Euro+ raushauen für so´ne alte Gurke.

  • Ich würde erstmal die unvalidierte 36GB löschen. Das dauert Sekunden und dein Fehler beim Booten sollte verschwinden.

    An der 38GB ist ja (noch?) nix kaputt. Ob die sich mit deinen müden 2MB RAM formatieren lässt, weiss ich nicht.


    Du kannst aber (glaube ich) zig 4GB-Partitionen an Stelle der 36/38GB Partitionieren :-P