Posts by Goldbug

    Hallo zusammen,


    ich versuche im CBMprgStudio ein Basicprogramm zu schreiben, welches eine sequentielle Datei auf das Laufwerk schreibt.
    Nun will das mit dem Start von VICE mit eingelegtem Diskimage (Ziel) nicht funktionieren.
    Kann Vice mittels Parameter, beim Start ein Image eingelegt bekommen?


    Wenn ja, wie??


    Danke

    OK, kein Problem.


    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.


    ************** Exception Text **************
    System.IO.FileNotFoundException: Could not load file or assembly 'System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. Das System kann die angegebene Datei nicht finden.
    File name: 'System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'
    at CBMPrgGen.frmMain.frmMain_Load(Object sender, EventArgs e)
    at System.EventHandler.Invoke(Object sender, EventArgs e)
    at System.Windows.Forms.Form.OnLoad(EventArgs e)
    at System.Windows.Forms.Form.OnCreateControl()
    at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
    at System.Windows.Forms.Control.CreateControl()
    at System.Windows.Forms.Control.WmShowWindow(Message& m)
    at System.Windows.Forms.Control.WndProc(Message& m)
    at System.Windows.Forms.ScrollableControl.WndProc(Message& m)
    at System.Windows.Forms.ContainerControl.WndProc(Message& m)
    at System.Windows.Forms.Form.WmShowWindow(Message& m)
    at System.Windows.Forms.Form.WndProc(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].




    ************** Loaded Assemblies **************
    mscorlib
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
    ----------------------------------------
    CBMPrgStudio
    Assembly Version: 1.0.0.0
    Win32 Version: 1.0.0.0
    CodeBase: file:///C:/Programme/CBMprgStudio/CBMPrgStudio.exe
    ----------------------------------------
    Microsoft.VisualBasic
    Assembly Version: 8.0.0.0
    Win32 Version: 8.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
    ----------------------------------------
    System
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
    ----------------------------------------
    System.Windows.Forms
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
    ----------------------------------------
    System.Drawing
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
    ----------------------------------------
    System.Runtime.Remoting
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Runtime.Remoting/2.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll
    ----------------------------------------
    FastColoredTextBox
    Assembly Version: 2.8.3.0
    Win32 Version: 2.8.3.0
    CodeBase: file:///C:/Programme/CBMprgStudio/FastColoredTextBox.DLL
    ----------------------------------------
    WeifenLuo.WinFormsUI.Docking
    Assembly Version: 2.5.0.15095
    Win32 Version: 2.5.0.0
    CodeBase: file:///C:/Programme/CBMprgStudio/WeifenLuo.WinFormsUI.Docking.DLL
    ----------------------------------------
    System.Configuration
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
    ----------------------------------------
    System.Xml
    Assembly Version: 2.0.0.0
    Win32 Version: 2.0.50727.42 (RTM.050727-4200)
    CodeBase: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
    ----------------------------------------


    ************** JIT Debugging **************
    To enable just-in-time (JIT) debugging, the .config file for this
    application or computer (machine.config) must have the
    jitDebugging value set in the system.windows.forms section.
    The application must also be compiled with debugging
    enabled.


    For example:


    <configuration>
    <system.windows.forms jitDebugging="true" />
    </configuration>


    When JIT debugging is enabled, any unhandled exception
    will be sent to the JIT debugger registered on the computer
    rather than be handled by this dialog box.



    Du musst mir nicht für die Geduld danken, sondern ich danke dir für das C64 Studio !


    Goldbug

    Nee, bestimmt nicht. Die Fehlermeldung wäre interessant, ich lasse das auch immer wieder am XP-Laptop laufen.


    Bitte beim Nächsten Absturz zusenden, dann bereinige ich das!



    OK, die Meldung lautet:


    Die Anwendung konnte nicht initialisiert werden (0xc0000135). Klicken Sie auf OK um die Anwendung zu beenden


    Das Programm lässt sich instalieren, aber nicht starten.


    Hab gerade mal danach gegooglt: "Hast du das NET-Framework installiert? Die Fehlermeldung lässt darauf schliessen, dass dieses fehlt."


    Ich werd das mal runterladen und testen!


    Goldbug







    Goldbug

    Hallo zusammen,


    ich hab gerade das Studio unter Win XP installiert.
    Kann es nicht starten. Fehlermeldung! (hab ich grad nicht, weil das ein anderer Rechner ist)


    Unter Win7 (32bit) hab ich das am laufen.


    Ist mein System im Ar... ?


    Goldbug

    Hallo zusammen,


    ich bastel mir gerade ein Kabel für den Userport.
    Leider ist mir nicht klar, wie die Anschlüsse durchgezählt werden.


    Ich vermute mal das die Anschlüsse, welche mit Buchstaben bezeichnet sind, unten liegen.
    Allerdings wo befindet sich das A und wo das W???


    Ich hänge mal ein (auch gebasteltes) Bild aus dem Wiki an. Stimmt das so????


    Ach ja, wo sind den die Buchtaben G und I?


    Danke für eure Informationen,
    Goldbug

    OK,


    der Monitor ist ausser Betrieb und wird es wohl erst einmal bleiben.
    Danke für den Schaltplan.
    Selber werde ich da nicht dran fummeln (an dem Monitor meine ich :P )


    Hab da noch etwas gefunden:
    Zitat von »Thunder.Bird« (Tip#1:tauscht euren 1901-Netzfilter Kondensator aus, sonst raucht der bald ab!)


    Direkt am Netzschalter, bzw. Netzspannungseingang sozusagen hängt das Ding parallel.
    Nach den 20 Jahren rauchen die gern reihenweise ab und das stinkt nicht nur, das knn auch Brände verursachen.


    Damit alle beruhigt sind:
    An alle: IST GEFÄHRLICH!!! Nur Fachleute machen lassen!!!

    Hallo zusammen,


    ich hab einen 1901 Monitor der nach ca. 10Min. Betrieb zwar ein Bild anzeigt, aber auch raucht und stinkt.
    Meine Frau schreit dann schon immer rum :böse


    Ich dachte das dieses selten ist, aber scheint nicht so:
    Zitat von Neuromancer (27. Juli 2010, 12:05)
    ....
    Den 1901 würde ich nicht einfach am Netz hängen lassen. Wenn der Kondensator abraucht, dann qualmt und stinkt es gewaltig (Brandgefahr ?).
    Außerdem geht der Netzschalter gerne kaputt. Daher schalte ich meinen 1901er immer nur über eine abschaltbare Steckdose ein und aus.


    Gibt es eine Reparaturmöglichkeit? oder ist der Monitor nun Schrott?
    Zu meinem Erfahrungstand: Ich leide unter Schaltplanlegasthenie und ich vermute , wo ein Lötkolben heiss wird ist vorne?


    Danke für eure Hilfe,
    Goldbug

    Guten Abend,


    ich hab gerade ein Modul getestet. OK.
    Beim Abziehen oder wann auch immer hab ich wohl was falsch gemacht. :whistling:
    Jetzt bleibt mein Bildschirm dunkel :böse


    Es handel sich um einen C64 II mit Assy 250469
    Was knallt den hier durch?
    Kann ich die "Käfer" mit "käfern" von anderen Boards austauschen? z.B. CIA (auf der linken Seite)?


    Bitte um schnelle Hilfe.


    Danke
    Goldbug

    Also ich bring


    - was zum Wichteln mit. Soll ich Speckulatius von Aldi mitbringen?
    - einen TI99 /4a zum rummachen + Kassettenspieler + Fernseher und Kabeltrommel
    bei Interesse kann ich mal eine Odyssey 2001 zum
    Und folgendes zum bearbeiten (wo ich eure Hilfe gebrauchen könnte):
    - einen VC 20, der nur einen Startbildschirm anzeigt, aber ohne blinkenden Cursor! Kennt jemand Reparaturtipps?
    - einen Commodore 1901 und einen Scartstecker, kann mir jemand beim Umbau behilflich sein?
    - Videostecker und ein Scartkabel zum zusammenbauen (Belegungsplan wäre gut).
    - Lötkolben und Lötzinn
    - erste Hilfekiste aus dem Auto :P


    Mir fehlt eine Taste 4 +Feder für einen C64 C II (Farbe CYN vorne, Zeichen 4+$ oben)
    Zu einer Atari 2600 Konsole fehlt mir der Schiebeschalter "Game Reset" bzw. ist abgebrochen.
    Hat jemand Ersatzteile?


    Bis hier ersteinmal vielen Dank,
    Goldbug
    P.S. Viele Grüße an alle meine Freunde im Forum!

    Ja, das gefällt mir.
    Ich lese die Data's bis zum "t_9" und mach dann weiter.
    Ich versuchs mal im CBM-Studio.


    Was jetzt blöd ist:
    Alle Zeilen, welche >80 Zeichen sind als "greater then 80..." gekennzeichnet. Ist klar, aber trotzdem doof!
    Alle Zeilen mit _ gehen auch nicht.
    Alle Zeilen mit umlauten gehen auch nicht
    Alle Datazeilen sind ohne Zeilennr. RENAME funktioniert wohl nicht richtig oder ich bin zu blöd? CMB Studio stürtzt ab!


    Ich fummel morgen mal weiter.


    Gute Nacht


    Ach ja, Zeilennummern werden bei den Fehler mit angezeigt (z.B.Line 38). Im Quelltext leider nicht. Zum Einstellen hab ich noch nichts gefunden.

    Hallo zusammen,


    ich hab mal in Blitzbasic ein kleines Progamm geschrieben. Ein TEXTABENTEUER mit fast ohne Grafik.
    Nun will ich mal eine Umsetzung für den C64 machen.
    Ich hab ja den ganzen Text schon einmal geschrieben und möchte die Datei gerne noch einmal benutzen.


    Es gab max. 6 Zeilen Text. Dann die Anzahl der möglichen Antworten. Nach den Antworten die nächste Nr. des nächsten Textfeldes.


    Hier ein kleiner Auszug:
    .T_9
    Data "In dem Faß ist ausgezeichneter Wein,"
    Data "dessen Genuß deine Trefferpunkte um eins erhöht."
    Data " "
    Data " "
    Data " "
    Data " "
    ;
    Data 2 ;Anzahl der möglichen Antworten
    Data "Willst du nun das Gerümpel untersuchen",87;
    Data "oder den Raum verlassen.",77


    Der Spieler hat den Text gelesen und sich für eine der Antworten entschieden und dann kam halt ein weiterer Text. Der Spieler hat den Text gelesen und sich für eine der Antworten entschieden und dann...u.s.w....u.s.w.


    Im Quellcode konnte ich damals soetwas wie RESTORE_t benutzen um zum DATABLOCK _T zu springen und die DATA's einlesen.
    Wie genau das war ist mir entfallen, ist ja auch schon einpaar Jahre her.
    Geht das auch in BASICV2.0 ?


    Ich hatte nun die Idee die texte auf Floppy zu schreiben und bei Bedarf einzulesen. Die textdatei ist im Editor 80K groß.
    Oder habt Ihr eine bessere Idee, bevor ich jetzt gleich falsch oder umständlich anfange, freue ich mich über eure Rückmeldungen.
    Danke

    Hallo zusammen,
    ich möchte auch kommen.
    Ich würde einen (oder zwei) reparaturbedürftige vc20 mitbringen.
    Hat evtl. noch jemand ein 2-pol. Netzteil ? Oder kann mir sagen was man für einen Selbstbau benötigt? Würde alles besorgen und dann vor Ort Bauen.
    An meinem Atari 2600 ist ein Schiebeschalter (Gamereset) abgebrochen. Wie kann ich das reparieren?
    Hab seit ein paar Tagen einen TI99, bring ich auch mit.
    Ansonsten versuche ich gute Laune mitzubringen :-)


    Wird wieder gewichtelt?


    CU
    Goldbug (a.k.a. Otto-Rehagel)