Posts by toms01

    Ja, das möchte ich noch machen. Allerdings wäre es schön noch eine defekte Paddleplatine zu bekommen (kann gern ohne Chips, Kabel und Gehäuse sein) zum genauen Maßnehmen.

    Falls also jemand sowas noch rumliegen hat und es loswerden möchte: Bitte bei mir melden :)

    Hast Du Mal die Konsole probiert? Also im OSD den UART auf console stellen. Mit Ncomm musste ich bei mir (3.1.4) nur die 115200 Baud einstellen. Wenn das tut, geht zumindest Mal die serielle Schnittstelle.

    Ich kann mich jetzt verbinden, "Fehler" war eine zu hohe gewählte Auflösung (SuperHires 256 Farben), das frisst wohl zuviel Leistung vom serial.device.

    Unter der Standard-Auflösung läuft es. Schade.

    Nichts zu machen mit Roadshow unter PPP 115200, manchmal wird kurzzeitig eine Verbindung hergestellt und dann das:

    Jul 21 12:17:22 MiSTer daemon.debug pppd[1402]: rcvd [LCP ConfReq id=0x4b <mru 1500> <magic 0x30feb98d> <asyncmap 0x0> <pcomp> <accomp>]

    Jul 21 12:17:22 MiSTer daemon.debug pppd[1402]: sent [LCP ConfAck id=0x4b <mru 1500> <magic 0x30feb98d> <asyncmap 0x0> <pcomp> <accomp>]

    Jul 21 12:17:22 MiSTer daemon.debug pppd[1402]: sent [LCP ConfReq id=0x3 <asyncmap 0x0> <magic 0x17d2902a> <pcomp> <accomp>]

    Jul 21 12:17:25 MiSTer daemon.debug pppd[1402]: rcvd [LCP ConfReq id=0x4b <mru 1500> <magic 0x30feb98d> <asyncmap 0x0> <pcomp> <accomp>]

    Jul 21 12:17:25 MiSTer daemon.debug pppd[1402]: sent [LCP ConfAck id=0x4b <mru 1500> <magic 0x30feb98d> <asyncmap 0x0> <pcomp> <accomp>]

    Jul 21 12:17:25 MiSTer daemon.debug pppd[1402]: sent [LCP ConfReq id=0x3 <asyncmap 0x0> <magic 0x17d2902a> <pcomp> <accomp>]

    Jul 21 12:17:27 MiSTer daemon.debug pppd[1402]: rcvd [LCP EchoReq id=0x37 magic=0x30feb98d]

    Jul 21 12:17:28 MiSTer daemon.debug pppd[1402]: rcvd [LCP ConfReq id=0x4b <mru 1500> <magic 0x30feb98d> <asyncmap 0x0> <pcomp> <accomp>]

    Jul 21 12:17:28 MiSTer daemon.debug pppd[1402]: sent [LCP ConfAck id=0x4b <mru 1500> <magic 0x30feb98d> <asyncmap 0x0> <pcomp> <accomp>]

    Jul 21 12:17:28 MiSTer daemon.debug pppd[1402]: sent [LCP ConfReq id=0x3 <asyncmap 0x0> <magic 0x17d2902a> <pcomp> <accomp>]

    Jul 21 12:17:31 MiSTer daemon.debug pppd[1402]: sent [LCP ConfReq id=0x3 <asyncmap 0x0> <magic 0x17d2902a> <pcomp> <accomp>]

    Jul 21 12:17:34 MiSTer daemon.debug pppd[1402]: sent [LCP ConfReq id=0x3 <asyncmap 0x0> <magic 0x17d2902a> <pcomp> <accomp>]

    Jul 21 12:17:37 MiSTer daemon.debug pppd[1402]: sent [LCP ConfReq id=0x3 <asyncmap 0x0> <magic 0x17d2902a> <pcomp> <accomp>]

    Jul 21 12:17:40 MiSTer daemon.debug pppd[1402]: sent [LCP ConfReq id=0x3 <asyncmap 0x0> <magic 0x17d2902a> <pcomp> <accomp>]

    Jul 21 12:17:43 MiSTer daemon.debug pppd[1402]: sent [LCP ConfReq id=0x3 <asyncmap 0x0> <magic 0x17d2902a> <pcomp> <accomp>]

    Jul 21 12:17:46 MiSTer daemon.debug pppd[1402]: sent [LCP ConfReq id=0x3 <asyncmap 0x0> <magic 0x17d2902a> <pcomp> <accomp>]

    Jul 21 12:17:49 MiSTer daemon.warn pppd[1402]: LCP: timeout sending Config-Requests

    Hi,

    hoffe ich bin damit richtig hier:

    Ist es euch gelungen Roadshow mit 115200-Baud-RTSCTS-PPP (Standardeinstellung auf dem MiSTer) zum laufen zu bekommen?

    Falls ja, wie?

    Ich schätze das serial.device ist zu langsam, möchte aber ungern für den UART die Default-Baudrate senken.

    Danke,

    toms01

    Dank der Spende eines Paddle (vielen Dank an Voigoth) für meine bei Ebay ersteigerte 1551 (Paddle wurde abgeschnitten) ist erstmal folgender Ersatz auf CPLD-Basis entstanden.

    DSC_2415.JPG


    Somit läuft der Ersatz für den 6523T (und damit auch 6523), die PLA wurde auch nachgebildet und das Paddle kommt ohne Commodore-Chips aus.

    DSC_2413.JPGDSC_2416.JPG


    Auch der schon vor einiger Zeit angekündigte 6529-Ersatz ist mittlerweile in einer ersten Prototypenversion geschrumpt:

    DSC_2414.JPGDSC_2412.JPG


    Ziel ist es das gesamte Paddle nur mit einem CPLD nachzubilden, es soll dann wieder in das Originalgehäuse passen.

    Falls jemand noch ein geschrottetes Paddle-PCB zum "nackig-machen" über hat, würde ich mich über eine Spende freuen (möchte davon genaue Maße nehmen).


    Auch nochmals Danke androSID für die vielen Löcher, die ich ihn in den Bauch fragen durfte! :thumbsup:

    Hatte ein angebrochenes und mit Bohrlöchern verunstaltetes Gehäuse per Lötkolben wieder verschweisst und gespachtelt. Danach kann man es nur noch lackieren.
    Mit o.g. Farbton muss man wirklich mehrmals hinschauen, um es von meinen anderen drei A1000 (nicht lackiert) unterscheiden zu können.
    Kommt natürlich immer auf die Vorarbeit drauf an: Reinigen, schleifen (600er und mehr) , reinigen, mehrfach lackieren(inkl. Kunststoffhaftgrund), abschliessend Klarlack in Seidenmatt drauf.

    Ich glaube dieser eine Schaltregler war schlichtweg defekt, ich werde ihn demnächst mal mit einem Oszi genauer untersuchen.
    Mir dauerte nur der Versand aus den Staaten zu lange, um einen Vergleichstypen zu testen.
    Wie gesagt, mit Linearregler hatte ich keine Probleme.

    Moin,


    hatte eine defekte 1551 bekommen mit einem defekten Brückengleichrichter, leider lief diese auch mit einem später ausgetauschten Ersatzschaltregler psu5 nicht zufriedenstellend, hatte oft Lesefehler.
    (Edit: was am psu5 lag, Linearregler funktionierte, war mir bei diesem Projekt aber zu warm. Naja, vielleicht schon defekt geliefert angekommen).
    Daher kam die Idee sämtliche wärmeren Bauteile aus dem Laufwerk zu verbannen und auch sonst ein leichtes Temp-Tuning durchzuführen :)


    Ein Meanwell RD-50A-Netzteil kostet kaum mehr als zwei Ersatzschaltregler (psu5/psu6).
    Damit braucht man die zwei Brückengleichrichter, alle Netzteilelkos/-kerkos und auch die Linear- o. Schaltregler nicht mehr.
    Auch die Stinkbombe Netzfilter ist überflüssig und auch der Sicherungshalter wird dafür nicht mehr benötigt.
    Mal sehen, werde dafür wohl noch einen Blindstopfen entwerfen.
    Im 1551 bedeutet es, dass lediglich der C13-47uF-Elko übrig blieb, und diesen kann man (getestet) auch durch einen Kerko (bedrahtet, 47uF, 50V habe ich genommen)
    ersetzen.


    Somit gibt es keine Elkos mehr auf dem alten Board. Fürs Netzteil wurde eine passende Halterung für die Originalposition entworfen, ich habe das STL mal angehängt
    falls es jemand gebrauchen kann. Müsste auch in eine 1541 passen, meine nächste defekte werde ich mal ebenso umbauen.


    Das Board ist ziemlich leer geworden, es müssen lediglich 6 Brücken gelötet werden, dann kann man den Original-Stromanschluss nutzen.
    Ich habe mir (da jetzt dort die 5 und 12V eingespeist werden) eine verpolungssichere Stiftleiste eingelötet.


    Schlussendlich sind ein paar Kühlkörper auf die wärmeren ICs gekommen und das ROM wurde durch ein W27C512 (hatte kein anderes) ausgetauscht.
    Insgesamt läuft das Laufwerk jetzt prima und auch die Wärmeabgabe ist deutlich geringer als vorher.


    It should work only at the keyboard-side (one-way-ticket :) ) in a Plus/4.
    I made some working replacement stuff with a cpld, but i have to make it smaller. There isn't so much space unter the keyboard in a Plus/4.

    Das wird wohl kaum jemand beantworten können, aber nicht alle alten Komponenten haben eine teils fressende Flüssigkeitsfüllung.
    Und ich vertraue neuen Gummidichtungen mehr als alten, aus denen der Weichmacher langsam raus ist...

    hehe, ich glaube vom Thema 1571 sind wir schon lange entfernt :) Da macht das jetzt auch nichts mehr :D
    Aber im Ernst: Ich finds klasse, dass Hardware-Cracks wie kinzi, ADAC, Gerrit, ... einem Nicht-E-Techniker
    bei der Fehlersuche anleiten, das hat schon so einige Geräte hier wieder auf die Füße geholfen.
    Ich würde mir wünschen, dass das ganze Wissen mal zentral pro Gerät hier im Forum gesammelt werden
    würde.

    Wie oben schon geschrieben wurde Versorgungsspannungen messen oder stützelkos prüfen sind absolutes Basic. Man schiesst nicht mit Kanonen auf Spatzen. Und ich wechseln nichts auf verdacht oder weil es grade so in Mode ist.

    Da sollte man differenzieren, bei vorhandenen Schaltplänen oder genannt simplen Schaltung ist das sicherlich kein Problem. Befindet sich ein A2000 in der Sammlung? Da gibt es mittlerweile wohl weniger Fälle in den Roederstein-Kondensatoren keine Probleme gemacht haben, ebenso die ganze SMD-Elkoreihe im A1200.
    In bekannten Fällen wechsele ich, würde ich auch jedem raten - auch vorsorglich :D


    csdragon: Ich schätze kinzi meint damit die Kondensatoren im VIC-Gehäuse (Blechschachtel) auf dem C64-Board.