Posts by bigby

    So, habe "probiert". :-)


    Erwartungsgemäß ist R4 überflüssig, es macht keinen erkennbaren Unterschied, wenn ich ihn entferne. Also wird er entfernt.


    Ich habe die Schaltung anschließend testweise direkt mit 12V betrieben und dabei einen LM1881 "gegrillt": Der Käfer ist so heiß geworden, daß ich mir fast den Flünken verbrannt hätte, und jetzt tut er nicht mehr. So ganz verstehe ich diese Reaktion nicht; meine erste Vermutung wäre, daß ich beim Bezug aus Fernost an einen "unvollständigen" Nachbau geraten bin. Aber da er auch mit Spannungsregler nur ein Bruchteil kostet, werde ich es wohl dabei belassen.


    Hat noch jemand eine Meinung zur Dimensionierung von R1? Sind die 220 Ohm, die ich aus der ursprünglichen Schaltung übernommen habe (die dann ja aber auch noch einen Verstärker enthielt) möglicher Weise überdimensioniert? Subjektiv habe ich den Eindruck, daß sich das Bild minimal verbessert, wenn ich den Wert halbiere. Für Rückmeldungen wäre ich hier sehr dankbar...

    Laut Datenblatt verträgt der LM1881 zwischen 5 und 12V an Vcc und ich bin immer noch der Meinung, daß R4 eigentlich nicht gebraucht wird.

    Den Hinweis zu R4 habe ich nicht überlesen, vielen Dank dafür. Genau auf diese Art von Rückmeldung hatte ich ja gehofft, als ich den Thread hier eröffnet habe. Die Schaltung ist eher "aus dem Bauch" heraus entstanden, ich verstehe zu wenig davon, um mir da sicher zu sein.


    Daß der LM1881 12V verträgt, hatte ich gesehen. Die ursprüngliche Schaltung, auf der ich aufgebaut habe, lief auf 5V und ich dachte, mit Rücksicht auf Display und C64 wäre es vielleicht ratsam das beizubehalten. Aber möglicher Weise galten die 5V dort auch nur dem noch enthaltenen AVR Controller.


    Du meinst also, man könnte das alles problemlos auf auf 12V betreiben? Sollte man R4 dann definitiv weglassen, oder ist er Deiner Meinung nach dann auch "nur" überflüssig?

    Ich habe inzwischen ein wenig am Board Layout gefeilt. Vermutlich ist es jetzt dicht dran an dem, was ich machen lassen werde, aber ich lasse das noch mal "sacken" bis nächstes Jahr. ;)


    Anbei schon mal der Schaltplan und eine Vorschau auf das Board. Das KiCAD Projekt ist auch schon auf Github verfügbar, aber es fehlen noch letzte Details wie z.B. eine freie Lizenz.



    Ich muß jetzt gleich erst mal offline für Silvester mit der Familie. :)

    Files

    • SyncFix64.pdf

      (21.94 kB, downloaded 74 times, last: )
    • SyncFix64.pdf

      (21.94 kB, downloaded 39 times, last: )

    Ein sehr spannender Ansatz, finde ich! Und möglicher Weise eine Lösung für mein Problem aus der entgegengesetzten Richtung.


    Ich Deine Hinweise zum Dump der Firmware überflogen und bin mir nicht sicher, ob ich das damit hinbekomme. Vielleicht könntest Du dazu noch eine detailliertere Anleitung schreiben? Wenn ich es dann schaffe, einen Dump zu ziehen, schicke ich ihn Dir gerne! Das einzige was mir ad hoc einfiele, wäre, das Flash auszulöten und mit einem Programmer auszulesen...

    @nocash: Ja, auf einem meiner Bilder kann ich klar erkennen, daß es sich um einen AMT630A handelt. Über einen Einbau in den C64 habe ich auch nachgedacht, das dann aber aus verschiedenen Gründen verworfen, u.a. weil ich 1 Display und mehrere C64 habe. Kommt halt auf den Anwendungsfall an.


    @butzel: Ja, wenn ich das Layout fertig habe, soll es unter einer freien Lizenz verfügbar sein.


    Für alle anderen: Ich werde im Laufe der Woche mal einen Schwung Platinen ordern. Dann kalkuliere ich mal durch, was ich für Patine, Bausatz und Versand nehmen muß, um die Kosten zu decken.

    Basierend auf meinem ersten Steckbrett-Entwurf habe ich gestern dann mal ein kleines Board entworfen und um einen Spannungsregler ergänzt. Ich habe mich auf SMD-Bauteile beschränkt, weil ich das ganze mit in das Gehäuse des TFT einbauen wollte. Als ich dann gemerkt habe, daß ich ohne größere Probleme auch ein Layout mit nur einem Layer hinbekomme, habe ich dann auch gleich das Toner-Transfer-Papier und das Eisen(III)-Chlorid rausgekramt. Ich präsentiere das "SyncFix64 Modul rev. 0" :



    So ohne Lackmaske war das Löten nicht ganz einfach, hat aber dann doch hingehauen. Paßt ins Gehäuse und tut. Nun habe ich ein Display mit einem regulären und einem "aktiven" Eingang. Hier noch ein paar mehr Details.


    In der Zwischenzeit gab es schon ein paar Anfragen von Leuten, die auch Bedarf für so etwas hätten. Ich könnte mir durchaus vorstellen, das Layout noch ein wenig "aufzuhübschen", daraus ein Panel zuerstellen und das dann fertigen zu lassen. Ein wenig fehlt mir dabei die Erfahrung, wie man das hier am besten organisiert. Im ersten Schritt würde ich gerne ein Gefühl dafür bekommen, wie groß die Nachfrage tatsächlich wäre und ob sich das lohnt.


    Ich würde in jedem Fall versuchen, die Kosten möglichst niedrig zu halten, denn schließlich ist das ja auch für billige TFTs gedacht, deren Preis das ganze nicht sprechen sollte. Das hieße also Bestellung in Fernost mit entsprechenden Wartezeiten. Möglicher Weise macht es auch Sinn, den LM1881 dort gesammelt zu bestellen, das mach ihn locker um Faktor 10 billiger.


    Wäre es bei großem Interesse möglicher Weise besser, erst mal eine kleine Stückzahl für "Beta-Tester" zu machen? Fragen über Fragen...

    Vielen Dank schon mal für Euer Feedback Leute!


    Ich nehme mit, daß der C64 keine Probleme kriegen sollte, das ist ja die Hauptsache. Und da auch sonst entsetzte Aufschreie ausgeblieben sind, gehe ich davon aus, daß ich zumindest keinen totalen Bockmist gebaut habe. ;-)


    Hat noch jemand konstruktive Kritik zum Rest des Aufbaus? Zur Dimensionierung der Widerstände oder zur Wahl der FETs?


    Sonst würde ich mich dran machen und mir ein kleines Board entwerfen, das dann gleich noch mit in das Gehäuse des Display paßt.

    Genug Off-Topic, welche Mosfets hast Du denn verwendet?

    Was ich so da hatte und was ins Brett paßte: 2N7000. Aber auch da lasse ich mich gerne belehren!


    Momentan denke ich über eine SMD-Variante nach, die ich mit in das Gehäuse des TFT packen könnte. Da würde ich es wohl mit BSS138 versuchen.

    Ich habe mir vor einiger Zeit in der Bucht für 13€ ein Billigst-TFT bestellt, das ich nutzen wollte, um die Video-Ausgabe der alten Hardware "auf die Schnelle" direkt auf der Werkbank testen zu können:



    Als ich das Teil dann nach ein paar Wochen in der Hand hatte, mußte ich feststellen, daß ich beim Anschluß an den C64 kein Bild bekomme, nur ein sporadisches Flackern. Allzu sehr hat mich das dann auch nicht überrascht. Bei der darauffolgenden Recherche bin ich auf diese Seite gestoßen. Dort wird ein sehr ähnliches Problem beschrieben und sehr vage eine etwas abenteuerliche Lösung. Diese Lösung habe ich versucht zu vereinfachen und dabei vermutlich noch abenteuerlicher gemacht (weitere Details hier):



    Nachdem nun wieder ein paar Wochen zur Beschaffung der nötigen Teile vergangen sind, habe ich das ganze letzte Nacht auf einem Steckbrett zusammengeschustert und zu meiner Überraschung tatsächlich ein dem Preis des TFT angemessenes Bild erhalten:



    Aber irgendwie ging mir das verdächtig einfach, daher hätte ich gerne Eure Meinung dazu gehört. Insbesondere zu der Frage, ob ich mit dieser Konstruktion meine Video-Quelle gefährde. Wenn nein, kann ich ja nicht ganz falsch liegen (siehe Bild ;) ), aber es gibt bestimmt noch Raum für weitere Verbesserung/Vereinfachung - besonders wo die Elektronik ins analoge abdriftet tue ich mich schwer und hab noch viel zu lernen. Also, laßt hören aber seid bitte nicht allzu streng mit mir... :nixwiss:

    Nope, funktioniert nicht bei JLCPCB. Sobald ich GERMANY auswähle kommen 22$ Versand oben drauf

    Hattest Du die Bestellung schon im Warenkorb? Mir wurden die Versandkosten auch erst im Verlaufe des Bestellvorgangs quasi als Gutschein wieder abgezogen. Am Ende habe ich dann 1,76€ bezahlt. Andererseits ist das nun auch schon 10 Tage her, vielleicht ist die Aktion schon wieder beendet?

    Zwischen den Glaubenskriegen hier mal wieder ein kleiner Tipp für die Sparfüchse unter den Bastlern. Der Board-Hersteller "JLCPCB" hat derzeit ein Angebot, daß sogar "AllPCB" noch in den Schatten stellt. Für nur $2 bekommt man dort derzeit 10 Platinen inklusive Express-Versand per DHL, und dabei sind sogar Dateien mit Board-Panels erlaubt wie diese hier:



    Von Bestellung bis Lieferung unter 1 Woche. Allerdings habe ich leider erst zu spät bemerkt, daß der Versand nur bei der ersten Bestellung inklusive ist. Sonst hätte ich vielleicht doch etwas anderes bestellt als diese 80 OpenC64Saver Platinen, von denen ich eigentlich nur 2 brauche...

    Was kostet den deine Variante, und kann man das irgendwo so als Bausatz bestellen?

    Einen vollständige Bausatz gibt es bisher nicht, das ganze ist ja auch noch ganz frisch. Sollte genügend Interesse bestehen, ließe sich da bestimmt etwas organisieren. Aktuell arbeite ich noch an der Version 1.1 des Boards, im ersten Anlauf haben sich ein paar Fehler eingeschlichen.


    Die genauen Kosten sind nicht so leicht anzugeben. Mein Layout ist ja sehr modular aufgebaut. Es kommt also darauf an, was man alles bestücken möchte und dann natürlich auch, wo und wieviele der Komponenten man bestellt. Für die minimale Ausstattung braucht man eigentlich nur das Board, den Stecker und den WeMos D1 mini. Das sind dann in Summe rund 5€, wenn man mit genügend Geduld in Fernost bestellt. Für die volle Ausstattung ist man vermutlich mit etwa 10€ für alle Teile dabei.

    Was hat gegen den Einsatz der NodeMCU und eines simplen OLED Display gesprochen?

    Die WeMos Module sind kompakter und eher noch preiswerter. Vor allem aber sind sie, und die passenden Shields, besser "normiert". Ich habe hier sehr viele, leicht unterschiedliche ModeMCUs rumliegen. Bei den Displays ähnlich, da unterscheidet sich schon mal die Reihenfolge der Pins...

    Ich habe seit kurzem das Nightly-Build von KiCAD installiert, weil ich den Egale-Import ausprobieren wollte. Die Einstellungen für das Projekt habe ich noch mit der 4.07 gemacht. Die sollten noch stimmen, auch wenn die Dialoge etwas anders aussehen.


    Hast Du den Haken bei "Use Protel filename extensions" gesetzt?


    Ich will noch einmal betonen, daß ich nicht weiß, ob diese Einstellungen wirklich alle notwendig sind. Aber mit den Einstellungen aus meinen Screenshots hat alles funktioniert.

    Nachdem gestern die Boards eingetroffen sind, habe ich gerade meine erste, eigene Variante des Alwyz-Modems fertiggestellt.



    In der einfachsten Ausbaustufe wird nur das Board, ein Stecker und ein WeMos D1 mini benötigt. Es bietet diverse Ausbaumöglichkeiten, die ich allerdings noch nicht alle testen konnte:

    • Das OLED-Shield ist oben ja schon zu sehen.
    • Platz für eine RGB-LED als Status-Anzeige.
    • Zusätzliche Absicherung durch Diode und Polyfuse.
    • Level-Shifter für alle die das wollen.
    • Alternative, externe Stromversorgung.

    Weitere Details und eine "englische Übersetzung" finden sich hier.