Posts by Asklia

    Habe einen passenden Adapter aus China bereits im Zulauf. User X1541 und ich haben etwas weiter oben danach gegooglet und einen preiswerten geordert. Also kein Vermögen ausgeben ;-)


    Einen GALEP-5 hätte ich hier; der kann diese brennen. Brauche aber noch ein paar von den kleinen 25L4006. X1541 meint, die kosten nur 0.50 Teuro.


    Vielleicht mache ich am WE ein paar Bilder zum Einbau des Displays.


    Gruss

    Morgen machte ich noch einen Versuch, das Flash auszulöten und programmieren mit dem 123 Patch.


    Hattest Du schon Erfolg mit dem ablöten des kleinen 25L4006? Wie machst Du das denn: Eine Entlötstation mit Vakuumpumpe ist bei SMDs ja eher weniger geeignet, die passt wohl nur für bedrahtete Bauteile. Ganz feine Entlötlitze?


    Gruss

    8 MHz Z80 Karte für den C64 (Artikel von mir in der ct; hier ist ein Thread dazu). Die 80 Zeichenkarte aus dem damaligen Projekt ebenfalls.


    CP/M für C64


    Will beides "aufsteckbar" auf den 50-poligen internen SX Bus layoutet haben; evtl sogar auf eine Platine. Vor dem 50-pol Anschluss dann das Layout für den klassischen 44-pol Anschluss. Für SX-interne Verwendung abtrennbar.


    Als kleine Miniprojekt dazu auch die SX-Expansionport-Adapterplatine kleiner fertigen lassen, damit man auch zwei Floppies UND die Adapterplatine hineinbekommt.

    für den Einbau im den SX-64 könnte ich eine Version machen, die nur SVideo hat... falls gewünscht.



    Ausserordentlich nett :-)


    Hausptsache nach dem Einschalten bleibt das Display auf SV. Aber da dort auch noch eine 80 Zeichenkarte eines Tages das Bild darstellen soll, würde ich mir gerne den CV Eingang erhalten und umschalten können.


    Die Anfragen an die Platinenfirmen für SX Exp-port Adapter, Z80 und 80Chr sind jedenfall raus: Aber zum Layouten von altem Kram haben die keine besondere Lust.


    Dann lass Dich für den Flohmarkt registrieren! Solche Anfragen im Forum sind unerwünscht!



    Ich gelobe Besserung! Habe hier auch kein Angebot erwartet.
    Mir ging es eher um Erfahrungen anderer mit dem Gerät und dem Weg dahin.


    Danke an alle.

    Erstklassige Arbeit!


    Ideal für jeden SX-64 - der hat für den internen Monitor ja ohnehin nur die beiden SV Signale. Nun muss nur noch mein Adapter aus China zum Brennen eintreffen...


    Habt ihr schon eine Quelle für die EEPROMs oder nehmt ihr das auf- und abgelötete?


    Gruss :thumbsup:

    Ich weiss ;)


    Deswegen löte ich die anderen aber trotzdem nicht alle aus :abgelehnt


    Gerade mal wieder den alten Heizungstest gemacht: Zwei 4040 übereinander für zwei stunden laufen alssen: Der Spannungsregler-Kühlkörper wurde wie damals "unanfassbar" heiss. Laufen trotzdem bei de noch :thumbup:

    RAM einlöten tut man nicht, da wartet man bis die bestellten Sockel im Briefkasten sind.


    Wollte ich ja auch. Hatte aber keine 2x9er Sockel. Und soviele Carrier-Fassungen (Sockel ohne Plastik auf einem Blechträger; da könnte man anpassen) habe ich auch nicht mehr. Und Lieferungen ins EU Ausland dauern stets etwas länger.


    Hatte auch Glück: Es war gleich das erste von den beiden fraglichen angezeigten RAMs. Das Sanyo RAM hält bestimmt länger als ich.

    Kleiner Nachtrag: Meine zweite "echte" 4040 Doppelfloppy hat 2114er RAM-Bausteine von MOS; hergestellt 21/81. Da sind auch schon zwei Stück mal vor mehr als 10 Jahren ersetzt worden. Und die MOS RAMs werden noch etwas wärmer als die von National Semiconductor NS. Nur das neue Sanyo Low Power CMOS bleibt kalt :-)

    Das 5x Blinken bezieht sich auf die Zeropage vom Diskcontroller, sprich auf das RAM im 6530. Der Fehler kommt generell, wenn die Buscontroller CPU beim Selbsttest nicht über das Common RAM mit der Diskcontroller CPU kommunizieren kann. Insofern kann es schon gut ein Common RAM Fehler sein.


    Hast Du in einer 8250LP oder SFD1001 eine Adapterplatine unter dem 6530? Diese ersetzt das ROM im 6530 durch ein EPROM. So kann jeder 6530 aus einer Floppy in jeder anderen Floppy laufen, wenn das EPROM passend beschrieben ist. Zum Testen manchmal geschickt.


    Das 5x Blinken bezieht sich auf die Zeropage vom Diskcontroller, sprich auf das RAM im 6530. Der Fehler kommt generell, wenn die Buscontroller CPU beim Selbsttest nicht über das Common RAM mit der Diskcontroller CPU kommunizieren kann. Insofern kann es schon gut ein Common RAM Fehler sein.


    Hast Du in einer 8250LP oder SFD1001 eine Adapterplatine unter dem 6530? Diese ersetzt das ROM im 6530 durch ein EPROM. So kann jeder 6530 aus einer Floppy in jeder anderen Floppy laufen, wenn das EPROM passend beschrieben ist. Zum Testen manchmal geschickt.



    RAM: Ja, das denke ich auch. Der Zeropage Fehler wird gewiss durch daen RAM Fehler ausgelöst.


    6530: Der 6530 einer SFD/8250 ist trotz Adapterplatine aber nicht der gleiche wie in einer 4040: Die CBM Nummer ist eine andere; und der 4040-6530 hat ja kein externes ROM.


    Jaja, suchen bei zimmers.net und als EPROM auf die Adapterplatine zum testen, ich höre es schon... ;)


    Ich löte die RAMs gerade mit feinster Litze aus.

    Man sollte einen 6504 durch einen 6502 ersetzen können wenn man die Pinbelegung anpasst, soll heissen einen Adapter bastelt.


    Darüber habe ich auch schonmal nachgedacht: Die Zeropage und der "untere" 4k Adressraum liegen beim 6502 wie beim 6504 natürlich unten ab 0000h. Beim NMI/RESET/IRQ greift ein 6502 auf die obersten Speicherstellen des 64k Adressraumes zu; ein 6504 aber auf die obersten Speicherstellen des 8k Adressraumes zu. Erfordert also geschicktes Einblenden des ROMs auf 4-8k und 60-64k.


    Und ob die gesamte Programmierung des 6504 nur mit relativen statt absoluten Adressen ausgeführt wurde? Das stele ich mir nicht ganz so einfach vor. Nur die Adressbeinchen offenlassen genügt da sicher nicht.

    Meine heissgeliebte CBM 4040 Doppelfloppy (ist sogar eine 3040 mit den Aufrüst-ROMS einer 4040) gibt neuerdings nur noch einen Blinkcode von sich


    Entweder (selten) 5x oder (meist) 6 x. Gemäss alten Handbüchern ist das entwewder ein Fehler in der Zero-Page oder ein RAM-Fehler.


    Die 6532er sowie den 6502 habe ich bereits kreuzweise mit einer 8250LP gewechselt; an denen lag es nicht (das wäre ja einer der üblichen Fehler). Einen 6504 habe ich natürlich nicht; der ist wohl sehr selten. Der 6530 aus einer 8250 ist nicht nummerngleich und damit tauschkompatibel; der enthält wohl den 8050 Code.


    Vielleicht sind es ja tatsächlich die alten 2114er RAMs (oder eines davon). Kompatible RAMs von Sanyo LC3514L waren noch zu haben; also eine Stange besorgt. Bevor ich nun aber die 8 x 2114 RAMs alle mühsam auslöte, frage ich mal vorsichtg hier, ob jemand einen solchen Fehler an einer 4040 auch schon hatte (und beseitigen konnte).


    Den alten Thread mit dem Wechsel der 6532er Bausteine in einer 4040 mit Dauerblinken habe ich gefunden; dieser Fehler trifft hier (leider) nicht zu.


    Gruss

    Eine UND Schaltung mit zwei Dioden am Handshake-Pin eines 65C22N funktioniert prinzipiell: Jetzt hängt sich der C64/SX ncht gleich weg. Allerdings würden die Datenleitungen wohl eine vergleichbare Schaltung benötigen; und hierbei ist die Richtung ja entscheidend.


    Mein Fazit: Mit 65C22 wird das Parallelkabel mit mehr als einem Laufwerk nicht funktionieren. Morgen wechsle ich mal wieder auf NMOS CHips 6522.

    Hm, ich bin kein Hochfrequenztechniker (ich habe nur Chemie und Physik studiert).


    Da gelten ganz spezielle Regeln (z.B. runde Leiterbahnenführung statt eckige, weil die an den Ecken wegen der grösseren Richtungsänderung eine grössere Beschleunigung der Ladungen und damit höhere Abstrahlung erzeugen).


    Eine Abschirmung stellt natürlich eine parasitäre Kapazität (gemäss dem Modell eines Plattenkondensators) dar. Energie geht verloren; wiederum zuerst bei hohen Frequenzen. Aber die Abschirmung vermindert fremde Einstrahlungen und damit Übersprechen zwischen mehrere Leitungen.