Posts by GMP

    Selbst beim Aufspielen der Firmware musste ich keine Knöpfe drücken. Aber unter bestimmten Bedingungen scheint scheint das wohl trotzdem notwendig zu sein.

    Er flasht nur dann ohne irgendeine Betätigung, wenn der Flashspeicher vorher leer war. Also entweder im Auslieferungszustand oder aber wenn man ihn vorher komplett gelöscht hat.
    Ist bereits eine Firmware installiert, so muss man ihn mittels der Boot-Taste erst in den Flashmodus versetzen.


    VG

    Thomas

    Wir werden in Kürze alle Dokumentationen auf unserer Seite zur Verfügung stellen. Diese sind im Moment noch im Aufbau, bzw. in den letzten Verfeinerungen. Habt bitte noch etwas Geduld.

    Kann man künftige WIC64 so gestalten, dass sie mit unmodifizierten SX-Rechnern klarkommen?

    Leider nein. Über die 5V-Leitung möchte ich nicht gehen. Wenn dann nur über die externe 5V-Einspeisung via Micro-USB.

    Ist ja kein WiC-Fehler.


    VG

    Thomas

    Jetzt muss ich wohl meine Aussage, das der WiC auch nach der 9V-Modifikation nicht funktioniert, revidieren. Hätte ich jetzt nicht gedacht. Dann muss ich mir meinen SX, von dem ich bisher meinte, er wäre okay, wohl mal zur Brust nehmen.
    Für die Verwirrung, die ich gestiftet habe, bitte ich um Entschuldigung.


    VG

    Thomas

    Hallo Puehn,


    ich wohne direkt um die Ecke und könnte Deine Sachen abholen kommen.
    Wäre ebenfalls interessiert, wenn nicht schon an anderen versprochen.


    Edit: Ich sehe gerade, das es hier schon genügend Interessenten gab. Also nur, wenn das von den anderen her okay ist.

    Ich möchte mich jetzt hier nicht vordrängeln.


    VG

    Thomas

    Nicht schlecht, ist das wirklich ein Konstruktionfehler vergleichbar den falsch eingelöteten Kondis beim Amiga oder steckt dahinter ein Sinn. Es macht im Produktionsprozess schon Extraarbeit die Pins zu verlöten. Vielleicht hatte sich Commodore dabei was gedacht

    Ja, in dem Sinne schon, denn im Schaltplan ist diese Verbindung nicht eingezeichnet.

    Hier auch ein schönes Video dazu:


    Aber wenn du das Ding zur Fehleranalyse haben willst, dann schicke ich dir den gerne.

    Sehr sehr gerne. :)

    zur Hardware noch ein interessanter Artikel bezüglich Stromversorgung des ESP:

    https://arduino-hannover.de/20…er-esp32-stromversorgung/


    Ich hatte bisher keine Probleme und vielleicht gibt es die auch gar nicht wegen der Konstellation 9V~ +Brückengleichrichtung :loet

    Den Artikel hatte ich mir schon vor der Entwicklung des WiCs zu Gemüte geführt. Genau deshalb entschied ich mich auch für die 9V-Leitung.

    Die WiCs wurden bei uns tagelang malträtiert und kein einziger ist ausgefallen, geschweige denn ein C64 hat die Grätsche gemacht.

    Ich würde sogar behaupten, dass das der eigentliche Sinn des WiC64 wird 8o !! (oder gedacht war)

    Na ok, zum Chatten und Multiplayer wäre sicher ein zentraler Server sinnvoll

    DerSchatten


    Ja, völlig richtig. Das WiC soll Euren C64 erst einmal primär ins Internet bringen. Von wo Ihr Eure Daten bezieht, soll komplett Euch überlassen werden.

    Ihr könnt z.B. heute schon mit Hilfe eines kleinen Programms irgend ein x-beliebiges Repository (auch in Eurem eigenen Netzwerk) im WiC fest hinterlegen

    und ab sofort ladet Ihr von dort. Ganz einfach. Und wer weiß, vielleicht gibt es ja irgendwann sogar mal einen eigenen Browser dafür.


    Und die Dienste, die zentral bereitgestellt werden, wie z.B. der Chat, die Multiplayer-Area und vieles andere mehr,

    sollen Euch in keinster Weise an irgend etwas binden. Sie stehen auch in keinem direkten Zusammenhang zum WiC.

    Seht das als Angebot. Ob Ihr das Portal zum Einstieg dieser nun nutzt (oder nicht), liegt völlig in Eurer Hand.

    Ihr könnt auch selbst etwas bereitstellen. Rein gar nichts soll Euch davon abhalten.

    Nutzt den WiC für Eure eigenen Projekte. Schreibt Software dafür, macht Euer eigenes Ding damit. Euch steht alles dafür zur Verfügung.

    Das war und ist unser Ziel. Amen. :D


    Einen schönen Abend noch.


    VG

    Thomas

    Das Tool zum Löschen des ESPs (ESP-Eraser) findet Ihr ab sofort hier:

    WiC64 Flashen - ESP32 Flasher

    Aber wenn der Flasher sich nicht mehr mit dem ESP verbinden will, dann hilft das vermutlich wenig oder?

    Der Eraser will sich doch sicher auch mit dem ESP verbinden?

    Das glaube ich aber so nicht. Man muss mit den beiden Tastern auf dem ESP schon ein bisschen herumspielen. Der eine verträgt eher den Druck auf Boot, der andere eher auf EN, bis die Verbindung steht. Da muss schon wirklich was passiert sein, das einer so richtig defekt ist.

    Zu der Sache mit den ESPs. Anscheinend existieren hier welche, die nach kurzer Zeit ihren Dienst quittieren. Die Ursache dafür ist noch nicht ganz geklärt. Anscheinend liegt es aber am Flashspeicher, der vor dem Aufspielen der WiC-Firmware nicht ganz sauber war. Im Falle von TurboMicha habe ich den ESP zuerst komplett gelöscht und im Anschluss daran die FW noch einmal neu geflasht. Danach hat er sich völlig normal verhalten.
    Zum genauen Löschvorgang werde ich gleich noch was schreiben.

    VG

    Thomas

    Das Tool zum Löschen des ESPs (ESP-Eraser) findet Ihr ab sofort hier:

    WiC64 Flashen - ESP32 Flasher