Posts by Oldschoolpeter

    Läuft es denn mit ner anderen ASSY 250407? Nicht das die U II+ Probleme mit bestimmten Board ASSYs hat. An der IRQ Leitung scheinen ja nur die CPU, CIAs, der Cartridgeport und der VIC zu hängen

    die somit allesamt als potentielle Fehlerquellen in Frage kämen. Eventuell mal nen Kreuztausch (CIAs, VIC, CPU) mit ner funktionierenden 250407 machen.

    Ich glaube es wär sinnvoll mal mit nem Oszilloskop zu prüfen wie das Signal auf der IRQ Leitung mit und ohne U II+ ausschaut. Ansonsten könnte man schauen ob man bei der U II+ noch irgendwelche

    Timings verstellen kann. Zur 250407 fällt mir noch ein das da manchmal gern die Elkos im VIC Käfig aufs Board pissen.

    Hab auch grad das Problem das der Launcher nur die Versionsnummer anzeigt und die obere LED am WIC-64 blinkt.

    Auf dem Display zählt ein Zähler paralell dazu immer weiter hoch. Ich nehme an das grad der WIC Server nicht erreichbar

    ist und das erfolglose Verbindungsversuche sind.

    Ich bin kein Hardwareguru und hatte dieses Fehlerbild auch noch nicht aber das es die PLA ist halte ich eher für unwahrscheinlich da die laut Schaltplan nix mit IRQ und co. zu tun hat. Abgesehen davon würde die miit großer Wahrscheinlichkeit eher aussteigen wenn sie warm wird und nicht andersrum. Gut zu wissen wäre ob schon die Spannungen auf dem Board gemessen und für gut befunden worden sind, bzw. ob sich mit einem anderen Netzteil das Fehlerbild ändert. Welche Demos sind es denn genau die zu schnell laufen?. Aber ein NTSC 64er ist es nicht zufällig? Da würden ja Demos auch eventuell aus dem Takt kommen ;-). Ein festgelötetes Abschirmblech wäre ein Zeichen das darauf hindeuten könnte das es ein US Gerät ist da die dort drüben damals recht streng waren was die Abschirmung von Geräten betrifft.

    Telespielator: Ich weiß aus dem Stehgreif auch nicht welche Spiele man mit einem Lightpen steuern kann, deswegen habe ich einfach
    Google bemüht und als Beispiel einen Link zu einem YouTube Video hier gepostet das zum Thema passt.

    Leider war ich damals nicht so schlau in meinen Post mit hineinzuschreiben um welches Spiel es sich handelt. Da das Video nicht mehr

    verfügbar ist und mittlerweile über vier Jahre vergangen sind weiß ich leider auch nicht mehr um welches Spiel es in dem Video ging.

    Merlin_The7thSign :


    Hab zwischenzeitlich auch noch mal die Version Von Giana Sisters herausgekramt die ich von früher kenne

    und festgestellt das dieser Sound dort garnicht vorhanden ist, das war mir garnicht mehr so bewußt

    da es ja eher ein kleines nebensächliches Detail ist das einem beim Spielen gar nicht so auffällt.

    Die Version die ich damals von nem Kumpel bekommen habe dürfte diese hier gewesen sein: CSDB-Link

    In dem Fall die Version ohne Pic, lustigerweise auch mit von einer "Wanderer Group" gecrackt bzw. gespreadet.

    Jo, da läuft n Timer. Somit scheint das der Speedrun Modus zu sein. Wenn ich TheRealWanderer richtig verstehe scheint

    der Speedrun Modus bei der WIC-64 Version dauerhaft automatisch aktiv und nicht abwählbar zu sein. Alternativ könnte

    man ne entsprechende Option im Titelscreen oder im Pausenmenü vorsehen oder ne alternative Version die dann halt im

    Games Menu des WIC Portals auswählbar ist

    Hab das Spiel vorhin mal kurz angetestet und finde es recht gelungen, vom Gefühl her ist die Steuerung präziser geworden und somit

    das Spiel auch für nicht so geübte Spieler wie mich besser spielbar. Mir ist allerdings aufgefallen das der Soundeffekt wenn man

    gegen einen Extrablock springt und das Extra dann "herausspringt" irgendwie kaputt klingt, das kann natürlich auch daran liegen das

    ich nen neuen SID (8580) und keinen alten (6581) drin habe oder daran das ein StereoInSID im double mono Betrieb verbaut ist.

    Viel gravierender finde ich dagegen das der gute alte Schummelcode "ARMIN" nicht mehr funktioniert und zumindest der Warpblock

    vom 3 ins 6te Level auch nichts bewirkt. Wenn man gegen den Warpblock springt erscheint dieser zwar aber nichts weiter

    geschieht. Normalerweise müsste ja die Levelmusik stoppen, die Warp Muisik abspielen und das Game weiter ins 6te Level wechseln.


    Wenn ich da jetzt wirklich den richtigen Schaltplan gefunden habe ist diese Buchse dafür da um Kassetten mit einem Rekorder

    der einen DIN Anschluß hat zu kopieren. Jedenfalls ist die Buchse wohl an der "READ" Leitung der Datasette angelötet.


    Natürlich kann man da auch einfach nur nen Verstärker oder eine Anlage, die ne DIN Buchse hat, dort anschließen und einfach nur mithören ;-)

    Wie Ebster schon sagte wäre es wohl die sinnvollste und auch einfachste Lösung für die Stereo SID Files eine eigene Playlist zu erstellen.

    Dann liegt es in der Eigenverantwortung des einzelnen Users dafür zu sorgen das die Stereo Files ordnungsgemäß abgespielt werden können,

    da durch die Erstellung einer separaten Playlist die Vorraussetzung dafür geschaffen worden ist.

    InsertDisk2: Alleine ne einfache "Stereoanzeige" würde schon ausreichen da man dann zumindest weiß warum das SID File so "kaputt" klingt.

    Da ja je nach verwendeter "Stereo SID" Hardware die Umschaltung der Adresse für den zweiten SID unterschiedlich realisiert wird gibt es ja keine

    "Patentlösung" mit der man in jedem Fall eine Problemfreie Umschaltung im laufenden Betrieb gewährleisten kann, da müssten ja dann die betroffenen

    User oder die Entwickler der jeweiligen Hardware eine für den jeweiligen Fall passende Lösung finden.

    Ich habe wie gesagt die Widerstände nachgerüstet und mir eine kleine Schaltung zusammengefrickelt die aus einem Taster, einem 4017 IC und ein paar Reed Relais

    besteht die dann die Verbindungen die sonst durch Jumper am StereoInSID eingestellt werden über die Relaiskontakte herstellt.

    -trb- : In dem 64er den ich als "SID Player" nutze Habe ich nen StereoInSID drin, dort habe ich für den zweiten SID an der /CS

    Leitung einen Pullup und an der R/W Leitung einen Pulldown Widerstand nachgerüstet da der 64er ansonsten abstürzt wenn man

    die Adresse des 2ten SID im Betrieb umschaltet. Alleine schon weil das bestimmt nicht jeder nachgerüstet hat wäre solch eine Anzeige

    sinnvoll.

    InsertDisk2: Eines davon war das hier: https://csdb.dk/sid/?id=44985

    Bei dem SID wo es mir ursprünglich aufgefallen ist bin ich mir grad nicht so sicher,

    Ich glaube das war Hexadecimal von Dane kann allerdings sein das ich mich da irre.

    Ich weiß bloß das SIDs die mehr als einen SID unterstützen meist einen entsprechenden

    Vermerk im Filenamen haben (2SID, 3SID...) ob da auch etwas im Fileheader vermerkt ist

    weiß ich leider auch nicht, allerdings zeigt soweit ich weiß der SID Player der Ultimate 1541 II+

    an wenn ein SID File mehrere SIDs unterstützt und auf welchen Adressen diese liegen.

    Bin seit kurzem auch WIC-64 Besitzer und habe das SID-Radio auch schon mal ne ganze Weile nebenher laufen lassen.

    Einige SIDs klangen etwas kaputt bis ich dann mal auf die Idee gekommen bin auf Stereobetrieb umzuschalten.

    Also wäre es sinnvoll sowas wie ne "Stereoanzeige" mit einzubauen damit man weiß das es sich um ein Stereo SID File handelt.

    Ramirez : Sind das die Richtigen Widerstandsnetzwerke? Das sieht für mich nach einem aus bei dem die Widerstände einen gemeinsamen Anschluß haben,

    soweit ich das im Easyflash Schaltplan erkennen kann wird aber eines mit "einzelnen" Widerständen benötigt.

    Ef1snippet.jpg


    Ich kann das auf dem Bild nicht richtig erkennen aber kann es sein das es keine 100 Ohm (101) sondern 100k Ohm (104) Widerstandsnetzwerke sind die du da drauf hast?