Posts by echo

    Es wäre aber hilfreich, sich nicht immer zwischendurch auf das einzige Thema zurückziehen zu wollen, dass gar nicht diskutiert werden will und muss: Linux auf dem Server. Da ist Linux auf Platz 1 (wurde, glaube ich, noch nicht erwähnt, daher übernehme ich das jetzt mal). Und das sicherlich mit was? Mit Recht!


    Du vergisst Router und Switche und weitere Netz-Devices und IOT-Geräte.
    Alles Linux. Einige wenige eines der BSD-Linien und nahezu vernachlässigbare Menge an Windows (in diesem Segment).

    Windows ist nur auf dem Client eine ernstzunehmende Größe. Wobei ich in großen Teilen das Userfeeling unterm Mac besser fand.

    Man-Pages sind ja wohl eher was für Leute, die auf der Shell was erledigen wollen.

    Habe noch nie die Man für ein Programm lesen müssen, um eine Gui zu bedienen.


    So müsste man, wen dann die Shell-Programme mit den CMD oder Power-Shell Programmen und derer Hilfe vergleichen, wenn man es denn irgendwie gerecht machen wollen würde.

    Gibts hier eine Fan der Doku vom MS Power-Shell Befehlen bzw. den CMD-Befehlen?


    Mir Persönlich fehlen die Beispiele in den Man-Pages ebenso. An einigen wenigen Stellen findet man doch welche, aber sie sind tatsächlich zu selten. Komme selbst aus dem HPUX und dort waren die Man-Pages deutlich besser. Leider investiert GNU dort einfach zu wenig rein, was sehr schade ist. Eine gute Doku kann auch ein schweres Programm bedienbar erscheinen.


    Da ich den Slot mittlerweile festgeklebt habe, ist ein Austausch eher unerwünscht.
    Ohne das Festkleben hat sich der Sockel immer wieder beim einschieben einer Catridge nach oben gebogen. Ich befürchtete, dass irgendwann eine Lötstelle bricht oder gar eine der Beine.


    Übrigens, die Beine des Slots sind deutlich dünner, als die des original Commodore Slots auf meinem C64 Brotkasten Edition. Ich tippe mal, dass die Duschkontaktierungen kleiner sind und der alte Slot dort nicht passt. Oder wenn, dann nur ganz knapp.

    bis auf PA0 und PA1, die anscheinend nicht genutzt werden, konnte ich alle Leitungen verfolgen und als funktionsfähig zum Sockel zuordnen.

    Natürlich werden die verwendet, die schalten die VIC-Bank um. Sie gehen auf den 74LS258.

    Für dieses Problem (Black Screen) spielen sie aber keine Rolle.

    (Es ist ja mittlerweile auch klar, wo die Ursache liegt.)

    Oh, danke für den Hinweis.

    Ich hatte diese Leitungen im C64 Schaltplan nicht gefunden und dachte, die wären über.

    hm, da berühren sich tatsächlich mehrere gegenüberliegende Zungen.

    Anscheinend ist der Modulslott von Jens eine Enttäuschung. Zuerst nicht festgeklebt und nun so was.


    Ich hoffe ich bekomme die Zungen irgendwie wieder in eine Position fixiert, wo der C64 wieder normal läuft.


    Danke für eure Hilfe.

    Sockeltausch und Kühlkörper.

    Hat er denn danach noch funktioniert?

    Der Umbau ist schon Jahre her und ich bin der Meinung, dass er danach sauber funktioniert hat. Auch das Check64-Modul habe ich an zwei C64 getestet. Aber passieren kann ja immer was.

    Ich hab bereits den CIA#2 und den SID-Sockel durch gemessen bis auf PA0 und PA1, die anscheinend nicht genutzt werden, konnte ich alle Leitungen verfolgen und als funktionsfähig zum Sockel zuordnen.

    Was meinst du denn mit "bootet nicht"? Schwarzer Bildschirm oder blauer? Keine Schrift, kein Cursor?

    Der Screen bleibt einfach dunkel. Keine Farbe, kein Muster, einfach so als wenn du ihn gar nicht eingeschaltet hast.

    1. Sind die Aufnahmen von Check64 mit Harness ?

    Ohne Harness sind sie Fehler auf dem Serial Port/Control Port nämlich normal.

    Was bedeutet Harness?

    2. Betreibst du den C64 mit Softkernal über die Ultimate?

    Dann würde ich vermuten das der C64 nicht auf das eingebaute Kernal zugreifen kann.

    Ja, ich nutze die Überlagerung des Kernel-Roms durch die Ultimate.

    Wenn ich dieses Feature jedoch in der Ultimate ausschalte kommt dann der normale C64 Boot-Screen.


    Ich könnte das normale Boot-Rom des C64Reloaded auch auslesen. Hardware habe ich dafür, aber ich weiß nicht wie das richtig aussehen sollte. Immerhin kann man dort zwei Kernals unterbringen.


    PS:

    Auf http://wiki.icomp.de/wiki/C64_…_Kernal_and_character_set findet sich die reihen folge im Eprom.


    Address rangecontents
    $0000-$0ffffirst character set
    $1000-$1fffsecond character set
    $2000-$3fffBasic ROM
    $4000-$5ffffirst Kernal ROM
    $6000-$7fffsecond Kernal ROM


    Kann ich dazu die Roms aus dem Vice-Paket nehmen, diese mit "copy /b chargen + basic + kernal + kernal c64r.rom" zu einem rom zusammenfassen und den inhalt des Roms vergleichen?

    Ein Chargen2 gibt es leider in dem Ordner von Vice nicht. Ich vermute das beide Chars dort schon zusammengefasst sind?


    PPS:

    das Char2 ist anscheinend tatsächlich ein alternatives Char und nicht wie ich zunächst gedacht hatte, die groß und Kleinschreibung ...

    Quote
    Punkt 1: Die Platinenversion ist sehr Wichtig für korrekte Hilfe. Bei Commodore Platinen steht meist ASSY gefolgt von einer Nummer drauf, die wollen wir wissen.

    C64 Reloaded MK 1

    Quote
    Punkt 2: Ist das Gerät modifiziert oder noch Orginal? eventuell andere ROM´s drin?

    Sockeltausch und Kühlkörper. Ansonsten unverändert

    Quote
    Punkt 3: Ist das Netzteil Orginal oder schon mal durch ein anderes ersetzt worden?

    Das Netzteil stammt von einem alten Monitor. Der Reloaded hat ja nur ein 12V Eingang.

    Quote
    Punkt 4: Tritt der Fehler nur auf wenn Zusatzhardware angeschlossen ist?

    Der Fehler tritt nur auf, wenn ich die Ultimate abziehe. Steckt sie drauf scheint der C64R normal zu arbeiten

    Quote
    Punkt 5: Tritt das Problem sporadisch auf oder ständig?

    Fehler ist reproduzierbar

    Quote
    Punkt 6: Werden irgendwelche Chips besonders heiss? so das man sich fast die Finger dran verbrennt?

    Ist mir nicht aufgefallen.

    Quote
    Punkt 7: Hat der Fragesteller ein Multimeter und weiss wie das benutzt wird?

    Multimeter ist vorhanden.

    Quote
    Punkt 8: Hat der Fragesteller irgendwelche Erfahrungen im Löten? wenn nicht gleich sagen.

    Lötkenntnis sind vorhanden.

    Quote
    Nachträge: Punkt 9: Reagieren Laufwerke korrekt auf Ladebefehle, mit LED-Blinken oder gar nicht?

    Programme ließen sich normal von der Ultimate laden.


    Bei einem Test mit dem Check64 erhalte ich zwei unterschiedliche Fehlerbilder:

    Auf dem ersten Bild wird der "Control Port" und "6581 U18" als BAD markiert


    Auf dem zweiten Bild wird zusätzlich noch "Serial Port" und "6526 U2" als BAD markiert.


    Jemand ne Idee wie ich vorgehen kann?

    Bei einer USB-Platte wäre das erste, dass man die ausbaut und in den Rechner verpflanzt.

    Ist dies nicht möglich, da Laptop würde ich zu nem alternativen USB-Controler greifen.


    Zweites nicht rumreparieren auf der bisherigen Platte. Zu groß das Risiko, dass du es nur verschlimmerst. Nutze tools wie ddrescue, um die Platte zu clonen. Dieses Image anschließend auf dem Rechner Kopieren und auf dieser Kopie kannst du deine Rettungsversuche unternehmen.


    Drittens finde ich nichts ob es eine SSD oder eine echte Hard Disk ist. Ist der defekt auf der ersteren ist vermutlich das Teil nur noch Schrott. Rettungsversuche sind im Privatem kaum möglich, da zu komplex.


    Aber wenn du die Daten eh hast und dies kein Testlauf, um es mal zu wissen ist, würde ich die Daten von deiner Datenquelle nochmals auf die Platte schaufeln. Alles andere dürfte länger dauern und ungewiss sein. Dennoch solltest du die Platte mal ordentlich durchtesten. Da sie bereits einmal ihre Unzuverlässig bewiesen hat, würde ich dem Gespann USB-Controller und Festplatte nicht ohne weiteres trauen.

    Dagegen helfen nur Tüten, in die die Originalteile früher verpackt waren. Dann kommt das Plastik nicht mit Weichmachern in Berührung.

    Ob Styropor da eine ähnliche negative Eigenschaft aufweist, ist mir unbekannt.

    Ich würd die original Folien dafür verwenden oder als Ersatz ne Folie aus Polyethylen (PE) oder Polyester (PS). Beide sind Säurefrei und Weichmacherfrei.

    Ersterer reagiert mit Licht und wird dann unschön. Letzterer ist auf Knicke empfindlich.

    Aber da du das Zeug darin lagern willst und nicht ausstellen, dürfte beides unwichtig sein.


    PS dürfte nicht in jedem Falle ESD-Komform sein. Die meisten ESD-Folien sind jedoch aus PE, daher würde ich eher dazu tendieren.

    Es gab noch das Produkt https://de.wikipedia.org/wiki/Channel_Videodat , wo man die Austastlücke des TVs als Daten-Medium missbrauchte.

    Das ganze wurde gerne beim WDR-Computer-Club benutzt und dort wurde auch der Sichtbare Bereich mit genutzt. Daher gabs dort immer im oberen Bild so sonderliches gekrissel.


    Ich vermute mal, dass alte VHS-Aufnahme diesen Daten-Stream mit gesichert haben ...


    Und dann gabs noch Packet-Radio. Hiermit konnte man 9600Baut/s über CB-Funk/Amateur-Funk übertragen. Dazu gibts spezielle Modems, die man heute noch nutzen könnte.

    https://de.wikipedia.org/wiki/Packet_Radio