Posts by Emwee

    Habe alle Kondensatoren usw. nochmal neu behandelt - war nat. dumm, hätte vorher Fotos machen sollen... sieht alles nicht so schön aus mit den Kleckschen Lötzinn nun - aber in Summe ist alles beim alten geblieben.


    Bliebe noch emulaThor dein Vorschlag den C10 zu entfernen, das dann morgen...

    Motto in diesem Thread hier ist eigentlich - Frenetic frei zitiert: "Wir haben hier noch jedes Sidekick zum Laufen gebracht." - Deshalb: Aufgeben ist hier eigentlich nicht vorgesehen! ;)


    Wenn Du trotz Kapitulation nochmal rangehen willst, dann würde ich mal - frag mich nicht, warum - den Kondensator C10 entfernen am Rand und danach nochmal testen.

    Okay okay ;)

    Gut, das kann ich gerne versuchen - zu verlieren habe ich ja nichts :D



    R6 und einige von den Kondensatoren scheinen wenig Zinn am Beinchen zu haben.

    Kannst Du schärfere Bilder machen ?:search:

    Ich kann es morgen mal versuchen, klar... ggfs. nat. auch nochmal bei denen nacharbeiten.


    Überlege gerade mir - für eine andere Sache - einen Pi4 zu holen, zum quertesten kann ich den nicht fürs Sidekick nehmen, oder?

    Du hast es ja nicht selbst bestückt, sondern jemand hat es für Dich gelötet, sagst Du. Derjenige könnte Dir doch evtl. helfen, wenn Du selbst nicht nochmal sorgfältig löten willst?

    Ich bin ja nochmal selber drüber gegangen, einmal ja noch ohne Flussmittel und dann noch einmal mit. Ist halt Pech, passiert schonmal.

    Ich halte einfach die Augen offen wenn ggfs. mal die neue Version auftaucht und mache einen neuen Anlauf, der Raspberry muß ja beschäftigt werden ;)


    Danke dir/euch für eure Hilfe bei der Fehlersuche! :)

    Ich werde wohl auch noch eine RGB cOpperdragon Karte für den ATX64 machen. Dann wird der VIC II Chip auf die Karte gesteckt :-) Für die Rear-Steck-Platinen ist die cOpperdragon Platine zu groß.

    Du machst mich schwach und glücklich zugleich :D


    D.h. ich schaue bei Gelegenheit nach einer weiteren c0pperdragon Karte ;) - die aktuelle ist ja fürs Tuning-Board reserviert :D

    Alles was mit Akku und Ladeelektronik zu tun hat, ist meine Baustelle...


    Denke aktuell an das Modul:

    https://www.ebay.de/itm/USB-Li…r%3D1&hash=item217fad9ba0

    Da kann man aus einer Zelle 12V erzeugen, ist war nicht wirklich Effizient, 3V Boost auf 12V, dann Step Down auf 5V, für den Sid wieder Boost auf 9V...
    Direkt auf 5V Boosten und nur aus 5V 9V oder 12V für den SID machen würde viel energie sparen.

    Danke für deine Empfehlung - werde ich mir beides mal heranholen :) (und...falls ich "lost" bin nochmal schreien ;) )

    Vieles funktioniert ja bei Deinem Sidekick, aber nicht immer. Selbst beim überwiegend roten NeoRAM-Test sind auch grüne Blocks dabei, dort gab es keine Fehler. Nun ist für mich die Frage - warum funktioniert es zu bestimmten Zeitpunkten fehlerfrei?


    Du hast ja einen Raspberry Pi 3B+ dran, und der ist ein paar Gramm schwerer als ein 3A+. Wie stabilisierst Du Dein Sidekick v0.3 mit dem großen Raspi, so dass er nicht nach hinten/unten kippt? Stützt Du das Sidekick ab, wenn es im Expansionport steckt?

    Ich habe unterschiedliche Varianten bzgl. des Abstützens gemacht - beim normalen "liegenden" Einsatz erstmal eine Schachtel untergelegt, die das ganze stützt.
    Ansonten habe ich noch einen 90° Expansionsport-Adapter genutzt um das ganze "stehend" laufen zu lassen.

    Hast Du noch einen zweiten Raspberry Pi 3B+ / 3A+ zum Quertauschen?

    Hast Du eine andere SD-Karte zum Tauschen?

    Nein, ich habe keinen weiteren Pi3b+/3a+ - habe mir diesen extra neu für Sidekick gekauft.
    SD-Karte habe ich schon zwei andere probiert, es ändert sich nichts.

    Hast Du auf der SD-Karte die neueste Software von Frenetic drauf und ist die Konfiguration auf der SD-Karte irgendwie abgeändert worden von Dir?

    Ich habe mir das Archiv "Sidekick_64_and_264_v0.45a.zip" geladen und auf der SD.
    Änderungen gab es nur um das korrekte Display einzustellen, sonst nichts.

    Was für eine Stromversorgung hast Du am Raspberry Pi?

    Das Netzteil: https://www.amazon.de/gp/produ…o_dt_b_asin_title_o03_s00 ist bei mir im Einsatz.

    Bin über alle Lötstellen (ohne Flussmittel, aber kann gerne nochmal mit drüber)... Das einzige was ich jetzt bei der Odie FM sehe ist die Meldung "FM Jam not detected", obwohl SID/FM aktiv ist.


    Edit:

    Bin nochmal mit Flussmittel beigegangen, "das taugt alles nichts": Problem bleibt bestehen.


    Was ich vorher nicht erwähnt hatte, aber glaube ich bei dem ganzen auch gar keinen Unterschied mehr macht:

    Bin ich im Sidekick-Menu und scrolle z.B. durch die PRGs ist zwischendurch auch mal das Bild "schwarz", dann muß ich weiterscrollen oder eine (blinde) Auswahl machen und das SideKick-Menu/Übersicht der PRGs kommt wieder.
    Das ganze passiert auch dann und wann wenn ich einfach in die Settings will (F5), dann muß ich wieder F5 (oder eine andere Taste) drücken und der Text kommt zurück.

    Hast Du es selbst gelötet?

    Steckt ein OLED-Display dran bei Dir? Funktioniert das?

    Funktionieren die 4 LEDs (Knightrider-Effekt)?

    Beim Überprüfen der Lötstellen auch auf die 2x20er-Leiste achten, wo der Raspi draufsteckt.

    Nein, das habe ich nicht gelötet - ich trau mich selber nicht an SMD-Sachen ran.

    Oled ist eingesteckt und Funktioniert, zeigt auch entsprechend das SideKick-Logo oder wenn die SID-Emu läuft da das passende Bild/die passende Animation an.

    Den Knightrider-Effekt habe ich, ja.

    Also von den ICs die Lötstellen nachgehen... na das wird ja ein Spaß :D Ich glaube da schaue ich ggfs. direkt schon nach einem neuen Platinchen *lache*

    Hab diesen mal durchlaufen lassen und du hast Recht, es kommen Fehler - ganz am Ende steht auch dick am Bildschirm "Error":
    georam.jpg

    Und das Problem ist immer gleich? - Also liegt es an den Löststellen auf der Platine.

    Ja, zumindest bei der FM-Emulation klingt es immer gleich, den SID 100% ersetzt habe ich nur bei einem Rechner.

    Das Problem mit der Reaktionsmüdigkeit beim Menu ist immer bei allen.

    Holst Du Dir den Sound über ein Audiokabel, das am Raspberry Pi an die Miniklinkenbuchse angeschlossen ist?

    Ja, hatte da Kopfhörer angeschlossen und für diese Aufnahme halt dann den Sound vom Raspi in die Capture-Karte.

    Ich habe ein zwei/drei Fragen (Probleme?) mit dem Sidekick:


    - wenn ich den SID aus dem C64 nehme und den SID-Pin vom SideKick mit dem C64 verbinde kann ich die SID-Emulation auswählen, allerdings ist der Sound selbst mit bestem Willen nicht als gut zu empfinden (siehe/höre Video im Anhang, Ton kommt grob ab Sekunde 17, der Rest ist nur damit ihr seht was ich lade, bzw. am Ende: wie die SID-Einstellungen aussehen). Habt ihr da eine Idee woran das liegen könnte?

    - das Navigieren ist ein Geduldsspiel: mal wird ein Tastendruck erkannt, mal nicht... aber öfters wird er nicht registriert als das er registriert wird (im C64-Startbild funktioniert alles bestens, betrifft nur wenn ich in der Oberfläche vom Sidekick bin) - worin mag das begründet sein?

    - ich meine gelesen zu haben, aber da kann ich mich täuschen, das man einen weiteren SID auch emulieren kann wenn ein Originaler SID im Rechner ist? Wenn ja... wie? Wenn nein, verdammt, war wohl ein Tagtraum ;)


    SideKick ist V0.3, Raspberry ein 3B+, Saft kommt über ein extra Netzteil.


    Video mit dem Soundproblem:

    [External Media: https://youtu.be/8stVPY9r6JI]


    HDMI-Ausgabe vom Raspi, wenn ich ihn einschalte:
    IMG_0355.jpeg

    Danke :)

    Der Handheld wird jetzt vermutlich meine nächste Zusammenbau-Aktion.


    Hat sich da schon irgendwas als gute Lösung für Akku/Ladeelektronik herauskristallisiert? Ich gestehe das ich da ja null bis gar keine Ahnung von habe...

    Zu lange gewartet, kann den Beitrag nicht mehr bearbeiten...


    :P Ich bin bereit für die erste/nächste "Erweiterung" des Tuning-Boards:

    und es wird noch ein Tuning Board II mit lustigen Features geben :-)

    Öhm! Öhhhm! Da bekomme ich schon direkt wieder nervöse Zuckungen - also plane ich doch schonmal perspektivisch den Kauf von zwei neuen Gehäusen ein (eins... für TuningBoard I und eins für das II. :P ).