Posts by Bulli_

    Ich hab auch seit einigen Tagen einen Ultimate64 Elite und einen FPGASID. Aufgrund der für mich teilweise verwirrenden Angaben wie das nun angeschlossen wird, habe ich Gideon einfach mal angeschrieben.

    Verwirrend war es für mich deshalb, da es ja unterschiedliche Versionen vom Ultimate64 gibt und ich immer nur Teilinformationen gefunden habe, teilweise über mehrere Seiten verstreut, dann war ich auch nicht sicher für welche Version es gemeint war.


    Also, hier die Anleitung von Gideon zum Anschluss eines FPGASID in einem Ultimate64 Elite v 1.4

    • FPGASID second SID raw audio to pin 27 of SID socket 2.
      forum64.de/wcf/index.php?attachment/217776/
    • IO1 (/DE00) to pin 8 of SID socket 2. In this case, you will be able to use the address of Socket 2 secondary address. For this, the configuration of the FPGASID has to be I/O1 / DE00.
    • When you set the configuration of the FPGASID to D420;
      A5 of the FPGASID will be used to address the second SID. You then connect A5 pin of the FPGASID to the left pin of P7. In the configuration you can then select which of the address lines appears at P7: A5, A6, A7, A8 or A9. This means that you do not need to change the configuration of the FPGASID; FPGASID will always 'think' it is A5. The U64 maps it to D420, D440, D480, D500 or D600 rather; depending on the address line you choose in the configuration (and assuming Socket 1 is at D400).
    • So, if you need to map the second SID to DE00, you can only do it with the I/O1 / DE00 pin / wire. If you use "sub-addresses" of the D400-D7FF range, then it is better to use the A5 method.



    Hier wie ich den FPGASID angeschlossen habe


    1 -> Schalter für A oder B

    2 -> nicht angeschlossen

    3 -> Schalter für A oder B

    4 -> nicht angeschlossen

    5 -> nicht angeschlossen

    6 -> Linker Pin von P7

    7 -> nicht angeschlossen

    8 -> SID Sockel Pin 8

    9 -> SID Sockel Pin 27


    pasted-from-clipboard.png

    IMG_0316.jpeg



    Konfiguriert habe ich den FPGASID mit ConfiGuru. Nur so konnte ich Modus A und B einstellen. Die UltiSIDs habe ich ganz deaktiviert.

    Modus A ist bei mir SID1 8580 D400 und SID2 6581 D400.

    Modus B ist bei mir SID1 8580 D400 und SID2 8580 D420.



    "Breakout" Kabel


    Dann gibt es ja noch dieses Anschlusskabel, welches man mit dem FPGASID dazu bestellen kann.

    Hier ist zu beachten, dass beim Ultimate64 der rechte Kanal auf Pin 5 liegt. Das ist bei diesem Kabel der blaue Stecker.

    pasted-from-clipboard.png

    Ich möchte die Tage meinen Commodore 1701 restaurieren. Also zerlegen, komplett reinigen und alle Kondensatoren tauschen. Eine Liste der Kondensatoren hab ich schon gefunden.

    Gerne mach ich auch eine kleine Fotodokumentation. Ob ich sowas tolles hinbekomme wie AREA51HD hier geschrieben hat, weiß ich nicht :)


    Eine Frage habe ich zuvor aber noch zu dem Bild. Es ist auf der rechten Seite eine Farbverschiebung zu sehen. Der 1701 stand jahrelang im Keller links neben einem anderen Bildschirm, und der andere Bildschirm hat die selbe Verfärbung nur auf der linken Seite. Jetzt steht der 1701 nun schon einige Wochen allein, aber die Verfärbung ist immer noch da. Ich habe vermutet, wenn da irgendwas magnetisiert ist, wird das mit der Zeit weg gehen. Was könnte die Ursache für die Farbverschiebung sein, und bekomme ich das wieder weg?


    Zu den 80%: https://www.futurezone.de/digi…e-nur-bis-80-Prozent.html


    Solange da nicht steht: "Dieses iPhone wurde plötzlich heruntergefahren, weil die Batterie nicht...blabla" wie im Bild hier, ist der Akku in Ordnung.


    Wenn das dort steht, ist der Akku zu schach und die CPU wird gedrosselt, damit sie den Akku nicht mehr so stark belastet. Dadurch steigt die Betriebsdauer bis zum nächsten Aufladen, dafür wird das Telefon langsamer.

    Unter "Deaktivieren..." kann man das ausschalten, dann hast du wieder die richtige Performance, es könnte aber wieder zu Neustarts kommen, weil der Akku bei Leistungsspitzen in die Knie geht.

    (Früher hat Apple das gemacht ohne den Nutzer zu informieren, das war damals der ganze Skandal mit "Apple macht alte iPhones absichtlich langsamer" - hatte aber sehr wohl einen technischen, und wie ich finde, sinnvollen hintergrund)


    Das Optimierte Laden solltest du an lassen.


    Tipp: Vielleicht muss das Telefon den Akku neu anlernen. Einfach mal auf 100 % aufladen dann ganz leer werden lassen. Nach ein paar Tagen weiß das iPhone wann du aufstehst, und wird dann vorher auf 100 % aufladen.

    Ich habe den Harness in der Rev 0 und mache die Tests einmal mit und einmal ohne Keyboard Dongle.


    Ich kann die Ergebnisse soweit nachvollziehen, bis auf den Control Port.


    Control Port ohne Keyboard Dongle:

    1. Assy 250469: BAD

    2. Assy 250469: BAD

    3. Assy 250425: BAD

    4. Assy 250407: BAD

    5. C128D: OK

    6. C64 reloaded MK2: BAD


    Kann es sein dass Control Port: BAD angezeigt wird, obwohl die Control Ports eigentlich funktionieren? - Also mit Joysticks. Daher, sie sind nicht 100%ig in Ordnung. Aber im Betrieb fällt es noch nicht auf?

    Sollte der Test beim C64 reloaded mk2 überhaupt funktionieren? Bei dem ergibt der Test auch, dass der PLA defekt wäre.