Posts by Der_Alte_Bastler

    Ich habe dem High Performance M505/2BY aus der 1989er Hercules Prima 5 (ohne S) einen neuen Kolbenring spendiert und das Getriebeöl gewechselt.

    Die Kupplung eingestellt und morgen werde ich den Motor mal saubermachen und dann wieder in das Powermöf einbauen.


    Wenn Wetter ist, werde ich dann wieder mit den wahnsinns 1,2 kW und 28,3 km/h im 2. Gang durch die Straßen fetzen ... :thumbsup:

    2,50€ per Lot (5 pcs/Lot) von Ali letztes Jahr.

    10 Lot bestellt.

    13 waren mit guten Chips bestückt und können (fast) mit Retrotink 2X mithalten.


    Der Rest hat irgendwelche Kopien von Kopien, die ein Chinese schon mal kopiert hat, drin gehabt.

    Da war das Bild Streifensalat mit Artefakten ...


    Die 13 haben wir unter uns aufgeteilt. 2 Schrott sind noch da und den Rest hat der Chinese erstattet und auch die 25€ Porto nach China zurück noch zahlen müssen. (Paypal hat da super geholfen.)

    ShapeOko2 ist ein guter Einstieg.

    GRBL mit dem Arduino CNC Shield zur Steuerung.

    Die größte Herausforderung, zumindest für mich, war es eine Art Tool-Chain aufzusetzen, dass ich meine gezeichneten Ideen "auf die Fresse, äh Fräse" bekomme und reproduzierbar fertigen kann.


    In der Zwischenzeit ruht das Projekt ShapeOko ein wenig, weil wir in der Firma ein Fertigungszentrum haben mit 6 Achsen und 550x550x550 mm Platz für Werkstücke.


    Die ShapeOko2, wie sie seit ca. 6 Monaten hier herumsteht. Zuletzt mit LinuxCNC befeuert.



    Dann kamen gestern die CPU Relocator für den A500 an ...

    Leider nicht die Lösung meines Problem s ...


    Der RGBtoHDMI ist im Weg.

    Ach so ...

    Ganz nebenbei habe ich mir wohl in meinem Amiga 500 in dem ich mit den Kollegen zusammen, deren PiStorm getestet habe, den CPU Sockel kaputtgemacht ...

    Egal was ich reinstecke, ob CPU oder PiStorm, beim Umdrehen desMotherboatd fâllt das Teil wieder raus ..

    Also werde ich da wovhl einen neuen Sockel einbauen müssen.

    Die drei "Testamiga" haben ihren 68000er eiedr und sind zu.

    8 Stk. PiStorm fertiggemacht und in 3 versch. Amiga 500 Rev. 6a getestet.


    Jeder PiStorm hat dabei in der Standardkonfiguration mit Kickstart 3.1 als physisches ROM 30 Minuten diese "Running Cat Demo" laufen lassen ....

    Ich kann diesen Trommeldingsbumsrhytmus aus 3 Lautsprechern in unsyncronisiertem Ablauf nicht mehr hören ..... *GRAUEN*

    Jood wenn Du das Github Repo gecloned hast, dann ist Dein Arbeitsverzeichnis ~/pistomr/

    In dem Verzeichnis solltest Du Dich befinden, wenn Du ./nprog.sh (EMT570) oder ./nprog_240.sh (EMT240) ausführst.

    Ich weß nicht, wie es den Pi eingerichtet habe, aber ich mache vorsichtshalber sudo ./nprog.sh weil ich nicht weiß, ob der user pi die Berechtigungen hat um die gpio zu benutzen.

    In dem einfachen Repo gibt es nur 2 Bitstream im Verzeichnis ./rtl von /home/pi/pistorm/ aus gesehen.


    Wenn so viele Fehlermeldungen kommen, dann kann es auch sein, dass eine Hand voll kalte Lötstellen im Bereich des JTAG am CPLD sind.

    Wenn das Programmieren geklappt hat, einfach mal mit ./build_buptest.sh den ./buptest bauen und laufen lassen ....

    Wenn der keine Meldungen bringt, dann kommuniziert der Pi ohne Fehler mit dem CPLD und der Bitstream ist richtig programmiert.

    Wenn nicht, dann sind es eben noch mehr kalte Lötstellen am CPLD weil die Antworten auf die Fragen von buptest nicht passen.


    Oder Du hast einen Fake CPLD.

    Was Dir aber auch noch passieren kann ... Du hast den EMT240T100 drauf ... Ohne C5N hinten ....

    Dann musst Du den 1,8V Spannungsregler bestücken und ???? weiß ich nicht. Aber dann wird es groovie. Habe ich irgendwoe im discord gelesen.

    Deshalb sind meine PiStorm und die 5 die weggehen mit den C5N am Ende bestückt und haben den buptest 30 Minuten ohne Rückmeldung von Fehlern durchlaufen.

    Wenn ich morgen nach der Frühschicht noch Lust habe, dann löte ich die Stiftleisten auf die Platinen und stecke Eine nach der Anderen zusammen mit einem Raspi 3A+ in den Rev. 6a Amiga 500 zum Test.

    Nach Erfolg dann in ein Versandbehältnis.

    Jood das hatte ich gemacht. Auch mit Aceton war ich drüber ...

    Im Platinenreiniger mit 45°C und dieser Waschlösung von Kontakt Chemie ist dann das Bad immer dunkler geworden und die CPLD hatten dann so ein mattes "Schleiffinish"


    Das Geld ist nach einem Anruf + E-Mail an den Verkäufer über Paypal erst mal auf hold.


    Der Verkäufer hat jetzt 14 Tage um zu reagieren.


    Wenn es so läuft wie mit den letzten Fakes aus Ali, dann ist morgen das Geld wieder zurück, oder eine E-Mail mit "Dear Friend, ..." und "To process the refund you need to send back the item to us for checking and we will refund if the item arrived."

    Die Antwort liest Paypal mit und ich schreibe denen das ich die 50 USD für den Versand an Paypal melde und die den Betrag mit auf den Refundbetrag addieren. Also kriege ich mehr zurück, als ich gezahlt habe ....


    Das hat nun schon 10 mal oder öfter so stattgefunden. Dann dauert es eine Weile und irgendwann erinnert Paypal den Verkäufer daran, shipping details zur Verfügung zu stellen.


    Bis auf einmal, wo ich tatsächlich was zurückgeschickt habe (13 USD Wert, 74 Dollar shipping nach China UPS Express) kommt dann das Geld zurück und der Verkäufer schließt den Fall.


    In dem Einzelfall habe ich dann 74 USD für shipping sofort zurückbekommen (dann erst den Versandschein bei UPS gemacht und bezahlt.) und nach 6 Wochen oder so, dann auch die 13 Dollar Refund.


    War wohl ein intelligenter Chinese, der nicht gedacht hat, das ich tatsächlich zurückschicken würde.

    Nun muss nur noch Reichelt liefern UND nicht noch mehr EMT570 bzw. EMT240 beim Entfernen des Flux ihre Beschriftung verlieren ...


    11 aus 20 hatten das Problem nun schon.

    Aber die, die 6,83 USD / Stk. gekostet haben.


    Die auf dem Bild haben die Schrift behalten.

    Da hab ich nun alle 0402 Kondensatoren drauf und auch sonst Alle Bauteile bis auf die Widerstände.


    Nen A310 hatte ich von 1993 bis etwa Mitte 1994.

    Der mit dem 2,6 Ltr. "Euromotor" und aus der Serie mit der Kombi aus Weber 32 DRT bis etwa Halbgas und Weber 40 DRT für den Rest.

    170 PS und rund 200 km/h Spitze.


    Der ist dann wegen jugendlichem Leichtsinn auf einer Landstraße zwischen Badem und Bitburg in einer Kurve "abgewickelt" worden.


    Gebastelt habe ich gestern bis etwa 3 Uhr heute morgen einen Teil der 0402 100nF Kondensatoren auf 6 PiStorm Platinen und endlich mal den HDMI Panelanschluß mit einem Taster in ein Slotblech am Amiga 2000.

    Bei mir stellt sich meistens das Problem so dar:

    Ich will eine Floppy / Datasette / sonst was teaten ... meist nach einer Reparatur oder Justage.


    Wie schön ist es dann, wenn man das Tool zum Testen dann nur auf Diskette / Kassette / sonst ein Medium hat, das man gerade auf dem zu testenden Gerät nicht lesen kann, weil man erst das Tool braucht umd den Datenträger mit dem Tool darauf wieder lesen zu können.

    Du kannst KT Werte im S5 DB anlegen ...

    Aber ob das mit enem DW geht, von der Länge her ???

    War das nicht DD ?

    Die Basis liegt als Oktal Wert vor, der Timerwert kann bis 65355 also schon ein Wort ... Oder bin ich da S7?

    Müsste heute Nacht mal in der Firma, wo ich gerade Service mache, einen Elektriker fragen .... Die haben noch ein oder 2 Maschinen mit S5 ...