Posts by olly

    Nachtrag.


    Habe gerade das Cassettenbuch von Data Becker entdeckt. Da steht ja quasi alles drin, um ein Programm zu entwickeln, dass die Programmköpfe von Kassettenprogrammen einliest und einiges mehr.

    Auch ein Programm zum Anlegen eines Kassetteninhaltsverzeichnisses mit Druckerausgabe wird geboten.


    Gibt´s also alles. :thumbsup:

    Also weil es gerade passt. Ich habe haargenau das gleiche Problem bzw. Vorhaben, wie der TE.


    Abgesehen von den vorgenannten Lösungsansätzen hier, dachte ich mir, dass es da sicher eine Programmlösung für geben müsste und bin im Netz auch fündig geworden. Die zwei Programmchen die ich gefunden habe und die gestellte Aufgabe erledigen sollten heißen:

    1.) Tape-Index

    2.) Tape Directory


    Beides Basic.Programme. Mein Problem ist jedoch, ich habe keine Ahnung, wie die Programme funktionieren. Irgendwie stelle ich mich wohl zu blöd an. Obwohl die Bedienung eigentlich selbsterklärend sein sollte.

    Tape zurück auf Anfang spulen, SPACE-Taste, dann PRESS PLAY ON TAPE und das Band läuft los. Eigentlich!


    Bei Programm 1.) kommt nach drücken der Playtaste die Fehlermeldung "Syntax Error in 200"

    In 200 steht am Ende der Load-Befehl in Turbo-Tape. Also <-L. Hab es dann mit Turbotape im Speicher versucht, funktionert auch nicht. Programm stürzt bei dem ersten Fund ab. So ähnlich auch das 2. Programm.


    Ich papp die beiden Programmchen hier mal mit dran. Vielleicht hat ja jemand eine Idee, wie das funktionieren soll.

    Wäre Super, wenn mir da mal jemand wissendes auf die Sprünge helfen könnte.


    lg

    Falls du ein neues Multimeter kaufst wähle auf jeden Fall eines mit Frequenzmessung bis mindestens 2 MHz, besser 20 MHz.

    Da hab ich tatsächlich drüber nachgedacht. Allerdings bin ich bei der Auswahl eines geeigneten, preiswerten Gerätes leicht überfordert.

    Kinzi, kannst Du mir ein Multimeter empfehlen?


    Muss nichts ausgefallenes sein. Wie Du weisst, bin ich gerne mal interressiert, selbst Hand anzulegen. Aber wirklich nur ab und zu.

    Wäre Dir sehr dankbar!:rolleyes:


    Edit:

    Der Taktgenerator ist U10, richtig?

    Fällt dir was auf?

    Auf jeden Fall! Nicht schlecht. Warum komme ich nicht auf so simple Ansätze? Danke Kinzi!

    Ich glaube wir vertagen die Sache, bis ich ein verlässliches Multimeter zur Hand habe.

    Alles andere macht keinen Sinn.

    ..vielleicht mal frische Batterien rein?

    Könnte gut möglich sein.


    Herzlichen Dank Euch beiden bis hierher und einen angenehmen Restsonntag.

    Hallo Kinzi,


    danke Dir, dass Du Dir die Zeit nimmst um mir zu helfen.

    stimmt dein Multimeter?

    Das ist eine sehr gute Frage! Das muss ich ersteinmal prüfen. Eine Messung einer LR20 1,5V Batterie ergab 1,71Volt. Das kann ja nicht stimmen, oder?

    Ich habe mir vor kurzem als Ersatz für ein in Rauch aufgegangenes 1581NT, dieses kombinierte NT zugelegt, was sehr gut funktioniert.

    Daran habe ich die Ausgangsspannungen wie folgt gemessen: 13,31V und 5,74V. Das stimmt doch nicht, oder?

    Ich habe irgendwo noch ein anderes Multimeter. Gib mir mal bitte einen Moment.

    Hallo Leute,


    ich habe hier einene 1571 Floppy ("Ebayreinfall") zu stehen, welche das Dauerlaufproblem nach einschalten hat. Habe schon alle verfügbaren Threads hier im Forum, sowie das Servicemanual durchgearbeitet, was aber nicht Zielführend war. Mein Wissen um die Technik ist beschränkt und ich komme alleine nicht weiter. Deshalb bitte ich hier die Profis um Hilfe, die Floppy wieder zu reanimieren.


    Messmittel vorhanden:

    Multimeter, Logiktester


    Getauscht habe ich die CPU 6502AD, das ROM und die CIA, ohne Erfolg.


    Meine Vermutung ist, dass schon die Ausgangsspannungen am Netzteil nicht stimmen, sprich zu hoch sind. Dazu habe ich irgendwie keine klaren Daten gefunden.


    Am NT-Ausgang messe ich auf der 5V-Schiene 5,51 Volt, auf der 12V-Schiene 12,98 Volt.


    Nächste Frage dazu. Wenn die Spannungen (wie gemessen) zu hoch sind, hält die CPU diese Überspannung aus, oder geht die deswegen zum Teufel? An PIN8 der CPU messe ich auch die 5,51V. Einen Reset macht die CPU jedenfalls.

    Der Logictester zeigt mir an den Adress- und Datenleitungen keine eindeutigen Zustände an. Beide LED am Tester leuchten (glimmen).


    Hat jemand eine Idee? Ich wäre sehr dankbar, wenn ich die Floppy mit eurer Hilfe wieder fit machen könnte.


    Beste Grüße

    Seit dem ich mich irgendwann in der Vergangenheit auch wieder dem C128/C64 zugewand habe, wollte ich natürlich auch Programmieren. Meine Ideen in Software bringen. In Basic und auch ASM.

    Habe mir dann alles an Literatur darüber besorgt, was ich bekommen konnte (und das ist einiges an echten Büchern und auch pdf) und hab einfach angefangen.


    Für mich war es am einfachsten, kommentierten Quellcode zu analysieren und zu versuchen die Vorgänge zu verstehen. Oder auch ASM-Code zu analysieren und so mit Hilfe der Literatur zu verstehen, was das Programm an welcher Stelle macht und warum. Ich habe mir sehr viele Notitzen gemacht und so dann auch einige eigene kleinere Programme zustande gebracht. Wie z. Bsp. eine kleine graphische Workbench mit Mausbedienung, Windows und Laufwerkserkennung in Basic7, oder auch das programmieren der 24h TOD-Clock (CIA) mit der Systemzeit aus der U2+ und IRQ gesteuerter Ausgabe des ganzen in einer 26.Bildzeile auf dem 80-Zeichenschirm des C128. Oder auch Radiobutton mit Mausbedienung in Basic oder den Z80 im C128 zu aktivieren und rudimentär zu programmieren und solche Dinge. Und da ich auch manchmal ein bisschen faul bin, hab ich auch vorhandenen Code einfach gemopst und für meine Zwecke angepasst und verwendet. Das setzt aber auch vorraus, dass man den Code aber auch versteht. Logisch. Und Faulheit ist m. E. nicht mal etwas schlimmes. Es macht das Leben oft auch einfacher und angenehmer. :D


    Was ich nicht auf Anhieb verstehe, kaue ich so oft durch, bis ich es verstehe (wenn das Interresse dafür groß genug ist). Das mag auch an meinem Sternzeichen liegen, welches den Ruf hat, allem auf den Grund gehen zu müssen. Das ist bei mir extrem ausgeprägt, wenn mich etwas interresiert. Und das hilft mir auch. Allerdings hab ich leider auch nicht das tolle Durchhaltevermögen. Wenn ich ein bestimmtes Level erreicht habe, passiert es auch, dass ich das Interresse verliere. Das ist dann wieder ein Handycap. Deshalb hab ich auch in der Vergangenheit warscheinlich auch so gut wie garnichts in der Richtung gemacht. Naja, gab auch paar andere wichtige Gründe. Aber es macht doch viel Spaß und lenkt auch gut vom Alltag ab.


    Wie auch immer, Interresse muss m. E. dafür schon da sein und jeder lernt auf andere Weise.

    Ja, durch ehrliche Arbeit ist noch keiner reich geworden.

    So ist es, nur blöd wenn man das zu spät erkennt weil einem was anderes suggeriert wird. 8|

    Anyway.


    Ja, der Regler ist bei Ebay gekauft. Gerade wegen der Handhabung. Der ist aber per Poti auch frei einstellbar. Nur dieser Enableport ist mir ein kleines Rätsel.


    Link - 5 Stück für 5,50€ ist ok für mich. Die Lieferung hat ca. 1 Woche gedauert.


    Gruß

    Hallo in die Runde,


    habe (nach langer Abstinenz) auch mal wieder was gebastelt was ich schon länger geplant hatte. Werde meine Vintage-Ghettoblastersammlung Bluetoothfähig machen. Nichts Wildes also. ^^


    Benutze dazu einen einfachen USB-Stereoaudio-Bluetooth-Stick der vom Geräteinternen Netzteil mit Spannung (ca. 15V) versorgt wird, die mit einem Sannungsregler auf die für den Bluetoothstick nötigen 5V gebracht wird.

    Einschleifen tue ich das Audiosignal dann in die LineIn-Eingängen der Geräte. Ein Probelauf mit einem 1. Prototypen verlief erfolgreich, wie ich mir das vorstelle.

    Die Bluetoothantenne hab ich für eine bessere Reichweite mit Sauglitze um 3cm verlängert. Das bringt schon was. ;)


    Das einzige was ich noch nicht genau ausklamüsert habe ist die Art, wie ich den Bluetoothteil aktiviere. Warscheinlich eher über einen extra Schalter der die Spannung zum USB-Modul unterbricht und im Batteriefach untergebracht wird.

    Schöner wäre natürlich einen vorhandenen Schalter (z. Bsp. den Mode-Switch an der Front) zu benutzen. Die Schaltpläne hab ich zwar alle, aber dafür reichen meine Elektronikskills wohl nicht aus.


    Eine Frage hätte ich trotzdem.Der Sannungsregler hat einen "Enable-Port". Vermutlich wird der Chip auf dem Regler damit aktiviert. Ich hab aber keine Ahnung, wie dieser Port funktioniert bzw. wie man ihn beschaltet. Kennt das jemand und könnt mir die Funktion dieses Enable-Port erklären? Ich wäre dankbar dafür und die Mühe.


    Hab noch ein paar Foto´s vom Prototypen drangehängt.


    Schönen Restsonntag! :winke:


    Eine ordentliche RTG gehört für mich schon aus Prinzip in einen vermeintlichen Highend Amiga. Damit steht einem dann schließlich auch Tür und Tor in der Anwendung des Gerätes offen. No more half measures! You known?

    Bei mir ist es die Picasso II. Solide und ausreichend. Und ja, OS 3.9 macht damit definitiv mehr Spaß. War damals so mit das erste was ich in den A3000 investiert hatte.


    Wenn man eine gute RTG zu einem fairen Preis ergattern kann (was ja immer aussichtsloser wird), sollte man meiner Meinung nach zuschlagen. Über Sinn oder Unsinn in dem Bereich ist jede Diskussion ehrlich gesagt eh obsolet.;)

    Den Ausführungen von Anthony ist eigentlich nichts hinzuzufügen. Ich gehe genau so vor wie Anthony (Multitrackrecording und Nachbearbeitung wenn ich mal was in der Richtung mache) außer das meine DAW FLStudio ist. Aber das ist ja Wurscht welche DAW man da benutzt. SIDFX ist m. E. in dem Fall der Rolls Roys und unbedingt zu Empfehlen. Ich nutze das Teil auch und bin sehr zufrieden! Ist aber auch nicht ganz so günstig. Lohnt sich aber ganz sicher und man kann das volle Potenzial der MSSIAH-Software nutzen. Soll ja auch Spaß machen.


    @Anthony W.


    Dein Last Ninja ist ja MEGA FETT!!!
    Was so ein bisschen Finetunig so anrichten kann!
    :respect:

    Hat jemand zufällig noch die Liste mit den ICs, die fehlen?

    Aber natürlich! Hier bitteschön.


    You need the following chips to run the computer:

    • 1 pcs. 8502 (CPU)
    • 1 pcs. Z80 (CPU)
    • 1 pcs. 8721 (PLA)
    • 1 pcs. 8722 (MMU)
    • 1 pcs. 8564 (VIC)
    • 1 pcs. 8563 or 8568 (VDC)
    • 1 pcs. 32Kbyte ROM
    • 1 pcs. 32Kbyte ROM
    • 1 pcs. Character ROM
    • 2 pcs. 6581 and/or 8580 (SID)
    • 2 pcs. 6526 (CIA)
    • 6 pcs. 64K (4-bit) dynamic RAM
    • 1 pcs. 2048 word x 8bit RAM

    Sind wohl so ziemlich alle, oder?


    PS: Momentan kann man sich die abgeschaltete Webseite noch im Googlecache in voller Pracht ansehen, wenn man weis wie das geht. ;)