Posts by oasenkind3

    katarakt

    ja, hast sicher recht.

    Die Blende mus ich nochmal " Verfeinern "


    So, weiter geht´s :

    Nach dem alle Tests erfolgreich waren,

    Kann das ganze jetzt zusammengebaut werden.


       


     


    Und hier mal das ganze in Betrieb,



    Klasse, es läuft alle suuper, ich habe eine 1581 , naja fast.

    Ist halt nicht original, aber bei den heutigen Preisen für son Ding ist das was ich es jetzt habe erst mal OK so.


    So. Das Projekt ist hiermit beendet.

    Und wenn ich mal gaaanzz viel Zeit habe, dann stelle ich hier vielleicht mal die Doku zu dem Projekt ein.


    Bis dahin.........

    Man sieht sich.......

    Obelix 20960

    Also die Platine habe ich ja selber gezeichnet und für meine Verhältnisse angepasst.

    Die passt auch speziell nur für diesen Umbau.

    Sprich Du zersägst Dir ein 1541 II - Gehäuse und hast dann alle Befestigungslöcher an der richtigen Stelle.

    Diese Platine passt so nicht in ein " Normales 1581 - Gehäuse.

    Sobald ich das Projekt hier beendet habe kann ich ja mal versuchen meine Dokumentation hierzu Online zu stellen.

    ( Weiß aber noch nicht wann genau ich da Zeit zu finde )

    Die gezeichnete Platine wird dann in GERBER - Dateien umgewandelt und zu einem Leiterplatten Herstelle geschickt.

    Das hat in meinem Fall ca 25,- EUR gekostet.

    Wie gesagt, wenn ich Zeit dazu finde kann ich die Daten ja hier mal einstellen.


    Jetzt aber erst mal weiter mit dem Projekt.

    Ich habe die Platine heute getestet.

    Als erstes mal den CLOCK gemessen. Als der in Ordnung war, habe ich nach und nach

    die weiteren IC bestückt. Soweit sogut.

    Ich habe mir dann das ROM 318045-02 runtergeladen und in ein EPROM gebrannt.

    ( Das 318045-01 - hat ja einen Fehler )

    Das Rom habe ich auch gesteckt


    Dann eingeschaltet und mit Spannung und dem C64 verbunden.

    Was soll ich sagen:

    Test ERFOLGREICH - DER GEHT :):):):)



    Ich habe aber jetzt noch eine Frage zu dem ROM.

    Ich habe im Netz noch eine Version gefunden.


    1581rom5.bin


    CBM-1581 Binary ROM Program UpDate-5 By TFSS Of The GPS ( von The GOlden Pig )

    CBM-1581 Source Listing ROM UpDate-5 (August 11, 1996) Using 8K SRAM Expansion $2000-$3FFE, And MOSTECH 6529B PIO $3FFF for parallel data transfer routine from BARD'S TALE III

    Kennt diese Version jemand von euch ?

    Was macht die genau.

    Es sieht so aus als ob die den 6529 unterstützt anstelle des 8520 ?

    Und was ist mit Parallel gemeint? ( Ist das sone Art - Dolphion DOS )


    Also, bitte, wenn jemand was näheres über das ROM weiß, gebt hier mal bitte kurz bescheid.

    Danke.....


    So, für Heute wars das auch schon wieder.

    Morgen baue ich das Ganze mal zusammen.

    Obelix 20960

    Das mit der fertig bestückten Platine wird wohl ehr weniger was.

    Ich hab mir die einzelnen IC teilweise auch in der Bucht zusammengesucht. ( MOS 8520 vom Amiga , Speicher usw... )

    Die Buchsen für die Stromversorgung und dem seriellen Bus hatte ich noch von einer alten 1541 II Platine.

    Auch der Ein / Aus Schalter war da noch drauf. Den Rest bekommt man noch bei den bekannten Elektronik Versendern.

    Man muss sich halt die alten Teile zusammensuchen.....


    Superingo

    Ja, das ganze muss ich noch mal ordentlich schleifen und lackieren,

    Das ist jetzt erst mal zum prüfen ob das überhaupt geht......

    ( Für mich sieht es erst mal gut aus... )


    So, weiter geht es :

    Die Platine ist gestern noch aus CHINA gekommen :

    Das ist eine Super Qualität.

    ( Wenn ich da an früher denke, mit Klebeband die Leiterbahnen geklebt und dann mit Eisen 3 Chlorid geätzt , was ne Arbeit ....) .

    Heute ist das um vieles einfacher.

    Hier mal ein Foto von der Platine :




    Die passt auch bestens in den Abschirmkäfig der 1541 II

    ( Auch die 3 Befestigungslöcher passen dank der Anpassungen super )




    Nach dem Bestücken der Platine sieht es aus wie gekauft,

    wahnsinn was Heute alle möglich ist :




    Hier noch ein letztes Foto für Heute:

    Platine bestückt und eingebaut im Abschirmblech.

    Es wird langsam........:)



    Ok.....

    Bis Morgen....

    Tach....

    Es geht weiter.....


    Damit das PC – Floppylaufwerk in das Commodore Gehäuse passt,

    müssen an die Floppy mit Stehbolzen jeweils links und rechts Adapter Winkel angeschraubt werden.




    Das Laufwerk kann dann in das Gehäuse eingebaut werden.


       



    Gestern habe ich noch die Gehäuseteile lackiert. Die sind inzwischen getrocknet.

    Hier mal alles probeweise zusammengebaut. Sieht schon gar nicht mal so schlecht aus.

    Die Blende muss ich wohl noch mal etwas nachschleifen und noch mal neu lackieren.

    Aber für den Anfang schon mal gut, und besser als nix :-)


       


    Für heute wars das auch schon wieder,

    bis Morgen mal............

    Moin moin,

    Es geht weiter :

    Nun wird die Frontblende bearbeitet.

    Hier muss die Blende für das 3 ¼ Zoll Laufwerk in die zu große Blende einer 1541 - II eingebaut werden.




    Dazu wird auch hier ( Wie solls auch anders sein ) wieder 34mm aus der Mitte entfernt.




    An den beiden Hälften wird der Ausschnitt für die 3 ¼ Zoll Blende angezeichnet und ausgesägt.

    Ja, die neue 3¼ Zoll Blende passt gut in das ausgesägte Loch.


       



    Hier mal ein Bild Von dem zusammengebauten Gehäuse.

    Sieht schon mal nach was brauchbarem aus wie ich finde.

    Ist noch nicht gespachtel und lackiert, die Form passt aber schon mal.....


      &thumbnail=1



    Die Frontblende habe ich dann schon mal gespachtelt.

    Der Füllspachtel vom PATTEX ist echt gut. Trocknet schnell und lässt sich prima abschleifen.


     



    So, das wars auch schon wieder für Heute,

    Morgen geht es weiter............

    Hallo zusammen,

    weiter gehts mit dem Bau.

    Jetzt kommt der Deckel dran. Hier das gleiche Spiel, auch hier muss 34mm aus der Mitte entfernt werden.




    Nachdem das Stück aus de Mitte entfernt ist, sehen die Kühlrippen wenn ich die so zusammenkleben würde nicht sehr gut aus.

    Deshalb habe ich in der Mitt einen " Zwischenstreifen " eingefügt. Nun sieht es ein wenig besser aus.

    Dann habe ich die 2 Deckelhälften auch mit 2K - Kleber zusammengeklebt.


       



    Jetzt kann ich die Blende mit den Auschnitten für die Stecker und Schalter auch einkleben.




    Und hier mal beide Hälften aufeinander gelegt. Es wird :)



    Vielleicht gibt es heute Abend noch ein Update,

    ansonsten bis Morgen...........

    tuxer

    Du kannst Die Platine von einer Originalen 1581 leider so nicht verwenden.

    Der Metallkäfig einer 1541 II hat nur 3 Befestigungslöcher für die Platine.

    Die Originalplatine hat aber 4 Befestigungslöcher.


    Damit die Steuerplatine auch in das Abschirmblech passt, muss eine Original 1581 Platine angepasst werden.

    Die Befestigungslöcher sind hier jetzt an einer anderen Stelle

    Der Steckverbinder CN2 ist um 180° gedreht worden, damit man die Floppy direkt und ohne das Flachkabel zu verdrehen anschließen kann.

    Ich habe auch 3 neue Jumper eingefügt, so das man wählen kann, welche Signale an Pin 2 und Pin 34 des CN2 anliegen ( Stecker zum Laufwerk ) ,

    man kann so wählen, ob man ein AMIGA Laufwerk oder ein PC – Floppylaufwerk anschließen möchte.





    Dazu habe ich schon mal die Originalplatine von Fotos und dem Schaltplan aus dem Service Manual neu gezeichnet

    und an meine Gegebenheiten angepasst.


         


    Die Platinen habe ich vor ca. 2 Wochen schon mal in CHINA bestellt....

    Hi oobdoo,

    ja, endlich mal wieder zeit für ein neues Projekt.

    Der SX64 funktioniert technisch wieder. ( Danke noch mal für die gedruckten Modulport Klappen - Die passen bestens . )

    Naja jetzt sind halt noch kosmetische dinge zu tun.

    Die Tastatur muss noch gespachtelt werden und das gehäuse neu lackiert werden.

    Sobald es da weiter geht werde ich hier mal wieder berichten.

    Inspiriert von TOMS01 genialer 1581 Replica habe ich mir gedacht es ist an der Zeit einmal eine 1581 komplett nachzubauen.

    Da die 1581 von COMMODORE ja im Moment richtig viel Geld kostet, habe ich beschlossen mir selber ein solches 3 ¼ Zoll Laufwerk zu bauen.

    Klar ist das kein Original, aber ich versuche das mal ziemlich originalgetreu nachzubauen.


    Dazu habe ich noch ein altes leeres Gehäuse von einer 1541 – II hier rumliegen.



    So jetzt bitte nicht wieder hauen, wegen, wie kann man nur ein Originales Gehäuse zerstören.

    Ja ich weiß, aber das Gehäuse hat eh schon Kratzer und ist ein wenig vergilbt.

    Ich möchte halt mal das 3 ¼ Zoll Laufwerk haben.



    Aus diesem Gehäuse werden zunächst einmal alle alten Halterungen vorsichtig herausgebrochen,

    die brauchen wir nicht mehr.





    An dem Abschirmblech müssen neue Abstandsbolzen angebracht werden, damit das Blech auf die passende Höhe kommt.

    Ansonsten kann das Blech so aus einer 1541 – II übernommen werden.





    Aus der Rückwand muss die Blende für die Stecker und den Schalter entfernt werden,

    das Gehäuse wird ja schmaler und deshalb muss die Blende an eine andere Stelle verschoben werden.





    Aus dem Boden muss in der Mitte ein 34mm breiter Streifen entfernt werden, damit das Gehäuse schmaler wird.





    Ich habe das ganze mal probeweise mit Klebeband fixiert :

    Sieht gut aus und passt prima. Anschließend habe ich das mit 2K – Kleber verklebt.



    Die Untere Hälfte ist somit erst mal geschafft.

    So, für heute wars das erst mal,

    Morgen geht es weiter hier..........

    Hi ZahrlAn,
    mach mal Bitte ein paar Detailfoto´s vom Netzteil.


    Sind die Kondensatoren noch in Ordnung?
    ( Sind die vielleicht ausgelaufen ? )


    Also irgendwas zieht im Netzteil zuviel Strom.
    Ziehe doch mal den Stecker vom Mainboard ab.
    So das NUR das Netzteil alleine läuft.


    Wechsel mal die Sicherung und schau mal ob die
    Sicherung jetzt ganz bleibt.


    Falls ja, liegt der Fehler schon mal nicht am Netzteil.
    ( Dann ist der Fehler auf der Hauptplatine )

    So,
    heute hab ich mich mit dem Resettaster befasst.
    Der Taster war so eingebaut, das der Drücker zu weit herausgeragt hat,
    die Klappe die die Einstellregler für Lautstärke usw. verdeckt,
    ließ sich nicht mehr richtig schließen.


    Ich habe da einfach ein Stück 4mm Kunststoff zurechtgeschnitten und den Taster
    dort eingebaut.



    Das Stück Kunststoff habe ich auch mit 2K Kleber an der Frontblende angeklebt:
    Durch die 4mm ist der Drücker jetzt weitgenug nach hinten verlegt,
    so das sich die Fronttür gut schließen lässt.



    Bei der Gelegenheit habe ich die Verbindungsleitung vom Taste über Steckverbinder angebracht,
    so kann man den einfach abziehen wenn man mal wieder die Frontblende lösen muss.
    ( Kein Löten mehr )



    So das wars auch schon wieder für Heute.
    Bis bald mal......

    So, ich hab mich gestern mal mit dem IEC Bus befasst.
    Also sowas sieht man selten.
    ( ein Lötpad kann ja mal abreißen, aber alle man man )
    ( Derjenige der die alte floppy dort eingebaut hat, hat alles gegeben :( )
    ( ALLE Pads waren weg )



    Und die Vorderseite sieht auch nicht besser aus.
    ( Ich glaube derjenige hat die Buchse einfach RAUSGERISSEN, wozu Löten ? :( )
    ( Komlette Leiterbahnen waren auch durchtrennt. )



    Ich hab mich dann dazu entschlossen Die Buchse mit 2 Komponenten Kleber einzukleben.
    Zusätzlich konnte ich die noch mit den 2 vorderen Löchern verlöten.



    Die Leitungen habe ich dann direkt an der Eingeklebten Buchse ( an den Pins angelötet )
    und mit ein wenig Heißkleber festgemacht.



    Ist mir den Umständen entsprechend ganz gut gelungen wie ich finde.
    Nun kann man auch wieder von Außen eine Floppy anstecken.

    Der Kondensator kann z.B. der hier sein
    https://www.ebay.de/itm/Konden…79770d:g:qTgAAOxyx-BSa8Bg


    Aber hier auch unbedingt auf die richtige POLUNG achten.
    Der weiße Streifen mit den Minuszeichen ist der Minuspol, der andere Kontakt ist dann der Pluspol.
    Ich hab Dir den richtigen Einbau auch wieder im Schaltbild eingezeichnet.
    Trafo.jpg


    Wie gesagt UNBEDINGT die richtige Einbaulage beachten.
    ( Falls der falsch herum eingebaut wird kann der auch wieder zerplatzen )

    Wobei ich sehe gerade, das der Kondensator C802 ja NUR 10V Spannung verträgt.
    Die 9VAC ergeben als Gleichspannung aber 9VAC * SQR(2) = 12,7VDC ( Gleichspannung ).
    Hiervon fallen jetzt noch ca. 1,2VDC am Gleichrichter ab. Also bleiben noch ca. 11,5VDC übrig.


    Der Kondensator C802 ist also von der Spannung her ( 10V ) zu klein für die 9VAC.
    Du müsstest den gegen einen 12000uf mit 16V oder besser 25V tauschen, wenn Du die 9V AC
    wie gezeichnet anschliest. Ansonsten wird der Kondensator das nich überleben ( Das ist gefährlich, der kann
    unter Umständen sogar zerplatzen )


    Also vorher den Kondensator auf die höhere Spannung tauschen, oder einen weiteren Trafo mit ca. 7VAC
    besorgen ( Anstelle der 9V AC )


    Bitte unbedingt BEACHTEN...........

    Hi ballblazer,
    da Du ja zwei Trafos kaufst, muss Du beide Trafos in Reihe schalten
    ( Das hast Du ja schon richtig im Post 23 gezeichnet )


    Hierbei ist es egal, welches ende der beiden Trafos Du zusammen lötest.


    ----- Spannungsabgang 1
    #
    # Trafo 1 ( 16V AC )
    #
    ------
    \
    | An dieser Stelle werden die beiden Trafos zusammengelötet ( Masse )
    /
    ------
    #
    # Trafo 2 ( 16V AC )
    #
    ------ Spannungsabgang 2

    Hi,


    ich möchte noch eins anmerken, ich glaube der Trafo muss entweder eine Wicklung mit Mittelanzapfung
    oder zwei getrennte wicklungen haben, bei der man die mitte miteinander verbindet.


    Das würde auch die beiden getrennten Sicherungen F3 und F4 erklären .


    seht euch mal das folgende Muster Bild an :
    Trafo.JPG


    Der PURPLE Anschluss ist die Mittelanzapfung vom Trafo.
    Bitte prüfen und falls ich falsch liege bitte berichtigen.