Posts by ILAH

    Man kann das Laufwerk für die Rückseiten umbauen. Stichwort Flippy-Mod. Da wird ein Index-Loch unabhängiges Index-Signal erzeugt. Die Disk muss hier aber umgedreht werden. Das klappt bei mir gut.


    Der Autor von Greaseweazle hat auch mal angedeutet das per Software das Indexloch beim Lesen ignoriert werden kann. Dann wäre der Laufwerks-Mod überflüssig. Das ist aber glaube ich nicht umgesetzt.

    Hier mal mein Script zum Einlesen der Disks unter Windows.

    Ich suche eine Möglichkeit eine G64 Datei nach SCP (SupercardPro) umzuwandeln.


    Diese will ich dann mit Greaseweazle auf eine Floppy zurückschreiben. Dies ist für D64 Dateien (nach Konvertierung auf SCP) möglich.


    Gibts hier ein Programm das diese Konvertierung durchführt?

    Ich häng mich hier mal ran.


    Ich habe ein Greaseweazle F1 Board und daran eine Epson SD-600 Floppy.

    Damit kann ich (auf Umwegen / Konvertierungen mit fluxengine und hxc) d64 Dateien auf Disk schreiben und Disketten kopieren.

    Jetzt möchte ich noch g64 / nib Dateien schreiben, dazu müssten sie ins scp „Format“ konvertiert werden.


    Das geht theoretisch mit hxc aber die exportierte und auf Disk geschriebene scp Datei funktioniert nicht. Gibts da eine Möglichkeit? Evtl. die g64 als raw einlesen und dann mit den richtigen Parametern umwandeln.


    Gruss

    Ich habe auch diese Fehlermeldung. d64copy und nibread läuft aber regelrecht.



    Meine Config: ProMicro DIY/Parallel-Kabel, Firmware ist jetzt v08. Ich hatte vorher Firmware v07 und als Treiber libusb-win32 (v1.2.6.0).


    Hier ein Screenshot von Zadig und aus dem Gerätemanager. Stimmt das so?


    Ich beobachte am meinem xum1541 mit ProMicro Platine ein merkwürdiges Verhalten.


    1. Wenn ich die Einschaltreihenfolge, erst ProMicro über USB anstecken (rote LED an, danach grüne LED an) dann Floppy einschalten, einhalte geht es. Wenn ich aber den ProMicro zuerst an der Floppy einstecke geht auch die rote LED an, die grüne LED bleibt aber aus. Wenn ich dann erst USB einstecke gibt es Probleme. Das Gerät wird im Gerätemanager zwar erkannt aber lässt sich nicht nutzen (cbmctrl detect bleibt hängen). Ist ja nicht so schlimm, halte ich mich einfach an die Reihenfolge, oder gibts eine Möglichkeit zur Abhilfe?


    2. Anscheinend verträgt sich das xum1541 mit einer meiner Floppys nicht. Ich bekommen beim Schreiben mit d64copy auf den Tracks 14-16 immer Fehler (siehe Bild). Mit nibwrite und Parallelkabel geht es aber ohne Fehler. Die gleiche Disk in anderen Laufwerken geht ohne Probleme mit d64copy. Kann das an einen dejustierten Drive liegen?



    3. Der Stand der Dinge für ein xum1541/ProMicro ist wohl noch Firmware v07 oder? Bei v08 lassen sich wohl die nibtools nicht nutzen, oder gibts da was neues.


    Gruss ILAH

    So, im Prinzip funktioniert es jetzt. Ist aber natürlich etwas störanfällig.


    Der Lautsprecher kommt an die beiden nebeneinander liegenden Anschlüsse am Rand. Als Mikrofon habe ich einen leichten Lautsprecher aus der Wühlkiste genommen. Hier an GND und „MIC“ in der Mitte angeschlossen. 12V bleibt ungenutzt.


    Zum Testen habe ich das ganze dann direkt auf einen Datafon Akustikkoppler gelegt und kann so Zeichen übertragen.

    Damit bin ich erstmal zufrieden. Vielleicht probiere ich nochmal was anderes als Mikrofon und mach die Muffen schöner.


    Danke an Eloy_Dorian


    @Elay_Dorian


    Danke für den Tipp. An die beiden Anschlüsse unten gehört der Lautsprecher, das klappt schon mal.

    Mit dem einzelnen Schalter lässt sich Originate/Answer umschalten.


    An den 3 weiteren Anschlüssen liegen GND/oben, ?Mic/Mitte?, 12V/unten an. Mal sehen was ich da testweise als Mikrofon anschliessen kann. Ich wollte eigentlich auch einen Lautsprecher nehmen, wie beim CCC Datenklo. Ich hab aber auch ein Kapselmikrofon mit 3 Anschlüssen hier rumliegen. Ob das wohl 12V verträgt?


    Gruss und Danke ILAH



    Ich versuche meinem ersten Akustikkoppler für den C64 wieder „Lebenszeichen“ zu entlocken. Es ist ein Modell für den Userport.


    Leider hatte ich den Userport-Stecker, die zwei Kippschalter und Mikrofon/Lautsprecher mal entfernt. =O

    z. T. habe ich das, nach Bildvorlage aus dem Internet (Lutz G), wieder gerichtet. Jetzt hänge ich aber bei Mikro/Lautsprecher.


    Kennt jemand dieses Modell oder kann aus der Schaltung ableiten wo Mikro/Lautsprecher hingehören? Ich hänge auch Bilder meiner Platine an.




    Gruss ILAH

    Betreibt jemand sein Pi1541 erfolgreich mit einen USB - Stick. Bei mir klappt das nicht richtig.

    Ich habe ein Display und einen Rotary Encoder verbaut, das läuft mit allen Daten auf der SD - Karte soweit problemlos.


    Mein Setup mit USB - Stick:

    Die Systemdateien, Konfig. und ROM Dateien sind auf der SD - Karte.

    Auf dem USB - Stick liegen im Verzeichniss 1541 die .d64 Files, z.T. in Unterordnern.


    Am Anfang lande ich im 1541 Verzeichniss des USB - Stick.

    Wenn ich jetzt mit dem Rotary Encoder in ein Verzeichnisse gehe, werden zwei invertierte Punkte angezeigt und das System steht. Dies geschieht aber nur bei einigen, leider vielen Verzeichnissen. Da hilft dann nur ein Kaltstart.


    Gruss ILAH

    Ich suche eine 3D Druck Vorlage für ein Gehäuse für die o.g. Schaltung. Gibts sowas schon?

    Das Gehäuse von Reichelt GEH KS 21 (72x50x21mm) passt wohl echt gut. Hier muss aber die Platine und das Gehäuse angepasst werden.


    Gruss ILAH