Posts by Gothicman/AFL

    Banzai!

    Ich befasse mich noch nicht so lange mit dem ganzen Gedöns der FOR-Schleifen unter Kickassembler.

    Grundsätzlich kann ich ja Zeug wie dieses eingeben

    ldx #$00

    !: .for (var i=0; i<8; i++) {

    lda $2800+i*$100,x

    eor #$ff

    sta $2800+i*$100,x

    }

    inx

    bne !-


    und erstellt wird dann

    ldx #$00

    lda $2800,x

    eor #$ff

    sta $2800,x

    ...

    lda $2f00,x

    eor #$ff

    sta $2f00,x

    ...


    Wenn ich nun aber z.B. einen Upscroller unrollen wollte, also:


    lda $0428

    sta $0400

    lda $0429

    sta $0401

    ...


    WIE müsste ich das anstellen?

    Vermutlich ist das ganz easy, aber ich raffe es nicht. :(



    Prost:



    Christoph

    Wie die Überschrift schon sagt, suche eine Lösung zum exakten vergleichen zweier scheinbar identischer Dateien.
    Da es sich um zwei C64-.prg Files handelt, vermute ich, dass es keine Windowstools für so etwas gibt, oder liege ich falsch?


    Thanx in advance...

    Danach kommt eine SPACE-Abfrage.
    Ich denke, ich gehe erst einmal pennen und werde wieder fit.
    Aber da mein Liquor der Hitze wegen kocht und ein paar Bierchen das nicht besser gemacht haben...


    ...Wer weiss, was der neue Tag bringt?


    Wie ich schon erwähnte: Ich kann das problemlos anders lösen. Ätzend bleibt es trotzdem.



    Ich dem Sinn erstmal Dank an alle, die sich hier eingebracht haben und: PROST! :)

    Nice to know aber in dem Fall ohne Erfolg.
    Selbst wenn ich diese ganze Kacke weglasse und NUR die Grafik darstelle, dann kommt dieses bekackte "Kunstwerk".
    Ist auch kein Ghostbyte oder so.


    Egal. Ich werde das jetzt ganz brachial lösen.

    Bin jetzt meine alten Sourcecodes durchgegangen.
    Der Fehler war da, wurde aber irgendwie von mir gefixt.


    Der Code allerdings ist absolut identisch.


    Erneut ein Punkt an dem ich erkenne, dass ich weniger saufen sollte... :(

    lda #$07
    sta $d020
    sta $d021
    ldx #$00
    !: lda #$07
    sta $c000,x
    sta $c100,x
    sta $c200,x
    sta $c300,x
    sta $d800,x
    sta $d900,x
    sta $da00,x
    sta $db00,x
    inx
    bne !-
    lda #$3b
    sta $d011
    lda #$08
    sta $d018
    lda #$18
    sta $d016
    lda #$00
    sta $dd00
    lda #$c0
    sta $0288

    Ahoi!


    Ein Problem, welches sich mir so schon öfter gestellt hat und irgendwie immer gefixt werden konnte.
    Nun habe ich allerdings schon über ein Jahr nix mehr für den C64 gemacht und kacke mal wieder ab.


    Ich habe eine Monocolor-Grafik ab $e000 abgelegt.
    Bildschirm liegt bei $c000 und $d800-$dbf7 wird mit #$07 gefüllt.
    Ständig bleibt jedoch so ein fieser kleiner Drecksbereich, der super-ätzend aussieht.


    Kann sich da irgendwer einen Reim drauf machen?

    Tach!


    Ich versuche seit geraumer Zeit mich in folgende BBS einzuwählen:
    telnet://colosseum.64bbs.org:6400


    Ich nutze dazu Win7 Ultimate 64 und VDSL.
    Telnet ist installiert und zusätzlich habe ich für FF SynTerm 1.0b installiert.


    Im CMD prompt läuft es teilweise, aber auch nie 100%.


    Jemand Vorschläge oder muss ich mich direkt an die SysOps wenden?!



    Thanx in advance...