Posts by dl1av

    Hier mal meine Erfahrung dazu:


    Erstmal auch die Frage, ob das ein Hardware-Problem ist (kalte Lötstelle, kann mal vorkommen)? Ich hatte sowas auch mal als Treiberproblem an einem DOS-Rechner. Vielleicht mal einen Linux-Stick booten, ob das dann noch auftritt?
    GDP hat generell einen guten Ruf, das braucht natürlich nicht für den Endverkäufer zu gelten.


    In einem Fall wie deinem, wenn du das Gerät wirklich zurück geben willst (mit Reparatur und dann wieder zuschicken würde ich in der Konstellation gar nicht anfangen, da sind die erfahrungsgemäß nicht drauf vorbereitet), würde ich die harte Tour fahren und einen Paypal-Claim aufmachen (du hast doch mit PP bezahlt?).


    Einfach "Gerät ist nicht wie beschrieben", dann sperrt PP das Geld schonmal auf dem Konto des Händlers und fordert dich auf, es zurückzuschicken und eine Trackingnummer anzugeben. Wenn du das gemacht hast, bekommst du nach mehr oder weniger langer Zeit den Zahlbetrag zurück und bleibst dann höchstens auf dem Rücksendeporto sitzen (Schwund gibts im internationalen Handel immer, ist halt so). Bei PP ist sozusagen über den Käuferschutz immer dieses Rücksenderecht eingebaut, auch wenn das nicht so kommuniziert wird.


    Gleichzeitig kannst du nochbeim Alibaba einen case aufmachen - wenn der nicht schon durch den PP-case automatisch erstellt ist (bei ebay ist das so).


    Zusammengefasst: Es bringt nichts, da wie bei einem deutschen Händler zu handeln und auf einen ordnungsgemäßen Ablauf zu hoffen. Die Wahrscheinlichkeit ist gross, dass dan Geld und Gerät weg sind.


    Mir persönlich wäre das erstmal egal mit dem Kartenleser. Ich will mir selbst bald einen GPD-Pocket 2 bestellen, diese Rechner sind too cute :) Allerdings kommt bei mir gleich ein Linux drauf, WIN10 brauche ich erstmal nicht.

    Naja, mein Vorschlag ist sicher nicht so ganz durchdacht *ggg*


    Aber trotzdem: So, wie das Wichteln hier in den letzten Jahren aussieht, kann ich es mir nicht leisten, mitzumachen. Da müsste ich vorher auch erst einkaufen gehen, um ein den durchschnittlich realisierten Erwartungen entsprechendes Paket zusammenzustellen.


    Oder ich probiere mal unter einer neuen id meinen "wichtel-scam" aus *fg*

    Nur mal eine Idee von einem Aussenstehenden:


    Mir ist über die Jahre aufgefallen, dass das mit den Wichtelgeschenken ziemlich durch die Decke gegangen ist. Da werden meist wirklich kleine Schätze verschenkt hinter denen man bei ebay lang und teuer hinterherrennen muss, wenn man es denn haben möchte.


    Selbst wenn man das erhaltene Geschenk nicht sofort für ein aktuelles Projekt verwenden kann, sind das alles schöne Sammlersachen, die man sich auf jeden Fall in die Vitrine legen kann oder bei ebay für um die 20eur oder mehr verkauft.


    Dass das natürlich auch einige schräge Vögel anzieht, die sich auf die Liste schreiben lassen, eine Klorolle verschicken und selbst reichlich ernten (es gibt ja kein Treuhandsystem wie z.B. Paypal bei der Sache), musste ja irgendwann mal passieren.


    Mein Vorschlag: Nur noch aktive Forenmitgleidern mit soundsoviel sinnvollen Beiträgen, die sich möglichst auch zumindest flüchtig irgendwo her kennen. Also eine Art Oberaufsicht. Ansonsten wirds wohl immer mehr Leute geben, die unzufrieden sind.


    Just my 2cents....

    Ja, das müsste man wirklich mal machen. Und erstmal messen, was da überhaupt raus kommt.


    Insgesamt scheint das nicht viel zu sein. Richtig stabil jedesmal die "Disk-Basic"-Meldung bekomme ich erst, seit ich wirklich beide Abschirmkappen über den Steckern drüber und auf den Kabel-Schirm gelegt habe. Das kann also kein V.24 sein, das wäre nämlich deutlich robuster.


    Jetzt klappt das aber jedesmal, mein System ist zumindest dafür stabil zusammengestellt :) .


    Wenn im Screenmode die shell auf dem PC vollgeschrieben ist und anfängt zu scrollen, wird es aber sehr langsam. Da bräuchte man einen schnelleren Server, oder man schaut sichs auf dem HX20 an. Filetransfer funktioniert.


    Allerdings kann ich manche Dateien einfach nicht laden, das bricht immer mit einer allgemeinen DU-Fehlermeldung ab.
    Erst dachte ich, das liegt am Speicher.
    Habe dann mal die 16k-Erweiterung angeschraubt. Das funktioniert leider gar nicht. Es gibt schon gleich eine Fehlermeldung, sobald der HX20 zum ersten mal den Server pollt. Nicht nur eine Fehlermeldung, sondern eine trap, die nur durch einen Hardware-reset zu beenden ist.


    Hier scheint es also einen massiven Speicherfehler zu geben, vielleicht hat der Programmautor das gar nicht testen können.


    Ansonsten: Es funktioniert, auf jeden Fall für kleinen Filetransfer. Das Kabel muss sehr sorgfältig gebaut werden, weil die Pegel anscheinend recht klein sind. Display funktioniert auch, allerdings sollte man dafür einen schnellen Rechner haben.



    Alles in allem eine feine und unkomplizierte Sache, wenn man die Tips aus diesem Thread berücksichtigt. Seit 15 Jahren schon hab ich den HX20 und konnte nie was mit anfangen, weil ich keine Programmcassetten hatte. Jetzt gehts los :)

    Jo, stimmt so. ESD kann immer passieren. Das ist auch nicht auf die Joystick-ports beschränkt, das gilt für alle Steckverbinder am Rechner.


    Es wäre sogar ein Szen ario denkbar, bei dem das blosse Berühren des Gehäuses genügt.


    Schützen kann man sich dagegen nur, indem man den Rechner ESD-gerecht umbaut, zumindest alle Schnittstellen dementsprechend erweitert. Wenn man dann immer noch sein ESD-Bändchen trägt, kann kaum was passieren.



    Ehrlich gesagt: Mich kümmert diese Problematik absolut nicht, weil es überhaupt nicht nachweisbar ist, ob ein spezieller Schaden auf ESD zurückzuführen ist. Alle hier genannten Beispiele sind nicht zwingend auf ESD zurückzuführen. ESD kann auch eine Vorschädigung des betroffenen Bauteils erzeugen, die vielleicht Jahre später erst zu einem Ausfall führt.


    Insgesamt ist das eine Sache für Statistiken, im Einzelfall lassen sich keine Aussagen treffen, es sei denn, man röngt seinen Schaltkreis. Auf den Bildchen lassen sich schon gewisse Hinweise auf ESD erkennen, aber selbst hier gibt es keine Garantie. Mann könnte genausogut herauslesen, dass der Fehler durch normale Korrosion (undichte Verkapselung) ermöglicht wurde. Selbst hier besteht also eine Unsicherheit.


    Das Ganze ist so ein bisschen wie bei der Diskussion um die Belastung des Organismus durch Handystrahlung. Es gibt gewisse Indikatoren, dass da im Einzelfall doch etwas passiert, aber diese Erfahrungen sind nicht statistisch belastbar, treten nur zufällig und im unteren Promillebereich auf und es ist keinesfalls ein Grenzwert oder eine "wenn-dann-Kette" auszumachen. Also für jemanden, der einigermassen rational durchs Leben geht, völlig unbedeutend. Schliesslich kann einem ja auch der Himmel auf den Kopf fallen.

    Drei Sachen sind mir noch auf die Schnelle aufgefallen:


    1. Die "Disk-Basic" Copyright-Meldung kommt nicht immer beim Starten des HX20 mit dem Server. Trotzdem kann man "screen 1" erfolgreich ausführen, auch wenn diese Meldung vorher nicht angezeigt wurde.


    2. Die Zeilen scrollen furchtbar langsam am PC durch. Langsamer, als das eigentlich bei 38k4 zu erwarten wäre. Ein Zeilenvorschub dauert gefühlt eine halbe Sekunde. bei dem langen Filelisting ist das jetzt schon etwas lang.
    Liegt das an dem lahmen Server bei mir? Geht das auf einem aktuellen PC schneller? Hab dafür gerade keinen zur Hand. Es läuft jetzt auf einem Pentium 1 mit 80MB RAM und Win2000.


    3. Sauberes TTL-Kabel gebaut, mit 60cm Kabellänge gehts, länger macht Probleme.

    Hallo Norbert und guidol,


    danke für euren schnellen Input.


    Das Ergebnis zuerst: es geht :)


    Das mit dem com-port habe ich gestern schon geklärt, da hing bei mir ein anderes Transferprogramm davor. Mit einem sauberen WinXP-Rechner ging das auf dieser Seite. Nur die Verbindung hat nicht funktioniert.


    Nach einer Nacht drüber schlafen ist mir eingefallen, dass es hier manchmal Probleme mit den Pegeln gibt. Diese nichtRS232-Highspeed-Schnittstellen hatten ja meist TTL-Pegel. Mit V.24 zusammen kann das gehen, muss aber nicht.
    Das Kabel hatte ich erst grosszügig dimensioniert, 2m alte Strippe aus der Kabelkiste, die an einem Ende sogar noch einen angegossenen Dsub-Stecker hat.
    Anscheinend kam damit nichts mehr an. Heute morgen hatte ich es dann nochmal mit einem simplen Breakout-Aufbau und 20cm Klingeldraht probiert. Nun funktioniert es anscheinend, zumindest kann ich die File-list sehen und es erscheinen die Eingaben am HX20 auch auf dem ThinkPad.


    Am Wochenende will ich mir vielleicht mal ein besseres Kabel bauen (irgendwo hab ich noch diese MAX232-Platinchen) und das Programm dann weiter testen. Mit dieser kurzen Kabelverbindung jetzt ist das etwas nervig. Mal sehen, ob das auch auf dem Win98-Rechner geht.


    Vielen Dank nochmal und bis bald!
    Stefan

    Ja, das hab ich dann auch gesehen, dass meine com-ports etwas verbogen waren. Auf einem sauberen Rechner ist der server dann bereit geblieben und es kam keine Fehlermeldung. Danke dir fürs ausprobieren.


    Allerdings funktioniert das mit meinem HX20 wohl aus irgendeinem Grund nicht. Ich kann zwar diesen Disk-ROM einblenden (die "screen"-Befehle stehen sonst gar nicht zur Verfügung), allerdings gibts bei mir nicht diese "Disk-Basic"-Meldung wie auf dem Foto in der Anleitung.


    Danach hab ich nochmal ein einfaches Terminal an den HX20 angeschlossen: Da psssiert gar nichts. Nicht mit 38k4 und auch nicht mit 19k2 oder 9k6. Aus der Bootreihenfolge (erst PC, dann HX20) schliesse ich mal, dass der HX20 beim Initialisieren irgendwie den Server pollt und es dann erst richtig los geht. Aber aus meinem HX20 kommt nichts raus. Auch nicht, wenn ich an dem Diodenstecker links und rechts vertausche (manchmal sind sich die Leute nicht so einig, was nun 1 und was 3 ist).


    Also falls es nicht noch einen in der Anleitung vergessenen Tastendruck gibt, funktioniert das bei mir nicht.

    Funktioniert bei mir nicht.


    Ich hab allerdings keine modernen PCs, sondern hab es auf zwei verschiedenen XP-Rechnern mit verschiedenen com-ports probiert.


    So, wie ich das verstanden habe, ist das Windows-Programm der Server, der also nie abbricht, sondern nach dem Aufruf im Vordergrund bleibt und auf das Einschalten des HX20 wartet.


    Bei mir kommt nach der Copyright-Meldung nur: Error in serial connection (createfile failed) und dann wieder der C:\



    Kann vielleicht mal jemand auf einem Windows7/10-PC ausprobieren, ob er den Server gestartet bekommt? Dazu brauchts gar keinen HX20 dran.
    http://members.aon.at/nkehrer/flashx20/flashx20.zip


    Dabei ist es egal, ob ich den HX20 dran hab. Den DIP-switch4 hab ich auch umgestellt. Mein HX20 meldet sich dann leider auch nicht mit dem "Disk-Basic", aber das hat erstmal nichts mit dem Server-Abbruch zu tun.



    Noch ein Update: Ich hab den Server zum Laufen bekommen, auch auf einem Windows98-Rechner.


    Allerdings verbindet sich mein HX20 nicht. Er bootet zwar beim Einschalten länger, nachdem ich den DIP-switch umgestellt habe, es kommt aber keine Disk-Basic-Interpretermeldung (wie auf der Webseite des Autors). Wahrscheinlich ist meine Firmware einfach zu alt und das Disk-Basic ist nur unvolständig enthalten.


    Vielleicht hat ja einer Lust, das mal mit einem neueren HX20 zu testen. Zumindest den DIPswitch 4 auf "ON" zu schalten und zu sehen, ob er dann die Disk-Basic-Meldung beim Einschalten bekommt

    Ja klar, kann durchaus passieren, klassischer ESD-Schaden. Aber das kann immer passieren, ob das Gerät nun an ist oder aus. Wenn du wirklich mit einer elektrostatischen (Hoch-)Spannung auf dem Stecker an den Computer kommst, kann Schluss sein. Das muss dann gar nicht unmittelbar dieses IC an dem Stecker betreffen, kann auf dem ganzen Mainboard passieren. Sofort und gleich, oder aber erst in 5 Jahren (statt in 50 Jahren, wie vielleicht stochastisch erwartet)



    Davor kann man sich aber nicht schützen, es sei denn, man verrammelt nachträglich den ganzen Rechner ESD-gerecht.
    Das ESD-Armbändchen sollte dann aber auch immer angelegt sein, das ist noch die einfachste Methode, das Gerät zu schützen.


    Für mich persönlich sehe ich bei einer Aufwands/Nutzenabwägung in diesem Rechnersegment momentan noch keinen Sinn dafür, 64er gibts genug und man wird nie wissen, ob sie nun an ESD gestorben sind, oder an was ganz anderem.
    Ich glaube, einen unmittelbaren ESD-Schaden hatte ich im ganzen Leben noch nicht und eine mittelbare Lebensdauerverkürzung ist im Einzelfall nicht nachweisbar, das kann tausende Gründe haben

    Ich habe mir bereits 2 CIA's mit umstecken kaputt gemacht.
    Es war jeweils ein Pin am CIA defekt welcher nicht mehr auf Eingaben reagiert hat.
    Einmal Feuer Eins und das andere Mal Rechts.

    Falls das dann wirklich mit dem Steckvorgang zu tun hat, ist das aber ESD (vielleicht in Verbindung mit einem angegammelten bonding auf dem die, da hab ich schon Rötgenbilder gesehen....).
    ESD-Schäden müssen sich auch nicht sofort bemerkbar machen, sondern ein solcher Überschlag kann den betroffenen Halbleiter auch gewissermaßen vorschädigen, dass dann seine Gesamtlebensdauer stark verkürzt ist.


    Und für ESD ist es statistisch relativ egal, ob das Gerät aus oder an ist. Schaltungstechnisch kann es sogar sicherer sein, das Gerät eingeschaltet zu lassen, falls dann die betroffenen IC-Anschlüsse mittel/niederohmig werden und nicht mehr im Tri-State hochohmig sind).


    Durch den Joystick selbst kann nichts passieren, selbst wenn ein Grobmotoriker den etwas wackelig einsteckt, da sind alle Leitungen unterbrochen (also "in der Luft").


    Sicher wird es auch Konstellationen geben, wo jemand nur durch das Einstecken seinen chip kurzgeschlossen hat (Isolationsfehler, Pin verbogen, was weiss ich...), aber die tendieren sicher anteilig bei der Millionenzahl bisheriger solcher Steckvorgänge gegen Null.