Hello, Guest the thread was called3.2k times and contains 82 replays

last post from darkvision at the

WIP: cbmHDscsi64 - Neues Management Utility für CMD-HD

  • Du hast recht, habe wohl vergessen bei der HD Reset zu drücken.

    Da fällt mir ein: Kam da keine Warnung? cmdHDscsi müsste da folgendes anzeigen:

    Code
    1. 50181 print" warning!{down}"
    2. 50182 print" make sure the cmd-hd is using its own"
    3. 50183 print" default device address.{down}"
    4. 50184 print" swap-8/9 or any other device address"
    5. 50185 print" set by 3rd-party applications may"
    6. 50186 print" cause problems!{down}"

    Also wenn die SWAP-8/9 Taste gedrückt ist oder wenn GEOS die Adresse geändert hat.

  • Habe diese Warnung noch nicht gesehen!


    Kann ich jetzt auch nicht nachvollziehen. Nach meinem letzten, erfolgreichen Versuch, hatte ich ja vorher den Reset Knopf an der HD gedrückt. Ich weiß leider nicht, wie es vorher war. Sorry.


    Eben nochmal probiert. 64er Modus, Cbmscsicopy64 Basic (HD ID(4) eingestellt) verlassen. Cbmhdscsi64 Basic ohne Zeile 1210 (ohne Reset CMD HD) gestartet, im Programm wird gleich die vorher eingestellte ID(4) angezeigt.


    Alles noch ohne serielles Kabel.

  • Eben nochmal probiert. 64er Modus, Cbmscsicopy64 Basic (HD ID(4) eingestellt) verlassen. Cbmhdscsi64 Basic ohne Zeile 1210 (ohne Reset CMD HD) gestartet, im Programm wird gleich die vorher eingestellte ID(4) angezeigt.

    Nur zum Verständnis: Es geht um die Geräteadresse der CMD-HD, nicht um das aktive SCSI-Gerät. Also z.B. SWAP-8/9 gedrückt oder GEOS hat die HD auf die GEOS-Laufwerksadresse angepasst.


    Ich hab nochmal darüber nachgedacht: Bei cbmSCSIcopy kann ich darauf testen, bei cbmHDscsi muss die Adresse #30 = Konfigurationsmodus erlaubt sein -> Falls die Disk nicht initialisiert ist hängt sich die CMD-HD sonst auf. In dem Fall muss man den Konfigurationsmodus einschalten.


    Ich hab jetzt aber noch zwei Änderungen eingefügt... ggf. löst es das Problem.


    Grundsätzlich empfohlen: RESET (Ausnahme nicht initialisierte Disk) und ser.Kabel :)


    So, jetzt aber genug getestet!!! :D