Hello, Guest the thread was called7.2k times and contains 135 replays

last post from C=Mac at the

GEOS und SCSI-Connect

  • Ich habe noch ein SCSI JAZ Drive hier rumliegen. Das wollte ich immer mal für Backups nutzen (ggf. ohne GEOS).

    Wenn Ihr davon eine Device Nummer / SCSI Nummer / was auch immer braucht, um das im SCSI Connect einzubauen (falls das nicht eh schon geht),

    wäre ich gerne behilflich. Müsste mir nur jemand sagen wie ich am besten an die Info rankomme, die ihr braucht.

    Aber achtung: Ich bin quasi GEOS Anfänger. :)


    Hallo Larry,

    hast Du eigentlich eine Möglichkeit gefunden, Dein Jaz Laufwerk, an der CMD HD zum laufen zu bringen? Hab das Thema, damals, irgendwie aus den Augen verloren. Sorry.;(


    Gruß Jojo

  • Ja so halb. Das SCSI Gerät wurde irgendwann erkannt. Aber viel weiter bin ich dann nicht mehr gekommen.

    Lag aber auch daran, dass ich es irgendwann nicht weiter probiert habe. Deswegen wird's langsam Zeit für einen neuen Anlauf.

    Und wenn das JAZ Drive von GEOS bzw. dem SCSI Manager unterstützt wird, dann ist das schon mal eine gute Motivation das Ding wieder anzuschließen.

  • Ok, hast Du es auch geschafft ein lauffähiges CMD System zu erstellen?


    Wenn nicht:


    Hast Du die Möglichkeit, Dein Jaz Laufwerk an einen Windows PC anzuschließen?


    Man kann per Raw Copy (PC Programm) ein CMD IMAGE auf ein leeres Jaz Medium kopieren. Danach das Laufwerk mit der CMD HD verbinden und schon müßte das System benutzbar sein (eventuell unter Commodore die richtige Größe des neuen Systems noch anpassen).:)


    Die Programme und das Image wären vorhanden.


    Gruß Jojo

  • Leider habe ich keine SCSI Karte o.ä. in meinem PC. Daher fällt die Möglichkeit schon mal aus.

    Wenn ich eine CMD mit Daten habe, die nicht gelöscht werden sollten, wie kann ich dann das JAZ Laufwerk mit CMD Tools soweit bringen, dass ich von HD auf JAZ kopieren könnte ?

    Ich habe im Netz nur beschreibungen gefunden, wo man erst die HD bis auf's letzte Byte Partitionieren muss, um dann ein ZIP Laufwerk dranhängen zu können.

    Geht das nicht auch anders bzw. einfacher ?

  • Geht das nicht auch anders bzw. einfacher ?

    Das wäre jetzt auch mal meine Frage... ist das nicht ein LLFORMAT + CREATE.SYS nachdem man die ID umgestellt hat?

  • Hier noch mal eine SCSI Tool Sammlung. Die Programme ZP-Create 2.2 und HD-Zip(al) ausprobieren.

    Müßte auch für andere Laufwerke funktionieren (nicht nur Zip). C64, C128? Mußt Du testen.


    Da ich schon viele Jahre die Möglichkeit habe, meine diversen SCSI Geräte, per Karte, am PC anzuschließen und die Images direkt aufzuspielen und entsprechend anzupassen, kann ich über die Programme nicht mehr viel sagen. Mit den original CMD Formatierungsprogrammen hatte ich damals auch so meine Schwierigkeiten.


    Wenn Du es so nicht hinbekommst, könnte ich ein Jaz Medium bespielen und Dir schicken.:)


    Nachtrag, wenn alles läuft: Das SCSI Connect 1.5 würde ich durch die Plus Versionen (64/128), von darkvision, ersetzen. Die funktionieren ohne spezielle Einschränkungen. Die Geos Umsetzung gibt es ja Testweise auch schon.:whistling:


    Gruß Jojo

  • Wenn ich das Programm unter MP3 128 benutze, wird der SSCSI Manager erst normal ausgeführt. Nach klick auf ein SCSI Laufwerk Symbol im Programm, wird ein Partitionsverzeichnis angezeigt.


    Probleme gibt es erst, wenn ich eine Partition zum kopieren auswähle. Nach dem anklicken gibt es Farbfehler auf dem Bildschirm im Bereich der angewählten Partition. Danach lässt sich die Zielpartition auch nicht mehr auswählen.

    Wenn ich es noch recht im Kopf habe.

    Kann unter MP3-128 kopiert werden, einfach mit diversen Fehler.


    - Grafikfehler in der Mitte des Bildschirms (Quadrat)

    - Es kann nur Partition um Partition kopiert werden. Bei Wheels können mehrere Partitionen angewählt und zugewiesen werden.

    - Zeitanzeige für die Dauer des Kopiervorgangs, steht bei MP3 immer auf 99:99

    - Die verbleibenden Partitionen sind immer 255 Partitionen


    Aus diesen Gründen habe ich SCSI-Manager eigentlich nur noch unter Wheels 128 benutzt.


    Eine Anpassung an MP3 (128 und 64), vielleicht auch Erweiterung, wäre begrüssenswert. :rolleyes:


    Gruss C=Mac.

  • Auch wenn es ggf. Off-Topic hier ist:

    Mit Add Drive v2.0 von CMD wird mein JAZ als SCSI Dev.5 erkannt. Ich kann es hinzufügen.

    LLFORMAT 2.0 findet das JAZ Drive ebenfalls als Dev.5 LUN 0. Ein Formatier Versuch startet aber nicht.
    Stattdessen bekomme ich einen SCSI Error 70 05 24.


    Habt ihr eine Idee was das sein kann, bzw. wo der Fehler liegt ?

    1 GB Jaz Medium ist im Drive.

  • Das wäre jetzt auch mal meine Frage... ist das nicht ein LLFORMAT + CREATE.SYS nachdem man die ID umgestellt hat?

    Kleine Korrektur: LLFORMAT scheint eine Auswahl anzubieten was die ID angeht. Schon etwas her das ich die SD-Karte formatiert hatte.


    Bei "CREATE SYS" ist die ID:0 aber fest im Programm verankert: Zeile 1270, Variable SD=0

    D.h. damit kann man nur die Systempartition auf der ID:0 erstellen, es sei denn man ändert die Variable SD. Aber nur eine Vermutung.

  • Bei "CREATE SYS" ist die ID:0 aber fest im Programm verankert:

    Bei den SCSI (ZIP) - Programmen der Bachmänner ist ein eigenes Create Sys dabei, genannt Create Sys_e(al).



    Ist ADD Drive nicht ein Programm, welches das neue Laufwerk (Jaz) mit in das "Alte LW" einbindet/integriert.

    Richtig "ADD Drive" fügt ein LfW zum Bestehenden dazu.

    Aus zwei 20 MB Platten wird eine 40 MB Platte, so verstehe ich jedenfalls die Beschreibung des Programms.


    Gruss C=Mac.

  • Ist ADD Drive nicht ein Programm, welches das neue Laufwerk (Jaz) mit in das "Alte LW" einbindet/integriert. Vielleicht liege ich auch falsch.

    Das hab ich auch so in Erinnerung. Damit vergrößert man das gesamte Laufwerk, also HD+ZIP,JAZ,MO..., kann es daher später nicht mehr wechseln.


    Ein Formatier Versuch startet aber nicht.
    Stattdessen bekomme ich einen SCSI Error 70 05 24.

    Sieht so aus als würde der Format-Befehl falsche Angaben beinhalten. Aber was genau ?(

  • Das JAZ-Medium ist nicht schreib geschützt?

    Das müsste einen anderen SCSI-Fehler ergeben.


    Ich hab mir den Format-Befehl in LLFORMAT mal angeschaut.

    Der sendet 6 Bytes: 04 18 00 00 01 00

    04 ist der Format-Befehl.

    18 definiert die "DEFECT"-Liste mit defekten Sektoren auf dem Medium.

    00 "Vendor specific"

    00 "Reserved"

    01 "Fast format field"

    00 "Control"

    Das 2Byte "18" und das 5Byte "01" wäre das einzige was man ändern könnte. Byte5 könnte einen "ILLEGAL REQUEST" verursachen. Evtl.mal Zeile 1670 in LLFORMAT anpassen und auf "00" setzen.

    Wenn das nichts hilft die "18" mal auf "00" setzen.


    Keine Ahnung ob das hilft oder alles schlimmer macht. Hoffentlich hast Du ein Backup der HD ;)


    Ansonsten die Tools von JoJo mal testen...

  • Uhhh.. das 5. Byte auf 00 und nun rattert es im JAZ Drive. Sieht so aus als ob das was gebracht hat.

    Ich verlinke hier auch noch mal auf meinen alten Threat, da es hier ja eigentlich ums SCSI Connect geht.

    Aber danke schon mal.

    Nuja... Ganz OffTopic ist das nicht. Den Format-Befehl haben wir ja schonmal... wenn ich in 14Jahren in Rente gehe hätte ich Zeit das evtl. mit einzubauen ;)


    Noch wissen wir ja nicht ob das formatieren funktioniert hat.


    Was jetzt noch fehlt ist CREATE SYS. Da, wie gesagt, arbeitet das Programm immer mit ID:0. Siehe Zeile 1270, Variable SD. Sonst wird die HDD mit einer neuen Systempartition versehen.

    USE AT OWN RISK!!!!

  • Das Drive wurde vom LL Format als Dev#5 Lun#0 erkannt. D.h. es müsste vorher als Dev#0 eingestellt werden, oder reicht LUN#0 auf Dev#5 ?

    Dev#0 ist das interne Laufwerk, die HDD, Dev#5 das JAZ.


    Wenn Du das tauschen kannst, dann wäre das gut. Denn CREATESYS arbeitet nur mit DEV#0.

    Ansonsten müsste man testen ob man CREATESYS patchen kann (siehe oben).


    Das formatieren kann etwas dauern... SD geht sicherlich schneller, aber da hier das MEDIUM jetzt KOMPLETT formatiert wird (wegen Byte5), würde ich es einfach mal laufen lassen...